aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2017-06-23 15:36:51 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2017-06-23 15:36:51 +0000
commit5225207f78142c3edaa0e91e69cc948aceeb2a97 (patch)
tree82ed10522004d469270470fadf6fc9655a28c19e
parent55bdedaae7808e1f386ecd5aac1fe8e796e4fc0b (diff)
downloadports-5225207f78142c3edaa0e91e69cc948aceeb2a97.tar.gz
ports-5225207f78142c3edaa0e91e69cc948aceeb2a97.zip
Notes
-rw-r--r--dns/knot2/Makefile15
-rw-r--r--dns/knot2/distinfo6
-rw-r--r--dns/knot2/files/pkg-message.in2
-rw-r--r--dns/knot2/pkg-plist24
4 files changed, 26 insertions, 21 deletions
diff --git a/dns/knot2/Makefile b/dns/knot2/Makefile
index 8ee267004b26..e614d454807e 100644
--- a/dns/knot2/Makefile
+++ b/dns/knot2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= knot
-PORTVERSION= 2.4.3
+PORTVERSION= 2.5.1
CATEGORIES= dns ipv6
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
http://dns-lab.com/downloads/knot-dns/
@@ -13,18 +13,16 @@ COMMENT= High performance authoritative-only DNS server
LICENSE= GPLv3
-LIB_DEPENDS= libfstrm.so:devel/fstrm \
- libgnutls.so:security/gnutls \
- libjansson.so:devel/jansson \
+LIB_DEPENDS= libgnutls.so:security/gnutls \
liblmdb.so:databases/lmdb \
libnettle.so:security/nettle \
liburcu.so:sysutils/liburcu
CONFLICTS= knot-1.* knot1-[0-6].*
-USES= alias compiler:c11 libedit libtool pkgconfig tar:xz
+USES= autoreconf alias compiler:c11 libedit libtool localbase pkgconfig python shebangfix tar:xz
+SHEBANG_FILES= src/utils/pykeymgr/pykeymgr.in
USE_LDCONFIG= yes
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-rundir=/var/run/knot \
--with-storage=/var/db/knot \
@@ -42,11 +40,14 @@ SUB_LIST+= USERS="${USERS}" GROUPS="${GROUPS}"
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS
+BROKEN_i386= Issues in knot/modules/*/*.c: undefined reference to '__atomic_fetch_add_8'
+
OPTIONS_DEFINE= DNSTAP FASTPARSER IDN
DNSTAP_DESC= dnstap support (see dnstap.info)
DNSTAP_CONFIGURE_ENABLE= dnstap
-DNSTAP_LIB_DEPENDS= libprotobuf-c.so:devel/protobuf-c
+DNSTAP_LIB_DEPENDS= libprotobuf-c.so:devel/protobuf-c \
+ libfstrm.so:devel/fstrm
# XXX: because `kdig_CPPFLAGS += $(DNSTAP_CFLAGS)' line is missing from
# `src/Makefile.am' file (and thus pre-generated `src/Makefile.in') which
# should contain "$libfstrm_CFLAGS $libprotobuf_c_CFLAGS" set by configure
diff --git a/dns/knot2/distinfo b/dns/knot2/distinfo
index d85537f94dbf..953137d0c552 100644
--- a/dns/knot2/distinfo
+++ b/dns/knot2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1493403989
-SHA256 (knot-2.4.3.tar.xz) = f90258bcb29c1f351cd8d824ff8d67aef906ae5d5ff0f652c4f69c69ed8a704f
-SIZE (knot-2.4.3.tar.xz) = 1110588
+TIMESTAMP = 1496870306
+SHA256 (knot-2.5.1.tar.xz) = 6c08cdc0a0182e262136b936a968ad667abce112195d99c27e50ea22afc08398
+SIZE (knot-2.5.1.tar.xz) = 1070108
diff --git a/dns/knot2/files/pkg-message.in b/dns/knot2/files/pkg-message.in
index 8c603db26451..2690023b5102 100644
--- a/dns/knot2/files/pkg-message.in
+++ b/dns/knot2/files/pkg-message.in
@@ -12,7 +12,7 @@
######################################################################
Please consult the documentation:
- - man knot.conf
+ - man knotd
- https://www.knot-dns.cz/documentation/
######################################################################
diff --git a/dns/knot2/pkg-plist b/dns/knot2/pkg-plist
index 4d2e9a49a6ca..16d401af2030 100644
--- a/dns/knot2/pkg-plist
+++ b/dns/knot2/pkg-plist
@@ -10,20 +10,17 @@ include/dnssec/binary.h
include/dnssec/crypto.h
include/dnssec/dnssec.h
include/dnssec/error.h
-include/dnssec/event.h
-include/dnssec/kasp.h
include/dnssec/key.h
include/dnssec/keyid.h
-include/dnssec/keystate.h
include/dnssec/keystore.h
include/dnssec/keytag.h
-include/dnssec/keyusage.h
include/dnssec/list.h
include/dnssec/nsec.h
include/dnssec/random.h
include/dnssec/sign.h
include/dnssec/tsig.h
include/dnssec/version.h
+include/knot/module.h
include/libknot/attribute.h
include/libknot/binary.h
include/libknot/codes.h
@@ -67,29 +64,32 @@ include/libknot/rrtype/txt.h
include/libknot/tsig-op.h
include/libknot/tsig.h
include/libknot/version.h
+include/libknot/yparser/yparser.h
+include/libknot/yparser/ypformat.h
+include/libknot/yparser/ypschema.h
+include/libknot/yparser/yptrafo.h
include/zscanner/error.h
include/zscanner/scanner.h
include/zscanner/version.h
lib/libdnssec.a
lib/libdnssec.so
-lib/libdnssec.so.2
-lib/libdnssec.so.2.1.0
+lib/libdnssec.so.4
+lib/libdnssec.so.4.0.0
lib/libknot.a
lib/libknot.so
-lib/libknot.so.5
-lib/libknot.so.5.0.0
+lib/libknot.so.6
+lib/libknot.so.6.0.0
lib/libzscanner.a
lib/libzscanner.so
lib/libzscanner.so.1
lib/libzscanner.so.1.0.0
+libdata/pkgconfig/knotd.pc
libdata/pkgconfig/libdnssec.pc
libdata/pkgconfig/libknot.pc
libdata/pkgconfig/libzscanner.pc
-libexec/knot1to2
man/man1/kdig.1.gz
man/man1/khost.1.gz
man/man1/kjournalprint.1.gz
-man/man1/knot1to2.1.gz
man/man1/knsec3hash.1.gz
man/man1/knsupdate.1.gz
man/man1/kzonecheck.1.gz
@@ -97,6 +97,10 @@ man/man5/knot.conf.5.gz
man/man8/keymgr.8.gz
man/man8/knotc.8.gz
man/man8/knotd.8.gz
+man/man8/pykeymgr.8.gz
sbin/keymgr
sbin/knotc
sbin/knotd
+sbin/pykeymgr
+@dir /var/db/knot
+@dir /var/run/knot