aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-18 15:12:03 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-18 15:12:03 +0000
commit53c1b67661ce255f1acf899fe0db3443474dd5aa (patch)
tree9f36558416ac29cea172d01ae9008e6fac4bee14
parent2e56491a69470166176315c4d77a21d248d0674f (diff)
downloadports-53c1b67661ce255f1acf899fe0db3443474dd5aa.tar.gz
ports-53c1b67661ce255f1acf899fe0db3443474dd5aa.zip
Notes
-rw-r--r--games/noegnud-slashem/Makefile11
-rw-r--r--games/noegnud-slashem/files/patch-variants::Makefile47
-rw-r--r--games/noegnud-slashem/pkg-descr1
-rw-r--r--games/noegnud-slashem/pkg-plist4
4 files changed, 19 insertions, 44 deletions
diff --git a/games/noegnud-slashem/Makefile b/games/noegnud-slashem/Makefile
index 7761f49d2b03..2bc6e0ced4e1 100644
--- a/games/noegnud-slashem/Makefile
+++ b/games/noegnud-slashem/Makefile
@@ -18,18 +18,16 @@ COMMENT= The noeGNUd UI for the SLASH'EM variant of Nethack
RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
-USES= bison gmake
+USES= bison gmake tar:bzip2
USE_GL= yes
WANT_SDL= yes
USE_SDL= sdl image mixer
-USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/variants
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
ALL_TARGET= se006e4f8
INSTALL_TARGET= install_se006e4f8
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
.include <bsd.port.pre.mk>
pre-everything::
@@ -46,6 +44,13 @@ post-extract:
post-patch:
(cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-slashem-0.0.6E4F8)
@(${PATCH} ${PATCH_ARGS} < ${FILESDIR}/noegnud-slashem.patch)
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
+ -e 's|make|${MAKE_CMD}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E -e 's,ch(grp|own),true,' \
+ -e '/(^FILE_AREA|^VARDIR|ln -s|sed)/! s,(GAME|SHELL|VAR)DIR),DESTDIR)$$(&,g' \
+ -e '/sed/! s,FILE_AREA_(BONES|DOC|LEVL|SAVE|SHARE|UNSHARE|VAR)),DESTDIR)$$(&,g' \
+ -e '/ln -s/ s,SHELLDIR,DESTDIR)$$(&,2' \
+ ${WRKSRC}/${NOEGNUDVERSION}-slashem-0.0.6E4F8/sys/unix/Makefile.top
do-configure:
(cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-slashem-0.0.6E4F8/Makefile)
diff --git a/games/noegnud-slashem/files/patch-variants::Makefile b/games/noegnud-slashem/files/patch-variants::Makefile
index 64a0919d8c0d..990e3b819ba5 100644
--- a/games/noegnud-slashem/files/patch-variants::Makefile
+++ b/games/noegnud-slashem/files/patch-variants::Makefile
@@ -1,51 +1,20 @@
---- variants/Makefile.orig Mon Nov 15 03:02:30 2004
-+++ variants/Makefile Mon Nov 15 03:03:25 2004
-@@ -1,7 +1,6 @@
+--- variants/Makefile.orig 2004-08-23 19:13:51.000000000 +0200
++++ variants/Makefile 2014-04-17 11:49:09.027549877 +0200
+@@ -1,7 +1,7 @@
NOEGNUDVERSION=noegnud-0.8.0
# you __MUST__ change this if you change the prefix for any variants' install !!!!!!!!!!!!!
# although ..... " make -e foo " also works :O ;)
-PREFIX = /usr/local
++PREFIX = %%PREFIX%%
GAMEUID = games
GAMEGRP = bin
CHOWN = chown
-@@ -62,31 +61,31 @@
- install: install_all
-
- install_nh342: nh342
-- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2 install
-
- install_nh343: nh343
-- make -e -C $(NOEGNUDVERSION)-nethack-3.4.3 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.3 install
+@@ -68,7 +68,7 @@
+ make -e -C $(NOEGNUDVERSION)-nethack-3.4.3 install
install_se006e4f8: se006e4f8
- make -e -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
++ make -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
install_se007e2: se007e2
-- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
-
- install_se007e5: se007e5
-- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
-
- install_se007e6: se007e6
-- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
-
- install_se007e6f2: se007e6f2
-- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
-
- install_lh001: lh001
-- make -e -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
-
- install_nh342-dt: nh342-dt
-- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
-
- # data
-
+ make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
diff --git a/games/noegnud-slashem/pkg-descr b/games/noegnud-slashem/pkg-descr
index 995cda3bf5cd..d549b925b29f 100644
--- a/games/noegnud-slashem/pkg-descr
+++ b/games/noegnud-slashem/pkg-descr
@@ -6,5 +6,4 @@ and an outstanding 3D-Mode.
This port installs noeGNUd for the SLASH'EM variant of Nethack.
-Author: Clive Crous
WWW: http://noegnud.sourceforge.net/
diff --git a/games/noegnud-slashem/pkg-plist b/games/noegnud-slashem/pkg-plist
index d70c3f40d8db..309f4e3b2be1 100644
--- a/games/noegnud-slashem/pkg-plist
+++ b/games/noegnud-slashem/pkg-plist
@@ -1,5 +1,7 @@
bin/noegnud-0.8.0-slashem-0.0.6E4F8
bin/noegnud-slashem-0.0.6E4F8
+@owner games
+@group bin
share/noegnud-0.8.0/slashem-0.0.6E4F8/Arc-fila.lev
share/noegnud-0.8.0/slashem-0.0.6E4F8/Arc-filb.lev
share/noegnud-0.8.0/slashem-0.0.6E4F8/Arc-goal.lev
@@ -179,7 +181,7 @@ share/noegnud-0.8.0/slashem-0.0.6E4F8/wizard2.lev
share/noegnud-0.8.0/slashem-0.0.6E4F8/wizard3.lev
share/noegnud-0.8.0/slashem-0.0.6E4F8/wizhelp
share/noegnud-0.8.0/slashem-0.0.6E4F8/yeenoghu.lev
-@exec chown games:bin %D/share/noegnud-0.8.0/slashem-0.0.6E4F8
+@exec chown root:wheel %D/share/noegnud-0.8.0
@exec chmod 775 %D/share/noegnud-0.8.0/slashem-0.0.6E4F8
@dirrmtry share/noegnud-0.8.0/slashem-0.0.6E4F8/save
@dirrmtry share/noegnud-0.8.0/slashem-0.0.6E4F8