aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-11-19 17:35:59 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-11-19 17:35:59 +0000
commit54172754af468444c13946bf33e134d00e492c9e (patch)
tree710ca3c072e1903e63d5e589865d8058979a9574
parent913cc7b281d5041a153864d635cc2de3221ea40d (diff)
downloadports-54172754af468444c13946bf33e134d00e492c9e.tar.gz
ports-54172754af468444c13946bf33e134d00e492c9e.zip
- Hook to the build
- Cleanup a bit - Mark BROKEN: Missing MASTER_SITES With hat: portmgr
Notes
Notes: svn path=/head/; revision=372799
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gdtclft/Makefile6
2 files changed, 4 insertions, 3 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 93e1f6b52042..ed0c893eef72 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -239,6 +239,7 @@
SUBDIR += gdchart
SUBDIR += gdk-pixbuf
SUBDIR += gdk-pixbuf2
+ SUBDIR += gdtclft
SUBDIR += geeqie
SUBDIR += gegl
SUBDIR += generic_image_decoder
diff --git a/graphics/gdtclft/Makefile b/graphics/gdtclft/Makefile
index 35e955d0ca8a..cdcd3eb496af 100644
--- a/graphics/gdtclft/Makefile
+++ b/graphics/gdtclft/Makefile
@@ -11,6 +11,8 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= mi@aldan.algebra.com
COMMENT= TCL interface to the Thomas Boutell's Gd library
+BROKEN= Missing MASTER_SITES
+
LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
USES= tcl:84+ uidfix
@@ -19,11 +21,9 @@ MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_ENV= TCL_VER=${TCL_VER} MKDIR="${MKDIR}" \
TCL_SHLIB_VER=${TCL_SHLIB_VER} \
INSTALL_DATA="${INSTALL_DATA}" STAGEDIR="${STAGEDIR}"
-ALL_TARGET= all
MANNPAGE= gdtclft.n
GDTCLDIR= lib/tcl${TCL_VER}/gdtclft
-PLIST_DIRS= ${GDTCLDIR}
PLIST_FILES= ${GDTCLDIR}/pkgIndex.tcl
PLIST_FILES+= ${GDTCLDIR}/libGdtclft2.so
PLIST_FILES+= man/mann/${MANNPAGE}.gz
@@ -32,6 +32,6 @@ post-patch:
${REINPLACE_CMD} -Ee 's,[[:space:]]+$$,,' ${WRKSRC}/${MANNPAGE}
post-install:
- ${GZIP_CMD} -9 -f < ${WRKSRC}/${MANNPAGE} > ${STAGEDIR}${PREFIX}/man/mann/${MANNPAGE}.gz
+ ${INSTALL_MAN} ${WRKSRC}/${MANNPAGE} ${STAGEDIR}${PREFIX}/man/mann
.include <bsd.port.mk>