aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-05 09:29:19 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-05 09:29:19 +0000
commit54575bcb911ac670d358c332f0e9ca7e13423516 (patch)
treec50f0d0bf2b4c7985230dce842e7a6128596cfa3
parent253f789f774e0aff32b1a93bc343c48823787897 (diff)
downloadports-54575bcb911ac670d358c332f0e9ca7e13423516.tar.gz
ports-54575bcb911ac670d358c332f0e9ca7e13423516.zip
Notes
-rw-r--r--net/tcpview/Makefile12
-rw-r--r--net/tcpview/files/patch-Makefile76
-rw-r--r--net/tcpview/pkg-descr8
3 files changed, 61 insertions, 35 deletions
diff --git a/net/tcpview/Makefile b/net/tcpview/Makefile
index d00f2dc55281..a009f106de86 100644
--- a/net/tcpview/Makefile
+++ b/net/tcpview/Makefile
@@ -13,22 +13,14 @@ COMMENT= Motif-based TCP/IP protocol analyzer
USES= bison motif
-MAKE_JOBS_UNSAFE= yes
-
MAN1= tcpview.1
-.include <bsd.port.pre.mk>
-
post-patch:
.for f in nametoaddr.c addrtoname.c print-nfs.c detail-tcp.c tv_addrtoname.c
@${REINPLACE_CMD} -e 's/NTOHL/ntohl/ ; s/NTOHS/ntohs/' ${WRKSRC}/${f}
.endfor
-.if ${OSVERSION} >= 800000
- @${REINPLACE_CMD} -e "s|-DCSLIP|-UCSLIP|" \
- ${WRKSRC}/Makefile
-.endif
post-install:
- ${INSTALL_DATA} ${WRKSRC}/DOC/Tcpview ${LOCALBASE}/lib/X11/app-defaults/
+ ${INSTALL_DATA} ${WRKSRC}/DOC/Tcpview ${LOCALBASE}/lib/X11/app-defaults
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/tcpview/files/patch-Makefile b/net/tcpview/files/patch-Makefile
index 403254edc6bc..54acfde83bb9 100644
--- a/net/tcpview/files/patch-Makefile
+++ b/net/tcpview/files/patch-Makefile
@@ -1,6 +1,14 @@
--- Makefile.orig Thu Apr 22 23:40:24 1993
+++ Makefile Mon Feb 17 13:32:10 2003
-@@ -28,10 +28,10 @@
+@@ -21,17 +21,16 @@
+ # @(#) $Header: /usr/staff/martinh/tcpview/RCS/Makefile,v 1.3 1992/11/17 21:59:47 martinh Exp martinh $ (UW)
+
+ # Possible Options:
+-# -DCSLIP include support for kernel slip interface
++# -UCSLIP include support for kernel slip interface
+ # -DPPP include support for point to point protocol
+ # -DIBMRTPC enable the MERIT additions to the Stanford Enetfilter
+ # -DNOVFPRINTF simulate vfprintf() on systems that don't have it
#
# CSLIP and PPP work only under BPF.
#
@@ -8,14 +16,13 @@
-CCOPT = -O2
-INCLUDES = -I..
-LIB =
-+DEFINES = -DCSLIP -DPPP
-+CCOPT = -O0
++DEFINES = -UCSLIP -DPPP
+INCLUDES = -I.. -I$(LOCALBASE)/include
+LIB =-ll
# These are for the Sun4 version
#CCOPT = -O2 -Bstatic
-@@ -41,20 +41,20 @@
+@@ -41,20 +40,20 @@
XLIB= -lXm -lXt -lX11
# The installed binary is owned by this group.
@@ -44,7 +51,7 @@
# Standard CFLAGS
STANDARD_CFLAGS = $(CCOPT) $(DEFINES) $(INCLUDES)
-@@ -70,7 +70,7 @@
+@@ -70,7 +69,7 @@
#tahoe-bsd#CFLAGS = $(STANDARD_CFLAGS)
#vax-bsd#CFLAGS = $(STANDARD_CFLAGS)
#vax-ultrix#
@@ -53,7 +60,7 @@
#mips-irix#CFLAGS = $(STANDARD_CFLAGS) -D_BSD_COMPAT
SUBDIRS = hp300-bsd mips-ultrix sun?-sunos? sun4-bsd tahoe-bsd vax-bsd \
-@@ -92,7 +92,8 @@
+@@ -92,7 +91,8 @@
# Also, gcc does not remove the .o before forking 'as', which can be a
# problem if you don't own the file but can write to the directory.
.c.o:
@@ -63,7 +70,7 @@
# List all C source files here
-@@ -189,7 +190,7 @@
+@@ -189,7 +189,7 @@
$(CC) $(CFLAGS) -o $@ $(TCPDUMP_OBJ) $(LIB)
tcpview: $(TCPVIEW_OBJ)
@@ -72,8 +79,37 @@
tcpslice: $(TCPSLICE_OBJ)
$(CC) $(CFLAGS) -o $@ $(TCPSLICE_OBJ)
-@@ -261,20 +262,21 @@
- cd $$dir ; ${MAKE} ${MFLAGS} depend2
+@@ -209,12 +209,12 @@
+ -@dir=$(MD)-$(OS)-tcpdump; \
+ if [ ! -d $$dir ]; then ${MAKE} ${MFLAGS} config1; fi; \
+ set -x; \
+- cd $$dir; ${MAKE} ${MFLAGS} tcpdump; ${MAKE} ${MFLAGS} tcpslice
++ ${MAKE} -C $$dir ${MFLAGS} tcpdump tcpslice
+ -@dir=$(MD)-$(OS)-tcpview; \
+ if [ ! -d $$dir ]; then ${MAKE} ${MFLAGS} config2; fi; \
+ set -x; \
+- cd $$dir; ${MAKE} ${MFLAGS} DEFINES="${DEFINES} -DTCPVIEW" tcpview; \
+- ${MAKE} ${MFLAGS} FILTERS
++ ${MAKE} -C $$dir ${MFLAGS} DEFINES="${DEFINES} -DTCPVIEW" tcpview; \
++ ${MAKE} -C $$dir ${MFLAGS} FILTERS
+
+ # N.B.- symbolic links are used in the subdirectory rather than VPATH
+ # because at least one Sun cc compiler puts the .o in the wrong place
+@@ -239,7 +239,7 @@
+ ln -s ../net $$dir/net; \
+ sed -e "/^all:/d" -e "s/^#$$dir#//" Makefile >$$dir/Makefile; \
+ chmod ug+w $$dir/Makefile; \
+- cd $$dir ; ${MAKE} ${MFLAGS} depend1
++ ${MAKE} -C $$dir ${MFLAGS} depend1
+
+ config2:
+ -@md=$(MD); os=$(OS); dir=$$md-$$os-tcpview; list=; \
+@@ -258,23 +258,24 @@
+ ln -s ../TCPVIEW_VERSION $$dir/TCPVIEW_VERSION; \
+ sed -e "/^all:/d" -e "s/^#$$dir#//" Makefile >$$dir/Makefile; \
+ chmod ug+w $$dir/Makefile; \
+- cd $$dir ; ${MAKE} ${MFLAGS} depend2
++ ${MAKE} -C $$dir ${MFLAGS} depend2
tcplex.c: tcplex.l
- rm -f $@
@@ -97,7 +133,7 @@
sed 's/.*/char tcpview_version[] = "&";/' TCPVIEW_VERSION >> version.c
set `sed 's/\([0-9]*\)\.\([0-9]*\).*/\1 \2/' VERSION` ; \
{ echo '#define VERSION_MAJOR' $$1 ; \
-@@ -287,22 +289,22 @@
+@@ -287,22 +288,20 @@
install: force
-mkdir -p $(TCPVIEW_DIR)
-mkdir -p $(FILTER_DIR)
@@ -110,30 +146,30 @@
+# install -m 755 -g $(GROUP) -c tcpdump $(DESTDIR)$(BINDEST); \
+# install -m 755 -c tcpslice $(DESTDIR)$(TCPSLICE_BINDEST)
@dir=$(MD)-$(OS)-tcpview; set -x; \
- cd $$dir ; \
+- cd $$dir ; \
- install -m 755 -g $(GROUP) tcpview $(DESTDIR)$(BINDEST); \
- install -m 755 -g $(GROUP) BGP $(FILTER_DIR); \
- install -m 755 -g $(GROUP) telnet $(FILTER_DIR); \
- install -m 755 -g $(GROUP) generic $(FILTER_DIR); \
-+ ${BSD_INSTALL_PROGRAM} -c tcpview $(DESTDIR)$(BINDEST); \
-+ ${BSD_INSTALL_PROGRAM} -c BGP $(FILTER_DIR); \
-+ ${BSD_INSTALL_PROGRAM} -c telnet $(FILTER_DIR); \
-+ ${BSD_INSTALL_PROGRAM} -c generic $(FILTER_DIR); \
- cd ../DOC ; \
+- cd ../DOC ; \
- install -m 666 -c hosts $(TCPVIEW_DIR); \
- install -m 666 -c manuf $(TCPVIEW_DIR); \
- install -c tcpdump.1 $(DESTDIR)$(TCPDUMP_MANDEST); \
- install -c tcpview.1 $(DESTDIR)$(TCPVIEW_MANDEST); \
- install -c tcpslice.1 $(DESTDIR)$(TCPSLICE_MANDEST)
-+ ${BSD_INSTALL_DATA} -c hosts $(TCPVIEW_DIR); \
-+ ${BSD_INSTALL_DATA} -c manuf $(TCPVIEW_DIR); \
-+ ${BSD_INSTALL_MAN} -c tcpview.1 $(DESTDIR)$(TCPVIEW_MANDEST); \
++ ${BSD_INSTALL_PROGRAM} -c $$dir/tcpview $(DESTDIR)$(BINDEST); \
++ ${BSD_INSTALL_PROGRAM} -c $$dir/BGP $(FILTER_DIR); \
++ ${BSD_INSTALL_PROGRAM} -c $$dir/telnet $(FILTER_DIR); \
++ ${BSD_INSTALL_PROGRAM} -c $$dir/generic $(FILTER_DIR); \
++ ${BSD_INSTALL_DATA} -c $$dir/../DOC/hosts $(TCPVIEW_DIR); \
++ ${BSD_INSTALL_DATA} -c $$dir/../DOC/manuf $(TCPVIEW_DIR); \
++ ${BSD_INSTALL_MAN} -c $$dir/../DOC/tcpview.1 $(DESTDIR)$(TCPVIEW_MANDEST); \
+# install -m 444 -c tcpdump.1 $(DESTDIR)$(TCPDUMP_MANDEST); \
+# install -m 444 -c tcpslice.1 $(DESTDIR)$(TCPSLICE_MANDEST)
lint: force
lint -hbxn $(CSRC) | \
-@@ -367,8 +369,3 @@
+@@ -367,8 +366,3 @@
-../mkdep $(DEFINES) $(INCLUDES) $(TCPVIEW_CSRC) \
tcpgram.c tcplex.c
rm -f $(GEN)
diff --git a/net/tcpview/pkg-descr b/net/tcpview/pkg-descr
index 6b410fb22066..50cfca9c913e 100644
--- a/net/tcpview/pkg-descr
+++ b/net/tcpview/pkg-descr
@@ -1,7 +1,5 @@
-Tcpview is Motif-based TCP/IP protocol analyzer.
-
-It is a graphic version conterpart of the tcpdump.
-It enables the user to analysis the tcp/ip packet with confortable
-graphic interface.
+Tcpview is Motif-based TCP/IP protocol analyzer. It is a graphic version
+counterpart of tcpdump(1). It allows users to analyze TCP/IP packets with
+comfortable graphic interface.
WWW: ftp://ftp.cac.washington.edu/pub/noc-tools/tcpview/tcpview-1.0.tar.readme