aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-04-01 12:19:37 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-04-01 12:19:37 +0000
commit5483285813283df2562d15d805f04cfafae78cb5 (patch)
tree0e19d573dd550bcd5fcc49e490e0a6b66a499cc4
parentbab26234f520b8a357c3ea45945561cab0a2af30 (diff)
downloadports-5483285813283df2562d15d805f04cfafae78cb5.tar.gz
ports-5483285813283df2562d15d805f04cfafae78cb5.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Modern/Makefile33
-rw-r--r--devel/p5-Test-Modern/distinfo2
-rw-r--r--devel/p5-Test-Modern/pkg-descr13
-rw-r--r--devel/p5-Test-Modern/pkg-plist2
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c06701b16311..3483a78e7b81 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3024,6 +3024,7 @@
SUBDIR += p5-Test-MockObject
SUBDIR += p5-Test-MockRandom
SUBDIR += p5-Test-MockTime
+ SUBDIR += p5-Test-Modern
SUBDIR += p5-Test-Module-Used
SUBDIR += p5-Test-Moose-More
SUBDIR += p5-Test-More-UTF8
diff --git a/devel/p5-Test-Modern/Makefile b/devel/p5-Test-Modern/Makefile
new file mode 100644
index 000000000000..fb0415fc0716
--- /dev/null
+++ b/devel/p5-Test-Modern/Makefile
@@ -0,0 +1,33 @@
+# Created by: Muhammad Moinur Rahman <bofh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Test-Modern
+PORTVERSION= 0.013
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:TOBYINK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= Precision testing for modern perl
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Exporter-Tiny>=0:${PORTSDIR}/devel/p5-Exporter-Tiny \
+ p5-Import-Into>=1:${PORTSDIR}/devel/p5-Import-Into \
+ p5-Module-Runtime>=0.012:${PORTSDIR}/devel/p5-Module-Runtime \
+ p5-Test-API>=0.004:${PORTSDIR}/devel/p5-Test-API \
+ p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Fatal>0:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-Test-Warnings>0:${PORTSDIR}/devel/p5-Test-Warnings
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose
+
+USES= perl5
+USE_PERL5= configure
+
+test:
+ cd ${WRKSRC} && ${MAKE} test
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Modern/distinfo b/devel/p5-Test-Modern/distinfo
new file mode 100644
index 000000000000..b78ac97be0be
--- /dev/null
+++ b/devel/p5-Test-Modern/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Modern-0.013.tar.gz) = 63ebc04b761c5748a121006d0e2672a6836d39cfb9e0b42dda80c8161f7a1246
+SIZE (Test-Modern-0.013.tar.gz) = 38747
diff --git a/devel/p5-Test-Modern/pkg-descr b/devel/p5-Test-Modern/pkg-descr
new file mode 100644
index 000000000000..52bd0a0f8e9b
--- /dev/null
+++ b/devel/p5-Test-Modern/pkg-descr
@@ -0,0 +1,13 @@
+Test::Modern provides the best features of Test::More, Test::Fatal,
+Test::Warnings, Test::API, Test::LongString, and Test::Deep, as well as ideas
+from Test::Requires, Test::DescribeMe, Test::Moose, and Test::CleanNamespaces.
+
+Test::Modern also automatically imposes strict and warnings on your script, and
+loads IO::File. (Much of the same stuff Modern::Perl does.)
+
+Although Test::Modern is a modern testing framework, it should run fine on
+pre-modern versions of Perl. It should be easy to install on Perl 5.8.9 and
+above; and if you can persuade its dependencies to install (not necessarily
+easy!), should be OK on anything back to Perl 5.6.1.
+
+WWW: http://search.cpan.org/dist/Test-Modern/
diff --git a/devel/p5-Test-Modern/pkg-plist b/devel/p5-Test-Modern/pkg-plist
new file mode 100644
index 000000000000..f877286f6e4f
--- /dev/null
+++ b/devel/p5-Test-Modern/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Test/Modern.pm
+%%PERL5_MAN3%%/Test::Modern.3.gz