aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-18 04:49:52 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-18 04:49:52 +0000
commit5581fcace8d627f1b1f4647a1892dd1204c9c015 (patch)
tree90388648916e4df546d297daf2e49a2899906595
parent33dcbbaadd056f0e5fdbd399cd2c0f8b2c57f660 (diff)
Notes
-rw-r--r--www/apache20/Makefile23
-rw-r--r--www/apache20/Makefile.doc3
-rw-r--r--www/apache20/files/patch-buildconf20
-rw-r--r--www/apache20/files/patch-configure.in38
-rw-r--r--www/apache20/files/patch-srclib__Makefile.in9
-rw-r--r--www/apache20/files/patch-srclib__apr-util__buckets__apr_brigade.c12
-rw-r--r--www/apache20/files/patch-srclib__apr-util__build__dbm.m480
-rw-r--r--www/apache20/files/patch-srclib__apr-util__config.layout10
-rw-r--r--www/apache20/files/patch-srclib__apr-util__strmatch__apr_strmatch.c18
-rw-r--r--www/apache20/files/patch-srclib__apr-util__xml__apr_xml.c48
-rw-r--r--www/apache20/files/patch-srclib__apr-util__xml__expat__buildconf.sh20
-rw-r--r--www/apache20/files/patch-srclib__apr__build__buildcheck.sh11
-rw-r--r--www/apache20/files/patch-srclib__apr__buildconf75
-rw-r--r--www/apache20/files/patch-srclib__apr__config.layout10
-rw-r--r--www/apache20/files/patch-srclib__apr__configure.in43
-rw-r--r--www/apache20/files/patch-srclib__apr__threadproc__unix__procsup.c18
-rw-r--r--www/apache20/pkg-plist79
17 files changed, 24 insertions, 493 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 9bff90e579db..c34896da7a25 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -23,7 +23,8 @@ MAINTAINER?= apache@FreeBSD.org
COMMENT?= Version 2.0.x of Apache web server with ${WITH_MPM:L} MPM.
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
- pcre.0:${PORTSDIR}/devel/pcre
+ pcre.0:${PORTSDIR}/devel/pcre \
+ apr-0:${PORTSDIR}/devel/apr0
MAKE_JOBS_SAFE= yes
@@ -49,14 +50,6 @@ CONFLICTS= apache+mod_ssl-1.* apache+mod_ssl+ipv6-1.* apache+mod_ssl+modsnmp-1.*
# LDAP "Enable LDAP Support" Off \
# THREADS "Enable threads in apr" Off
-SCRIPTS_ENV+= \
- LIBTOOL=${LIBTOOL} \
- LIBTOOL_VERSION=${LIBTOOL_VERSION} \
- LIBTOOL_M4=${LIBTOOL_M4} \
- LIBTOOLIZE=${LIBTOOLIZE} \
- AUTOCONF=${AUTOCONF} \
- AUTOHEADER=${AUTOHEADER}
-
USE_ICONV= yes
USE_AUTOTOOLS= autoconf:262 libtool:22
USE_PERL5= yes
@@ -82,6 +75,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
--with-port=${WITH_HTTP_PORT} \
--with-expat=${LOCALBASE} \
--with-iconv=${LOCALBASE} \
+ --with-apr=${LOCALBASE}/bin/apr-config \
+ --with-apr-util=${LOCALBASE}/bin/apu-config \
--libdir=${PREFIX_RELDEST}/lib/apache2 \
--includedir=${PREFIX_RELDEST}/include/apache2
@@ -166,10 +161,6 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-openssl-9.8up.patch
BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
.endif
-.if exists(${LOCALBASE}/lib/libapr-0.so) || defined(WITH_APR_FROM_PORTS)
-IGNORE= apr from ports (WITH_APR_FROM_PORTS) is no longer supported
-.endif
-
.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --enable-threads
. if ${ARCH} == i386
@@ -215,17 +206,13 @@ post-patch:
@${RM} -f ${WRKSRC}/docs/manual/index.html.ko.euc-kr
@${RM} -f ${WRKSRC}/docs/conf/highperformance-std.conf
@${RM} -rf ${WRKSRC}/srclib/pcre ${WRKSRC}/include/pcreposix.h
+ @${RM} -rf ${WRKSRC}/srclib/apr ${WRKSRC}/srclib/apr-util
@${GREP} -Rl REG_NOSUB ${WRKSRC}/modules | ${XARGS} ${REINPLACE_CMD} -e 's,REG_NOSUB,0,g'
@${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' \
${WRKSRC}/server/core.c
- @${REINPLACE_CMD} -e 's,freebsd\[2345\],freebsd\[23456789\],' \
- ${WRKSRC}/srclib/apr/build/apr_hints.m4
@${REINPLACE_CMD} -e "s,\$abs_builddir/srclib/pcre/libpcre.la,${LOCALBASE}/lib/libpcre.la," ${WRKSRC}/configure.in
@${INSTALL_DATA} ${WRKSRC}/NOTICE ${WRKSRC}/docs/manual
-pre-configure:
- @cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ./buildconf
-
post-configure:
@FTPUSERS=`${EGREP} -v '^#' /etc/ftpusers| ${TR} -s "\n" " "` ;\
${REINPLACE_CMD} -e "s,%%FTPUSERS%%,$${FTPUSERS}, ; \
diff --git a/www/apache20/Makefile.doc b/www/apache20/Makefile.doc
index 4d8e373535b0..b01c7250cb82 100644
--- a/www/apache20/Makefile.doc
+++ b/www/apache20/Makefile.doc
@@ -73,9 +73,6 @@
## WITH_CUSTOM_WWW: Let you choose your ${PREFIX}/www components
## [cgi|errordocs|icons|wwwdata]
##
-## Optionnal patches:
-## WITH_KQUEUE_SUPPORT Add kqueue support to apr/httpd
-##
## Available make targets:
## show-options: prints this message
## show-modules: prints list of available modules
diff --git a/www/apache20/files/patch-buildconf b/www/apache20/files/patch-buildconf
deleted file mode 100644
index 83fd0bac9ddd..000000000000
--- a/www/apache20/files/patch-buildconf
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./buildconf.orig 2010-05-06 20:50:20.262614348 -0400
-+++ ./buildconf 2010-05-06 20:48:47.000000000 -0400
-@@ -102,7 +102,6 @@
-
- apr_configure="$apr_src_dir/configure"
- aprutil_configure="$apu_src_dir/configure"
--pcre_configure="srclib/pcre/configure"
- config_h_in="include/ap_config_auto.h.in"
-
- cross_compile_warning="warning: AC_TRY_RUN called without default to allow cross compiling"
-@@ -157,9 +156,6 @@
- touch ssl_expr_scan.c
- cd ../..
-
--echo rebuilding $pcre_configure
--(cd srclib/pcre && ${AUTOCONF:-autoconf})
--
- echo rebuilding $config_h_in
- rm -f $config_h_in
- ${AUTOHEADER:-autoheader} 2>&1 | grep -v "$cross_compile_warning"
diff --git a/www/apache20/files/patch-configure.in b/www/apache20/files/patch-configure.in
index c09a104796f0..844028703975 100644
--- a/www/apache20/files/patch-configure.in
+++ b/www/apache20/files/patch-configure.in
@@ -1,23 +1,5 @@
--- ./configure.in.orig 2005-09-12 16:41:34.000000000 -0400
-+++ ./configure.in 2010-05-06 17:30:34.855458994 -0400
-@@ -69,7 +69,7 @@
-
- if test "$apr_found" = "reconfig"; then
- APR_SUBDIR_CONFIG(srclib/apr,
-- [$apache_apr_flags --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$bindir --datadir=$datadir --with-installbuilddir=$installbuilddir],
-+ [$apache_apr_flags --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$libdir --datadir=$datadir --with-installbuilddir=$installbuilddir],
- [--enable-layout=*|\'--enable-layout=*])
- dnl We must be the first to build and the last to be cleaned
- AP_BUILD_SRCLIB_DIRS="apr $AP_BUILD_SRCLIB_DIRS"
-@@ -106,7 +106,7 @@
-
- if test "$apu_found" = "reconfig"; then
- APR_SUBDIR_CONFIG(srclib/apr-util,
-- [--with-apr=../apr --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$bindir],
-+ [--with-apr=../apr --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$libdir],
- [--enable-layout=*|\'--enable-layout=*])
- dnl We must be the last to build and the first to be cleaned
- AP_BUILD_SRCLIB_DIRS="$AP_BUILD_SRCLIB_DIRS apr-util"
++++ ./configure.in 2010-05-13 18:12:08.745593083 -0400
@@ -124,11 +124,6 @@
AC_PROG_CC
AC_PROG_CPP
@@ -39,3 +21,21 @@
SH_LIBTOOL='$(LIBTOOL)'
SHLTCFLAGS="-prefer-pic"
LTCFLAGS="-prefer-non-pic -static"
+@@ -485,7 +480,7 @@
+ AC_DEFINE_UNQUOTED(AP_SUEXEC_UMASK, 0$withval, [umask for suexec'd process] ) ] )
+
+ dnl AP_LIBS specifies the actual libraries. note we have some required libs.
+-AP_LIBS="$abs_builddir/srclib/pcre/libpcre.la $AP_LIBS"
++AP_LIBS="$a/usr/local/lib/libpcre.la $AP_LIBS"
+
+ dnl APR should go after the other libs, so the right symbols can be picked up
+ AP_LIBS="$AP_LIBS `$apu_config --link-libtool --libs` `$apr_config --link-libtool --libs`"
+@@ -526,7 +521,7 @@
+ APACHE_FAST_OUTPUT(Makefile modules/Makefile srclib/Makefile)
+ APACHE_FAST_OUTPUT(os/beos/Makefile os/os2/Makefile os/Makefile)
+ APACHE_FAST_OUTPUT(os/unix/Makefile server/Makefile)
+-APACHE_FAST_OUTPUT(support/Makefile srclib/pcre/Makefile)
++APACHE_FAST_OUTPUT(support/Makefile)
+
+ if test -d ./test; then
+ APACHE_FAST_OUTPUT(test/Makefile)
diff --git a/www/apache20/files/patch-srclib__Makefile.in b/www/apache20/files/patch-srclib__Makefile.in
deleted file mode 100644
index d7c5f70f7a31..000000000000
--- a/www/apache20/files/patch-srclib__Makefile.in
+++ /dev/null
@@ -1,9 +0,0 @@
---- srclib/Makefile.in.orig 2010-05-06 21:03:45.453360110 -0400
-+++ srclib/Makefile.in 2010-05-06 21:03:50.421209682 -0400
-@@ -1,5 +1,5 @@
-
--SUBDIRS = pcre
-+SUBDIRS =
- BUILD_SUBDIRS = $(AP_BUILD_SRCLIB_DIRS)
- CLEAN_SUBDIRS = $(AP_CLEAN_SRCLIB_DIRS)
-
diff --git a/www/apache20/files/patch-srclib__apr-util__buckets__apr_brigade.c b/www/apache20/files/patch-srclib__apr-util__buckets__apr_brigade.c
deleted file mode 100644
index 252a83e67d66..000000000000
--- a/www/apache20/files/patch-srclib__apr-util__buckets__apr_brigade.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./srclib/apr-util/buckets/apr_brigade.c.orig 2005-02-04 15:39:09.000000000 -0500
-+++ ./srclib/apr-util/buckets/apr_brigade.c 2010-05-06 16:06:03.715831795 -0400
-@@ -653,9 +653,6 @@
- return -1;
- }
-
-- /* tack on null terminator to remaining string */
-- *(vd.vbuff.curpos) = '\0';
--
- /* write out what remains in the buffer */
- return apr_brigade_write(b, flush, ctx, buf, vd.vbuff.curpos - buf);
- }
diff --git a/www/apache20/files/patch-srclib__apr-util__build__dbm.m4 b/www/apache20/files/patch-srclib__apr-util__build__dbm.m4
deleted file mode 100644
index d87f299c4cd9..000000000000
--- a/www/apache20/files/patch-srclib__apr-util__build__dbm.m4
+++ /dev/null
@@ -1,80 +0,0 @@
---- ./srclib/apr-util/build/dbm.m4.orig 2006-11-09 10:50:42.000000000 -0500
-+++ ./srclib/apr-util/build/dbm.m4 2010-05-06 16:06:03.775832049 -0400
-@@ -298,8 +298,8 @@
- fi
- APU_CHECK_BERKELEY_DB(1, -1, -1,
- "$places",
-- "db_185.h",
-- "db"
-+ "db.h",
-+ "c"
- )
- if test "$apu_have_db" = "1"; then
- apu_db_version=185
-@@ -341,7 +341,7 @@
- APU_CHECK_BERKELEY_DB(3, -1, -1,
- "$places",
- "db3/db.h db.h",
-- "db3 db"
-+ "db3"
- )
- if test "$apu_have_db" = "1"; then
- apu_db_version=3
-@@ -361,8 +361,8 @@
- fi
- APU_CHECK_BERKELEY_DB("4", "0", "-1",
- "$places",
-- "db4/db.h db.h",
-- "db-4.0 db4 db"
-+ "db4/db.h",
-+ "db4"
- )
- if test "$apu_have_db" = "1"; then
- apu_db_version=4
-@@ -382,8 +382,8 @@
- fi
- APU_CHECK_BERKELEY_DB("4", "1", "-1",
- "$places",
-- "db41/db.h db4/db.h db.h",
-- "db-4.1 db4 db"
-+ "db41/db.h",
-+ "db41"
- )
- if test "$apu_have_db" = "1"; then
- apu_db_version=4
-@@ -403,13 +403,14 @@
- fi
- APU_CHECK_BERKELEY_DB("4", "2", "-1",
- "$places",
-- "db42/db.h db4/db.h db.h",
-- "db-4.2 db4 db"
-+ "db42/db.h",
-+ "db-4.2"
- )
- if test "$apu_have_db" = "1"; then
- apu_db_version=4
- fi
- ])
-+
- dnl
- dnl APU_CHECK_DB43: is DB4.3 present?
- dnl
-@@ -422,8 +423,8 @@
- fi
- APU_CHECK_BERKELEY_DB("4", "3", "-1",
- "$places",
-- "db43/db.h db4/db.h db.h",
-- "db-4.3 db43 db4 db"
-+ "db43/db.h",
-+ "db-4.3"
- )
- if test "$apu_have_db" = "1"; then
- apu_db_version=4
-@@ -579,6 +580,7 @@
- fi
- fi
- fi
-+
- AC_MSG_CHECKING(for Berkeley DB)
- if test "$apu_have_db" = "1"; then
- AC_MSG_RESULT(found db$apu_db_version)
diff --git a/www/apache20/files/patch-srclib__apr-util__config.layout b/www/apache20/files/patch-srclib__apr-util__config.layout
deleted file mode 100644
index c0bb5aabd726..000000000000
--- a/www/apache20/files/patch-srclib__apr-util__config.layout
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./srclib/apr-util/config.layout.orig 2004-11-24 18:45:40.000000000 -0500
-+++ ./srclib/apr-util/config.layout 2010-05-06 16:06:03.777832029 -0400
-@@ -229,3 +229,7 @@
- infodir: ${exec_prefix}/share/info
- libsuffix -${APRUTIL_MAJOR_VERSION}
- </Layout>
-+
-+<Layout FreeBSD>
-+ libsuffix:
-+</Layout>
diff --git a/www/apache20/files/patch-srclib__apr-util__strmatch__apr_strmatch.c b/www/apache20/files/patch-srclib__apr-util__strmatch__apr_strmatch.c
deleted file mode 100644
index cc0cb97825f2..000000000000
--- a/www/apache20/files/patch-srclib__apr-util__strmatch__apr_strmatch.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./srclib/apr-util/strmatch/apr_strmatch.c.orig 2005-02-04 15:39:09.000000000 -0500
-+++ ./srclib/apr-util/strmatch/apr_strmatch.c 2010-05-06 16:06:03.717832055 -0400
-@@ -103,13 +103,13 @@
- if (case_sensitive) {
- pattern->compare = match_boyer_moore_horspool;
- for (i = 0; i < pattern->length - 1; i++) {
-- shift[(int)s[i]] = pattern->length - i - 1;
-+ shift[(unsigned char)s[i]] = pattern->length - i - 1;
- }
- }
- else {
- pattern->compare = match_boyer_moore_horspool_nocase;
- for (i = 0; i < pattern->length - 1; i++) {
-- shift[apr_tolower(s[i])] = pattern->length - i - 1;
-+ shift[(unsigned char)apr_tolower(s[i])] = pattern->length - i - 1;
- }
- }
- pattern->context = shift;
diff --git a/www/apache20/files/patch-srclib__apr-util__xml__apr_xml.c b/www/apache20/files/patch-srclib__apr-util__xml__apr_xml.c
deleted file mode 100644
index 37059a0da8b1..000000000000
--- a/www/apache20/files/patch-srclib__apr-util__xml__apr_xml.c
+++ /dev/null
@@ -1,48 +0,0 @@
---- ./srclib/apr-util/xml/apr_xml.c.orig 2007-04-02 12:19:29.000000000 -0400
-+++ ./srclib/apr-util/xml/apr_xml.c 2010-05-06 16:06:03.712831964 -0400
-@@ -339,6 +339,25 @@
- return APR_SUCCESS;
- }
-
-+#if XML_MAJOR_VERSION > 1
-+/* Stop the parser if an entity declaration is hit. */
-+static void entity_declaration(void *userData, const XML_Char *entityName,
-+ int is_parameter_entity, const XML_Char *value,
-+ int value_length, const XML_Char *base,
-+ const XML_Char *systemId, const XML_Char *publicId,
-+ const XML_Char *notationName)
-+{
-+ apr_xml_parser *parser = userData;
-+
-+ XML_StopParser(parser->xp, XML_FALSE);
-+}
-+#else
-+/* A noop default_handler. */
-+static void default_handler(void *userData, const XML_Char *s, int len)
-+{
-+}
-+#endif
-+
- APU_DECLARE(apr_xml_parser *) apr_xml_parser_create(apr_pool_t *pool)
- {
- apr_xml_parser *parser = apr_pcalloc(pool, sizeof(*parser));
-@@ -364,6 +383,19 @@
- XML_SetElementHandler(parser->xp, start_handler, end_handler);
- XML_SetCharacterDataHandler(parser->xp, cdata_handler);
-
-+ /* Prevent the "billion laughs" attack against expat by disabling
-+ * internal entity expansion. With 2.x, forcibly stop the parser
-+ * if an entity is declared - this is safer and a more obvious
-+ * failure mode. With older versions, installing a noop
-+ * DefaultHandler means that internal entities will be expanded as
-+ * the empty string, which is also sufficient to prevent the
-+ * attack. */
-+#if XML_MAJOR_VERSION > 1
-+ XML_SetEntityDeclHandler(parser->xp, entity_declaration);
-+#else
-+ XML_SetDefaultHandler(parser->xp, default_handler);
-+#endif
-+
- return parser;
- }
-
diff --git a/www/apache20/files/patch-srclib__apr-util__xml__expat__buildconf.sh b/www/apache20/files/patch-srclib__apr-util__xml__expat__buildconf.sh
deleted file mode 100644
index 8723e96bbd5a..000000000000
--- a/www/apache20/files/patch-srclib__apr-util__xml__expat__buildconf.sh
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./srclib/apr-util/xml/expat/buildconf.sh.orig 2006-03-25 16:41:35.000000000 -0500
-+++ ./srclib/apr-util/xml/expat/buildconf.sh 2010-05-06 16:06:03.780832140 -0400
-@@ -3,7 +3,7 @@
- #
- # Build aclocal.m4 from libtool's libtool.m4
- #
--libtoolize=`conftools/PrintPath glibtoolize libtoolize`
-+libtoolize=${LIBTOOLIZE}
- if [ "x$libtoolize" = "x" ]; then
- echo "libtoolize not found in path"
- exit 1
-@@ -16,7 +16,7 @@
- rm -rf aclocal.m4 libtool.m4 ltsugar.m4 autom4te*.cache
-
- ltpath=`dirname $libtoolize`
--ltfile=${LIBTOOL_M4-`cd $ltpath/../share/aclocal ; pwd`/libtool.m4}
-+ltfile=${LIBTOOL_M4}
- echo "Incorporating $ltfile into aclocal.m4 ..."
- echo "dnl THIS FILE IS AUTOMATICALLY GENERATED BY buildconf.sh" > aclocal.m4
- echo "dnl edits here will be lost" >> aclocal.m4
diff --git a/www/apache20/files/patch-srclib__apr__build__buildcheck.sh b/www/apache20/files/patch-srclib__apr__build__buildcheck.sh
deleted file mode 100644
index 5aaee2aa15c2..000000000000
--- a/www/apache20/files/patch-srclib__apr__build__buildcheck.sh
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./srclib/apr/build/buildcheck.sh.orig 2004-11-24 18:10:04.000000000 -0500
-+++ ./srclib/apr/build/buildcheck.sh 2010-05-06 16:06:03.782832400 -0400
-@@ -26,7 +26,7 @@
- # output is multiline from 1.5 onwards
-
- # Require libtool 1.3.3 or newer
--libtool=`build/PrintPath glibtool libtool`
-+libtool=${LIBTOOL}
- lt_pversion=`$libtool --version 2>/dev/null|sed -e 's/([^)]*)//g;s/^[^0-9]*//;s/[- ].*//g;q'`
- if test -z "$lt_pversion"; then
- echo "buildconf: libtool not found."
diff --git a/www/apache20/files/patch-srclib__apr__buildconf b/www/apache20/files/patch-srclib__apr__buildconf
deleted file mode 100644
index 0dfca545ea8e..000000000000
--- a/www/apache20/files/patch-srclib__apr__buildconf
+++ /dev/null
@@ -1,75 +0,0 @@
---- ./srclib/apr/buildconf.orig 2006-09-20 12:04:09.000000000 -0400
-+++ ./srclib/apr/buildconf 2010-05-06 16:48:57.802430154 -0400
-@@ -23,7 +23,7 @@
- #
- build/buildcheck.sh || exit 1
-
--libtoolize=`build/PrintPath glibtoolize libtoolize`
-+libtoolize="${LIBTOOLIZE}"
- if [ "x$libtoolize" = "x" ]; then
- echo "libtoolize not found in path"
- exit 1
-@@ -35,29 +35,48 @@
- # Note: APR supplies its own config.guess and config.sub -- we do not
- # rely on libtool's versions
- #
--echo "Copying libtool helper files ..."
-+echo "buildconf: copying libtool helper files using $libtoolize"
-
- # Remove any libtool files so one can switch between libtool 1.3
- # and libtool 1.4 by simply rerunning the buildconf script.
--(cd build ; rm -f ltconfig ltmain.sh libtool.m4)
--
--$libtoolize --copy --automake
--
--ltpath=`dirname $libtoolize`
--ltfile=${LIBTOOL_M4-`cd $ltpath/../share/aclocal ; pwd`/libtool.m4}
-+(cd build ; rm -f ltconfig ltmain.sh libtool.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 lt~obsolete.m4)
-
--if [ ! -f $ltfile ]; then
-+lt_pversion=`$libtoolize --version 2>/dev/null|sed -e 's/([^)]*)//g;s/^[^0-9]*//;s/[- ].*//g;q'`
-+lt_version=`echo $lt_pversion|sed -e 's/\([a-z]*\)$/.\1/'`
-+IFS=.; set $lt_version; IFS=' '
-+if test "$1" = "1"; then
-+ $libtoolize --copy --automake
-+ if [ -f libtool.m4 ]; then
-+ ltfile=`pwd`/libtool.m4
-+ else
-+ ltfindcmd="`sed -n \"/=[^\\\`]/p;/libtool_m4=/{s/.*=/echo /p;q;}\" \
-+ < $libtoolize`"
-+ ltfile=${LIBTOOL_M4-`eval "$ltfindcmd"`}
-+ # Expecting the code above to be very portable, but just in case...
-+ if [ -z "$ltfile" -o ! -f "$ltfile" ]; then
-+ ltpath=`dirname $libtoolize`
-+ ltfile=${LIBTOOL_M4}
-+ fi
-+ fi
-+ if [ ! -f $ltfile ]; then
- echo "$ltfile not found"
- exit 1
-+ fi
-+ # Do we need this anymore?
-+ echo "buildconf: Using libtool.m4 at ${ltfile}."
-+ cat $ltfile | sed -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' > build/libtool.m4
-+fi
-+if test "$1" = "2"; then
-+ $libtoolize --copy
-+ # Wouldn't it just be better to define top_builddir??
-+ mv build/libtool.m4 build/libtool.m4.$$
-+ cat build/libtool.m4.$$ | sed -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' > build/libtool.m4
-+ chmod 664 build/libtool.m4.$$
-+ rm build/libtool.m4.$$
- fi
-
--echo "buildconf: Using libtool.m4 at ${ltfile}."
--
--cat $ltfile | sed -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' > build/libtool.m4
--
--# This is just temporary until people's workspaces are cleared -- remove
--# any old aclocal.m4 left over from prior build so it doesn't cause errors.
--rm -f aclocal.m4
-+# Clean up any leftovers
-+rm -f aclocal.m4 libtool.m4
-
- #
- # Generate the autoconf header and ./configure
diff --git a/www/apache20/files/patch-srclib__apr__config.layout b/www/apache20/files/patch-srclib__apr__config.layout
deleted file mode 100644
index 43e11afdd16d..000000000000
--- a/www/apache20/files/patch-srclib__apr__config.layout
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./srclib/apr/config.layout.orig 2004-11-24 18:02:04.000000000 -0500
-+++ ./srclib/apr/config.layout 2010-05-06 16:06:03.785831951 -0400
-@@ -229,3 +229,7 @@
- infodir: ${exec_prefix}/share/info
- libsuffix: -${APR_MAJOR_VERSION}
- </Layout>
-+
-+<Layout FreeBSD>
-+ libsuffix:
-+</Layout>
diff --git a/www/apache20/files/patch-srclib__apr__configure.in b/www/apache20/files/patch-srclib__apr__configure.in
deleted file mode 100644
index e2ef93ecff03..000000000000
--- a/www/apache20/files/patch-srclib__apr__configure.in
+++ /dev/null
@@ -1,43 +0,0 @@
---- ./srclib/apr/configure.in.orig 2007-11-03 10:18:38.000000000 -0400
-+++ ./srclib/apr/configure.in 2010-05-06 16:06:03.731831919 -0400
-@@ -7,6 +7,7 @@
- AC_INIT(build/apr_common.m4)
- AC_CONFIG_HEADER(include/arch/unix/apr_private.h)
- AC_CONFIG_AUX_DIR(build)
-+AC_CONFIG_MACRO_DIR(build)
-
- dnl
- dnl Include our own M4 macros along with those for libtool
-@@ -16,6 +17,11 @@
- sinclude(build/apr_threads.m4)
- sinclude(build/apr_hints.m4)
- sinclude(build/libtool.m4)
-+sinclude(build/ltsugar.m4)
-+sinclude(build/argz.m4)
-+sinclude(build/ltoptions.m4)
-+sinclude(build/ltversion.m4)
-+sinclude(build/lt~obsolete.m4)
-
- dnl Save user-defined environment settings for later restoration
- dnl
-@@ -98,6 +104,8 @@
- dnl preload section from invoking the macro to get compiler info.
- AC_PROG_CC
-
-+AC_PROG_SED
-+
- dnl Preload
- APR_PRELOAD
-
-@@ -137,6 +145,11 @@
- AC_ARG_ENABLE(experimental-libtool,[ --experimental-libtool Use experimental custom libtool (not included in source distribution)],
- [experimental_libtool=$enableval],[experimental_libtool=no])
-
-+dnl Workarounds for busted Libtool 2.x when we don't call AC_PROG_LIBTOOL
-+if test "x$Xsed" = "x"; then
-+ Xsed="$SED -e 1s/^X//"
-+fi
-+
- case $host in
- *os2*)
- # Use a custom-made libtool replacement
diff --git a/www/apache20/files/patch-srclib__apr__threadproc__unix__procsup.c b/www/apache20/files/patch-srclib__apr__threadproc__unix__procsup.c
deleted file mode 100644
index 2e7198492a39..000000000000
--- a/www/apache20/files/patch-srclib__apr__threadproc__unix__procsup.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./srclib/apr/threadproc/unix/procsup.c.orig 2006-09-20 12:04:09.000000000 -0400
-+++ ./srclib/apr/threadproc/unix/procsup.c 2010-05-06 16:06:03.788832062 -0400
-@@ -21,6 +21,7 @@
- int x;
-
- chdir("/");
-+#ifndef FREEBSD_THREAD_HACK
- #if !defined(MPE) && !defined(OS2) && !defined(TPF) && !defined(BEOS)
- /* Don't detach for MPE because child processes can't survive the death of
- * the parent. */
-@@ -56,6 +57,7 @@
- return errno;
- }
- #endif
-+#endif
-
- /* close out the standard file descriptors */
- if (freopen("/dev/null", "r", stdin) == NULL) {
diff --git a/www/apache20/pkg-plist b/www/apache20/pkg-plist
index dd84f89e7fd2..fe103441884d 100644
--- a/www/apache20/pkg-plist
+++ b/www/apache20/pkg-plist
@@ -22,68 +22,6 @@ include/apache2/ap_mpm.h
include/apache2/ap_provider.h
include/apache2/ap_regkey.h
include/apache2/ap_release.h
-include/apache2/apr.h
-include/apache2/apr_allocator.h
-include/apache2/apr_anylock.h
-include/apache2/apr_atomic.h
-include/apache2/apr_base64.h
-include/apache2/apr_buckets.h
-include/apache2/apr_compat.h
-include/apache2/apr_date.h
-include/apache2/apr_dbm.h
-include/apache2/apr_dso.h
-include/apache2/apr_env.h
-include/apache2/apr_errno.h
-include/apache2/apr_file_info.h
-include/apache2/apr_file_io.h
-include/apache2/apr_fnmatch.h
-include/apache2/apr_general.h
-include/apache2/apr_getopt.h
-include/apache2/apr_global_mutex.h
-include/apache2/apr_hash.h
-include/apache2/apr_hooks.h
-include/apache2/apr_inherit.h
-include/apache2/apr_ldap.h
-include/apache2/apr_ldap_url.h
-include/apache2/apr_lib.h
-include/apache2/apr_md4.h
-include/apache2/apr_md5.h
-include/apache2/apr_mmap.h
-include/apache2/apr_network_io.h
-include/apache2/apr_optional.h
-include/apache2/apr_optional_hooks.h
-include/apache2/apr_poll.h
-include/apache2/apr_pools.h
-include/apache2/apr_portable.h
-include/apache2/apr_proc_mutex.h
-include/apache2/apr_queue.h
-include/apache2/apr_reslist.h
-include/apache2/apr_ring.h
-include/apache2/apr_rmm.h
-include/apache2/apr_sdbm.h
-include/apache2/apr_sha1.h
-include/apache2/apr_shm.h
-include/apache2/apr_signal.h
-include/apache2/apr_strings.h
-include/apache2/apr_strmatch.h
-include/apache2/apr_support.h
-include/apache2/apr_tables.h
-include/apache2/apr_thread_cond.h
-include/apache2/apr_thread_mutex.h
-include/apache2/apr_thread_proc.h
-include/apache2/apr_thread_rwlock.h
-include/apache2/apr_time.h
-include/apache2/apr_uri.h
-include/apache2/apr_user.h
-include/apache2/apr_uuid.h
-include/apache2/apr_version.h
-include/apache2/apr_want.h
-include/apache2/apr_xlate.h
-include/apache2/apr_xml.h
-include/apache2/apu.h
-include/apache2/apu_compat.h
-include/apache2/apu_version.h
-include/apache2/apu_want.h
%%WORKER%%include/apache2/fdqueue.h
%%THREADPOOL%%include/apache2/pod.h
include/apache2/http_config.h
@@ -125,18 +63,6 @@ include/apache2/util_md5.h
include/apache2/util_script.h
include/apache2/util_time.h
include/apache2/util_xml.h
-lib/apache2/apr-config
-lib/apache2/apr.exp
-lib/apache2/aprutil.exp
-lib/apache2/apu-config
-lib/apache2/libapr-0.a
-lib/apache2/libapr-0.la
-lib/apache2/libapr-0.so
-lib/apache2/libapr-0.so.9
-lib/apache2/libaprutil-0.a
-lib/apache2/libaprutil-0.la
-lib/apache2/libaprutil-0.so
-lib/apache2/libaprutil-0.so.9
libexec/apache2/httpd.exp
%%MOD_ACCESS%%libexec/apache2/mod_access.so
%%MOD_ACTIONS%%libexec/apache2/mod_actions.so
@@ -209,16 +135,11 @@ sbin/httxt2dbm
sbin/logresolve
sbin/rotatelogs
%%MOD_SUEXEC%%sbin/suexec
-share/apache2/build/apr_rules.mk
share/apache2/build/config_vars.mk
share/apache2/build/config.nice
share/apache2/build/instdso.sh
share/apache2/build/library.mk
-share/apache2/build/libtool
share/apache2/build/ltlib.mk
-share/apache2/build/make_exports.awk
-share/apache2/build/make_var_export.awk
-share/apache2/build/mkdir.sh
share/apache2/build/program.mk
share/apache2/build/rules.mk
share/apache2/build/special.mk