aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2003-10-27 18:45:16 +0000
committerGreg Lewis <glewis@FreeBSD.org>2003-10-27 18:45:16 +0000
commit56d50228c1ad839b535182b3b0527cb91e66c1f2 (patch)
treeed1909714102efd2b573599b42c025bd5dde04cf
parent0f91b7ffb6bddba09bae0a3008b2182d52357a41 (diff)
downloadports-56d50228c1ad839b535182b3b0527cb91e66c1f2.tar.gz
ports-56d50228c1ad839b535182b3b0527cb91e66c1f2.zip
. Fix build on 5.x (gcc 3.3)
PR: 58426 Submitted by: Samy Al Bahra <samy@kerneled.com>
Notes
Notes: svn path=/head/; revision=92335
-rw-r--r--audio/xtuner/Makefile8
-rw-r--r--audio/xtuner/files/patch-misc.c14
2 files changed, 15 insertions, 7 deletions
diff --git a/audio/xtuner/Makefile b/audio/xtuner/Makefile
index fc6458fdaf32..db7c74aff81e 100644
--- a/audio/xtuner/Makefile
+++ b/audio/xtuner/Makefile
@@ -19,10 +19,4 @@ LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
USE_IMAKE= YES
USE_XPM= YES
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/xtuner/files/patch-misc.c b/audio/xtuner/files/patch-misc.c
new file mode 100644
index 000000000000..ea8ac2badc9d
--- /dev/null
+++ b/audio/xtuner/files/patch-misc.c
@@ -0,0 +1,14 @@
+$FreeBSD$
+
+--- misc.c.orig Mon Oct 27 11:29:57 2003
++++ misc.c Mon Oct 27 11:30:19 2003
+@@ -90,8 +90,7 @@
+ else
+ {
+ fprintf(stderr,"Usage: xtuner [-0x20 | -0x30] -24 \n");
+- fprintf(stderr,"Which specifies the port for the radio card and 24hr
+- time format \n");
++ fprintf(stderr,"Which specifies the port for the radio card and 24hr time format \n");
+ exit(1);
+ }
+ cmd++;