aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-04-24 12:40:47 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-04-24 12:40:47 +0000
commit56f716c819b3eba7ac808ac70ed6130d2dbf2be5 (patch)
tree9f73bc496fe6f45a56aca336548b2b2eeff97c82
parent424e280054b1a54425167f44c299afbff6d3861d (diff)
downloadports-56f716c819b3eba7ac808ac70ed6130d2dbf2be5.tar.gz
ports-56f716c819b3eba7ac808ac70ed6130d2dbf2be5.zip
Notes
-rw-r--r--print/foomatic-db-engine/Makefile5
-rw-r--r--print/foomatic-db-engine/distinfo5
-rw-r--r--print/foomatic-db-engine/files/patch-foomatic-getpjloptions.in18
3 files changed, 17 insertions, 11 deletions
diff --git a/print/foomatic-db-engine/Makefile b/print/foomatic-db-engine/Makefile
index 16f45b0cf3e0..dd6a52b00920 100644
--- a/print/foomatic-db-engine/Makefile
+++ b/print/foomatic-db-engine/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= foomatic-db-engine
-PORTVERSION= 4.0.12
-PORTREVISION= 1
+PORTVERSION= 4.0.13
PORTEPOCH= 2
CATEGORIES= print
MASTER_SITES= http://www.openprinting.org/download/foomatic/
@@ -15,8 +14,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libcurl.so:ftp/curl
-USE_GNOME= libxml2
USES= gmake perl5
+USE_GNOME= libxml2
GNU_CONFIGURE= yes
CONFIGURE_ENV= PERL=${PERL} LIBDIR=${PREFIX}/share/foomatic/ \
LIB_CUPS=${LOCALBASE}/libexec/cups \
diff --git a/print/foomatic-db-engine/distinfo b/print/foomatic-db-engine/distinfo
index ac0c8ca10d85..362778db2f1f 100644
--- a/print/foomatic-db-engine/distinfo
+++ b/print/foomatic-db-engine/distinfo
@@ -1,2 +1,3 @@
-SHA256 (foomatic-db-engine-4.0.12.tar.gz) = 66143b76ed5b325b7025e261ad917b543de534c6d0a6e495d5489a20cace7c21
-SIZE (foomatic-db-engine-4.0.12.tar.gz) = 360499
+TIMESTAMP = 1524530260
+SHA256 (foomatic-db-engine-4.0.13.tar.gz) = b5c89027aa26967d2e6db62e2af7db0c4039d2480d4fbf2476a6ddcf609a5faf
+SIZE (foomatic-db-engine-4.0.13.tar.gz) = 360631
diff --git a/print/foomatic-db-engine/files/patch-foomatic-getpjloptions.in b/print/foomatic-db-engine/files/patch-foomatic-getpjloptions.in
index 4fed5b958c1c..fec55b2652e4 100644
--- a/print/foomatic-db-engine/files/patch-foomatic-getpjloptions.in
+++ b/print/foomatic-db-engine/files/patch-foomatic-getpjloptions.in
@@ -9,14 +9,16 @@ Remove useless braces around variable-names.
-mi
---- foomatic-getpjloptions.in 2015-02-14 07:21:56.000000000 -0500
-+++ foomatic-getpjloptions.in 2015-02-15 07:36:23.000000000 -0500
-@@ -1,3 +1,3 @@
+--- foomatic-getpjloptions.in.orig 2018-03-02 19:15:50 UTC
++++ foomatic-getpjloptions.in
+@@ -1,4 +1,4 @@
-#!@SH@
+#!/bin/sh
#
# Polls PJL options from local or network printers
-@@ -23,6 +23,5 @@
+ #
+@@ -22,8 +22,7 @@
+
NC=@NC@
CAT=@CAT@
-PRINTF=@PRINTF@
@@ -24,12 +26,16 @@ Remove useless braces around variable-names.
+PRINTF=printf # sh builtin
usage(){
-@@ -63,12 +62,13 @@
+ cat <<EOF ;
+@@ -60,15 +59,16 @@ esac
+ $PRINTF "@PJL INFO CONFIG\r\n"
+ $PRINTF "\033%%-12345X"
+ ) | if [ ${2:-X} != X ]; then
- # We have two arguments, do ethernet printer request
+ # We have two arguments, do network printer request
# Poll the printer's answer and filter out the newpage characters
-+ # as well as the carriage-returns (\r or, in octal, 015)
- ${NC} -w 3 ${1} ${2} 2>/dev/null | ${PERL} -p -e "s/\014//"
++ # as well as the carriage-returns (\r or, in octal, 015)
+ $NC -w 3 $1 $2 2>/dev/null | tr -d "\015\014"
else
# We have one argument, do local printer request