aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-02-29 03:53:27 +0000
committerSteve Wills <swills@FreeBSD.org>2012-02-29 03:53:27 +0000
commit5760eef8fd1519900ef8a8585014cda62f3b30e0 (patch)
tree1b87b631e98d573ce238367050d53d9cb3ec0371
parentaf4526daaef33d895a20a0e3b13a42fb7fdc4755 (diff)
downloadports-5760eef8fd1519900ef8a8585014cda62f3b30e0.tar.gz
ports-5760eef8fd1519900ef8a8585014cda62f3b30e0.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-IP-Minimal/Makefile21
-rw-r--r--net/p5-Net-IP-Minimal/distinfo2
-rw-r--r--net/p5-Net-IP-Minimal/pkg-descr3
-rw-r--r--net/p5-Net-IP-Minimal/pkg-plist7
5 files changed, 34 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f0e412e7c6c7..cabf51750207 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -578,6 +578,7 @@
SUBDIR += p5-Net-HTTP
SUBDIR += p5-Net-Hiveminder
SUBDIR += p5-Net-INET6Glue
+ SUBDIR += p5-Net-IP-Minimal
SUBDIR += p5-Net-IP-RangeCompare
SUBDIR += p5-Net-IPTrie
SUBDIR += p5-Net-IRR
diff --git a/net/p5-Net-IP-Minimal/Makefile b/net/p5-Net-IP-Minimal/Makefile
new file mode 100644
index 000000000000..c3defdd8d0dd
--- /dev/null
+++ b/net/p5-Net-IP-Minimal/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Net-IP-Minimal
+# Date created: 2012-02-28
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-IP-Minimal
+PORTVERSION= 0.02
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Minimal functions from Net::IP
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::IP::Minimal.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-IP-Minimal/distinfo b/net/p5-Net-IP-Minimal/distinfo
new file mode 100644
index 000000000000..d1af532aaa63
--- /dev/null
+++ b/net/p5-Net-IP-Minimal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-IP-Minimal-0.02.tar.gz) = e02e01fe921bb4a10d7a5ffa973805df220f8de4e4db121eb0dbb9de39c6e10f
+SIZE (Net-IP-Minimal-0.02.tar.gz) = 10828
diff --git a/net/p5-Net-IP-Minimal/pkg-descr b/net/p5-Net-IP-Minimal/pkg-descr
new file mode 100644
index 000000000000..47f85a1ec835
--- /dev/null
+++ b/net/p5-Net-IP-Minimal/pkg-descr
@@ -0,0 +1,3 @@
+Minimal functions from Net::IP
+
+WWW: http://search.cpan.org/dist/Net-IP-Minimal/
diff --git a/net/p5-Net-IP-Minimal/pkg-plist b/net/p5-Net-IP-Minimal/pkg-plist
new file mode 100644
index 000000000000..d519afb1c346
--- /dev/null
+++ b/net/p5-Net-IP-Minimal/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/IP/Minimal/.packlist
+%%SITE_PERL%%/Net/IP/Minimal.pm
+@dirrmtry %%SITE_PERL%%/Net/IP
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/IP/Minimal
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/IP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net