aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-11-18 00:37:15 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-11-18 00:37:15 +0000
commit57e3213639e451ddc7e2311587929b679827e385 (patch)
tree2b38c4ddded75d6142be0d45209292474f0596a8
parentec67c2b687d0b609821be9dac725661545f90926 (diff)
downloadports-57e3213639e451ddc7e2311587929b679827e385.tar.gz
ports-57e3213639e451ddc7e2311587929b679827e385.zip
Notes
-rw-r--r--comms/bforce-kst/Makefile33
-rw-r--r--comms/bforce-kst/pkg-plist12
-rw-r--r--comms/bpl+/Makefile7
-rw-r--r--comms/bpl+/pkg-plist2
-rw-r--r--comms/callsign/Makefile3
-rw-r--r--comms/cdr_read/Makefile12
-rw-r--r--comms/cdr_read/pkg-plist3
-rw-r--r--comms/dfu-util/Makefile4
-rw-r--r--comms/gkermit/Makefile12
-rw-r--r--comms/gkermit/pkg-plist4
-rw-r--r--comms/gpredict/Makefile9
-rw-r--r--comms/gpredict/pkg-plist1
-rw-r--r--comms/grig/Makefile5
-rw-r--r--comms/grig/pkg-plist7
-rw-r--r--comms/gsmlib/Makefile5
-rw-r--r--comms/gsmlib/pkg-plist6
-rw-r--r--comms/nokryptia/Makefile6
-rw-r--r--comms/nokryptia/files/patch-nokryptia.cc174
-rw-r--r--comms/serialoverip/Makefile3
-rw-r--r--comms/seyon/Makefile5
-rw-r--r--comms/sredird/Makefile14
-rw-r--r--comms/sredird/pkg-plist3
-rw-r--r--comms/tkscanfax/Makefile11
-rw-r--r--comms/tkscanfax/pkg-plist6
-rw-r--r--comms/xdx/Makefile2
-rw-r--r--comms/xdx/pkg-plist11
-rw-r--r--comms/yaps/Makefile18
-rw-r--r--comms/yaps/files/patch-Makefile21
-rw-r--r--comms/yaps/pkg-plist6
-rw-r--r--comms/zssh/Makefile4
-rw-r--r--comms/zssh/files/patch-Makefile.in15
31 files changed, 304 insertions, 120 deletions
diff --git a/comms/bforce-kst/Makefile b/comms/bforce-kst/Makefile
index 35fd39c1543a..c1700976fb25 100644
--- a/comms/bforce-kst/Makefile
+++ b/comms/bforce-kst/Makefile
@@ -38,11 +38,10 @@ FIXME= include/bforce.h include/util.h include/logger.h \
WRKSRC= ${WRKDIR}/${DISTNAME}/source
-PORTDOCS= CHANGES CHANGES.kst COPYING README README.kst
+DOCS= CHANGES CHANGES.kst COPYING README README.kst
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
pre-configure:
@${MKDIR} ${WRKSRC}/bin
@@ -55,25 +54,23 @@ post-patch:
.include <bsd.port.options.mk>
do-install:
- @${MKDIR} ${PREFIX}/etc/fido/bforce
- ${INSTALL_DATA} ${WRKSRC}/../examples/bforce.conf ${PREFIX}/etc/fido/bforce/bforce.conf.sample
- ${INSTALL_DATA} ${WRKSRC}/../examples/bforce.passwd ${PREFIX}/etc/fido/bforce/bforce.passwd.sample
- ${INSTALL_DATA} ${WRKSRC}/../examples/bforce.subst ${PREFIX}/etc/fido/bforce/bforce.subst.sample
- ${INSTALL_DATA} ${WRKSRC}/../examples/freq.aliases ${PREFIX}/etc/fido/bforce/freq.aliases.sample
- ${INSTALL_DATA} ${WRKSRC}/../examples/freq.dirs ${PREFIX}/etc/fido/bforce/freq.dirs.sample
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/fido/bforce
+ ${INSTALL_DATA} ${WRKSRC}/../examples/bforce.conf ${STAGEDIR}${PREFIX}/etc/fido/bforce/bforce.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/../examples/bforce.passwd ${STAGEDIR}${PREFIX}/etc/fido/bforce/bforce.passwd.sample
+ ${INSTALL_DATA} ${WRKSRC}/../examples/bforce.subst ${STAGEDIR}${PREFIX}/etc/fido/bforce/bforce.subst.sample
+ ${INSTALL_DATA} ${WRKSRC}/../examples/freq.aliases ${STAGEDIR}${PREFIX}/etc/fido/bforce/freq.aliases.sample
+ ${INSTALL_DATA} ${WRKSRC}/../examples/freq.dirs ${STAGEDIR}${PREFIX}/etc/fido/bforce/freq.dirs.sample
- ${MKDIR} ${DATADIR} ${DATADIR}/bfha ${DATADIR}/u-srif/conf ${DATADIR}/u-srif/lib
+ ${MKDIR} ${STAGEDIR}${DATADIR} ${STAGEDIR}${DATADIR}/bfha ${STAGEDIR}${DATADIR}/u-srif/conf ${STAGEDIR}${DATADIR}/u-srif/lib
.for i in ${CONTRIBS}
- ${INSTALL_DATA} ${WRKSRC}/../contrib/${i} ${DATADIR}/${i}
+ ${INSTALL_DATA} ${WRKSRC}/../contrib/${i} ${STAGEDIR}${DATADIR}/${i}
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/../,} ${DOCSDIR}
-.endif
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/bforce ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/bfindex ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/bfstat ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/nlookup ${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/../,} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/bforce ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/bfindex ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/bfstat ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/nlookup ${STAGEDIR}${PREFIX}/bin
@${SED} -e 's|%%PREFIX%%|${PREFIX}|' -e 's|%%CONFIGDIR%%|etc/fido/bforce|' ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/comms/bforce-kst/pkg-plist b/comms/bforce-kst/pkg-plist
index e757ad3b97df..659d8120fb86 100644
--- a/comms/bforce-kst/pkg-plist
+++ b/comms/bforce-kst/pkg-plist
@@ -1,5 +1,5 @@
-bin/bforce
bin/bfindex
+bin/bforce
bin/bfstat
bin/nlookup
etc/fido/bforce/bforce.conf.sample
@@ -27,10 +27,16 @@ etc/fido/bforce/freq.dirs.sample
%%DATADIR%%/u-srif/u-srif-index.py
%%DATADIR%%/u-srif/u-srif-lookup.py
%%DATADIR%%/u-srif/u-srif.py
-@dirrm etc/fido/bforce
-@dirrm etc/fido
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.kst
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.kst
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/u-srif/lib
@dirrm %%DATADIR%%/u-srif/conf
@dirrm %%DATADIR%%/u-srif
@dirrm %%DATADIR%%/bfha
@dirrm %%DATADIR%%
+@dirrm etc/fido/bforce
+@dirrm etc/fido
diff --git a/comms/bpl+/Makefile b/comms/bpl+/Makefile
index 931abae70f5b..669f7ff5db36 100644
--- a/comms/bpl+/Makefile
+++ b/comms/bpl+/Makefile
@@ -12,9 +12,10 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= B Plus file transfer protocol
-NO_STAGE= yes
+PLIST_FILES= bin/bp bin/bpl
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bpl ${PREFIX}/bin
- @${LN} -fs ${PREFIX}/bin/bpl ${PREFIX}/bin/bp
+ ${INSTALL_PROGRAM} ${WRKSRC}/bpl ${STAGEDIR}${PREFIX}/bin
+ (cd ${STAGEDIR}${PREFIX}/bin; ${LN} -sf bpl bp)
.include <bsd.port.mk>
diff --git a/comms/bpl+/pkg-plist b/comms/bpl+/pkg-plist
deleted file mode 100644
index 34897bbe3c18..000000000000
--- a/comms/bpl+/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/bpl
-bin/bp
diff --git a/comms/callsign/Makefile b/comms/callsign/Makefile
index 4639b7dfc044..fcb37c0f2187 100644
--- a/comms/callsign/Makefile
+++ b/comms/callsign/Makefile
@@ -15,8 +15,7 @@ WRKSRC= ${WRKDIR}
NO_BUILD= YES
PLIST_FILES= bin/callsign
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/callsign ${LOCALBASE}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/callsign ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/comms/cdr_read/Makefile b/comms/cdr_read/Makefile
index 71eb389b59b6..1d2fd298a21a 100644
--- a/comms/cdr_read/Makefile
+++ b/comms/cdr_read/Makefile
@@ -14,19 +14,13 @@ USE_DOS2UNIX= readme_eng.txt
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
NO_WRKSUBDIR= yes
-PLIST_FILES= sbin/cdr_read
-PORTDOCS= *
-
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME} ${PREFIX}/sbin
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/readme_eng.txt ${DOCSDIR}/readme.txt
-.endif
+ ${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/readme_eng.txt ${STAGEDIR}${DOCSDIR}/readme.txt
.include <bsd.port.mk>
diff --git a/comms/cdr_read/pkg-plist b/comms/cdr_read/pkg-plist
new file mode 100644
index 000000000000..16cd4e003af0
--- /dev/null
+++ b/comms/cdr_read/pkg-plist
@@ -0,0 +1,3 @@
+sbin/cdr_read
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/comms/dfu-util/Makefile b/comms/dfu-util/Makefile
index 454d2102b0ce..f956853895b5 100644
--- a/comms/dfu-util/Makefile
+++ b/comms/dfu-util/Makefile
@@ -16,8 +16,6 @@ CONFIGURE_ENV= USE_LIBS="-lusb" \
ac_cv_lib_usbpath_usb_path2devnum=no
CONFIGURE_ARGS= --disable-silent-rules
-MAN1= dfu-util.1
-PLIST_FILES= bin/dfu-suffix bin/dfu-util
+PLIST_FILES= bin/dfu-suffix bin/dfu-util man/man1/${PORTNAME}.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/comms/gkermit/Makefile b/comms/gkermit/Makefile
index 30faaaf00c71..6e1769134e09 100644
--- a/comms/gkermit/Makefile
+++ b/comms/gkermit/Makefile
@@ -11,20 +11,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= File transfer utility using the kermit protocol
NO_WRKSUBDIR= yes
-MAN1= gkermit.1
-PORTDOCS= gkermit.txt
-PLIST_FILES= bin/gkermit
ALL_TARGET= posix
-NO_STAGE= yes
post-extract:
cd ${WRKSRC} && ${MV} makefile Makefile
do-install:
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/gkermit ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/gkermit.nr ${PREFIX}/man/man1/gkermit.1
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/gkermit.txt
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/gkermit ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/gkermit.nr ${STAGEDIR}${PREFIX}/man/man1/gkermit.1
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/gkermit.txt
.include <bsd.port.mk>
diff --git a/comms/gkermit/pkg-plist b/comms/gkermit/pkg-plist
new file mode 100644
index 000000000000..e373e96c5eab
--- /dev/null
+++ b/comms/gkermit/pkg-plist
@@ -0,0 +1,4 @@
+bin/gkermit
+man/man1/gkermit.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/gkermit.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/comms/gpredict/Makefile b/comms/gpredict/Makefile
index 93a18010462c..ab38799725a8 100644
--- a/comms/gpredict/Makefile
+++ b/comms/gpredict/Makefile
@@ -11,17 +11,14 @@ COMMENT= Amateur Radio satellite tracking and prediction
LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= hamlib:${PORTSDIR}/comms/hamlib \
- curl:${PORTSDIR}/ftp/curl \
- goocanvas:${PORTSDIR}/graphics/goocanvas
+LIB_DEPENDS= libhamlib.so:${PORTSDIR}/comms/hamlib \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libgoocanvas.so:${PORTSDIR}/graphics/goocanvas
USES= gettext pathfix gmake pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-MAN1= gpredict.1
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
'/^Icon/s|=.*|=${PREFIX}/share/pixmaps/gpredict-icon.png|' \
diff --git a/comms/gpredict/pkg-plist b/comms/gpredict/pkg-plist
index 2b217b304bd4..0be82851ecc4 100644
--- a/comms/gpredict/pkg-plist
+++ b/comms/gpredict/pkg-plist
@@ -1,4 +1,5 @@
bin/gpredict
+man/man1/gpredict.1.gz
share/applications/gpredict.desktop
%%DATADIR%%/AUTHORS
%%DATADIR%%/COPYING
diff --git a/comms/grig/Makefile b/comms/grig/Makefile
index 8899cab2df58..c14b3f43de06 100644
--- a/comms/grig/Makefile
+++ b/comms/grig/Makefile
@@ -12,15 +12,12 @@ COMMENT= Amateur Radio control front-end
LICENSE= GPLv2
-LIB_DEPENDS= hamlib:${PORTSDIR}/comms/hamlib
+LIB_DEPENDS= libhamlib.so:${PORTSDIR}/comms/hamlib
USE_GNOME= gtk20
GNU_CONFIGURE= yes
USES= gettext gmake pkgconfig
-MAN1= grig.1
-
-NO_STAGE= yes
post-patch:
@${FIND} ${WRKSRC} -name Makefile.* | ${XARGS} ${REINPLACE_CMD} -e \
's|-D.*_DISABLE_DEPRECATED||g'
diff --git a/comms/grig/pkg-plist b/comms/grig/pkg-plist
index c66f72d3a6c1..b60f13288cbd 100644
--- a/comms/grig/pkg-plist
+++ b/comms/grig/pkg-plist
@@ -1,17 +1,18 @@
bin/grig
+lib/locale/fr/LC_MESSAGES/grig.mo
+man/man1/grig.1.gz
%%DATADIR%%/AUTHORS
%%DATADIR%%/COPYING
%%DATADIR%%/ChangeLog
%%DATADIR%%/NEWS
%%DATADIR%%/README
-lib/locale/fr/LC_MESSAGES/grig.mo
share/pixmaps/grig/digits_normal.png
share/pixmaps/grig/digits_small.png
share/pixmaps/grig/grig-logo.png
share/pixmaps/grig/ic910.png
share/pixmaps/grig/smeter.png
+@dirrm share/pixmaps/grig
+@dirrm %%DATADIR%%
@dirrmtry lib/locale/fr/LC_MESSAGES
@dirrmtry lib/locale/fr
@dirrmtry lib/locale
-@dirrm share/pixmaps/grig
-@dirrm %%DATADIR%%
diff --git a/comms/gsmlib/Makefile b/comms/gsmlib/Makefile
index 122ff5660219..809aa584273c 100644
--- a/comms/gsmlib/Makefile
+++ b/comms/gsmlib/Makefile
@@ -18,15 +18,10 @@ USES= gmake
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-MAN1= gsmctl.1 gsmpb.1 gsmsendsms.1 gsmsmsstore.1
-MAN7= gsminfo.7
-MAN8= gsmsmsd.8
-
CPPFLAGS+= -I${LOCALBASE}/include -DBROKEN_STRFTIME -DHAVE_DECL_GETOPT \
${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/comms/gsmlib/pkg-plist b/comms/gsmlib/pkg-plist
index 164a58a6b8f4..95caf26724c5 100644
--- a/comms/gsmlib/pkg-plist
+++ b/comms/gsmlib/pkg-plist
@@ -31,5 +31,11 @@ lib/libgsmme.a
lib/libgsmme.la
lib/libgsmme.so
lib/libgsmme.so.1
+man/man1/gsmctl.1.gz
+man/man1/gsmpb.1.gz
+man/man1/gsmsendsms.1.gz
+man/man1/gsmsmsstore.1.gz
+man/man7/gsminfo.7.gz
+man/man8/gsmsmsd.8.gz
%%NLS%%share/locale/de/LC_MESSAGES/gsmlib.mo
@dirrm include/gsmlib
diff --git a/comms/nokryptia/Makefile b/comms/nokryptia/Makefile
index 596d86251c6c..94a52411c899 100644
--- a/comms/nokryptia/Makefile
+++ b/comms/nokryptia/Makefile
@@ -10,15 +10,13 @@ MASTER_SITES= http://tuxmobil.org/software/nokryptia/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool for fast loading mp3s into Nokia 5510
-LIB_DEPENDS= id3-3.8:${PORTSDIR}/audio/id3lib
+LIB_DEPENDS= libid3-3.so:${PORTSDIR}/audio/id3lib
GNU_CONFIGURE= yes
USE_BZIP2= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
-MAN1= nokryptia.1
-PLIST_FILES= bin/nokryptia
+PLIST_FILES= bin/nokryptia man/man1/${PORTNAME}.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/comms/nokryptia/files/patch-nokryptia.cc b/comms/nokryptia/files/patch-nokryptia.cc
new file mode 100644
index 000000000000..5427267e5932
--- /dev/null
+++ b/comms/nokryptia/files/patch-nokryptia.cc
@@ -0,0 +1,174 @@
+--- src/nokryptia.cc.orig 2013-11-17 23:12:21.000000000 +0800
++++ src/nokryptia.cc 2013-11-17 23:14:38.000000000 +0800
+@@ -20,7 +20,7 @@
+ */
+
+ #include <stdio.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <string.h>
+ #include <getopt.h>
+ #include "config.h"
+@@ -40,21 +40,21 @@ int verbose;
+ int action; /* 1 for upload, 2 for download */
+
+ void writeHelpMessage(const char * progname) {
+- cout << PACKAGE << " version " << VERSION
+- << " copyright by Roel Derickx" << endl
++ std::cout << PACKAGE << " version " << VERSION
++ << " copyright by Roel Derickx" << std::endl
+ << "THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY! "
+- << "USE AT YOUR OWN RISK!" << endl << endl
+- << "Usage:" << endl
+- << " " << progname << " [options] file" << endl
+- << "Options:" << endl
+- << " -u convert mp3 into lse for upload" << endl
+- << " -d convert lse into mp3 for download" << endl
+- << " -a <artistname> set artist to artistname" << endl
+- << " -t <songtitle> set title to songtitle" << endl
+- << " -o <directory> directory to where output files should be written" << endl
+- << " -v be verbose" << endl
+- << " -h print this help screen" << endl
+- << "See the man page for more information" << endl;
++ << "USE AT YOUR OWN RISK!" << std::endl << std::endl
++ << "Usage:" << std::endl
++ << " " << progname << " [options] file" << std::endl
++ << "Options:" << std::endl
++ << " -u convert mp3 into lse for upload" << std::endl
++ << " -d convert lse into mp3 for download" << std::endl
++ << " -a <artistname> set artist to artistname" << std::endl
++ << " -t <songtitle> set title to songtitle" << std::endl
++ << " -o <directory> directory to where output files should be written" << std::endl
++ << " -v be verbose" << std::endl
++ << " -h print this help screen" << std::endl
++ << "See the man page for more information" << std::endl;
+ }
+
+ /*
+@@ -83,7 +83,7 @@ int parseInputFiles(int argc, char *argv
+ /* also remove the path from infilename */
+
+ if (optind >= argc) {
+- cout << "No input file given!" << endl;
++ std::cout << "No input file given!" << std::endl;
+ return 1;
+ }
+ strcpy(infilename, argv[optind++]);
+@@ -104,15 +104,15 @@ int parseInputFiles(int argc, char *argv
+ switch (action) {
+ case 1:
+ if (looknchange(outfilename,".mp3",".lse") != 0) {
+- cout << "Input file must have mp3 "
+- << "extension!" << endl;
++ std::cout << "Input file must have mp3 "
++ << "extension!" << std::endl;
+ return 1;
+ }
+ break;
+ case 2:
+ if (looknchange(outfilename,".lse",".mp3") != 0) {
+- cout << "Input file must have lse "
+- << "extension!" << endl;
++ std::cout << "Input file must have lse "
++ << "extension!" << std::endl;
+ return 1;
+ }
+ break;
+@@ -167,7 +167,7 @@ int parseOptions(int argc, char * argv[]
+ strcat(outfilename,"\0");
+ break;
+ default:
+- cout << "Unknown option " << optopt << endl;
++ std::cout << "Unknown option " << optopt << std::endl;
+ } /* end of switch */
+ } /* end of while */
+
+@@ -198,9 +198,9 @@ void makeTag(char * artist, char * title
+ int lengthTitle = strlen(title);
+
+ if (verbose) {
+- cout << "Writing tag to output :" << endl;
+- cout << "artistname = " << artist << endl;
+- cout << "songtitle = " << title << endl;
++ std::cout << "Writing tag to output :" << std::endl;
++ std::cout << "artistname = " << artist << std::endl;
++ std::cout << "songtitle = " << title << std::endl;
+ }
+
+ /* allocate memory */
+@@ -235,7 +235,7 @@ void makeHeader() {
+ char * buf;
+ int i;
+
+- if (verbose) cout << "Writing LockStream key to output" << endl;
++ if (verbose) std::cout << "Writing LockStream key to output" << std::endl;
+
+ /* allocate memory */
+ buf = new char[512];
+@@ -266,8 +266,8 @@ int readAndTestHeader() {
+ char * buf;
+
+ if (verbose) {
+- cout << "Testing if the lse file is not written by "
+- << "the Nokia Audio Manager" << endl;
++ std::cout << "Testing if the lse file is not written by "
++ << "the Nokia Audio Manager" << std::endl;
+ }
+
+ /* allocate memory */
+@@ -276,7 +276,7 @@ int readAndTestHeader() {
+
+ bread = fread(buf,1,896,infile);
+ if (bread != 896) {
+- cout << "Input file is too small!" << endl;
++ std::cout << "Input file is too small!" << std::endl;
+ return 0;
+ }
+
+@@ -301,7 +301,7 @@ void copyData() {
+ int bread, bwritten;
+ char * buf;
+
+- if (verbose) cout << "Writing data to output" << endl;
++ if (verbose) std::cout << "Writing data to output" << std::endl;
+
+ /* allocate memory */
+ buf = new char[COPYBUFSIZE];
+@@ -347,8 +347,8 @@ int main(int argc, char * argv[]) {
+
+ /* open the infile */
+ if ((infile = fopen(infilename,"rb")) == NULL) {
+- cout << infilename
+- << ": No such file or directory" << endl;
++ std::cout << infilename
++ << ": No such file or directory" << std::endl;
+
+ cleanUpMemory();
+
+@@ -358,10 +358,10 @@ int main(int argc, char * argv[]) {
+
+ /* open the outfile */
+ if ((outfile = fopen(outfilename,"wb")) == NULL) {
+- cout << "An error occured while opening "
+- << outfilename << " for writing." << endl
++ std::cout << "An error occured while opening "
++ << outfilename << " for writing." << std::endl
+ << "Do you have write permission "
+- << "in this directory?" << endl;
++ << "in this directory?" << std::endl;
+
+ cleanUpMemory();
+
+@@ -383,9 +383,9 @@ int main(int argc, char * argv[]) {
+ copyData();
+ }
+ else {
+- cout << "This file was encrypted by the "
+- << "official nokia program." << endl
+- << "Unable to decrypt!" << endl;
++ std::cout << "This file was encrypted by the "
++ << "official nokia program." << std::endl
++ << "Unable to decrypt!" << std::endl;
+ }
+ }
+
diff --git a/comms/serialoverip/Makefile b/comms/serialoverip/Makefile
index c5575b6a1dc9..cdad7f375869 100644
--- a/comms/serialoverip/Makefile
+++ b/comms/serialoverip/Makefile
@@ -11,11 +11,10 @@ COMMENT= Transport of serial interfaces over UDP/IP
PLIST_FILES= sbin/${PORTNAME}
-NO_STAGE= yes
do-build:
@cd ${WRKSRC}; ${CC} ${CFLAGS} ${PORTNAME}.c -o ${PORTNAME}
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin/
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin/
.include <bsd.port.mk>
diff --git a/comms/seyon/Makefile b/comms/seyon/Makefile
index 4570f0d81705..fb0bc2228997 100644
--- a/comms/seyon/Makefile
+++ b/comms/seyon/Makefile
@@ -17,9 +17,8 @@ USES= imake
USE_XORG= x11 xext xpm xmu xaw xt sm ice
MAKE_JOBS_UNSAFE= yes
-MAN1= seyon.1
PLIST_FILES= bin/seyon lib/X11/app-defaults/Seyon \
- lib/X11/app-defaults/Seyon-color lib/X11/seyon.help
+ lib/X11/app-defaults/Seyon-color lib/X11/seyon.help \
+ man/man1/${PORTNAME}.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/comms/sredird/Makefile b/comms/sredird/Makefile
index 770a903b5935..3d8b1f1db3f7 100644
--- a/comms/sredird/Makefile
+++ b/comms/sredird/Makefile
@@ -13,22 +13,14 @@ COMMENT= RFC 2217 compliant serial port redirector
LICENSE= GPLv2
-PLIST_FILES= libexec/sredird
-PORTDOCS= README
-
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
do-build:
${CC} ${CFLAGS} -Wall -o ${WRKSRC}/sredird ${WRKSRC}/sredird.c
-.include <bsd.port.options.mk>
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sredird ${PREFIX}/libexec
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/sredird ${STAGEDIR}${PREFIX}/libexec
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/comms/sredird/pkg-plist b/comms/sredird/pkg-plist
new file mode 100644
index 000000000000..0331017aa79c
--- /dev/null
+++ b/comms/sredird/pkg-plist
@@ -0,0 +1,3 @@
+libexec/sredird
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/comms/tkscanfax/Makefile b/comms/tkscanfax/Makefile
index ee5ef2695b2b..73b65b5a7acb 100644
--- a/comms/tkscanfax/Makefile
+++ b/comms/tkscanfax/Makefile
@@ -20,18 +20,17 @@ PLIST_SUB= TKSCANFAXDIR="${TKSCANFAXDIR:S,^${PREFIX}/,,}"
TKSCANFAXDIR= ${PREFIX}/lib/tkscanfax1
-NO_STAGE= yes
post-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -i '' -e \
's|/usr/local/lib|${PREFIX}/lib|g'
do-install:
- @${MKDIR} ${TKSCANFAXDIR}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${TKSCANFAXDIR})
+ @${MKDIR} ${STAGEDIR}${TKSCANFAXDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${TKSCANFAXDIR})
.for file in tkfax tkscan
- ${CHMOD} ${BINMODE} ${TKSCANFAXDIR}/${file}
- ${CHOWN} ${BINOWN}:${BINGRP} ${TKSCANFAXDIR}/${file}
- ${LN} -sf ${TKSCANFAXDIR}/${file} ${PREFIX}/bin
+ ${CHMOD} ${BINMODE} ${STAGEDIR}${TKSCANFAXDIR}/${file}
+ ${CHOWN} ${BINOWN}:${BINGRP} ${STAGEDIR}${TKSCANFAXDIR}/${file}
+ ${LN} -sf ${TKSCANFAXDIR}/${file} ${STAGEDIR}${PREFIX}/bin
.endfor
.include <bsd.port.mk>
diff --git a/comms/tkscanfax/pkg-plist b/comms/tkscanfax/pkg-plist
index b37b0fe27608..1d746235ad01 100644
--- a/comms/tkscanfax/pkg-plist
+++ b/comms/tkscanfax/pkg-plist
@@ -1,3 +1,5 @@
+bin/tkfax
+bin/tkscan
%%TKSCANFAXDIR%%/Makefile
%%TKSCANFAXDIR%%/doc/C/Config_Help.html
%%TKSCANFAXDIR%%/doc/C/Cover_Page_Help.html
@@ -90,10 +92,6 @@
%%TKSCANFAXDIR%%/tkscan
%%TKSCANFAXDIR%%/tkscan.desktop
%%TKSCANFAXDIR%%/tkscanfax.spec
-@exec /bin/ln -sf %D/%%TKSCANFAXDIR%%/tkfax %D/bin
-@exec /bin/ln -sf %D/%%TKSCANFAXDIR%%/tkscan %D/bin
-@unexec /bin/rm -f %D/bin/tkfax
-@unexec /bin/rm -f %D/bin/tkscan
@dirrm %%TKSCANFAXDIR%%/tex
@dirrm %%TKSCANFAXDIR%%/scan-drivers
@dirrm %%TKSCANFAXDIR%%/images
diff --git a/comms/xdx/Makefile b/comms/xdx/Makefile
index 88d80a50be35..25cd3b8b2e2f 100644
--- a/comms/xdx/Makefile
+++ b/comms/xdx/Makefile
@@ -16,10 +16,8 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
USES= gmake pkgconfig
-MAN1= xdx.1
LICENSE= GPLv2
-NO_STAGE= yes
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|-D.*_DISABLE_DEPRECATED||g'
diff --git a/comms/xdx/pkg-plist b/comms/xdx/pkg-plist
index e2dda3813382..ca6b8a087fd7 100644
--- a/comms/xdx/pkg-plist
+++ b/comms/xdx/pkg-plist
@@ -1,5 +1,11 @@
bin/xdx
+man/man1/xdx.1.gz
share/applications/Xdx.desktop
+share/locale/es/LC_MESSAGES/xdx.mo
+share/locale/fr/LC_MESSAGES/xdx.mo
+share/locale/nl/LC_MESSAGES/xdx.mo
+share/locale/pl/LC_MESSAGES/xdx.mo
+share/locale/pt/LC_MESSAGES/xdx.mo
%%DATADIR%%/MANUAL
%%DATADIR%%/MANUAL.es
%%DATADIR%%/MANUAL.fr
@@ -22,8 +28,3 @@ share/applications/Xdx.desktop
@dirrm %%DATADIR%%/sounds
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%
-share/locale/es/LC_MESSAGES/xdx.mo
-share/locale/fr/LC_MESSAGES/xdx.mo
-share/locale/nl/LC_MESSAGES/xdx.mo
-share/locale/pl/LC_MESSAGES/xdx.mo
-share/locale/pt/LC_MESSAGES/xdx.mo
diff --git a/comms/yaps/Makefile b/comms/yaps/Makefile
index 34d08381427f..7944c8e07dfc 100644
--- a/comms/yaps/Makefile
+++ b/comms/yaps/Makefile
@@ -15,22 +15,12 @@ LICENSE= GPLv2
USES= gmake
-MAN1= yaps.1
-PLIST_FILES= bin/yaps etc/yaps.rc.sample
-PORTDOCS= yaps.doc yaps.html
-PORTDATA= *
-
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-install:
- ${INSTALL_DATA} ${WRKSRC}/yaps.rc ${PREFIX}/etc/yaps.rc.sample
- ${INSTALL_MAN} ${WRKSRC}/yaps.1 ${PREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/yaps.doc ${WRKSRC}/yaps.html ${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/yaps.rc ${STAGEDIR}${PREFIX}/etc/yaps.rc.sample
+ ${INSTALL_MAN} ${WRKSRC}/yaps.1 ${STAGEDIR}${PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/yaps.doc ${WRKSRC}/yaps.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/comms/yaps/files/patch-Makefile b/comms/yaps/files/patch-Makefile
new file mode 100644
index 000000000000..58eb808e59ec
--- /dev/null
+++ b/comms/yaps/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2013-11-17 23:01:50.000000000 +0800
++++ Makefile 2013-11-17 23:04:00.000000000 +0800
+@@ -33,15 +33,15 @@ yaps.doc: yaps.html
+ lynx -cfg=/dev/null -nolist -dump $< > $@
+
+ install: $(DSTFLE) $(CFGFILE)
+- if [ ! -d $(YAPS_LIBDIR) ]; then \
+- install -d -m 755 -o $(YAPS_USER) -g $(YAPS_GROUP) $(YAPS_LIBDIR) ; \
++ if [ ! -d $(DESTDIR)$(YAPS_LIBDIR) ]; then \
++ install -d -m 755 -o $(YAPS_USER) -g $(YAPS_GROUP) $(DESTDIR)$(YAPS_LIBDIR) ; \
+ fi
+ @if [ -f contrib/Makefile ]; then \
+ $(MAKE) -C contrib install ; \
+ fi
+
+ $(DSTFLE): yaps
+- install -o $(YAPS_USER) -g $(YAPS_GROUP) -m $(YAPS_MODE) -s yaps $@
++ install -o $(YAPS_USER) -g $(YAPS_GROUP) -m $(YAPS_MODE) -s yaps $(DESTDIR)$@
+
+ $(CFGFILE): yaps.rc
+ @if [ ! -f $@ ]; then \
diff --git a/comms/yaps/pkg-plist b/comms/yaps/pkg-plist
new file mode 100644
index 000000000000..535d0b5fee38
--- /dev/null
+++ b/comms/yaps/pkg-plist
@@ -0,0 +1,6 @@
+bin/yaps
+etc/yaps.rc.sample
+man/man1/yaps.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/yaps.doc
+%%PORTDOCS%%%%DOCSDIR%%/yaps.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/comms/zssh/Makefile b/comms/zssh/Makefile
index 308c3f8540e7..aa2e9b4cb0da 100644
--- a/comms/zssh/Makefile
+++ b/comms/zssh/Makefile
@@ -15,10 +15,8 @@ RUN_DEPENDS= lrz:${PORTSDIR}/comms/lrzsz
HAS_CONFIGURE= yes
-PLIST_FILES= bin/zssh bin/ztelnet
-MAN1= zssh.1 ztelnet.1
+PLIST_FILES= bin/zssh bin/ztelnet man/man1/zssh.1.gz man/man1/ztelnet.1.gz
-NO_STAGE= yes
post-configure:
@${REINPLACE_CMD} -e 's,^prefix.*,prefix = ${PREFIX},g' ${WRKSRC}/Makefile
diff --git a/comms/zssh/files/patch-Makefile.in b/comms/zssh/files/patch-Makefile.in
new file mode 100644
index 000000000000..864229dec4df
--- /dev/null
+++ b/comms/zssh/files/patch-Makefile.in
@@ -0,0 +1,15 @@
+--- Makefile.in.orig 2013-11-17 23:06:21.000000000 +0800
++++ Makefile.in 2013-11-17 23:07:02.000000000 +0800
+@@ -75,9 +75,9 @@ ztelnet : $(NAME)
+
+ install :
+ strip $(NAME)
+- $(INSTALL) -m 0711 zssh @bindir@
+- ln -f @bindir@/zssh @bindir@/ztelnet
+- $(INSTALL) -m 0644 $(MANS) @mandir@/man1
++ $(INSTALL) -m 0711 zssh $(DESTDIR)@bindir@
++ (cd $(DESTDIR)@bindir@; ln -f zssh ztelnet)
++ $(INSTALL) -m 0644 $(MANS) $(DESTDIR)@mandir@/man1
+
+ uninstall :
+ -cd @bindir@ && rm $(PRGS)