aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>2015-11-10 20:08:45 +0000
committerWarner Losh <imp@FreeBSD.org>2015-11-10 20:08:45 +0000
commit592864cb0f7d87bdaef08dd80672eb125cc56685 (patch)
tree8def0ca98e2914cbd0db3cd3a75faad13c305ff4
parent2a93f197e3ba42bce3b112af8c20c3267ec27b91 (diff)
downloadports-592864cb0f7d87bdaef08dd80672eb125cc56685.tar.gz
ports-592864cb0f7d87bdaef08dd80672eb125cc56685.zip
Notes
-rw-r--r--devel/arm-none-eabi-gdb/Makefile29
-rw-r--r--devel/arm-none-eabi-gdb/distinfo2
-rw-r--r--devel/arm-none-eabi-gdb/pkg-descr8
-rw-r--r--devel/arm-none-eabi-gdb/pkg-plist1
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/arm-none-eabi-gdb/Makefile b/devel/arm-none-eabi-gdb/Makefile
new file mode 100644
index 000000000000..bcbdb0870522
--- /dev/null
+++ b/devel/arm-none-eabi-gdb/Makefile
@@ -0,0 +1,29 @@
+# Created by: M. Warner Losh <imp@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= gdb
+PORTVERSION= 7.10
+PORTREVISION= 4
+CATEGORIES= devel
+MASTER_SITES= GNU
+PKGNAMEPREFIX= arm-none-eabi-
+DISTNAME= gdb-${PORTVERSION}
+
+MAINTAINER= imp@FreeBSD.org
+COMMENT= GNU GDB for the arm bare metal target
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
+
+USES= gmake tar:xz iconv gmake libtool
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --target=arm-none-eabi --program-prefix=arm-none-eabi- --disable-nls \
+ --disable-werror
+
+pre-configure:
+ cd ${WRKSRC} ; ${RM} -rf dejagnu expect tcl texinfo
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb \
+ ${STAGEDIR}${PREFIX}/bin/${PKGNAMEPREFIX}${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/arm-none-eabi-gdb/distinfo b/devel/arm-none-eabi-gdb/distinfo
new file mode 100644
index 000000000000..7640812397e3
--- /dev/null
+++ b/devel/arm-none-eabi-gdb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gdb-7.10.tar.xz) = 7ebdaa44f9786ce0c142da4e36797d2020c55fa091905ac5af1846b5756208a8
+SIZE (gdb-7.10.tar.xz) = 18540820
diff --git a/devel/arm-none-eabi-gdb/pkg-descr b/devel/arm-none-eabi-gdb/pkg-descr
new file mode 100644
index 000000000000..e6615e385bf5
--- /dev/null
+++ b/devel/arm-none-eabi-gdb/pkg-descr
@@ -0,0 +1,8 @@
+This is the GNU Debugger GDB, configured for the AVR microcontroller
+target.
+
+This debugger cannot really be used standalone, but is useful in
+connection with either AVaRICE (http://avarice.sourceforge.net/)
+or simulavr (http://www.freesoftware.fsf.org/simulavr/).
+
+WWW: http://www.gnu.org/software/gdb/
diff --git a/devel/arm-none-eabi-gdb/pkg-plist b/devel/arm-none-eabi-gdb/pkg-plist
new file mode 100644
index 000000000000..cab9ef949d11
--- /dev/null
+++ b/devel/arm-none-eabi-gdb/pkg-plist
@@ -0,0 +1 @@
+bin/arm-none-eabi-gdb