aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-06-02 04:49:36 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-06-02 04:49:36 +0000
commit5984aee4deac75408cd67917ca3b1e31fa7d5d41 (patch)
tree5c76612826a88a1f6625dc1f92e866948895deeb
parentbd8d25a2d69ed036c7a731829007c97146c0cdd1 (diff)
Add missing conflicts
Submitted by: Sulev-Madis "ketas" Silber <madis555@hot.ee> Approved by: tj (maintainer)
Notes
Notes: svn path=/head/; revision=297987
-rw-r--r--devel/cdecl/Makefile2
-rw-r--r--devel/cutils/Makefile2
-rw-r--r--textproc/html2text/Makefile2
-rw-r--r--textproc/py-html2text/Makefile2
4 files changed, 8 insertions, 0 deletions
diff --git a/devel/cdecl/Makefile b/devel/cdecl/Makefile
index fb45ba7cd4ca..54b591985631 100644
--- a/devel/cdecl/Makefile
+++ b/devel/cdecl/Makefile
@@ -22,6 +22,8 @@ MLINKS= cdecl.1 c++decl.1
PORTDOCS= testset testset++
PLIST_FILES= bin/cdecl bin/c++decl
+CONFLICTS= cutils-[0-9]*
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/devel/cutils/Makefile b/devel/cutils/Makefile
index b5de819402f6..4a255790bdce 100644
--- a/devel/cutils/Makefile
+++ b/devel/cutils/Makefile
@@ -22,4 +22,6 @@ PLIST_FILES= bin/cdecl bin/chilight bin/cobfusc bin/cundecl bin/cunloop \
bin/yyextract bin/yyref
MAKE_JOBS_UNSAFE= yes
+CONFLICTS= cdecl-[0-9]*
+
.include <bsd.port.mk>
diff --git a/textproc/html2text/Makefile b/textproc/html2text/Makefile
index 08d53d5ec368..d15b5f5dfd10 100644
--- a/textproc/html2text/Makefile
+++ b/textproc/html2text/Makefile
@@ -24,6 +24,8 @@ MAN5= html2textrc.5
PORTDOCS= CHANGES CREDITS KNOWN_BUGS README TODO
PLIST_FILES= bin/html2text
+CONFLICTS= py27-html2text-[0-9.]*
+
post-patch:
@${REINPLACE_CMD} -e '/echo=/s/ -e//' ${WRKSRC}/configure
.for file in Makefile.in libstd/Makefile.in
diff --git a/textproc/py-html2text/Makefile b/textproc/py-html2text/Makefile
index 186ae27be0df..a8e02c85ab6a 100644
--- a/textproc/py-html2text/Makefile
+++ b/textproc/py-html2text/Makefile
@@ -17,4 +17,6 @@ COMMENT= Convert HTML into clean plain ASCII text
USE_PYTHON= yes
USE_PYDISTUTILS=easy_install
+CONFLICTS= html2text-[0-9]*
+
.include <bsd.port.mk>