aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-06-25 06:12:16 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-06-25 06:12:16 +0000
commit59d6ceb78918c7023c0e286dc69ab26028caf270 (patch)
treee36aabe977b2e4fccc6787489c502363307297f8
parent918067bf2f13ead2636c38908839fc982827755f (diff)
downloadports-59d6ceb78918c7023c0e286dc69ab26028caf270.tar.gz
ports-59d6ceb78918c7023c0e286dc69ab26028caf270.zip
Notes
-rw-r--r--cad/ngspice_rework/Makefile6
-rw-r--r--cad/ngspice_rework/distinfo6
-rw-r--r--cad/ngspice_rework/files/patch-configure.ac34
-rw-r--r--cad/ngspice_rework/files/patch-src_frontend_com__sysinfo.c37
-rw-r--r--cad/ngspice_rework/pkg-plist1
5 files changed, 78 insertions, 6 deletions
diff --git a/cad/ngspice_rework/Makefile b/cad/ngspice_rework/Makefile
index db10d9560a43..f19571e35603 100644
--- a/cad/ngspice_rework/Makefile
+++ b/cad/ngspice_rework/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ngspice_rework
-PORTVERSION= 31
+PORTVERSION= 32
CATEGORIES= cad
MASTER_SITES= SF/ngspice/ng-spice-rework/${PORTVERSION}
DISTNAME= ngspice-${PORTVERSION}
@@ -21,7 +21,7 @@ shlib_PKGNAMESUFFIX= -shlib
shlib_CONFLICTS_INSTALL= ngspice_rework-2*
x11_CONFLICTS_INSTALL= ngspice_rework-shlib-2*
-USES= gmake libtool ncurses readline
+USES= gmake libtool ncurses readline autoreconf pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -35,7 +35,7 @@ CONFIGURE_ARGS+= --with-ngshared
PLIST_SUB+= SHLIB="" X11="@comment "
.else
USES+= xorg
-USE_XORG= ice sm x11 xaw xext xmu xt
+USE_XORG= ice sm x11 xaw xext xmu xt xft
CONFIGURE_ARGS+= --with-x
PLIST_SUB+= SHLIB="@comment " X11=""
.endif
diff --git a/cad/ngspice_rework/distinfo b/cad/ngspice_rework/distinfo
index 72bdb9d60037..7da6acae5f89 100644
--- a/cad/ngspice_rework/distinfo
+++ b/cad/ngspice_rework/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1572299061
-SHA256 (ngspice-31.tar.gz) = 845f3b0c962e47ded051dfbc134c3c1e4ac925c9f0ce1cb3df64eb9b9da5c282
-SIZE (ngspice-31.tar.gz) = 7250057
+TIMESTAMP = 1588964866
+SHA256 (ngspice-32.tar.gz) = 3cd90c4e94516d87c5b4d02a3a6405b1136b25d05c871d4fee1fd7c4c0d03ef2
+SIZE (ngspice-32.tar.gz) = 7728816
diff --git a/cad/ngspice_rework/files/patch-configure.ac b/cad/ngspice_rework/files/patch-configure.ac
new file mode 100644
index 000000000000..4dfd008d057f
--- /dev/null
+++ b/cad/ngspice_rework/files/patch-configure.ac
@@ -0,0 +1,34 @@
+--- configure.ac.orig 2020-05-06 06:11:56 UTC
++++ configure.ac
+@@ -707,7 +707,6 @@ fi
+ # Xft is optional, allows text rotation in plots
+
+ if test "x$no_x" != xyes ; then
+- X_CFLAGS="$X_CFLAGS -I/usr/include/freetype2"
+ AC_CHECK_LIB([Xaw], [main], [X_LIBS="$X_LIBS -lXaw"],
+ [AC_MSG_ERROR([Couldn't find Xaw library])], [$X_LIBS $X_EXTRA_LIBS])
+ AC_CHECK_LIB([Xmu], [main], [X_LIBS="$X_LIBS -lXmu"],
+@@ -716,21 +715,8 @@ if test "x$no_x" != xyes ; then
+ AC_CHECK_LIB([Xext], [XShmAttach], [X_LIBS="$X_LIBS -lXext"],
+ [AC_MSG_ERROR([Couldn't find Xext library])], [$X_LIBS $X_EXTRA_LIBS])
+ X_LIBS="$X_LIBS -lX11"
+- AC_CHECK_LIB([Xft], [main],
+- [AC_DEFINE([HAVE_LIBXFT], [1], [Have xft routines in libxft])]
+- X_LIBS="$X_LIBS -lXft -lfontconfig -lXrender -lfreetype"
+- has_xft=yes,
+- [has_xft=no], [$X_LIBS $X_EXTRA_LIBS])
+-
+- if test "x$has_xft" = xyes ; then
+- AC_CHECK_LIB([fontconfig], [main], [],
+- [AC_MSG_ERROR([Couldn't find fontconfig library])], [$X_LIBS $X_EXTRA_LIBS])
+-# AC_CHECK_LIB([Xrender], [main], [],
+-# [AC_MSG_ERROR([Couldn't find Xrender library])], [$X_LIBS $X_EXTRA_LIBS])
+- AC_CHECK_LIB([freetype], [main], [],
+- [AC_MSG_ERROR([Couldn't find freetype library])], [$X_LIBS $X_EXTRA_LIBS])
+- fi
+-
++ PKG_CHECK_MODULES([XFT], [xft], [X_CFLAGS="$X_CFLAGS $XFT_CFLAGS"; X_LIBS="$X_LIBS $XFT_LIBS"],
++ [AC_MSG_ERROR([Couldn't find freetype library])])
+ has_no_x=false
+ else
+ AC_DEFINE([X_DISPLAY_MISSING])
diff --git a/cad/ngspice_rework/files/patch-src_frontend_com__sysinfo.c b/cad/ngspice_rework/files/patch-src_frontend_com__sysinfo.c
new file mode 100644
index 000000000000..43b9d739a995
--- /dev/null
+++ b/cad/ngspice_rework/files/patch-src_frontend_com__sysinfo.c
@@ -0,0 +1,37 @@
+--- src/frontend/com_sysinfo.c.orig 2020-05-06 06:11:56 UTC
++++ src/frontend/com_sysinfo.c
+@@ -396,18 +396,6 @@ static void set_static_system_info(void)
+ return;
+ } /* end of function set_static_system_info */
+
+-#elif defined(__APPLE__) && defined(__MACH__)
+-/* Get memory information */
+-static int get_sysmem(struct sys_memory *memall)
+-{
+- fprintf(stderr, "System memory info is not available\n");
+- return -1;
+-}
+-/* Get system information */
+-static void set_static_system_info(void)
+-{
+-}
+-
+ #elif defined(_WIN32)
+
+ /* Get memory information */
+@@ -972,9 +960,14 @@ static void get_physical_processor_count(void)
+ return;
+ } /* end of function get_physical_processor_count */
+
++#else /* no Windows OS, no proc info file system */
+
++static int get_sysmem(struct sys_memory *memall)
++{
++ fprintf(stderr, "System memory info is not available\n");
++ return -1;
++}
+
+-#else /* no Windows OS, no proc info file system */
+ void set_static_system_info(void)
+ {
+ /* Set to no data available */
diff --git a/cad/ngspice_rework/pkg-plist b/cad/ngspice_rework/pkg-plist
index 223285e9eaf7..c4723abba754 100644
--- a/cad/ngspice_rework/pkg-plist
+++ b/cad/ngspice_rework/pkg-plist
@@ -135,6 +135,7 @@ include/ngspice/twodev.h
include/ngspice/twomesh.h
include/ngspice/typedefs.h
include/ngspice/wallace.h
+include/ngspice/wincolornames.h
include/ngspice/wordlist.h
include/ngspice/wstdio.h
share/ngspice/scripts/ciderinit