aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-22 01:26:48 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-08-22 01:26:48 +0000
commit5a56867b69c337cedb5054ae7f54fe8e3cd83046 (patch)
tree8d19eec88188aa21606ffce7296ac58a2a620d7b
parentfdde528fecb46d378da500b997ca8917a2311766 (diff)
downloadports-5a56867b69c337cedb5054ae7f54fe8e3cd83046.tar.gz
ports-5a56867b69c337cedb5054ae7f54fe8e3cd83046.zip
Notes
-rw-r--r--lang/polyml/Makefile7
-rw-r--r--lang/polyml/distinfo6
-rw-r--r--lang/polyml/files/patch-Makefile.in11
3 files changed, 19 insertions, 5 deletions
diff --git a/lang/polyml/Makefile b/lang/polyml/Makefile
index b6e6df78dbdd..6078db060ccb 100644
--- a/lang/polyml/Makefile
+++ b/lang/polyml/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= polyml
-PORTVERSION= 5.2.1
+PORTVERSION= 5.3
CATEGORIES= lang
MASTER_SITES= SF
DISTNAME= ${PORTNAME}.${PORTVERSION}
@@ -15,6 +15,9 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= beyert@cs.ucr.edu
COMMENT= Fast open-source implementation of Standard ML
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-x
USE_LDCONFIG= yes
@@ -27,7 +30,7 @@ PLIST_FILES= bin/poly \
lib/libpolyml.a \
lib/libpolyml.la \
lib/libpolyml.so \
- lib/libpolyml.so.1
+ lib/libpolyml.so.2
MAN1= poly.1 polyimport.1
MANCOMPRESSED= no
diff --git a/lang/polyml/distinfo b/lang/polyml/distinfo
index c6da0ef9dca1..a3000af15bd5 100644
--- a/lang/polyml/distinfo
+++ b/lang/polyml/distinfo
@@ -1,3 +1,3 @@
-MD5 (polyml/polyml.5.2.1.tar.gz) = 303ba7d26c262999685ddd54b36dd16b
-SHA256 (polyml/polyml.5.2.1.tar.gz) = c84148ae9a28e782f48208bcb8c5b82ee7bfdc178784fe81694cf1f0789ae62e
-SIZE (polyml/polyml.5.2.1.tar.gz) = 4114551
+MD5 (polyml/polyml.5.3.tar.gz) = c4e3a33307c4465c4f068ae4fa225ced
+SHA256 (polyml/polyml.5.3.tar.gz) = 154e836f4e65b5c72f8190d3c02e5ed237921cef716cb49add1e0e1e35fb2af4
+SIZE (polyml/polyml.5.3.tar.gz) = 5289077
diff --git a/lang/polyml/files/patch-Makefile.in b/lang/polyml/files/patch-Makefile.in
new file mode 100644
index 000000000000..94c6304d2c1c
--- /dev/null
+++ b/lang/polyml/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- libpolyml/Makefile.in.orig 2009-10-06 01:14:17.000000000 -0700
++++ libpolyml/Makefile.in 2010-08-16 14:31:38.000000000 -0700
+@@ -744,7 +744,7 @@
+
+ # Special rule for x86 assembly code.
+ x86asmtemp.S: x86asm.asm
+- sed -f $(srcdir)/masm2gas < $< > $@ || { rm -f $@; false; }
++ sed -f $(srcdir)/masm2gas < x86asm.asm > $@ || { rm -f $@; false; }
+
+ # Special rule for Power PC. This is needed because of pecularities with MAC OS X.
+ ppcasmtemp.s: power_assembly.S