aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-08-31 19:31:06 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-08-31 19:31:06 +0000
commit5c080d0f3d7607267b4e3b530dfbf448cbfa93ad (patch)
treee032320e3302d6db53784986be7a5157445259fa
parent850e406d554f56b016f974f67f08288a92af28c4 (diff)
downloadports-5c080d0f3d7607267b4e3b530dfbf448cbfa93ad.tar.gz
ports-5c080d0f3d7607267b4e3b530dfbf448cbfa93ad.zip
Notes
-rw-r--r--mail/ifile/Makefile2
-rw-r--r--mail/ifile/files/patch-Makefile.in16
-rw-r--r--mail/ifile/files/patch-argp_argp-fmtstream.h20
-rw-r--r--mail/ifile/files/patch-argp_argp-fs-xinl.c12
-rw-r--r--mail/ifile/files/patch-argp_argp-xinl.c12
-rw-r--r--mail/ifile/files/patch-argp_argp.h6
6 files changed, 61 insertions, 7 deletions
diff --git a/mail/ifile/Makefile b/mail/ifile/Makefile
index d7d2476072ee..c1c76a68d8c2 100644
--- a/mail/ifile/Makefile
+++ b/mail/ifile/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= http://people.csail.mit.edu/jrennie/ifile/
MAINTAINER= ports@FreeBSD.org
COMMENT= Application of machine learning to e-mail filtering
+LICENSE= GPLv2
+
USES= gmake
GNU_CONFIGURE= yes
USE_CSTD= gnu89
diff --git a/mail/ifile/files/patch-Makefile.in b/mail/ifile/files/patch-Makefile.in
index 40f7e2428cfe..0ce327e93d4b 100644
--- a/mail/ifile/files/patch-Makefile.in
+++ b/mail/ifile/files/patch-Makefile.in
@@ -1,14 +1,22 @@
---- Makefile.in.orig 2006-05-22 11:49:21.000000000 -0500
-+++ Makefile.in 2011-03-25 14:18:34.000000000 -0500
-@@ -48,3 +48,3 @@
+--- Makefile.in.orig 2006-05-22 16:49:21 UTC
++++ Makefile.in
+@@ -46,7 +46,7 @@ LIBS = @LIBS@
+ CFLAGS = @CFLAGS@
+ CPPFLAGS = @CPPFLAGS@
INCLUDEFLAGS =
-LDFLAGS =
+LDFLAGS = @LDFLAGS@
-@@ -56,4 +56,4 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+@@ -54,8 +54,8 @@ bindir = @bindir@
+ mandir = @mandir@
+
# Installation locations
-if [ ! $bindir ] ; then bindir = $(exec_prefix)/bin; fi
-if [ ! $mandir ] ; then mandir = $(prefix)/man; fi
+# if [ ! $bindir ] ; then bindir = $(exec_prefix)/bin; fi
+# if [ ! $mandir ] ; then mandir = $(prefix)/man; fi
+ #### This is just a test---feel free to delete ###
+ printdirs:
diff --git a/mail/ifile/files/patch-argp_argp-fmtstream.h b/mail/ifile/files/patch-argp_argp-fmtstream.h
new file mode 100644
index 000000000000..ed5a4a195fae
--- /dev/null
+++ b/mail/ifile/files/patch-argp_argp-fmtstream.h
@@ -0,0 +1,20 @@
+--- argp/argp-fmtstream.h.orig 2006-05-22 16:49:23 UTC
++++ argp/argp-fmtstream.h
+@@ -186,7 +186,7 @@ extern void __argp_fmtstream_update (arg
+ extern int _argp_fmtstream_ensure (argp_fmtstream_t __fs, size_t __amount);
+ extern int __argp_fmtstream_ensure (argp_fmtstream_t __fs, size_t __amount);
+
+-#ifdef __OPTIMIZE__
++#ifdef __OPTIMIZE_INLINE__
+ /* Inline versions of above routines. */
+
+ #if !_LIBC
+@@ -298,7 +298,7 @@ __argp_fmtstream_point (argp_fmtstream_t
+ #undef __argp_fmtstream_ensure
+ #endif
+
+-#endif /* __OPTIMIZE__ */
++#endif /* __OPTIMIZE_INLINE__ */
+
+ #endif /* ARGP_FMTSTREAM_USE_LINEWRAP */
+
diff --git a/mail/ifile/files/patch-argp_argp-fs-xinl.c b/mail/ifile/files/patch-argp_argp-fs-xinl.c
new file mode 100644
index 000000000000..56e38ba34db0
--- /dev/null
+++ b/mail/ifile/files/patch-argp_argp-fs-xinl.c
@@ -0,0 +1,12 @@
+--- argp/argp-fs-xinl.c.orig 2006-05-22 16:49:22 UTC
++++ argp/argp-fs-xinl.c
+@@ -24,7 +24,8 @@
+
+ #define ARGP_FS_EI
+ #undef __OPTIMIZE__
+-#define __OPTIMIZE__
++#define __OPTIMIZE__ 0
++#define __OPTIMIZE_INLINE__
+ #include "argp-fmtstream.h"
+
+ /* Add weak aliases. */
diff --git a/mail/ifile/files/patch-argp_argp-xinl.c b/mail/ifile/files/patch-argp_argp-xinl.c
new file mode 100644
index 000000000000..d99daaddf0aa
--- /dev/null
+++ b/mail/ifile/files/patch-argp_argp-xinl.c
@@ -0,0 +1,12 @@
+--- argp/argp-xinl.c.orig 2006-05-22 16:49:22 UTC
++++ argp/argp-xinl.c
+@@ -24,7 +24,8 @@
+
+ #define ARGP_EI
+ #undef __OPTIMIZE__
+-#define __OPTIMIZE__
++#define __OPTIMIZE__ 0
++#define __OPTIMIZE_INLINE__
+ #include "argp.h"
+
+ /* Add weak aliases. */
diff --git a/mail/ifile/files/patch-argp_argp.h b/mail/ifile/files/patch-argp_argp.h
index d9493d2995b2..f0f1113f1409 100644
--- a/mail/ifile/files/patch-argp_argp.h
+++ b/mail/ifile/files/patch-argp_argp.h
@@ -1,6 +1,6 @@
---- argp/argp.h.orig Tue Jun 10 23:09:27 2003
-+++ argp/argp.h Mon Jul 7 04:31:41 2003
-@@ -352,7 +352,7 @@
+--- argp/argp.h.orig 2006-05-22 16:49:22 UTC
++++ argp/argp.h
+@@ -352,7 +352,7 @@ struct argp_state
#define ARGP_NO_EXIT 0x20
/* Use the gnu getopt `long-only' rules for parsing arguments. */