aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-08 23:35:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-08 23:35:38 +0000
commit5cf79d08fffc30b2ecab1c8e4da0ddba94f24cbe (patch)
treede16acae18d16c1f52c093cad581b97d6320019f
parent78ce32f3eabd2edfba50d00e43c1a9ec51906498 (diff)
downloadports-5cf79d08fffc30b2ecab1c8e4da0ddba94f24cbe.tar.gz
ports-5cf79d08fffc30b2ecab1c8e4da0ddba94f24cbe.zip
Notes
-rw-r--r--games/xonotic/Makefile71
-rw-r--r--games/xonotic/distinfo4
-rw-r--r--games/xonotic/files/patch-source__darkplaces__BSDmakefile6
3 files changed, 35 insertions, 46 deletions
diff --git a/games/xonotic/Makefile b/games/xonotic/Makefile
index 0e876eb8aeab..390feb3b06eb 100644
--- a/games/xonotic/Makefile
+++ b/games/xonotic/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xonotic
-PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTVERSION= 0.8.1
CATEGORIES= games
MASTER_SITES= http://nl.dl.xonotic.org/ \
http://mirror.bitmissile.com/xonotic/releases/
@@ -32,43 +31,33 @@ USE_GCC= yes
PORTDATA= *
-OPTIONS_MULTI= COMPONENTS
-OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED ENCRYPTION
-OPTIONS_DEFAULT=CLIENT DEDICATED ENCRYPTION
+OPTIONS_DEFINE= ENCRYPTION
+OPTIONS_MULTI= COMPONENTS
+OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
+OPTIONS_DEFAULT= CLIENT DEDICATED ENCRYPTION
-CLIENT_DESC= Build client
-DEDICATED_DESC= Build dedicated server
-ENCRYPTION_DESC=Build encryption (required for stats submission)
-
-CLIENT_LIB_DEPENDS+= libmodplug.so:${PORTSDIR}/audio/libmodplug \
+CLIENT_DESC= Build client
+CLIENT_LIB_DEPENDS= libmodplug.so:${PORTSDIR}/audio/libmodplug \
libtheora.so:${PORTSDIR}/multimedia/libtheora \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libogg.so:${PORTSDIR}/audio/libogg
-
+CLIENT_USE= SDL=sdl
+CLIENT_ALL_TARGET= sdl-release
+CLIENT_PLIST_FILES= bin/${PORTNAME} share/pixmaps/${PORTNAME}.ico
+CLIENT_DESKTOP_ENTRIES= "Xonotic" \
+ "" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
+ "${PORTNAME}" \
+ "Game;Shooter;" \
+ ""
+
+DEDICATED_DESC= Build dedicated server
+DEDICATED_ALL_TARGET= sv-release
+DEDICATED_PLIST_FILES= bin/${PORTNAME}-dedicated
+
+ENCRYPTION_DESC= Build encryption (required for stats submission)
ENCRYPTION_LIB_DEPENDS= libd0_rijndael.so:${PORTSDIR}/security/d0_blind_id
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCLIENT}
-USE_SDL= sdl
-ALL_TARGET+= sdl-release
-PLIST_FILES+= bin/${PORTNAME}
-
-DESKTOP_ENTRIES="Xonotic" \
- "${COMMENT}" \
- "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
- "${PORTNAME}" \
- "Game;Shooter;" \
- ""
-
-PLIST_FILES+= share/pixmaps/${PORTNAME}.ico
-.endif
-
-.if ${PORT_OPTIONS:MDEDICATED}
-ALL_TARGET+= sv-release
-PLIST_FILES+= bin/${PORTNAME}-dedicated
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},' \
${BUILD_WRKSRC}/${MAKEFILE} ${BUILD_WRKSRC}/makefile.inc
@@ -77,21 +66,21 @@ post-patch:
@${ECHO_CMD} >> ${BUILD_WRKSRC}/prvm_offsets.h # silence 'no newline' warnings
do-install:
-.if ${PORT_OPTIONS:MCLIENT}
+ @${MKDIR} ${STAGEDIR}${DATADIR}/data
+ ${INSTALL_DATA} ${WRKSRC}/data/*.pk3 ${STAGEDIR}${DATADIR}/data/
+
+do-install-CLIENT-on:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/darkplaces-sdl ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/misc/logos/icons_ico/xonotic.ico ${STAGEDIR}${PREFIX}/share/pixmaps/
-.endif
-.if ${PORT_OPTIONS:MDEDICATED}
+
+do-install-DEDICATED-on:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/darkplaces-dedicated ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-dedicated
cd ${WRKSRC} && ${COPYTREE_SHARE} "server" ${STAGEDIR}${DATADIR}/
# Fixup lost +x permissions on scripts after COPYTREE_SHARE
${FIND} ${STAGEDIR}${DATADIR}/server -type f -name *.sh -o -name rcon*.pl | \
${XARGS} ${CHMOD} +x
-.endif
- ${MKDIR} ${STAGEDIR}${DATADIR}/data
- ${INSTALL_DATA} ${WRKSRC}/data/*.pk3 ${STAGEDIR}${DATADIR}/data/
-.if ${PORT_OPTIONS:MENCRYPTION}
+
+do-install-ENCRYPTION-on:
${INSTALL_DATA} ${WRKSRC}/key_0.d0pk ${STAGEDIR}${DATADIR}/
-.endif
.include <bsd.port.mk>
diff --git a/games/xonotic/distinfo b/games/xonotic/distinfo
index cdc28ec58ba9..110964a867e3 100644
--- a/games/xonotic/distinfo
+++ b/games/xonotic/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xonotic-0.8.0.zip) = 0a87c808827a8b234f2324b468ecb643aa48a6fd43322a29e616610dca316370
-SIZE (xonotic-0.8.0.zip) = 999151784
+SHA256 (xonotic-0.8.1.zip) = be8bcc41e2993a2f26d4d04c65a7eab810443bd98b11b45e482ffdbbf284c46f
+SIZE (xonotic-0.8.1.zip) = 984854761
diff --git a/games/xonotic/files/patch-source__darkplaces__BSDmakefile b/games/xonotic/files/patch-source__darkplaces__BSDmakefile
index 14016cff3c1b..c9a899fc8cc5 100644
--- a/games/xonotic/files/patch-source__darkplaces__BSDmakefile
+++ b/games/xonotic/files/patch-source__darkplaces__BSDmakefile
@@ -1,6 +1,6 @@
---- source/darkplaces/BSDmakefile.orig 2015-01-17 02:24:24.000000000 +0300
-+++ source/darkplaces/BSDmakefile 2015-01-17 02:26:51.000000000 +0300
-@@ -158,7 +158,7 @@
+--- source/darkplaces/BSDmakefile.orig 2015-08-25 12:10:24 UTC
++++ source/darkplaces/BSDmakefile
+@@ -158,7 +158,7 @@ LIB_SOUND=$(LIB_SND_BSD)
CFLAGS_MAKEDEP=-MD
.ifdef DP_FS_BASEDIR