aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:06:09 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:06:09 +0000
commit5d01d32e7efee099aaed0662d2156852317be44f (patch)
tree4fc47161a1bd6561f850c4766ba8a82b649f1225
parent71a1c44983057badad9e3a90e233bf5d0c225082 (diff)
downloadports-5d01d32e7efee099aaed0662d2156852317be44f.tar.gz
ports-5d01d32e7efee099aaed0662d2156852317be44f.zip
net/py-url-normalize: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--net/py-url-normalize/Makefile4
-rw-r--r--net/py-url-normalize/files/patch-pyproject.toml10
2 files changed, 13 insertions, 1 deletions
diff --git a/net/py-url-normalize/Makefile b/net/py-url-normalize/Makefile
index 7f1f5f8e0954..d5f81e8a9de8 100644
--- a/net/py-url-normalize/Makefile
+++ b/net/py-url-normalize/Makefile
@@ -1,5 +1,6 @@
PORTNAME= url-normalize
PORTVERSION= 1.4.3
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,10 +12,11 @@ WWW= https://github.com/niksite/url-normalize
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=0.12:devel/py-poetry-core@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/net/py-url-normalize/files/patch-pyproject.toml b/net/py-url-normalize/files/patch-pyproject.toml
new file mode 100644
index 000000000000..504c9326cedb
--- /dev/null
+++ b/net/py-url-normalize/files/patch-pyproject.toml
@@ -0,0 +1,10 @@
+--- pyproject.toml.orig 2020-10-26 02:02:45 UTC
++++ pyproject.toml
+@@ -30,5 +30,5 @@ tox = [{version="*", python="^3.6"}]
+ tox = [{version="*", python="^3.6"}]
+
+ [build-system]
+-build-backend = "poetry.masonry.api"
+-requires = ["poetry>=0.12"]
++build-backend = "poetry.core.masonry.api"
++requires = ["poetry-core>=0.12"]