aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2022-10-02 09:07:03 +0000
committerMatthias Andree <mandree@FreeBSD.org>2022-10-02 09:08:17 +0000
commit5d062d5c18a1de48b8c30bf69929e1e3cb37679f (patch)
tree5cdee5de6511bfcc728a1b83c66891e4b2ca1d64
parent22e214654b06d914fb602f54f63b6523d778d69b (diff)
downloadports-5d062d5c18a1de48b8c30bf69929e1e3cb37679f.tar.gz
ports-5d062d5c18a1de48b8c30bf69929e1e3cb37679f.zip
-rw-r--r--security/easy-rsa/Makefile4
-rw-r--r--security/easy-rsa/files/patch-easyrsa26
2 files changed, 23 insertions, 7 deletions
diff --git a/security/easy-rsa/Makefile b/security/easy-rsa/Makefile
index 02cd6237fa37..8a3ff8cf0c9d 100644
--- a/security/easy-rsa/Makefile
+++ b/security/easy-rsa/Makefile
@@ -1,12 +1,10 @@
PORTNAME= easy-rsa
DISTVERSION= 3.1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security net-mgmt
MASTER_SITES= https://github.com/OpenVPN/easy-rsa/releases/download/v${DISTVERSION}/
DISTNAME= EasyRSA-${DISTVERSION}
-# Eric F. Crist <ecrist@secure-computing.net> does not require my
-# approval for changes to this package. -- mandree@FreeBSD.org
MAINTAINER= mandree@FreeBSD.org
COMMENT= Small RSA key management package based on openssl
WWW= https://github.com/OpenVPN/easy-rsa
diff --git a/security/easy-rsa/files/patch-easyrsa b/security/easy-rsa/files/patch-easyrsa
index c6582845c35b..f839ca4b6015 100644
--- a/security/easy-rsa/files/patch-easyrsa
+++ b/security/easy-rsa/files/patch-easyrsa
@@ -3,12 +3,30 @@ Filed upstream as Issue #591 <https://github.com/OpenVPN/easy-rsa/issues/591>
--- easyrsa.orig 2022-05-19 01:53:50 UTC
+++ easyrsa
-@@ -3829,6 +3829,8 @@ VERSION_TEXT
+@@ -2037,7 +2037,7 @@ renewable() {
+ verify_ca_init
+
+ in_dir="$EASYRSA_PKI"
+- MATCH=$(echo "$*" | sed -re 's/\s+/|/g')
++ MATCH=$(echo "$*" | sed -re 's/[[:space:]]+/|/g')
+ DATE=$(date --date \
+ "+${EASYRSA_CERT_RENEW} days" \
+ +"%y%m%d%H%M%S")
+@@ -2445,7 +2445,7 @@ display_san() {
+
+ if echo "$EASYRSA_EXTRA_EXTS" | grep -q subjectAltName; then
+ print "$(echo "$EASYRSA_EXTRA_EXTS" | grep subjectAltName |
+- sed 's/^\s*subjectAltName\s*=\s*//')"
++ sed 's/^[[:space:]]*subjectAltName[[:space:]]*=[[:space:]]*//')"
+ else
+ san="$(
+ x509v3san="X509v3 Subject Alternative Name:"
+@@ -3828,6 +3828,8 @@ VERSION_TEXT
+
NL='
'
-
-+LC_TIME=C ; export LC_TIME ; unset LC_ALL
+
++LC_TIME=C ; export LC_TIME ; unset LC_ALL
+
# Be secure with a restrictive umask
[ -z "$EASYRSA_NO_UMASK" ] && umask "${EASYRSA_UMASK:-077}"
-