aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-14 15:57:10 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-14 15:57:10 +0000
commit5d7a17869841314a278a629b4a77dfd6d86bc6d9 (patch)
tree008dbbb6997dc16d54d396eda7638badcb71c1cf
parent1620e437ba17713edbf64619a06826a06d7b7b62 (diff)
downloadports-5d7a17869841314a278a629b4a77dfd6d86bc6d9.tar.gz
ports-5d7a17869841314a278a629b4a77dfd6d86bc6d9.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Bind/Makefile35
-rw-r--r--devel/p5-Data-Bind/distinfo3
-rw-r--r--devel/p5-Data-Bind/pkg-descr5
-rw-r--r--devel/p5-Data-Bind/pkg-plist7
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5c2e598563ad..f2c940f73284 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -864,6 +864,7 @@
SUBDIR += p5-DB_File-Lock
SUBDIR += p5-Danga-Socket
SUBDIR += p5-Data-ACL
+ SUBDIR += p5-Data-Bind
SUBDIR += p5-Data-Compare
SUBDIR += p5-Data-Dump
SUBDIR += p5-Data-Dump-Streamer
diff --git a/devel/p5-Data-Bind/Makefile b/devel/p5-Data-Bind/Makefile
new file mode 100644
index 000000000000..6ebf12b3b0d7
--- /dev/null
+++ b/devel/p5-Data-Bind/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: Data-Bind
+# Date created: Jul. 12, 2006
+# Whom: Ying-Chieh Chen
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Bind
+PORTVERSION= 0.27
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= yinjieh@csie.nctu.edu.tw
+COMMENT= A perl module to bind and alias variables
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/${PERL_ARCH}/Devel/Caller.pm:${PORTSDIR}/devel/p5-Devel-Caller \
+ ${SITE_PERL}/${PERL_ARCH}/Devel/LexAlias.pm:${PORTSDIR}/devel/p5-Devel-LexAlias \
+ ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Bind.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-Bind/distinfo b/devel/p5-Data-Bind/distinfo
new file mode 100644
index 000000000000..7c8ea58882b5
--- /dev/null
+++ b/devel/p5-Data-Bind/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Bind-0.27.tar.gz) = cb959c9389cc4bc6ff5b28540bac3a22
+SHA256 (Data-Bind-0.27.tar.gz) = d0377faa35dcdc652f02bc236da1f00401465a0acc7a7973c251db5547327912
+SIZE (Data-Bind-0.27.tar.gz) = 21414
diff --git a/devel/p5-Data-Bind/pkg-descr b/devel/p5-Data-Bind/pkg-descr
new file mode 100644
index 000000000000..0826ee2da894
--- /dev/null
+++ b/devel/p5-Data-Bind/pkg-descr
@@ -0,0 +1,5 @@
+This module implements the semantics for perl6-style variable binding,
+
+as well as subroutine call argument passing and binding, in Perl 5.
+
+WWW: http://search.cpan.org/dist/Data-Bind/
diff --git a/devel/p5-Data-Bind/pkg-plist b/devel/p5-Data-Bind/pkg-plist
new file mode 100644
index 000000000000..2cfe33dd804e
--- /dev/null
+++ b/devel/p5-Data-Bind/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Data/Bind.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Bind/Bind.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Bind/Bind.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Bind/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Bind
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Data