aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2016-05-25 13:59:07 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2016-05-25 13:59:07 +0000
commit5d82915c98fb29149bbd11c4ad36761d98a18692 (patch)
tree42798d6c70417ba642acb9a8656e8fc1f533229c
parent8a1f0e9c1fd5f5563e2f31d33043e2f4a7d13312 (diff)
downloadports-5d82915c98fb29149bbd11c4ad36761d98a18692.tar.gz
ports-5d82915c98fb29149bbd11c4ad36761d98a18692.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/acsccid/Makefile36
-rw-r--r--devel/acsccid/distinfo2
-rw-r--r--devel/acsccid/pkg-descr6
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index af3ec81c0782..0603c71b4b4a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -53,6 +53,7 @@
SUBDIR += ace
SUBDIR += ace+tao-doc
SUBDIR += acme
+ SUBDIR += acsccid
SUBDIR += activitymail
SUBDIR += ada-util
SUBDIR += adabooch
diff --git a/devel/acsccid/Makefile b/devel/acsccid/Makefile
new file mode 100644
index 000000000000..50b21cd67c19
--- /dev/null
+++ b/devel/acsccid/Makefile
@@ -0,0 +1,36 @@
+# Created by: mp39590@gmail.com
+# $FreeBSD$
+
+PORTNAME= acsccid
+PORTVERSION= 1.1.2
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= mp39590@gmail.com
+COMMENT= PC/SC driver for CS CCID smart card readers
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libpcsclite.so:${PORTSDIR}/devel/pcsc-lite
+
+USES= perl5 pkgconfig tar:bz2
+
+PLIST_FILES= lib/pcsc/drivers/ifd-acsccid.bundle/Contents/FreeBSD/libacsccid.so \
+ lib/pcsc/drivers/ifd-acsccid.bundle/Contents/Info.plist
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+# Old versions don't have pkgconfig files for libusb
+.if ${OSVERSION} < 1000024
+CONFIGURE_ENV+= LIBUSB_CFLAGS="-I${LOCALBASE}/include" \
+ LIBUSB_LIBS="-L${LOCALBASE}/lib -lusb"
+.endif
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pcsc/drivers/ifd-acsccid.bundle/Contents/FreeBSD/libacsccid.so
+
+.include <bsd.port.post.mk>
diff --git a/devel/acsccid/distinfo b/devel/acsccid/distinfo
new file mode 100644
index 000000000000..0128c282746e
--- /dev/null
+++ b/devel/acsccid/distinfo
@@ -0,0 +1,2 @@
+SHA256 (acsccid-1.1.2.tar.bz2) = 451c60400f6f4417f75892549283ab3a0301019a5ef2801abde3ab7580dae708
+SIZE (acsccid-1.1.2.tar.bz2) = 438206
diff --git a/devel/acsccid/pkg-descr b/devel/acsccid/pkg-descr
new file mode 100644
index 000000000000..f15be82ce154
--- /dev/null
+++ b/devel/acsccid/pkg-descr
@@ -0,0 +1,6 @@
+acsccid is a PC/SC driver for Linux/Mac OS X and it supports ACS CCID
+smart card readers. This library provides a PC/SC IFD handler
+implementation and communicates with the readers through the PC/SC Lite
+resource manager (pcscd).
+
+WWW: http://www.acs.com.hk/en/driver/4/acr38-smart-card-reader/