aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2017-03-15 13:13:09 +0000
committerDiane Bruce <db@FreeBSD.org>2017-03-15 13:13:09 +0000
commit5dd084cc9277f4fec90e240e8609fcd47ba4e2af (patch)
tree8fb2c68d7a1c00a8ed781247470914b96908ed0a
parentfaa6b853f8e16e79ff0e7d5d14659cdeebd83781 (diff)
downloadports-5dd084cc9277f4fec90e240e8609fcd47ba4e2af.tar.gz
ports-5dd084cc9277f4fec90e240e8609fcd47ba4e2af.zip
Notes
-rw-r--r--comms/Makefile1
-rw-r--r--comms/multimon-ng/Makefile35
-rw-r--r--comms/multimon-ng/distinfo3
-rw-r--r--comms/multimon-ng/files/patch-CMakeLists.txt12
-rw-r--r--comms/multimon-ng/pkg-descr18
5 files changed, 69 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index d8529ccd5c8c..d872555f2a3a 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -101,6 +101,7 @@
SUBDIR += minicom
SUBDIR += mlan3
SUBDIR += morse
+ SUBDIR += multimon-ng
SUBDIR += nasawash
SUBDIR += ncid
SUBDIR += nec2c
diff --git a/comms/multimon-ng/Makefile b/comms/multimon-ng/Makefile
new file mode 100644
index 000000000000..3a760c046dde
--- /dev/null
+++ b/comms/multimon-ng/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= multimon-ng
+PORTVERSION= 1.1.0
+CATEGORIES= comms hamradio
+
+MAINTAINER= bsdports@kyle-evans.net
+COMMENT= Digital transmission decoder
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GITHUB= yes
+GH_ACCOUNT= EliasOenal
+
+USES= cmake
+
+OPTIONS_DEFINE= PULSEAUDIO X11
+
+X11_CMAKE_BOOL= X11_SUPPORT
+
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+PULSEAUDIO_CMAKE_BOOL= PULSE_AUDIO_SUPPORT
+
+PLIST_FILES+= bin/multimon-ng
+
+.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MX11}
+USE_XORG+= sm ice x11 xext
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/multimon-ng ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/comms/multimon-ng/distinfo b/comms/multimon-ng/distinfo
new file mode 100644
index 000000000000..ba1178ef6339
--- /dev/null
+++ b/comms/multimon-ng/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1489583557
+SHA256 (EliasOenal-multimon-ng-1.1.0_GH0.tar.gz) = 378209bce0111ec496a8bf1878d43b8d42d67921958c8fbef4aedde2ea416c43
+SIZE (EliasOenal-multimon-ng-1.1.0_GH0.tar.gz) = 2420682
diff --git a/comms/multimon-ng/files/patch-CMakeLists.txt b/comms/multimon-ng/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..c2575c362558
--- /dev/null
+++ b/comms/multimon-ng/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2015-11-09 12:57:23 UTC
++++ CMakeLists.txt
+@@ -48,7 +48,8 @@ endif( X11_SUPPORT )
+
+ if( PULSE_AUDIO_SUPPORT )
+ include_directories( ${PULSEAUDIO_INCLUDE_DIR} )
+- link_libraries( ${PULSEAUDIO_LIBRARY} "-lpulse-simple" )
++ find_library( PULSE_SIMPLE NAMES pulse-simple REQUIRED )
++ link_libraries( ${PULSEAUDIO_LIBRARY} ${PULSE_SIMPLE} )
+ add_definitions( "-DPULSE_AUDIO" )
+ else( PULSE_AUDIO_SUPPORT )
+ add_definitions( "-DDUMMY_AUDIO" )
diff --git a/comms/multimon-ng/pkg-descr b/comms/multimon-ng/pkg-descr
new file mode 100644
index 000000000000..1b7b54e7c7eb
--- /dev/null
+++ b/comms/multimon-ng/pkg-descr
@@ -0,0 +1,18 @@
+multimon-ng a fork of multimon.
+It decodes the following digital transmission modes:
+
+POCSAG512 POCSAG1200 POCSAG2400
+FLEX
+EAS
+UFSK1200 CLIPFSK AFSK1200 AFSK2400 AFSK2400_2 AFSK2400_3
+HAPN4800
+FSK9600
+DTMF
+ZVEI1 ZVEI2 ZVEI3 DZVEI PZVEI
+EEA EIA CCIR
+MORSE CW
+
+As an example it can be used with rtl_sdr to decode radio amateurs packets:
+rtl_fm -f 144.390M -s 22050 | multimon-ng -v 10 -t raw -A -
+
+WWW: https://github.com/EliasOenal/multimon-ng/