aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-01 17:37:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-01 17:37:57 +0000
commit5def8ab192b99aeb798ae7dc99018c7795f52938 (patch)
tree57f600c2816284ea8e5d27a2c6e4d9c4a2fbedb9
parent5e8ace0a8d37b77738894c00a7151f2a6e0ff486 (diff)
downloadports-5def8ab192b99aeb798ae7dc99018c7795f52938.tar.gz
ports-5def8ab192b99aeb798ae7dc99018c7795f52938.zip
Notes
-rw-r--r--math/gambit/Makefile5
-rw-r--r--math/gambit/distinfo6
-rw-r--r--math/gambit/files/patch-library_src_linalg_btableau.cc18
-rw-r--r--math/gambit/files/patch-library_src_linalg_lemketab.cc13
-rw-r--r--math/gambit/files/patch-library_src_linalg_lhtab.cc17
-rw-r--r--math/gambit/files/patch-library_src_linalg_lptab.cc14
-rw-r--r--math/gambit/files/patch-library_src_linalg_ludecomp.cc17
-rw-r--r--math/gambit/files/patch-library_src_matrix.cc (renamed from math/gambit/files/patch-src_libgambit_matrix.cc)4
-rw-r--r--math/gambit/files/patch-src-labenski-src_sheet.cpp14
-rw-r--r--math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc10
-rw-r--r--math/gambit/pkg-plist6
11 files changed, 94 insertions, 30 deletions
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index e563a8a7c9dc..824e28303502 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gambit
-DISTVERSION= 15.1.1
-PORTREVISION= 1
+DISTVERSION= 16.0.1
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PORTVERSION:R:R}/${PORTVERSION}
@@ -13,7 +12,7 @@ COMMENT= Library of tools for doing computation in game theory
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++11-lib
+USES= compiler:c++11-lib gnome
GNU_CONFIGURE= yes
USE_GNOME= gtk20
USE_WX= 3.0
diff --git a/math/gambit/distinfo b/math/gambit/distinfo
index 8bb77789e5f4..0eea420c98af 100644
--- a/math/gambit/distinfo
+++ b/math/gambit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531253300
-SHA256 (gambit-15.1.1.tar.gz) = 7ede51739dc868242886815bb875307f5e11bb3789f22c546d3c83194fe75a1c
-SIZE (gambit-15.1.1.tar.gz) = 1777714
+TIMESTAMP = 1543682971
+SHA256 (gambit-16.0.1.tar.gz) = dbec0fc8c4cd3ad6b6a898a1330407fd7aa1bbac31ed94b6e96aa7e7196185f5
+SIZE (gambit-16.0.1.tar.gz) = 1802541
diff --git a/math/gambit/files/patch-library_src_linalg_btableau.cc b/math/gambit/files/patch-library_src_linalg_btableau.cc
new file mode 100644
index 000000000000..841916d62017
--- /dev/null
+++ b/math/gambit/files/patch-library_src_linalg_btableau.cc
@@ -0,0 +1,18 @@
+--- library/src/linalg/btableau.cc.orig 2018-12-01 17:24:33 UTC
++++ library/src/linalg/btableau.cc
+@@ -24,8 +24,7 @@
+ #include "gambit/matrix.imp"
+ #include "gambit/linalg/btableau.imp"
+
+-using namespace Gambit;
+-using namespace Gambit::linalg;
++namespace Gambit::linalg {
+
+ template class BaseTableau<double>;
+ template class BaseTableau<Rational>;
+@@ -33,4 +32,4 @@ template class BaseTableau<Rational>;
+ template class TableauInterface<double>;
+ template class TableauInterface<Rational>;
+
+-
++}
diff --git a/math/gambit/files/patch-library_src_linalg_lemketab.cc b/math/gambit/files/patch-library_src_linalg_lemketab.cc
new file mode 100644
index 000000000000..1cc652c90a1a
--- /dev/null
+++ b/math/gambit/files/patch-library_src_linalg_lemketab.cc
@@ -0,0 +1,13 @@
+--- library/src/linalg/lemketab.cc.orig 2018-12-01 17:13:48 UTC
++++ library/src/linalg/lemketab.cc
+@@ -22,7 +22,9 @@
+
+ #include "gambit/linalg/lemketab.imp"
+
+-using namespace Gambit::linalg;
++namespace Gambit::linalg {
+
+ template class LemkeTableau<double>;
+ template class LemkeTableau<Gambit::Rational>;
++
++}
diff --git a/math/gambit/files/patch-library_src_linalg_lhtab.cc b/math/gambit/files/patch-library_src_linalg_lhtab.cc
new file mode 100644
index 000000000000..d55e1ba15f20
--- /dev/null
+++ b/math/gambit/files/patch-library_src_linalg_lhtab.cc
@@ -0,0 +1,17 @@
+--- library/src/linalg/lhtab.cc.orig 2018-12-01 17:29:54 UTC
++++ library/src/linalg/lhtab.cc
+@@ -22,12 +22,11 @@
+
+ #include "gambit/linalg/lhtab.imp"
+
+-using namespace Gambit;
+-using namespace Gambit::linalg;
++namespace Gambit::linalg {
+
+ template class LHTableau<double>;
+ template class LHTableau<Rational>;
+
+-
++}
+
+
diff --git a/math/gambit/files/patch-library_src_linalg_lptab.cc b/math/gambit/files/patch-library_src_linalg_lptab.cc
new file mode 100644
index 000000000000..8f8f7b891910
--- /dev/null
+++ b/math/gambit/files/patch-library_src_linalg_lptab.cc
@@ -0,0 +1,14 @@
+--- library/src/linalg/lptab.cc.orig 2017-05-12 11:07:26 UTC
++++ library/src/linalg/lptab.cc
+@@ -22,8 +22,9 @@
+
+ #include "gambit/linalg/lptab.imp"
+
+-using namespace Gambit;
+-using namespace Gambit::linalg;
++namespace Gambit::linalg {
+
+ template class LPTableau<double>;
+ template class LPTableau<Rational>;
++
++}
diff --git a/math/gambit/files/patch-library_src_linalg_ludecomp.cc b/math/gambit/files/patch-library_src_linalg_ludecomp.cc
new file mode 100644
index 000000000000..a44fc2ebeeb3
--- /dev/null
+++ b/math/gambit/files/patch-library_src_linalg_ludecomp.cc
@@ -0,0 +1,17 @@
+--- library/src/linalg/ludecomp.cc.orig 2017-05-12 11:07:26 UTC
++++ library/src/linalg/ludecomp.cc
+@@ -22,11 +22,12 @@
+
+ #include "gambit/linalg/ludecomp.imp"
+
+-using namespace Gambit;
+-using namespace Gambit::linalg;
++namespace Gambit::linalg {
+
+ template class EtaMatrix<double>;
+ template class LUdecomp<double>;
+
+ template class EtaMatrix<Rational>;
+ template class LUdecomp<Rational>;
++
++}
diff --git a/math/gambit/files/patch-src_libgambit_matrix.cc b/math/gambit/files/patch-library_src_matrix.cc
index 8139197f2499..57f331fd9a61 100644
--- a/math/gambit/files/patch-src_libgambit_matrix.cc
+++ b/math/gambit/files/patch-library_src_matrix.cc
@@ -1,5 +1,5 @@
---- src/libgambit/matrix.cc.orig 2014-06-06 16:33:54.000000000 +0400
-+++ src/libgambit/matrix.cc 2015-04-13 21:39:08.802909000 +0300
+--- library/src/matrix.cc.orig 2018-12-01 16:51:25 UTC
++++ library/src/matrix.cc
@@ -25,11 +25,15 @@
using namespace Gambit;
diff --git a/math/gambit/files/patch-src-labenski-src_sheet.cpp b/math/gambit/files/patch-src-labenski-src_sheet.cpp
deleted file mode 100644
index b3d63f5fca12..000000000000
--- a/math/gambit/files/patch-src-labenski-src_sheet.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/labenski/src/sheet.cpp.orig 2013-06-24 11:57:48.000000000 +0200
-+++ src/labenski/src/sheet.cpp 2013-06-24 12:00:50.000000000 +0200
-@@ -7098,9 +7098,9 @@
- wxPrintf(wxT("COUNT MISMATCH ERROR! \n"));
-
- for (size_t n = 0; n < wxMin(ans.GetCount(), res.GetCount()); n++)
-- if (ans[n] != res[n]) wxPrintf(wxT("Error in item %u\n"), n);
-+ if (ans[n] != res[n]) wxPrintf(wxT("Error in item %zu\n"), n);
-
-- wxPrintf(msg + wxT("\n"));
-+ wxPrintf("%s\n", msg.ToAscii());
- }
-
- #define CSVT1(str, a1) { wxArrayString ar; ar.Add(wxT(a1)); CSV_TEST(wxT(str), ar, ParseLine(wxT(str))); }
diff --git a/math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc b/math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc
index 3259dd1b445a..850ceacc8edf 100644
--- a/math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc
+++ b/math/gambit/files/patch-src_tools_enumpoly_pelqhull.cc
@@ -1,6 +1,6 @@
---- src/tools/enumpoly/pelqhull.cc.orig 2014-05-27 12:07:04.000000000 +0400
-+++ src/tools/enumpoly/pelqhull.cc 2015-04-13 20:35:03.596285000 +0300
-@@ -2792,7 +2792,7 @@
+--- src/tools/enumpoly/pelqhull.cc.orig 2016-06-30 09:03:18 UTC
++++ src/tools/enumpoly/pelqhull.cc
+@@ -2792,7 +2792,7 @@ void qh_allstatA (void) {
/* zdef_(type,name,doc,average) */
zzdef_(zdoc, Zdoc2, "precision statistics", -1);
@@ -9,7 +9,7 @@
zdef_(wadd, Wnewvertex, "ave. distance of a new vertex to a facet (not 0s)", Znewvertex);
zdef_(wmax, Wnewvertexmax, "max. distance of a new vertex to a facet", -1);
zdef_(wmax, Wvertexmax, "max. distance of an output vertex to a facet", -1);
-@@ -2831,7 +2831,7 @@
+@@ -2831,7 +2831,7 @@ void qh_allstatB (void) {
zzdef_(zinc, Zsetplane, "facets created altogether", -1);
zdef_(zinc, Ztotridges, "ridges created altogether", -1);
zdef_(zinc, Zpostfacets, "facets before post merge", -1);
@@ -18,7 +18,7 @@
zdef_(wadd, Wangle, "average angle (cosine) for all ridges", Zangle);
zdef_(wmax, Wanglemax, "maximum angle (cosine) of a ridge", -1);
zdef_(wmin, Wanglemin, "minimum angle (cosine) of a ridge", -1);
-@@ -2946,7 +2946,7 @@
+@@ -2946,7 +2946,7 @@ void qh_allstatF(void) {
zdef_(zinc, Zintersect, "intersections found redundant vertices", -1);
zdef_(zadd, Zintersecttot, " ave. number found per vertex", Zintersect);
zdef_(zmax, Zintersectmax, " max. found for a vertex", -1);
diff --git a/math/gambit/pkg-plist b/math/gambit/pkg-plist
index ed36c77d018d..b58baac9ca97 100644
--- a/math/gambit/pkg-plist
+++ b/math/gambit/pkg-plist
@@ -10,15 +10,14 @@ bin/gambit-liap
bin/gambit-logit
bin/gambit-lp
bin/gambit-simpdiv
-include/libagg/GrayComposition.h
include/libagg/agg.h
include/libagg/bagg.h
include/libagg/gameagg.h
include/libagg/gamebagg.h
+include/libagg/gray.h
include/libagg/proj_func.h
include/libagg/trie_map.h
include/libagg/trie_map.imp
-include/libgambit/GrayComposition.h
include/libgambit/agg.h
include/libgambit/array.h
include/libgambit/bagg.h
@@ -29,11 +28,12 @@ include/libgambit/behavspt.h
include/libgambit/dvector.h
include/libgambit/dvector.imp
include/libgambit/function.h
+include/libgambit/gambit.h
include/libgambit/game.h
include/libgambit/gameagg.h
include/libgambit/gamebagg.h
+include/libgambit/gray.h
include/libgambit/integer.h
-include/libgambit/libgambit.h
include/libgambit/list.h
include/libgambit/matrix.h
include/libgambit/matrix.imp