aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-05 09:16:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-05 09:16:32 +0000
commit5e1d1e5b630a432b0ec36c5851914f3517b40f6f (patch)
tree47773b99a10d106ca3cbe094f0016e4fc3d6ed00
parentdb8c09320e9b1102cc8bdf2de0ddf84730bd18a2 (diff)
downloadports-5e1d1e5b630a432b0ec36c5851914f3517b40f6f.tar.gz
ports-5e1d1e5b630a432b0ec36c5851914f3517b40f6f.zip
Notes
-rw-r--r--mail/popfile/Makefile97
-rw-r--r--mail/popfile/distinfo4
-rw-r--r--mail/popfile/pkg-descr20
-rw-r--r--mail/popfile/pkg-plist31
4 files changed, 71 insertions, 81 deletions
diff --git a/mail/popfile/Makefile b/mail/popfile/Makefile
index 8e0dbaeb7be5..b92b4dbc05f8 100644
--- a/mail/popfile/Makefile
+++ b/mail/popfile/Makefile
@@ -1,94 +1,85 @@
-# New ports collection makefile for: popfile
-# Date created: 22 Feb 2004
-# Whom: matusita@FreeBSD.org
-#
+# Created by: matusita@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= popfile
-PORTVERSION= 1.1.1
-#PORTREVISION= 0
+PORTVERSION= 1.1.3
CATEGORIES= mail
-MASTER_SITES= http://getpopfile.org/downloads/
+MASTER_SITES= http://getpopfile.org/downloads/%SUBDIR%/
+MASTER_SITE_SUBDIR= . archive
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Automatic mail classification tool, acts as a POP3 proxy
+LICENSE= GPLv2
+
RUN_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
p5-HTML-Tagset>=0:${PORTSDIR}/www/p5-HTML-Tagset \
- p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template \
- p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
+ p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template
+
+OPTIONS_DEFINE= SSL XMLRPC UPGRADE_FROM_0_20 KAKASI MECABU
+SSL_DESC= \
+ Depend SSL libraries/modules to use SSL connection to the servers
+XMLRPC_DESC= \
+ Depend SOAP libraries to use POPFile as XMLRPC server
+UPGRADE_FROM_0_20_DESC= \
+ Depend BerkeleyDB libraries to upgrade old POPFile corpus
+KAKASI_DESC= \
+ Depend Kakasi library to handle Japanese text
+MECABU_DESC= \
+ Depend MeCab library to handle Japanese text
-NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
+NO_BUILD= yes
USE_ZIP= yes
USE_PERL5_RUN= yes
-START_SCRIPTS_SUB= DATADIR=${DATADIR}
+PLIST_SUB= VERSION="${PORTVERSION}"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_POPFILE_SSL)
+.if ${PORT_OPTIONS:MSSL}
# POPFile works with IO::Socket::SSL version 1.07 (and not 0.97/0.99).
RUN_DEPENDS+= p5-IO-Socket-SSL>=1.07:${PORTSDIR}/security/p5-IO-Socket-SSL
.endif
-.if defined(WITH_POPFILE_XMLRPC)
+.if ${PORT_OPTIONS:MXMLRPC}
RUN_DEPENDS+= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
.endif
-.if defined(WITH_POPFILE_SOCKS)
+#.if ${PORT_OPTIONS:MSOCKS}
# XXX: IO::Socket::Socks should be listed here but no ports yet. For those
# interested, check http://search.cpan.org/~reatmon/IO-Socket-Socks-0.1/.
-.endif
+#.endif
-.if defined(WITH_POPFILE_UPGRADE_FROM_0_20)
+.if ${PORT_OPTIONS:MUPGRADE_FROM_0_20}
RUN_DEPENDS+= p5-BerkeleyDB>=0:${PORTSDIR}/databases/p5-BerkeleyDB
.endif
-.if defined(WITH_POPFILE_JAPANESE)
-# For backward compatibility; popfile 0.x supports Kakasi only.
-WITH_POPFILE_KAKASI=YES
-.endif
-.if defined(WITH_POPFILE_KAKASI)
+.if ${PORT_OPTIONS:MKAKASI}
RUN_DEPENDS+= p5-Text-Kakasi>=0:${PORTSDIR}/japanese/p5-Text-Kakasi
.endif
-.if defined(WITH_POPFILE_MECAB)
+
+.if ${PORT_OPTIONS:MMECAB}
RUN_DEPENDS+= p5-MeCab>=0:${PORTSDIR}/japanese/p5-MeCab
.endif
-pre-fetch:
- @${ECHO_CMD} "This port has some compile-time options:"
- @${ECHO_CMD} ""
- @${ECHO_CMD} " * make WITH_POPFILE_SSL=YES"
- @${ECHO_CMD} " Depend SSL libraries/modules to use SSL connection to the servers."
- @${ECHO_CMD} ""
- @${ECHO_CMD} " * make WITH_POPFILE_XMLRPC=YES"
- @${ECHO_CMD} " Depend SOAP libraries to use POPFile as XMLRPC server."
- @${ECHO_CMD} ""
- @${ECHO_CMD} " * make WITH_POPFILE_UPGRADE_FROM_0_20=YES"
- @${ECHO_CMD} " Depend BerkeleyDB libraries to upgrade old POPFile corpus."
- @${ECHO_CMD} " This option is required only for upgrading POPFile 0.20.1 or before."
- @${ECHO_CMD} ""
- @${ECHO_CMD} " * make WITH_POPFILE_KAKASI=YES"
- @${ECHO_CMD} " Depend Kakasi library to handle Japanese text."
- @${ECHO_CMD} " * make WITH_POPFILE_MECAB=YES"
- @${ECHO_CMD} " Depend MeCab library to handle Japanese text."
-
post-patch:
- ${CHMOD} +x ${WRKSRC}/popfile.pl
- ${REINPLACE_CMD} -i '' -e "s,^#!/usr/bin/perl $$,#!${PERL}," ${WRKSRC}/popfile.pl
- ${FIND} ${PATCH_WRKSRC} -name '*.orig' -delete
+ @${REINPLACE_CMD} -e \
+ 's|^#!/usr/bin/perl$$|#!${PERL}|' ${WRKSRC}/popfile.pl
+ @${SED} 's|%%DATADIR%%|${DATADIR}|' \
+ < ${FILESDIR}/popfile.sh > ${WRKDIR}/popfile.sh
do-install:
- ${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/* ${DATADIR}
- @${SED} ${START_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/popfile.sh > ${WRKDIR}/popfile.sh
${INSTALL_SCRIPT} ${WRKDIR}/popfile.sh ${PREFIX}/sbin
- ${RM} ${WRKDIR}/popfile.sh
-
-.include <bsd.port.post.mk>
+ @${MKDIR} ${DATADIR}
+ (cd ${WRKSRC} && ${INSTALL_SCRIPT} *.pl ${DATADIR})
+ (cd ${WRKSRC} && ${INSTALL_DATA} \
+ stopwords *.change* *.gif *.ico *.pck *.png ${DATADIR})
+.for i in Classifier POPFile Proxy Services UI languages skins
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} ${DATADIR})
+.endfor
+
+.include <bsd.port.mk>
diff --git a/mail/popfile/distinfo b/mail/popfile/distinfo
index 101c43b36298..8ce9f7c0f309 100644
--- a/mail/popfile/distinfo
+++ b/mail/popfile/distinfo
@@ -1,2 +1,2 @@
-SHA256 (popfile/popfile-1.1.1.zip) = 4c54d8fd483c248a2208cdd2dbe1f4f4a0b79b974f24977ae694482b56f4d0f4
-SIZE (popfile/popfile-1.1.1.zip) = 535334
+SHA256 (popfile/popfile-1.1.3.zip) = d197a187fbdaaf655f7eefceb969e0944cb4d5d290c0aba419b132797dfd6c54
+SIZE (popfile/popfile-1.1.3.zip) = 523431
diff --git a/mail/popfile/pkg-descr b/mail/popfile/pkg-descr
index d5a6b71757c9..5f5dcec95bd4 100644
--- a/mail/popfile/pkg-descr
+++ b/mail/popfile/pkg-descr
@@ -1,14 +1,14 @@
-POPFile is an automatic mail classification tool. Once properly set up and
-trained, it will scan all email as it arrives and classify it based on your
-training. You can give it a simple job, like separating out junk e-mail, or
-a complicated one -- like filing mail into a dozen folders. Think of it as a
-personal assistant for your inbox.
+POPFile is an automatic mail classification tool. Once properly set up
+and trained, it will scan all email as it arrives and classify it based
+on your training. You can give it a simple job, like separating out junk
+e-mail, or a complicated one -- like filing mail into a dozen folders.
+Think of it as a personal assistant for your inbox.
Since v0.21.0, POPFile supports multiple user with a single instance.
-Using ${LOCALDIR}/sbin/popfile.sh, you can start your own POPFile easily;
-it uses ${HOME}/.popfile as a working directory.
+Using ${LOCALDIR}/sbin/popfile.sh, you can start your own POPFile
+easily; it uses ${HOME}/.popfile as a working directory.
-Note for old POPFile users: copy messages/ and corpus/ directory to
-your ${HOME}/.popfile directory (if not, create it), then start popfile.sh.
+Note for old POPFile users: copy messages/ and corpus/ directory to your
+${HOME}/.popfile directory (if not, create it), then start popfile.sh.
-WWW: http://popfile.sourceforge.net/
+WWW: http://getpopfile.org/
diff --git a/mail/popfile/pkg-plist b/mail/popfile/pkg-plist
index 54c545cc9396..532353f55492 100644
--- a/mail/popfile/pkg-plist
+++ b/mail/popfile/pkg-plist
@@ -56,7 +56,6 @@ sbin/popfile.sh
%%DATADIR%%/languages/Svenska.msg
%%DATADIR%%/languages/Turkce.msg
%%DATADIR%%/languages/Ukrainian.msg
-%%DATADIR%%/license
%%DATADIR%%/otto.gif
%%DATADIR%%/otto.png
%%DATADIR%%/pipe.pl
@@ -143,19 +142,6 @@ sbin/popfile.sh
%%DATADIR%%/skins/osx/style.css
%%DATADIR%%/skins/outlook/style.css
%%DATADIR%%/skins/simplyblue/style.css
-%%DATADIR%%/skins/sleet-rtl/bottom.gif
-%%DATADIR%%/skins/sleet-rtl/bottomLeft.gif
-%%DATADIR%%/skins/sleet-rtl/bottomRight.gif
-%%DATADIR%%/skins/sleet-rtl/button.gif
-%%DATADIR%%/skins/sleet-rtl/button2.gif
-%%DATADIR%%/skins/sleet-rtl/left.gif
-%%DATADIR%%/skins/sleet-rtl/menu.gif
-%%DATADIR%%/skins/sleet-rtl/menuButton.gif
-%%DATADIR%%/skins/sleet-rtl/right.gif
-%%DATADIR%%/skins/sleet-rtl/style.css
-%%DATADIR%%/skins/sleet-rtl/top.gif
-%%DATADIR%%/skins/sleet-rtl/topLeft.gif
-%%DATADIR%%/skins/sleet-rtl/topRight.gif
%%DATADIR%%/skins/sleet/bottom.gif
%%DATADIR%%/skins/sleet/bottomLeft.gif
%%DATADIR%%/skins/sleet/bottomRight.gif
@@ -169,6 +155,19 @@ sbin/popfile.sh
%%DATADIR%%/skins/sleet/top.gif
%%DATADIR%%/skins/sleet/topLeft.gif
%%DATADIR%%/skins/sleet/topRight.gif
+%%DATADIR%%/skins/sleet-rtl/bottom.gif
+%%DATADIR%%/skins/sleet-rtl/bottomLeft.gif
+%%DATADIR%%/skins/sleet-rtl/bottomRight.gif
+%%DATADIR%%/skins/sleet-rtl/button.gif
+%%DATADIR%%/skins/sleet-rtl/button2.gif
+%%DATADIR%%/skins/sleet-rtl/left.gif
+%%DATADIR%%/skins/sleet-rtl/menu.gif
+%%DATADIR%%/skins/sleet-rtl/menuButton.gif
+%%DATADIR%%/skins/sleet-rtl/right.gif
+%%DATADIR%%/skins/sleet-rtl/style.css
+%%DATADIR%%/skins/sleet-rtl/top.gif
+%%DATADIR%%/skins/sleet-rtl/topLeft.gif
+%%DATADIR%%/skins/sleet-rtl/topRight.gif
%%DATADIR%%/skins/smalldefault/style.css
%%DATADIR%%/skins/smallgrey/style.css
%%DATADIR%%/skins/strawberryrose/style.css
@@ -176,8 +175,8 @@ sbin/popfile.sh
%%DATADIR%%/skins/white/style.css
%%DATADIR%%/skins/windows/style.css
%%DATADIR%%/stopwords
-%%DATADIR%%/v%%PORTVERSION%%.change
-%%DATADIR%%/v%%PORTVERSION%%.change.nihongo
+%%DATADIR%%/v%%VERSION%%.change
+%%DATADIR%%/v%%VERSION%%.change.nihongo
@dirrm %%DATADIR%%/skins/windows
@dirrm %%DATADIR%%/skins/white
@dirrm %%DATADIR%%/skins/tinygrey