aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-14 21:40:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-14 21:40:06 +0000
commit5fc86b0d7c45dc5a5f0e3623f29b49bd548e184b (patch)
treeac378b3ec4405d575f99e1e44da908558b4cbb96
parent7ff6dcab61bed9fbed19f3381b3a927bce3e56a5 (diff)
downloadports-5fc86b0d7c45dc5a5f0e3623f29b49bd548e184b.tar.gz
ports-5fc86b0d7c45dc5a5f0e3623f29b49bd548e184b.zip
Notes
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/nagios-check_ice/Makefile24
-rw-r--r--net-mgmt/nagios-check_ice/distinfo3
-rw-r--r--net-mgmt/nagios-check_ice/pkg-descr7
-rw-r--r--net-mgmt/nagios-check_ice/pkg-plist2
5 files changed, 37 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 3218ec7019f2..32431b7acb94 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -109,6 +109,7 @@
SUBDIR += nagios-certexp-plugin
SUBDIR += nagios-check_bacula
SUBDIR += nagios-check_clamav
+ SUBDIR += nagios-check_ice
SUBDIR += nagios-check_nick
SUBDIR += nagios-check_ports
SUBDIR += nagios-check_puppet
diff --git a/net-mgmt/nagios-check_ice/Makefile b/net-mgmt/nagios-check_ice/Makefile
new file mode 100644
index 000000000000..e2e92b7d105f
--- /dev/null
+++ b/net-mgmt/nagios-check_ice/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: nagios-check_ice
+# Date created: 2009-07-11
+# Whom: steinex
+#
+# $FreeBSD$
+
+PORTNAME= check_ice
+PORTVERSION= 1.5
+CATEGORIES= net-mgmt
+MASTER_SITES= http://nognu.de/s/FreeBSD/distfiles/
+PKGNAMEPREFIX= nagios-
+
+MAINTAINER= steinex@nognu.de
+COMMENT= Nagios plug-in to check a shoutcast or icecast server
+
+do-build:
+ cd ${WRKSRC}; \
+ ${CC} ${CFLAGS} check_ice.c -o check_ice
+
+do-install:
+ @${MKDIR} ${PREFIX}/libexec/nagios
+ @${INSTALL_PROGRAM} ${WRKSRC}/check_ice ${PREFIX}/libexec/nagios/check_ice
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-check_ice/distinfo b/net-mgmt/nagios-check_ice/distinfo
new file mode 100644
index 000000000000..bce3406fea2a
--- /dev/null
+++ b/net-mgmt/nagios-check_ice/distinfo
@@ -0,0 +1,3 @@
+MD5 (check_ice-1.5.tar.gz) = f389649fccb508d3294e7d9815aceb93
+SHA256 (check_ice-1.5.tar.gz) = eab58474bd538e123545f7defbebcdf73e8a58dde73c0c2f06fde138820eb5b9
+SIZE (check_ice-1.5.tar.gz) = 1828
diff --git a/net-mgmt/nagios-check_ice/pkg-descr b/net-mgmt/nagios-check_ice/pkg-descr
new file mode 100644
index 000000000000..bf90c4eebc76
--- /dev/null
+++ b/net-mgmt/nagios-check_ice/pkg-descr
@@ -0,0 +1,7 @@
+check_ice is a Nagios plugin-in that checks if a stream is up or
+down on a shoutcast or icecast server. The program will look at
+the three digit error code (ie. 200, 404, etc.) to give the proper
+result code that Nagios can use to know if the stream is up, in
+warning or in critical.
+
+WWW: http://www.lns.com/papers/check_ice/
diff --git a/net-mgmt/nagios-check_ice/pkg-plist b/net-mgmt/nagios-check_ice/pkg-plist
new file mode 100644
index 000000000000..9deb48489f13
--- /dev/null
+++ b/net-mgmt/nagios-check_ice/pkg-plist
@@ -0,0 +1,2 @@
+libexec/nagios/check_ice
+@dirrmtry libexec/nagios