aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-01-19 18:57:32 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-01-19 18:57:32 +0000
commit604f18a7b4fed418aa4dfceb75e5e653de261ce1 (patch)
tree0033e162e8b4d53e38888b939178dcc4de3a90b3
parent87ce19696c25f022aded206b68d5d09b2e39ffdb (diff)
downloadports-604f18a7b4fed418aa4dfceb75e5e653de261ce1.tar.gz
ports-604f18a7b4fed418aa4dfceb75e5e653de261ce1.zip
Notes
-rw-r--r--devel/nspr/Makefile2
-rw-r--r--devel/nspr/distinfo6
-rw-r--r--devel/nspr/files/patch-bug3019869
3 files changed, 7 insertions, 10 deletions
diff --git a/devel/nspr/Makefile b/devel/nspr/Makefile
index afea7f2a4aa0..aed3ec428e99 100644
--- a/devel/nspr/Makefile
+++ b/devel/nspr/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nspr
-DISTVERSION= 4.17
+DISTVERSION= 4.18
CATEGORIES= devel
MASTER_SITES= MOZILLA/${PORTNAME}/releases/v${PORTVERSION}/src
diff --git a/devel/nspr/distinfo b/devel/nspr/distinfo
index 78b99da875fa..5cfc4a0496f6 100644
--- a/devel/nspr/distinfo
+++ b/devel/nspr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1505838746
-SHA256 (nspr-4.17.tar.gz) = 590a0aea29412ae22d7728038c21ef2ab42646e48172a47d2e4bb782846d1095
-SIZE (nspr-4.17.tar.gz) = 1141300
+TIMESTAMP = 1516279034
+SHA256 (nspr-4.18.tar.gz) = b89657c09bf88707d06ac238b8930d3ae08de68cb3edccfdc2e3dc97f9c8fb34
+SIZE (nspr-4.18.tar.gz) = 1139663
diff --git a/devel/nspr/files/patch-bug301986 b/devel/nspr/files/patch-bug301986
index c2d63b30731d..3576606f83bb 100644
--- a/devel/nspr/files/patch-bug301986
+++ b/devel/nspr/files/patch-bug301986
@@ -22,20 +22,17 @@ Better to just keep calling it pthread_t isntead of casting to anything.
/*
** Set the procedure that is called when a thread is dumped. The procedure
---- pr/src/pthreads/ptthread.c.orig 2015-10-16 13:22:19 UTC
+--- pr/src/pthreads/ptthread.c.orig 2018-01-18 12:37:14 UTC
+++ pr/src/pthreads/ptthread.c
-@@ -1155,12 +1155,12 @@ PR_IMPLEMENT(void) PR_ProcessExit(PRIntn
+@@ -1122,9 +1122,9 @@ PR_IMPLEMENT(void) PR_ProcessExit(PRIntn status)
_exit(status);
}
-PR_IMPLEMENT(PRUint32) PR_GetThreadID(PRThread *thred)
+PR_IMPLEMENT(pthread_t) PR_GetThreadID(PRThread *thred)
{
- #if defined(_PR_DCETHREADS)
- return (PRUint32)&thred->id; /* this is really a sham! */
- #else
- return (PRUint32)thred->id; /* and I don't know what they will do with it */
+ return thred->id; /* and I don't know what they will do with it */
- #endif
}
+ /*