aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-20 16:48:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-20 16:48:37 +0000
commit60684e64d5f1702373e8595d8cf760a1436b5bb3 (patch)
treeee91bc3b49e0e7aafc83deeb2c024c96b8e42cad
parentc949fe4c3eaf4c1bb65d90ebb56828a13383ea00 (diff)
downloadports-60684e64d5f1702373e8595d8cf760a1436b5bb3.tar.gz
ports-60684e64d5f1702373e8595d8cf760a1436b5bb3.zip
Notes
-rw-r--r--audio/prokyon3/Makefile66
-rw-r--r--audio/prokyon3/distinfo6
-rw-r--r--audio/prokyon3/files/patch-src_getopt.c11
-rw-r--r--audio/prokyon3/files/patch-src_job_importplaylist.cpp10
-rw-r--r--audio/prokyon3/files/patch-src_qmbflacfile.cpp67
-rw-r--r--audio/prokyon3/pkg-descr20
-rw-r--r--audio/prokyon3/pkg-plist106
7 files changed, 222 insertions, 64 deletions
diff --git a/audio/prokyon3/Makefile b/audio/prokyon3/Makefile
index a6730709af5d..3c41ec9c019e 100644
--- a/audio/prokyon3/Makefile
+++ b/audio/prokyon3/Makefile
@@ -6,32 +6,36 @@
#
PORTNAME= prokyon3
-PORTVERSION= 0.9.2
-PORTREVISION= 6
+PORTVERSION= 0.9.6
CATEGORIES= audio
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= Prokyon3 is a multithreaded MP3 manager and tag editor
+COMMENT= A multithreaded music manager and tag editor
-BUILD_DEPENDS= ${LOCALBASE}/lib/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt-mysql-plugin
-LIB_DEPENDS= id3-3.8:${PORTSDIR}/audio/id3lib \
- vorbis.4:${PORTSDIR}/audio/libvorbis
-RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+BUILD_DEPENDS= ${LOCALBASE}/lib/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt-mysql-plugin \
+ bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS= FLAC.10:${PORTSDIR}/audio/flac \
+ mad.2:${PORTSDIR}/audio/libmad \
+ musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
+ vorbis.4:${PORTSDIR}/audio/libvorbis \
+ tag.5:${PORTSDIR}/audio/taglib
+RUN_DEPENDS= ${LOCALBASE}/lib/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt-mysql-plugin
USE_XORG= x11 xft
USE_QT_VER= 3
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GETTEXT= yes
+USE_GNOME= gnometarget
USE_MYSQL= yes
USE_PERL5_BUILD=yes
-CONFIGURE_ARGS+=--with-qtdir=${LOCALBASE} --with-id3-libs=${LOCALBASE}\
- --with-ogg-libs=${LOCALBASE} --with-vorbis-libs=${LOCALBASE}
-QT_NONSTANDARD= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include \
- -I${QT_PREFIX}/include" LDFLAGS="${LDFLAGS}"
-LDFLAGS+= -L${LOCALBASE}/lib
+USE_GETTEXT= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-other-includes=${LOCALBASE}/include \
+ --with-other-libs=${LOCALBASE}/lib \
+ --without-mixxx --without-musicextras
+MAKE_ARGS= LIBS="-lqt-mt ${PTHREAD_LIBS}"
+
+.include <bsd.port.pre.mk>
.if defined(WITH_BURN)
USE_CDRTOOLS= yes
@@ -39,24 +43,28 @@ RUN_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123 \
ogg123:${PORTSDIR}/audio/vorbis-tools \
normalize:${PORTSDIR}/audio/normalize \
bash:${PORTSDIR}/shells/bash
-PLIST_FILES+= bin/prokburn
+PLIST_FILES+= BURN=""
+.else
+PLIST_SUB+= BURN="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-g -O2|${CFLAGS}|; s|-lqt-mt|-lqt-mt ${PTHREAD_LIBS}|' ${WRKSRC}/configure
-.if defined(WITH_BURN)
- @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' ${WRKSRC}/prokburn
-.else
- @${REINPLACE_CMD} -e 's|prokburn||' ${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e 's|prokburn||' ${WRKSRC}/Makefile.in
-.endif
- @${REINPLACE_CMD} -E 's|[[:alpha:]]+::||' ${WRKSRC}/src/gui.h \
- ${WRKSRC}/src/configuration.h
- @${REINPLACE_CMD} -e 's|QProgressDialogScroll::||' \
- ${WRKSRC}/src/jobbase.cpp
+ @${REINPLACE_CMD} -e \
+ 's|^#!.*$$|#!${LOCALBASE}/bin/bash|g ; \
+ s|^CXXFLAGS=|#CXXFLAGS=|g ; \
+ s|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|^#!.*$$|#!${LOCALBASE}/bin/bash|g' ${WRKSRC}/prokburn
+ @${REINPLACE_CMD} -e \
+ 's|: install-binSCRIPTS|:|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|getopt.$$(OBJEXT)||g' ${WRKSRC}/src/Makefile.in
post-install:
+.if defined(WITH_BURN)
+ ${INSTALL_SCRIPT} ${WRKSRC}/prokburn ${PREFIX}/bin
+.endif
@${CAT} ${PKGMESSAGE}
@sleep 5
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/prokyon3/distinfo b/audio/prokyon3/distinfo
index c3bae389aa34..b4f4855c8bd6 100644
--- a/audio/prokyon3/distinfo
+++ b/audio/prokyon3/distinfo
@@ -1,3 +1,3 @@
-MD5 (prokyon3-0.9.2.tar.gz) = 49e7b2662f4fffc3c366c4fb0ff53d4c
-SHA256 (prokyon3-0.9.2.tar.gz) = 1053ab6c5a01410d18d7fd402d6ef1b56197d6964e6c1cc0ce8d85b20cad7d17
-SIZE (prokyon3-0.9.2.tar.gz) = 593348
+MD5 (prokyon3-0.9.6.tar.gz) = c4b3d222a518ff82af66ea4aba458f55
+SHA256 (prokyon3-0.9.6.tar.gz) = a5c9477b8f15e791860dcd7e7608dcfdc0cf423528a56525a3d20e4d6935cb6a
+SIZE (prokyon3-0.9.6.tar.gz) = 1162620
diff --git a/audio/prokyon3/files/patch-src_getopt.c b/audio/prokyon3/files/patch-src_getopt.c
deleted file mode 100644
index 6c31966e4c51..000000000000
--- a/audio/prokyon3/files/patch-src_getopt.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/getopt.c.orig Sat Sep 20 10:34:30 2003
-+++ src/getopt.c Sat Sep 20 10:35:56 2003
-@@ -24,6 +24,8 @@
- #include "config.h"
- #endif
-
-+#define _(String)(String)
-+
- #ifndef __STDC__
- /* This is a separate conditional since some stdc systems
- reject `defined (const)'. */
diff --git a/audio/prokyon3/files/patch-src_job_importplaylist.cpp b/audio/prokyon3/files/patch-src_job_importplaylist.cpp
new file mode 100644
index 000000000000..837ee34deaf0
--- /dev/null
+++ b/audio/prokyon3/files/patch-src_job_importplaylist.cpp
@@ -0,0 +1,10 @@
+--- src/job_importplaylist.cpp.orig 2007-01-07 06:51:11.000000000 +0900
++++ src/job_importplaylist.cpp 2008-06-04 02:01:55.000000000 +0900
+@@ -9,6 +9,7 @@
+ #include <qstringlist.h>
+ #include <qregexp.h>
+ #include <qfile.h>
++#include <qdir.h>
+ #include <qfileinfo.h>
+
+ #ifdef EMBEDDED
diff --git a/audio/prokyon3/files/patch-src_qmbflacfile.cpp b/audio/prokyon3/files/patch-src_qmbflacfile.cpp
new file mode 100644
index 000000000000..b31a82664721
--- /dev/null
+++ b/audio/prokyon3/files/patch-src_qmbflacfile.cpp
@@ -0,0 +1,67 @@
+--- src/qmbflacfile.cpp.orig 2006-02-01 16:47:52.000000000 +0900
++++ src/qmbflacfile.cpp 2008-06-04 02:06:11.000000000 +0900
+@@ -33,6 +33,12 @@
+ #include <musicbrainz/mb_c.h>
+ #include <FLAC++/metadata.h>
+
++#if !defined(FLAC_API_VERSION_CURRENT) || FLAC_API_VERSION_CURRENT < 8
++#define LEGACY_FLAC
++#else
++#undef LEGACY_FLAC
++#endif
++
+ QMBFLACFile::QMBFLACFile()
+ : QMBFile(), FLAC::Decoder::File(), offset(0), decode_error(false) {
+ //we do nothing here. we want to allow checking of return value,
+@@ -57,17 +63,27 @@
+ int lastslash = filename.findRev('/');
+ metadata.SetFileName(filename.right(filename.length() - lastslash - 1));
+
++#ifdef LEGACY_FLAC
+ //set the filename with the FLAC::Decoder::File class
+ set_filename(fullfilename.latin1());
++#endif
+
+ //tell the decoder to call the metadata callback on vorbis comments so we can get the metadata already stored in the file
+ set_metadata_respond(FLAC__METADATA_TYPE_VORBIS_COMMENT);
+
+ //Start reading the FLAC file
++#ifdef LEGACY_FLAC
+ FLAC__FileDecoderState state = init();
+
+ if (state != FLAC__FILE_DECODER_OK) {
+ qWarning("QMBFLACFile::Extract(): error opening file: %i (%s).", state, FLAC__FileDecoderStateString[state]);
++#else
++ FLAC__StreamDecoderState state;
++ FLAC__StreamDecoderInitStatus initstate = init(fullfilename.latin1());
++
++ if (initstate != FLAC__STREAM_DECODER_INIT_STATUS_OK) {
++ qWarning("QMBFLACFile::Extract(): error opening file: %i (%s).", initstate, FLAC__StreamDecoderStateString[initstate]);
++#endif
+ finish();
+ return -1;
+ }
+@@ -75,7 +91,11 @@
+ //read through all the metadata so our callback can catch it all
+ if(!process_until_end_of_metadata ()) {
+ state = get_state();
++#ifdef LEGACY_FLAC
+ qWarning("QMBFLACFile::Extract(): error getting metadata: %i (%s).", state, FLAC__FileDecoderStateString[state]);
++#else
++ qWarning("QMBFLACFile::Extract(): error getting metadata: %i (%s).", state, FLAC__StreamDecoderStateString[state] );
++#endif
+ decode_error = true;
+ finish();
+ return -2;
+@@ -108,7 +128,11 @@
+ while (!decode_error && offset < (unsigned long) bufferlen) {
+ if (!process_single()) {
+ state = get_state();
++#ifdef LEGACY_FLAC
+ qWarning("QMBFLACFile::Extract(): error getting raw data: %i (%s).", state, FLAC__FileDecoderStateString[state]);
++#else
++ qWarning("QMBFLACFile::Extract(): error getting raw data: %i (%s).", state, FLAC__StreamDecoderStateString[state]);
++#endif
+ decode_error = true;
+ finish();
+ return -2;
diff --git a/audio/prokyon3/pkg-descr b/audio/prokyon3/pkg-descr
index e3bd7ad68c2a..31e1604bf4ff 100644
--- a/audio/prokyon3/pkg-descr
+++ b/audio/prokyon3/pkg-descr
@@ -1,10 +1,14 @@
-prokyon3 is a multithreaded MP3 manager and tag editor for Linux.
-It was written in C++ using the Qt3 widget set and the MySQL database.
-prokyon3 can access MP3 files on hard disk, CDROM, SMB, and NFS. Files
-can be played using XMMS, and can even be played when the files are on
-CD as prokyon3 identifies CDs by content. The files view is customizable
-and favorite artists are supported. prokyon3 also offers an editor for
-ID3 tags and has been designed to support tagging for multiple files en
-masse.
+prokyon3 is a multithreaded music manager and tag editor for Unix
+(developed on Linux). It was written in C++ using the Qt3 widget set
+and the MySQL database. prokyon3 can access MP3, Ogg and FLAC files on
+hard disk, CDROM or network. Files can be played using XMMS (default)
+or other players. The file view is customizable and favorite artists
+are supported. prokyon3 also offers an editor for ID3 and Ogg tags and
+has been designed to support tagging for large quantities of files.
+
+Beside it's own features prokyon3 is able to interact with a lot of
+other programms. Thanks to it's configurable interfaces you can combine
+prokyon3 with cd burners, media players and data aggregators of your
+choice.
WWW: http://prokyon3.sourceforge.net/
diff --git a/audio/prokyon3/pkg-plist b/audio/prokyon3/pkg-plist
index a64372a00666..9e75aad7c143 100644
--- a/audio/prokyon3/pkg-plist
+++ b/audio/prokyon3/pkg-plist
@@ -1,22 +1,70 @@
+%%BURN%%bin/prokburn
bin/prokyon3
+share/locale/ca/LC_MESSAGES/prokyon3.mo
+share/locale/de/LC_MESSAGES/prokyon3.mo
+share/locale/en/LC_MESSAGES/prokyon3.mo
+share/locale/es/LC_MESSAGES/prokyon3.mo
+share/locale/fr/LC_MESSAGES/prokyon3.mo
+share/locale/he/LC_MESSAGES/prokyon3.mo
+share/locale/hr/LC_MESSAGES/prokyon3.mo
+share/locale/it/LC_MESSAGES/prokyon3.mo
+share/locale/nl/LC_MESSAGES/prokyon3.mo
+share/locale/pl/LC_MESSAGES/prokyon3.mo
+share/locale/pt_BR/LC_MESSAGES/prokyon3.mo
+share/locale/ro/LC_MESSAGES/prokyon3.mo
+share/locale/ru/LC_MESSAGES/prokyon3.mo
+share/locale/sv/LC_MESSAGES/prokyon3.mo
+share/locale/tr/LC_MESSAGES/prokyon3.mo
+share/locale/yi/LC_MESSAGES/prokyon3.mo
+%%DATADIR%%/html/manual_one_file/images/docbook/important.png
+%%DATADIR%%/html/manual_one_file/images/docbook/note.png
+%%DATADIR%%/html/manual_one_file/images/docbook/tip.png
+%%DATADIR%%/html/manual_one_file/images/docbook/warning.png
+%%DATADIR%%/html/manual_one_file/index.html
+%%DATADIR%%/html/manual_one_file/index_fr.html
+%%DATADIR%%/images/0star.png
+%%DATADIR%%/images/1star.png
+%%DATADIR%%/images/2star.png
+%%DATADIR%%/images/3star.png
+%%DATADIR%%/images/4star.png
+%%DATADIR%%/images/5star.png
%%DATADIR%%/images/action_append.png
+%%DATADIR%%/images/action_burncd.png
%%DATADIR%%/images/action_connect.png
%%DATADIR%%/images/action_createdb.png
%%DATADIR%%/images/action_discard.png
%%DATADIR%%/images/action_disconnect.png
+%%DATADIR%%/images/action_documentation.png
+%%DATADIR%%/images/action_mextras_log.png
%%DATADIR%%/images/action_quit.png
%%DATADIR%%/images/action_readtags.png
%%DATADIR%%/images/action_remove.png
+%%DATADIR%%/images/action_rename.png
+%%DATADIR%%/images/action_selectall.png
%%DATADIR%%/images/action_settings.png
%%DATADIR%%/images/action_switchbottom.png
%%DATADIR%%/images/action_switchleft.png
%%DATADIR%%/images/action_switchright.png
%%DATADIR%%/images/action_synchronize.png
+%%DATADIR%%/images/action_unselectall.png
%%DATADIR%%/images/action_updateonly.png
%%DATADIR%%/images/action_writetags.png
-%%DATADIR%%/images/action_xmms.png
+%%DATADIR%%/images/amarok.png
+%%DATADIR%%/images/ask_musicbrainz.png
+%%DATADIR%%/images/beep-media-player.png
+%%DATADIR%%/images/down.png
+%%DATADIR%%/images/fileimport.png
+%%DATADIR%%/images/filenew.png
+%%DATADIR%%/images/filesave.png
+%%DATADIR%%/images/filter.png
%%DATADIR%%/images/help.png
+%%DATADIR%%/images/html.png
+%%DATADIR%%/images/icon.png
+%%DATADIR%%/images/idea.png
+%%DATADIR%%/images/jump.png
+%%DATADIR%%/images/kaffeine.png
%%DATADIR%%/images/lvi_album.png
+%%DATADIR%%/images/lvi_album16x16.png
%%DATADIR%%/images/lvi_artist.png
%%DATADIR%%/images/lvi_artist_favourite.png
%%DATADIR%%/images/lvi_cdrom.png
@@ -26,19 +74,51 @@ bin/prokyon3
%%DATADIR%%/images/lvi_playlist.png
%%DATADIR%%/images/lvi_smb.png
%%DATADIR%%/images/madsmiley.png
-%%DATADIR%%/images/pink_marble.png
+%%DATADIR%%/images/mixxx.png
+%%DATADIR%%/images/mplayer.png
+%%DATADIR%%/images/music_sixteenthnote.png
+%%DATADIR%%/images/noatun.png
+%%DATADIR%%/images/play-off-Ch1.png
+%%DATADIR%%/images/play-off-Ch2.png
+%%DATADIR%%/images/play-on-Ch1.png
+%%DATADIR%%/images/play-on-Ch2.png
+%%DATADIR%%/images/player_enqueue.png
+%%DATADIR%%/images/player_fwd.png
+%%DATADIR%%/images/player_next.png
+%%DATADIR%%/images/player_pause.png
+%%DATADIR%%/images/player_play.png
+%%DATADIR%%/images/player_prev.png
+%%DATADIR%%/images/player_rew.png
+%%DATADIR%%/images/player_stop.png
+%%DATADIR%%/images/prelisten_enqueue.png
+%%DATADIR%%/images/prelisten_fwd.png
+%%DATADIR%%/images/prelisten_next.png
+%%DATADIR%%/images/prelisten_pause.png
+%%DATADIR%%/images/prelisten_play.png
+%%DATADIR%%/images/prelisten_play2.png
+%%DATADIR%%/images/prelisten_prev.png
+%%DATADIR%%/images/prelisten_rew.png
+%%DATADIR%%/images/prelisten_stop.png
+%%DATADIR%%/images/prokyon_bump.png
+%%DATADIR%%/images/prokyon_logo.png
%%DATADIR%%/images/smiley.png
-%%DATADIR%%/images/splash4.png
-share/locale/de/LC_MESSAGES/prokyon3.mo
-share/locale/fr/LC_MESSAGES/prokyon3.mo
-share/locale/nl/LC_MESSAGES/prokyon3.mo
-%%DATADIR%%/images/action_burncd.png
-%%DATADIR%%/images/action_documentation.png
-%%DATADIR%%/html/manual_one_file/images/docbook/important.png
-%%DATADIR%%/html/manual_one_file/images/docbook/note.png
-%%DATADIR%%/html/manual_one_file/images/docbook/tip.png
-%%DATADIR%%/html/manual_one_file/images/docbook/warning.png
-%%DATADIR%%/html/manual_one_file/index.html
+%%DATADIR%%/images/splash5.png
+%%DATADIR%%/images/totem.png
+%%DATADIR%%/images/up.png
+%%DATADIR%%/images/xmms.png
+%%DATADIR%%/prokyon3_embedded_mysql.cnf
+%%DATADIR%%/testmusicextras/test1.mp3
+%%DATADIR%%/testmusicextras/test2.mp3
+%%DATADIR%%/testmusicextras/test3.mp3
+%%DATADIR%%/testmusicextras/test4.mp3
+%%DATADIR%%/testmusicextras/test5.mp3
+%%DATADIR%%/testmusicextras/test6.mp3
+%%DATADIR%%/testmusicextras/test7.mp3
+%%DATADIR%%/testmusicextras/testresults.pdf
+%%DATADIR%%/testmusicextras/testresults.sxw
+@dirrmtry share/locale/yi/LC_MESSAGES
+@dirrmtry share/locale/yi
+@dirrm %%DATADIR%%/testmusicextras
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%/html/manual_one_file/images/docbook
@dirrm %%DATADIR%%/html/manual_one_file/images