aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-09-06 14:09:58 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-09-06 14:09:58 +0000
commit612cfe0ea154a90e3801489229f9495f3ec8e6b3 (patch)
treea8c401f0deda5a3e77f253b818bf06325e930a49
parentef1a4679e246593be4bf9885347829abf80a9763 (diff)
downloadports-612cfe0ea154a90e3801489229f9495f3ec8e6b3.tar.gz
ports-612cfe0ea154a90e3801489229f9495f3ec8e6b3.zip
Notes
-rw-r--r--net-p2p/gtk-gnutella/Makefile40
-rw-r--r--net-p2p/gtk-gnutella/distinfo5
-rw-r--r--net-p2p/gtk-gnutella/files/patch-src_gcc.h11
-rw-r--r--net-p2p/gtk-gnutella/pkg-help28
4 files changed, 35 insertions, 49 deletions
diff --git a/net-p2p/gtk-gnutella/Makefile b/net-p2p/gtk-gnutella/Makefile
index 4461ed2d5c48..039e7e503708 100644
--- a/net-p2p/gtk-gnutella/Makefile
+++ b/net-p2p/gtk-gnutella/Makefile
@@ -1,42 +1,8 @@
# Created by: rbt@zort.on.ca
# $FreeBSD$
-#
-# A quick note on configurable make symbols:
-#
-# INTERACTIVE_CONFIGURE: Launches Configure in its default mode, which is
-# *very* interactive. Disabled here by default to conform to FreeBSD
-# guidelines, this mode is useful if you have problems with the
-# default Configure.
-#
-# GUI: Disable this to build a headless version of Gtk-Gnutella. Therefore,
-# monitoring of operations for Gtk-Gnutella will have to be
-# done without relying on any GUI, and the configuration is done via
-# files only.
-#
-# TLS: Enable support for scrambling GNet connections. Currently supported
-# only by Gtk-Gnutella.
-#
-# NLS: Enable National Language Support for translation of User Interface.
-#
-# IPV6: Enable to support IPv6 connections. The real configuration takes
-# place at run-time so keeping it enabled will not force IPv6 usage.
-#
-# DBUS: Enable D-Bus IPC support. Gtk-Gnutella will send out messages onto
-# the D-Bus message bus. That way external applications can easily
-# act on certain events that happen, such as a completed download.
-#
-# DEBUG: Compile with debugging symbols. Useful if you intend to make a
-# bug report.
-#
-# PORTABILITY: Configure code to use the PATH variable at run-time at a
-# cost in performance. Useful if you intend to move the executable
-# to multiple machines.
-#
-
PORTNAME= gtk-gnutella
-PORTVERSION= 1.1.9
-PORTREVISION= 1
+PORTVERSION= 1.1.10
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF
@@ -73,9 +39,11 @@ OPTIONS_SUB= yes
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
DBUS_CONFIGURE_OFF= -Ud_dbus
DEBUG_CONFIGURE_ON= -Ud_official
-GUI_USE= gnome=gtk20
+GUI_USE= gnome=gtk20,cairo
GUI_VARS= INSTALLS_ICONS=yes
GUI_CONFIGURE_OFF= -Dd_headless
+GUI_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
IPV6_CONFIGURE_OFF= -Ud_ipv6
NLS_USES= gettext
NLS_CONFIGURE_OFF= -Ud_nls
diff --git a/net-p2p/gtk-gnutella/distinfo b/net-p2p/gtk-gnutella/distinfo
index fa5c976f4f32..5f997076cd35 100644
--- a/net-p2p/gtk-gnutella/distinfo
+++ b/net-p2p/gtk-gnutella/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gtk-gnutella-1.1.9.tar.bz2) = 3b2e913969834a57edd93d22733646037b2a141172d5d4a240f5d6a9f56b6aff
-SIZE (gtk-gnutella-1.1.9.tar.bz2) = 19766381
+TIMESTAMP = 1472865668
+SHA256 (gtk-gnutella-1.1.10.tar.bz2) = 95e2a030124e7cc05e19e351eebc16f40f4520381b7bb306e8b940ed4e2e6409
+SIZE (gtk-gnutella-1.1.10.tar.bz2) = 19827825
diff --git a/net-p2p/gtk-gnutella/files/patch-src_gcc.h b/net-p2p/gtk-gnutella/files/patch-src_gcc.h
deleted file mode 100644
index 8a9ea6e60926..000000000000
--- a/net-p2p/gtk-gnutella/files/patch-src_gcc.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gcc.h.orig 2016-03-24 18:58:27 UTC
-+++ src/gcc.h
-@@ -310,7 +310,7 @@
- * warning purposedly for some section of the file and then later restore
- * the original warnings.
- */
--#if HAS_GCC(3, 0)
-+#if HAS_GCC(4, 8)
- #define G_IGNORE_PUSH(x) \
- G_PRAGMA(GCC diagnostic push) \
- G_PRAGMA(GCC diagnostic ignored #x)
diff --git a/net-p2p/gtk-gnutella/pkg-help b/net-p2p/gtk-gnutella/pkg-help
new file mode 100644
index 000000000000..906a66fc0144
--- /dev/null
+++ b/net-p2p/gtk-gnutella/pkg-help
@@ -0,0 +1,28 @@
+INTERACTIVE_CONFIGURE: Launches Configure in its default mode, which is
+ *very* interactive. Disabled here by default to conform to FreeBSD
+ guidelines, this mode is useful if you have problems with the
+ default Configure.
+
+GUI: Disable this to build a headless version of Gtk-Gnutella. Therefore,
+ monitoring of operations for Gtk-Gnutella will have to be
+ done without relying on any GUI, and the configuration is done via
+ files only.
+
+TLS: Enable support for scrambling GNet connections. Currently supported
+ only by Gtk-Gnutella.
+
+NLS: Enable National Language Support for translation of User Interface.
+
+IPV6: Enable to support IPv6 connections. The real configuration takes
+ place at run-time so keeping it enabled will not force IPv6 usage.
+
+DBUS: Enable D-Bus IPC support. Gtk-Gnutella will send out messages onto
+ the D-Bus message bus. That way external applications can easily
+ act on certain events that happen, such as a completed download.
+
+DEBUG: Compile with debugging symbols. Useful if you intend to make a
+ bug report.
+
+PORTABILITY: Configure code to use the PATH variable at run-time at a
+ cost in performance. Useful if you intend to move the executable
+ to multiple machines.