aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-12-30 18:31:12 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-12-30 18:31:12 +0000
commit6213e7477787a9b353f0b73141858cb15fac1888 (patch)
tree28ae4b3aaf67961db545d882aebb29bf6b069ac9
parent16751c982c44eb4d755d6ed4e4975fcb620f9c6a (diff)
downloadports-6213e7477787a9b353f0b73141858cb15fac1888.tar.gz
ports-6213e7477787a9b353f0b73141858cb15fac1888.zip
- Update to 0.8.2
- Remove unneeded patch - Add note about the hidden 'MiscSlimTabs' option (it requires Gtk+ > 3.20). If this option is set, lots of warnings will appear: Gtk-WARNING **: Theme parsing error: <data>:2:12: 'min-height' is not a valid property name Gtk-WARNING **: Theme parsing error: <data>:8:11: 'min-width' is not a valid property name
Notes
Notes: svn path=/head/; revision=430014
-rw-r--r--UPDATING8
-rw-r--r--x11/xfce4-terminal/Makefile2
-rw-r--r--x11/xfce4-terminal/distinfo6
-rw-r--r--x11/xfce4-terminal/files/patch-terminal_terminal-screen.c58
-rw-r--r--x11/xfce4-terminal/files/pkg-message.in3
5 files changed, 15 insertions, 62 deletions
diff --git a/UPDATING b/UPDATING
index f7fde248051f..06cf3c1b00c5 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20161230:
+ AFFECTS: users of x11/xfce4-terminal
+ AUTHOR: olivierd@FreeBSD.org
+
+ The port has been updated to the latest stable version 0.8.2.
+ Please, don't active the hidden 'MiscSlimTabs' option in
+ ~/.config/xfce4/terminal/terminalrc, it requires Gtk+ > 3.20.
+
20161228:
AFFECTS: users of multimedia/mlt
AUTHOR: avilla@FreeBSD.org
diff --git a/x11/xfce4-terminal/Makefile b/x11/xfce4-terminal/Makefile
index e7dfc49af4ab..57e13ab55952 100644
--- a/x11/xfce4-terminal/Makefile
+++ b/x11/xfce4-terminal/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-terminal
-PORTVERSION= 0.8.1
+PORTVERSION= 0.8.2
CATEGORIES= x11 xfce
MASTER_SITES= XFCE/src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
diff --git a/x11/xfce4-terminal/distinfo b/x11/xfce4-terminal/distinfo
index fcd63ae3bc3f..9a47ccb21921 100644
--- a/x11/xfce4-terminal/distinfo
+++ b/x11/xfce4-terminal/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477933186
-SHA256 (xfce4/xfce4-terminal-0.8.1.tar.bz2) = ddfe53a89d315a4a9170ca6d2cee2d33145bd63630062b2e867fb3a5fcde5fdf
-SIZE (xfce4/xfce4-terminal-0.8.1.tar.bz2) = 871184
+TIMESTAMP = 1483118380
+SHA256 (xfce4/xfce4-terminal-0.8.2.tar.bz2) = 92aad3e14f3ef8d4c6c1409463e989bd8f5eefb686234f3cdbfe574729401681
+SIZE (xfce4/xfce4-terminal-0.8.2.tar.bz2) = 929068
diff --git a/x11/xfce4-terminal/files/patch-terminal_terminal-screen.c b/x11/xfce4-terminal/files/patch-terminal_terminal-screen.c
deleted file mode 100644
index 7da770984e8c..000000000000
--- a/x11/xfce4-terminal/files/patch-terminal_terminal-screen.c
+++ /dev/null
@@ -1,58 +0,0 @@
-Revert commit, because default size is not anymore enabled.
-
---- terminal/terminal-screen.c.orig 2016-10-25 16:07:56 UTC
-+++ terminal/terminal-screen.c
-@@ -1673,47 +1673,31 @@ terminal_screen_get_geometry (TerminalSc
- *
- * I don't like this way, but its required to work-around a Gtk+
- * bug (maybe also caused by a Vte bug, not sure).
-- *
-- * Code borrowed from gnome-terminal (terminal_window_update_geometry).
- **/
- void
- terminal_screen_set_window_geometry_hints (TerminalScreen *screen,
- GtkWindow *window)
- {
- GdkGeometry hints;
-- GtkRequisition vbox_request;
-- GtkAllocation toplevel_allocation, vbox_allocation;
- glong char_width, char_height;
-- glong grid_width, grid_height;
-- glong chrome_width, chrome_height;
-- gint csd_width, csd_height;
-+ gint xpad, ypad;
-
- terminal_return_if_fail (TERMINAL_IS_SCREEN (screen));
- terminal_return_if_fail (VTE_IS_TERMINAL (screen->terminal));
- terminal_return_if_fail (gtk_widget_get_realized (screen));
- terminal_return_if_fail (gtk_widget_get_realized (window));
-
-- terminal_screen_get_geometry (screen, &char_width, &char_height, NULL, NULL);
-- terminal_screen_get_size (screen, &grid_width, &grid_height);
--
-- gtk_widget_get_preferred_size (TERMINAL_WINDOW (window)->vbox, NULL, &vbox_request);
-- chrome_width = vbox_request.width - (char_width * grid_width);
-- chrome_height = vbox_request.height - (char_height * grid_height);
--
-- gtk_widget_get_allocation (TERMINAL_WINDOW (window)->vbox, &vbox_allocation);
-- gtk_widget_get_allocation (GTK_WIDGET (window), &toplevel_allocation);
-- csd_width = toplevel_allocation.width - vbox_allocation.width;
-- csd_height = toplevel_allocation.height - vbox_allocation.height;
-+ terminal_screen_get_geometry (screen, &char_width, &char_height, &xpad, &ypad);
-
-- hints.base_width = chrome_width + csd_width;
-- hints.base_height = chrome_height + csd_height;
-+ hints.base_width = xpad;
-+ hints.base_height = ypad;
- hints.width_inc = char_width;
- hints.height_inc = char_height;
- hints.min_width = hints.base_width + hints.width_inc * 4;
- hints.min_height = hints.base_height + hints.height_inc * 2;
-
-- gtk_window_set_geometry_hints (window,
-- NULL,
-+ gtk_window_set_geometry_hints (GTK_WINDOW (window),
-+ screen->terminal,
- &hints,
- GDK_HINT_RESIZE_INC
- | GDK_HINT_MIN_SIZE
diff --git a/x11/xfce4-terminal/files/pkg-message.in b/x11/xfce4-terminal/files/pkg-message.in
index f1947f11404a..cd6c9cddd238 100644
--- a/x11/xfce4-terminal/files/pkg-message.in
+++ b/x11/xfce4-terminal/files/pkg-message.in
@@ -5,3 +5,6 @@ TerminalWindow GtkNotebook.notebook {
padding-top: 0;
padding-bottom: 0;
}
+
+Don't active the hidden MiscSlimTabs option in terminalrc. It requires
+Gtk+ >= 3.20