aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-09 17:06:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-09 17:06:48 +0000
commit622a4efb88c71be52c7c9d08b7dcf3b9d724c908 (patch)
tree57fc06350015113a3f643a7ac93875c0732e596a
parent48a4ab9e2212540d24133d7aa00e59eea6c94ef6 (diff)
downloadports-622a4efb88c71be52c7c9d08b7dcf3b9d724c908.tar.gz
ports-622a4efb88c71be52c7c9d08b7dcf3b9d724c908.zip
science/namd: Add IGNORE clause instead of the custom do-fetch clause for the licensing warning
Also add RESTRICTED, and remove GIT_URL. Reported by: mat
Notes
Notes: svn path=/head/; revision=479321
-rw-r--r--LEGAL1
-rw-r--r--science/namd/Makefile21
2 files changed, 8 insertions, 14 deletions
diff --git a/LEGAL b/LEGAL
index 6cdb74cd4cc4..494bd0058070 100644
--- a/LEGAL
+++ b/LEGAL
@@ -240,3 +240,4 @@ rainloop-1.*.zip mail/rainloop Redistribution in any form is prohibited
lha-114i.tar.gz archivers/lha Binary only redistribution is prohibited. Non-network redistribution such as CDROM requires prior notification to author. Commercial use whose main purpose is to provide the functions of this program is prohibited.
atom-*.tgz science/atom Redistribution in any form is prohibited
charm-uiuc* net/charm No commercial use: commercial use requires a commercial license
+namd* science/namd No commercial use: commercial use requires a commercial license
diff --git a/science/namd/Makefile b/science/namd/Makefile
index 631dc91b5308..01462df02c4d 100644
--- a/science/namd/Makefile
+++ b/science/namd/Makefile
@@ -22,11 +22,11 @@ BUILD_DEPENDS= bash:shells/bash \
LIB_DEPENDS= libck.so:net/charm \
libfftw3f.so:math/fftw3-float
+RESTRICTED= No commercial use: commercial use requires a commercial license
+
USES= fortran gmake localbase:ldflags python:build shebangfix tcl
SHEBANG_FILES= config
-GIT_URL= https://charm.cs.illinois.edu/gerrit/namd.git
-
ARCH_STR= Linux-${ARCH:S/amd64/x86_64/:S/i386/x86/}-g++
ARCH_STR_CHARM= linux${ARCH:S/amd64/64/:S/i386/32/}
@@ -44,18 +44,11 @@ PLIST_FILES= bin/flipbinpdb \
bin/psfgen \
bin/sortreplicas
-local-makesum: # Workaround: the generic 'make makesum' is broken when custom do-fetch is defined: it calls ${SCRIPTSDIR}/do-fetch.sh.
- @${MAKE} distclean fetch makesum
+.include <bsd.port.pre.mk>
-do-fetch:
- @if ! [ -f "${DISTDIR}/${DISTFILES}" ]; then \
- ${ECHO} "(!!)"; \
- ${ECHO} "(!!) Please download the release tarball of the version ${DISTVERSION} (${DISTFILES})"; \
- ${ECHO} "(!!) from https://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=NAMD,"; \
- ${ECHO} "(!!) put it into ${DISTDIR}, and run 'make' again."; \
- ${ECHO} "(!!)"; \
- ${FALSE}; \
- fi
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= please download the release tarball of the version ${DISTVERSION} (${DISTFILES}) from https://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=NAMD, put it into ${DISTDIR}, and run 'make' again
+.endif
do-configure:
@cd ${WRKSRC} && ${ECHO} "CHARMBASE=${LOCALBASE}" > Make.config
@@ -75,4 +68,4 @@ do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${e} ${STAGEDIR}${PREFIX}/bin
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>