aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-08-22 21:22:29 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-08-22 21:22:29 +0000
commit6244b17fc2b00594d9295b315a018a33f273d96a (patch)
tree925a2759b12db5c6ad2258970fb49c8deaa84a9b
parenta2c683daec79e22c62c782a653b968f5f68d8dcd (diff)
downloadports-6244b17fc2b00594d9295b315a018a33f273d96a.tar.gz
ports-6244b17fc2b00594d9295b315a018a33f273d96a.zip
Notes
-rw-r--r--mail/Makefile1
-rw-r--r--mail/gtkgrepmail/Makefile39
-rw-r--r--mail/gtkgrepmail/distinfo1
-rw-r--r--mail/gtkgrepmail/files/patch-gtkgrepmail49
-rw-r--r--mail/gtkgrepmail/pkg-comment1
-rw-r--r--mail/gtkgrepmail/pkg-descr7
-rw-r--r--mail/gtkgrepmail/pkg-plist12
7 files changed, 110 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index b48f405e9fbd..66f201a1d2a8 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -69,6 +69,7 @@
SUBDIR += gnumail
SUBDIR += gotmail
SUBDIR += grepmail
+ SUBDIR += gtkgrepmail
SUBDIR += hbiff
SUBDIR += icqmail
SUBDIR += ifile
diff --git a/mail/gtkgrepmail/Makefile b/mail/gtkgrepmail/Makefile
new file mode 100644
index 000000000000..6150c3d0d946
--- /dev/null
+++ b/mail/gtkgrepmail/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: gtkgrepmail
+# Date created: 19 May 2002
+# Whom: Oliver Braun <obraun@informatik.unibw-muenchen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkgrepmail
+PORTVERSION= 0.6
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.terminus.net.au/unix/perl/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= obraun@FreeBSD.org
+
+BUILD_DEPENDS= grepmail:${PORTSDIR}/mail/grepmail \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gnome.pm:${PORTSDIR}/x11-toolkits/p5-Gnome \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= grepmail:${PORTSDIR}/mail/grepmail \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gnome.pm:${PORTSDIR}/x11-toolkits/p5-Gnome \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI.pm:${PORTSDIR}/net/p5-URI
+
+PERL_CONFIGURE= YES
+
+MAN1= gtkgrepmail.1
+
+PORTDOCS= COPYING FAQ NEWS ROADMAP changelog INSTALL README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/gtkgrepmail/distinfo b/mail/gtkgrepmail/distinfo
new file mode 100644
index 000000000000..3ca35e6b6f8b
--- /dev/null
+++ b/mail/gtkgrepmail/distinfo
@@ -0,0 +1 @@
+MD5 (gtkgrepmail-0.6.tgz) = 73dfb91d3fd1ac9f772475695d0136e3
diff --git a/mail/gtkgrepmail/files/patch-gtkgrepmail b/mail/gtkgrepmail/files/patch-gtkgrepmail
new file mode 100644
index 000000000000..0443136ab3f2
--- /dev/null
+++ b/mail/gtkgrepmail/files/patch-gtkgrepmail
@@ -0,0 +1,49 @@
+--- gtkgrepmail.orig Sat May 18 11:27:24 2002
++++ gtkgrepmail Thu Aug 22 22:42:33 2002
+@@ -31,8 +31,8 @@
+ # Define variables
+ $defaultMailpath="$ENV{HOME}/Mail";
+ $defaultMailbox="search-results";
+-$defaultGrepmail="/usr/bin/grepmail";
+-$defaultIMAP="/usr/bin/X11/xterm -e /usr/bin/elm -f";
++$defaultGrepmail="/usr/local/bin/grepmail";
++$defaultIMAP="/usr/X11R6/bin/xterm -e /usr/bin/elm -f";
+ $defaultSSH="/usr/bin/ssh";
+ $defaultHost="localhost";
+ $defaultUser="$ENV{USER}";
+@@ -1043,7 +1043,7 @@
+ $chkRecurse->set_active(0);
+ $row = 0;
+ while ( $row <= $#filelist ) {
+- $lstFiles->unselect_item($row,0);
++ $lstFiles->unselect_row($row,0);
+ $row++;
+ }
+ @valfiles = "";
+@@ -1084,7 +1084,7 @@
+ }
+
+ sub select_item {
+- ( $widget, $path ) = @_;
++# ( $widget, $path ) = @_;
+ # FIXME - does not work
+ # $entry->set_text( $path );
+ # show_files( $path );
+@@ -1249,7 +1249,7 @@
+ if ( $valrdbAnd && $valAnd ) { $andspec = "| grepmail $scopeflag2 $valInverse $valCase -e \\\"$valAnd\\\"" }
+ elsif ( $valAnd ) { $orspec = "\\|\\\"$valAnd\\\"" };
+ if ( $valNot ) { $notspec = "| grepmail $scopeflag3 $valCase -v -e \\\"$valNot\\\"" };
+- $grepmailcmd = "$valGrepmail -e \\(\\\"$valSearch\\\"$orspec\\) $scopeflag $valInverse $valCase $valRecurse $valSkipattach $datespec @valfiles $andspec $notspec 2>&1 1>$valMailpath/$valMailbox";
++ $grepmailcmd = "$valGrepmail -e \\(\"$valSearch\"$orspec\\) $scopeflag $valInverse $valCase $valRecurse $valSkipattach $datespec @valfiles $andspec $notspec 2>&1 1>$valMailpath/$valMailbox";
+ if ( $usrHost eq "localhost" ) {
+ $grepmailcmd = "$grepmailcmd 2>/tmp/gtkgrepmail.$$"
+ } else {
+@@ -1262,7 +1262,7 @@
+ $dlgMain_form->window->set_cursor( new Gtk::Gdk::Cursor( 150 ) );
+ # Cursor does not redraw itself unless we do this
+ $dlgMain_form->draw(undef);
+- unless ($child = fork) {
++ unless (fork) {
+ exec "$grepmailcmd";
+ };
+ $signalid = $dlgMain_form->signal_connect( 'key_press_event', "on_dlgMain_keypress" );
diff --git a/mail/gtkgrepmail/pkg-comment b/mail/gtkgrepmail/pkg-comment
new file mode 100644
index 000000000000..5d8a2bb58b10
--- /dev/null
+++ b/mail/gtkgrepmail/pkg-comment
@@ -0,0 +1 @@
+A gtk front-end to grepmail
diff --git a/mail/gtkgrepmail/pkg-descr b/mail/gtkgrepmail/pkg-descr
new file mode 100644
index 000000000000..95b6e0b3b4c4
--- /dev/null
+++ b/mail/gtkgrepmail/pkg-descr
@@ -0,0 +1,7 @@
+Gtkgrepmail is a gtk front end to grepmail. Support is provided for both local
+mailboxes and remote mailboxes that are accessible via IMAP and ssh/rsh.
+
+WWW: http://malcolm.wattle.id.au/software.html
+
+- Oliver Braun
+obraun@informatik.unibw-muenchen.de
diff --git a/mail/gtkgrepmail/pkg-plist b/mail/gtkgrepmail/pkg-plist
new file mode 100644
index 000000000000..f76976a1d8d0
--- /dev/null
+++ b/mail/gtkgrepmail/pkg-plist
@@ -0,0 +1,12 @@
+bin/gtkgrepmail
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/gtkgrepmail/.packlist
+%%PORTDOCS%%share/doc/gtkgrepmail/COPYING
+%%PORTDOCS%%share/doc/gtkgrepmail/FAQ
+%%PORTDOCS%%share/doc/gtkgrepmail/NEWS
+%%PORTDOCS%%share/doc/gtkgrepmail/ROADMAP
+%%PORTDOCS%%share/doc/gtkgrepmail/changelog
+%%PORTDOCS%%share/doc/gtkgrepmail/INSTALL
+%%PORTDOCS%%share/doc/gtkgrepmail/README
+%%PORTDOCS%%share/doc/gtkgrepmail/TODO
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/gtkgrepmail
+%%PORTDOCS%%@dirrm share/doc/gtkgrepmail