aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-07-18 07:27:19 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-07-18 07:27:19 +0000
commit626f880bd07801b0b5c9b9324ca3f2088344b07c (patch)
treea7eea33c196ac68816cd250feb926aee4a921416
parentb727f60437bf6d4c8bf11533987fe18dcf1b1c09 (diff)
Notes
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/alef/Makefile40
-rw-r--r--x11-fonts/alef/distinfo2
-rw-r--r--x11-fonts/alef/pkg-descr8
-rw-r--r--x11-fonts/alef/pkg-plist3
5 files changed, 54 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 5b4564ef3577..c7284e1f0c02 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -3,6 +3,7 @@
COMMENT = X11 fonts and font utilities
+ SUBDIR += alef
SUBDIR += alegreya-sans
SUBDIR += alfont
SUBDIR += andika
diff --git a/x11-fonts/alef/Makefile b/x11-fonts/alef/Makefile
new file mode 100644
index 000000000000..7d15d9114eb3
--- /dev/null
+++ b/x11-fonts/alef/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= alef
+PORTVERSION= 1.0
+CATEGORIES= x11-fonts
+MASTER_SITES= http://alef.hagilda.com/
+DISTNAME= Alef
+
+MAINTAINER= cpm@fbsd.es
+COMMENT= A free multi-lingual font designed for screens
+
+LICENSE= OFL11
+
+BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+
+USES= zip
+USE_XORG= x11
+FONTSDIR= ${PREFIX}/lib/X11/fonts/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+NO_BUILD= yes
+
+PLIST_SUB= FONTSDIR="${FONTSDIR:S|${PREFIX}/||}"
+
+PORTDOCS= --COMING-SOON--.txt OFL-license.txt readme.txt
+
+OPTIONS_DEFINE= DOCS
+
+post-extract:
+ @${MKDIR} ${WRKSRC}
+ cd ${WRKDIR} ; ${MV} TTF ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TTF/* ${STAGEDIR}${FONTSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKDIR}/${f} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/alef/distinfo b/x11-fonts/alef/distinfo
new file mode 100644
index 000000000000..19f4d5123f8e
--- /dev/null
+++ b/x11-fonts/alef/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Alef.zip) = aae9b927858a1dbc56f371ac893af09348031e21c2ef0b94115ce5915d6ec990
+SIZE (Alef.zip) = 799409
diff --git a/x11-fonts/alef/pkg-descr b/x11-fonts/alef/pkg-descr
new file mode 100644
index 000000000000..908f6ae75f79
--- /dev/null
+++ b/x11-fonts/alef/pkg-descr
@@ -0,0 +1,8 @@
+Alef has been designed to meet very high standards whilst at a very small
+size. It was created under the consideration of its primary use for digital
+media, and overcomes great challenges in the rendition of small characters
+and cross-platform adjustment.
+
+The font supports Hebrew and various European Languages.
+
+WWW: http://alef.hagilda.com/
diff --git a/x11-fonts/alef/pkg-plist b/x11-fonts/alef/pkg-plist
new file mode 100644
index 000000000000..1dd1261938ba
--- /dev/null
+++ b/x11-fonts/alef/pkg-plist
@@ -0,0 +1,3 @@
+%%FONTSDIR%%/Alef-Bold.ttf
+%%FONTSDIR%%/Alef-Regular.ttf
+@dirrmtry %%FONTSDIR%%