aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-19 03:44:09 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-19 03:44:09 +0000
commit627965f725bf96fe7ba3bcac16f85900bd3c033f (patch)
tree0c428775c4600ff97fab39385f276023300c92d6
parent7545065b68055c633308cee695c089fb15d671ea (diff)
downloadports-627965f725bf96fe7ba3bcac16f85900bd3c033f.tar.gz
ports-627965f725bf96fe7ba3bcac16f85900bd3c033f.zip
New port: sysutils/sas2ircu
sas2ircu allows basic management of mps(4) based RAID controllers. This includes controllers based on the LSI SAS2 IR protocol. See the mps(4) man page for a more thorough list of controllers. May not be redistributed. Must accept license to download. WWW: http://www.lsi.com/ PR: 190399 Submitted by: Daniel Austin <freebsd-ports@dan.me.uk>
Notes
Notes: svn path=/head/; revision=365360
-rw-r--r--LEGAL1
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/sas2ircu/Makefile60
-rw-r--r--sysutils/sas2ircu/distinfo2
-rw-r--r--sysutils/sas2ircu/pkg-descr5
-rw-r--r--sysutils/sas2ircu/pkg-plist4
6 files changed, 73 insertions, 0 deletions
diff --git a/LEGAL b/LEGAL
index 4a7c6e343eb4..34ab576670f5 100644
--- a/LEGAL
+++ b/LEGAL
@@ -305,3 +305,4 @@ UrbanTerror*.zip games/urbanterror-data The mod files may not be sold or distrib
gmsh-* cad/gmsh Contact appropriate authors for commercial purposes if including Tetgen or Metis
gmsh-occ-* cad/gmsh-occ Contact appropriate authors for commercial purposes if including Tetgen or Metis
btsync_* net-p2p/btsync Redistribution forbidden by license
+sas2ircu-* sysutils/sas2ircu May not be redistributed. Must accept license to download.
diff --git a/sysutils/Makefile b/sysutils/Makefile
index f1395b751dfe..8b4275a8020a 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -849,6 +849,7 @@
SUBDIR += safecat
SUBDIR += samefile
SUBDIR += samesame
+ SUBDIR += sas2ircu
SUBDIR += savelogs
SUBDIR += sb16config
SUBDIR += sbniconfig
diff --git a/sysutils/sas2ircu/Makefile b/sysutils/sas2ircu/Makefile
new file mode 100644
index 000000000000..27fd021537e7
--- /dev/null
+++ b/sysutils/sas2ircu/Makefile
@@ -0,0 +1,60 @@
+# Created by: Daniel Austin <freebsd-ports@dan.me.uk>
+# $FreeBSD$
+
+PORTNAME= sas2ircu
+PORTVERSION= 16.00.00.00
+CATEGORIES= sysutils
+MASTER_SITES= #http://www.lsi.com/downloads/Public/Host%20Bus%20Adapters/Host%20Bus%20Adapters%20Common%20Files/SAS_SATA_6G_P16/
+DISTNAME= SAS2IRCU_P16
+
+MAINTAINER= freebsd-ports@dan.me.uk
+COMMENT= Tool for basic management of mps(4) based LSI RAID controllers
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+USES= zip
+NO_BUILD= yes
+
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= Binaries only available for i386 and amd64 from LSI
+
+RESTRICTED= May not be redistributed. Must accept license to download.
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.include <bsd.port.pre.mk>
+
+.if (!exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}))
+DISTFILE_INSTRUCTIONS=\n\
+Due to licensing restrictions, certain files must be fetched manually.\n\
+Please visit the following URL and accept the license agreement.\n\n\
+http://www.lsi.com/downloads/Public/Host%%20Bus%%20Adapters/Host%%20Bus%%20Adapters%%20Common%%20Files/SAS_SATA_6G_P16/SAS2IRCU_P16.zip\n\n\
+After the download has completed, please place ${DISTNAME}${EXTRACT_SUFX} in\n\
+${DISTDIR}, then restart the build.\n\n
+.endif
+
+.if defined(DISTFILE_INSTRUCTIONS)
+.if defined(PACKAGE_BUILDING)
+IGNORE= requires manual fetch
+.else
+pre-fetch:
+ @${PRINTF} "${DISTFILE_INSTRUCTIONS}"
+ @exit 1;
+.endif
+.endif
+
+do-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Readme_Release_Notes_SAS2IRCU_Phase_16.00.00.00.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/SAS2Flash_ReferenceGuide.pdf ${STAGEDIR}${DOCSDIR}
+.endif
+.if ${ARCH} == "amd64"
+ ${INSTALL_PROGRAM} ${WRKSRC}/sas2ircu_freebsd_amd64_rel/sas2ircu ${STAGEDIR}${PREFIX}/sbin
+.else
+ ${INSTALL_PROGRAM} ${WRKSRC}/sas2ircu_freebsd_i386_rel/sas2ircu ${STAGEDIR}${PREFIX}/sbin
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/sas2ircu/distinfo b/sysutils/sas2ircu/distinfo
new file mode 100644
index 000000000000..2cde45420304
--- /dev/null
+++ b/sysutils/sas2ircu/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SAS2IRCU_P16.zip) = e7209ec09105098ed7ad0132238d90bc87d1b5721b20add6e30b6ca6d4ac8f7b
+SIZE (SAS2IRCU_P16.zip) = 2894052
diff --git a/sysutils/sas2ircu/pkg-descr b/sysutils/sas2ircu/pkg-descr
new file mode 100644
index 000000000000..84525fecd655
--- /dev/null
+++ b/sysutils/sas2ircu/pkg-descr
@@ -0,0 +1,5 @@
+sas2ircu allows basic management of mps(4) based RAID controllers.
+This includes controllers based on the LSI SAS2 IR protocol.
+See the mps(4) man page for a more thorough list of controllers.
+
+WWW: http://www.lsi.com/
diff --git a/sysutils/sas2ircu/pkg-plist b/sysutils/sas2ircu/pkg-plist
new file mode 100644
index 000000000000..31bf7dcc7ea9
--- /dev/null
+++ b/sysutils/sas2ircu/pkg-plist
@@ -0,0 +1,4 @@
+sbin/sas2ircu
+%%PORTDOCS%%%%DOCSDIR%%/Readme_Release_Notes_SAS2IRCU_Phase_16.00.00.00.txt
+%%PORTDOCS%%%%DOCSDIR%%/SAS2Flash_ReferenceGuide.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%