aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-03-21 07:23:59 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-03-21 07:23:59 +0000
commit62aa63f89c7b2be10de0e4851e10f3d58403dcf8 (patch)
tree357f14547ece03ed6f1ea54e0eba79851d67f289
parent54bba85b246b786b4c603000430c3f52fc393206 (diff)
downloadports-62aa63f89c7b2be10de0e4851e10f3d58403dcf8.tar.gz
ports-62aa63f89c7b2be10de0e4851e10f3d58403dcf8.zip
devel/qca: update to 2.3
- qca-2.3 drop support for OSSL<1.1 - copy devel/qca to devel/qca-legacy which is held at the current version - update devel/qca to 2.3 - Add Uses/qca.mk which handles dependency on either of the ports depending on the FreeBSD version Users on FreeBSD11 must therefore change their pkg orign à la: pkg set -o devel/qca:devel/qca-legacy PR: 244682 Exp-run by: antoine Reviewed by: arrowd Differential Revision: https://reviews.freebsd.org/D24042
Notes
Notes: svn path=/head/; revision=528829
-rw-r--r--Mk/Uses/qca.mk31
-rw-r--r--UPDATING15
-rw-r--r--audio/amarok/Makefile5
-rw-r--r--audio/clementine-player/Makefile3
-rw-r--r--databases/kbibtex/Makefile3
-rw-r--r--deskutils/kdeconnect-kde/Makefile4
-rw-r--r--deskutils/kdepim-runtime/Makefile4
-rw-r--r--devel/Makefile1
-rw-r--r--devel/okteta/Makefile5
-rw-r--r--devel/qca-legacy/Makefile57
-rw-r--r--devel/qca-legacy/distinfo3
-rw-r--r--devel/qca-legacy/files/patch-plugins_qca-botan_CMakeLists.txt (renamed from devel/qca/files/patch-plugins_qca-botan_CMakeLists.txt)0
-rw-r--r--devel/qca-legacy/files/patch-plugins_qca-ossl_ossl110-compat.h (renamed from devel/qca/files/patch-plugins_qca-ossl_ossl110-compat.h)0
-rw-r--r--devel/qca-legacy/files/patch-plugins_qca-ossl_qca-ossl.cpp (renamed from devel/qca/files/patch-plugins_qca-ossl_qca-ossl.cpp)0
-rw-r--r--devel/qca-legacy/pkg-descr13
-rw-r--r--devel/qca-legacy/pkg-plist33
-rw-r--r--devel/qca/Makefile11
-rw-r--r--devel/qca/distinfo6
-rw-r--r--editors/calligra/Makefile3
-rw-r--r--finance/skrooge/Makefile5
-rw-r--r--games/ksirk/Makefile5
-rw-r--r--graphics/okular/Makefile3
-rw-r--r--graphics/qgis-ltr/Makefile5
-rw-r--r--graphics/qgis/Makefile5
-rw-r--r--irc/konversation/Makefile6
-rw-r--r--irc/quassel/Makefile6
-rw-r--r--net-im/kopete/Makefile5
-rw-r--r--net-im/ktp-auth-handler/Makefile6
-rw-r--r--net-im/psi/Makefile7
-rw-r--r--net-p2p/libktorrent/Makefile7
-rw-r--r--net/kget/Makefile4
-rw-r--r--net/messagelib/Makefile7
-rw-r--r--net/qoauth-qt5/Makefile6
-rw-r--r--polish/kadu/Makefile5
-rw-r--r--www/choqok/Makefile5
35 files changed, 212 insertions, 72 deletions
diff --git a/Mk/Uses/qca.mk b/Mk/Uses/qca.mk
new file mode 100644
index 000000000000..5fdae830dc40
--- /dev/null
+++ b/Mk/Uses/qca.mk
@@ -0,0 +1,31 @@
+# $FreeBSD$
+#
+# Handle dependency on qca
+#
+# Feature: qca
+# Usage: USES=qca
+# Valid ARGS none
+#
+# MAINTAINER: kde@FreeBSD.org
+
+.if ! defined(_INCLUDE_QCA_MK)
+_INCLUDE_QCA_MK= yes
+
+. if !empty(qca_ARGS)
+IGNORE+= USES=qca takes no arguments
+. endif
+
+_QCA_LIB= libqca-qt5.so
+
+_QCA_DEFAULT_PORT= devel/qca
+_QCA_LEGACY_PORT= devel/qca-legacy
+
+. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085 && ${SSL_DEFAULT} == base
+_QCA_CHOSEN_PORT= LEGACY
+. else
+_QCA_CHOSEN_PORT= DEFAULT
+. endif
+
+LIB_DEPENDS+= ${_QCA_LIB}:${_QCA_${_QCA_CHOSEN_PORT}_PORT}
+
+.endif
diff --git a/UPDATING b/UPDATING
index 13f4a0706ab5..19ff7d89c8fe 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,21 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20200320
+ AFFECTS: users of devel/qca
+ AUTHOR: kde@FreeBSD.org
+
+ New versions of devel/qca stopped supporting OpenSSL < 1.1.
+ For this reason devel/qca-legacy has been added, which is
+ held back at an older version until FreeBSD 11 goes EOL.
+
+ Ports depending on devel/qca should stop adding direct LIB_DEPENDS
+ and switch to depending on it via USES=qca.
+
+ FreeBSD 11 users might want to run something like
+
+ pkg set -o devel/qca:devel/qca-legacy
+
20200320:
AFFECTS: users of x11/libxkbcommon
AUTHOR: zeising@FreeBSD.org
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index 4d4eb1ebce82..0c1b736f009c 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -4,7 +4,7 @@ PORTNAME= amarok
DISTVERSIONPREFIX= v
DISTVERSION= 2.9.70
PKGVERSIONSUFFIX= -g${GH_TAGNAME}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio kde
MAINTAINER= kde@FreeBSD.org
@@ -17,13 +17,12 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libfftw3.so:math/fftw3 \
liblastfm5.so:audio/liblastfm-qt5 \
libqjson-qt5.so:devel/qjson \
- libqca-qt5.so:devel/qca \
libtag.so:audio/taglib \
libtag-extras.so:audio/taglib-extras \
liblz4.so:archivers/liblz4
USES= cmake compiler:c++11-lang desktop-file-utils \
- kde:5 mysql:client,embedded pkgconfig qt:5 shebangfix ssl xorg
+ kde:5 mysql:client,embedded pkgconfig qca qt:5 shebangfix ssl xorg
USE_QT= core concurrent declarative dbus gui location network phonon4 \
quickcontrols2 script scripttools sql svg webchannel \
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index 6dcba0020fa9..899b93142f4d 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -3,6 +3,7 @@
PORTNAME= clementine
DISTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= audio
PKGNAMESUFFIX= -player
@@ -16,7 +17,6 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libtag.so:audio/taglib \
libchromaprint.so:audio/chromaprint \
libprotobuf.so:devel/protobuf \
- libqca-qt5.so:devel/qca \
libqjson-qt5.so:devel/qjson \
libfftw3.so:math/fftw3 \
libechonest5.so:audio/libechonest \
@@ -27,6 +27,7 @@ USES= cmake \
desktop-file-utils \
gettext-tools \
pkgconfig \
+ qca \
qt:5 \
sqlite \
gl \
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index 8d93d832f9c8..f12fbec9756b 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -11,13 +11,12 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Bibliography editor for KDE
LIB_DEPENDS= libicuuc.so:devel/icu \
- libqca-qt5.so:devel/qca \
libpoppler.so:graphics/poppler \
libpoppler-qt5.so:graphics/poppler-qt5 \
libqoauth-qt5.so:net/qoauth-qt5
USES= cmake compiler:c++11-lang desktop-file-utils gettext gnome \
- iconv kde:5 qt:5 shared-mime-info tar:xz
+ iconv kde:5 qca qt:5 shared-mime-info tar:xz
USE_GNOME= libxml2 libxslt
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash ecm i18n iconthemes itemviews jobwidgets \
diff --git a/deskutils/kdeconnect-kde/Makefile b/deskutils/kdeconnect-kde/Makefile
index 3fb74f11c1e0..b151bc3cb9df 100644
--- a/deskutils/kdeconnect-kde/Makefile
+++ b/deskutils/kdeconnect-kde/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kdeconnect-kde
DISTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= deskutils kde
MASTER_SITES= KDE/stable/kdeconnect/${DISTVERSION}
DIST_SUBDIR= KDE
@@ -13,7 +14,6 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfakekey.so:x11/libfakekey \
- libqca-qt5.so:devel/qca \
libKF5PulseAudioQt.so:audio/pulseaudio-qt
BUILD_DEPENDS= kpeoplevcard>0:net/kpeoplevcard
RUN_DEPENDS= sshpass:security/sshpass \
@@ -23,7 +23,7 @@ RUN_DEPENDS= sshpass:security/sshpass \
CONFLICTS_INSTALL= kdeconnect-kde-0.7* kdeconnect-kde-kde4-0.7.*
USES= cmake compiler:c++11-lang desktop-file-utils gettext kde:5 \
- pkgconfig qt:5 tar:xz xorg
+ pkgconfig qca qt:5 tar:xz xorg
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons dbusaddons doctools ecm i18n iconthemes \
itemviews jobwidgets kcmutils kio kirigami2 notifications \
diff --git a/deskutils/kdepim-runtime/Makefile b/deskutils/kdepim-runtime/Makefile
index 92656ca926e3..7843fa512995 100644
--- a/deskutils/kdepim-runtime/Makefile
+++ b/deskutils/kdepim-runtime/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kdepim-runtime
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -12,11 +13,10 @@ LICENSE= LGPL21
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libcurl.so:ftp/curl \
libkolabxml.so:textproc/libkolabxml \
- libqca-qt5.so:devel/qca \
libsasl2.so:security/cyrus-sasl2 \
libxerces-c-3.2.so:textproc/xerces-c3
-USES= cmake:noninja compiler:c++11-lib gettext kde:5 qt:5 \
+USES= cmake:noninja compiler:c++11-lib gettext kde:5 qca qt:5 \
shared-mime-info tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons guiaddons holidays i18n iconthemes \
diff --git a/devel/Makefile b/devel/Makefile
index 89305787591d..0761ef2c4583 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5227,6 +5227,7 @@
SUBDIR += pythontidy
SUBDIR += qbs
SUBDIR += qca
+ SUBDIR += qca-legacy
SUBDIR += qconf
SUBDIR += qgit
SUBDIR += qjson
diff --git a/devel/okteta/Makefile b/devel/okteta/Makefile
index 8473e19483e5..881e326f7438 100644
--- a/devel/okteta/Makefile
+++ b/devel/okteta/Makefile
@@ -2,6 +2,7 @@
PORTNAME= okteta
DISTVERSION= 0.26.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel kde
MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}/src
@@ -9,9 +10,7 @@ MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}/src
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE hex editor
-LIB_DEPENDS= libqca-qt5.so:devel/qca
-
-USES= cmake compiler:c++11-lang gettext kde:5 qt:5 \
+USES= cmake compiler:c++11-lang gettext kde:5 qca qt:5 \
shared-mime-info tar:xz
USE_KDE= attica auth bookmarks codecs completion crash \
config configwidgets coreaddons dbusaddons doctools \
diff --git a/devel/qca-legacy/Makefile b/devel/qca-legacy/Makefile
new file mode 100644
index 000000000000..79623bab964f
--- /dev/null
+++ b/devel/qca-legacy/Makefile
@@ -0,0 +1,57 @@
+# Created by: Vsevolod Stakhov <vsevolod@highsecure.ru>
+# $FreeBSD$
+
+PORTNAME= qca
+PORTVERSION= 2.2.1
+PORTREVISION= 5
+CATEGORIES= devel
+MASTER_SITES= KDE/stable/qca/${PORTVERSION}
+PKGNAMESUFFIX= -legacy-qt5
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Cross-platform crypto API for Qt ${FLAVOR:C/qt//} -- for FreeBSD 11
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFLICTS_INSTALL= qca-qt5-*
+
+BUILD_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+
+USES= cmake compiler:c++11-lang qt:5 tar:xz
+CMAKE_ARGS= -DBUILD_PLUGINS=none -DBUILD_TESTS=no \
+ -DPKGCONFIG_INSTALL_PREFIX=${PREFIX}/libdata/pkgconfig \
+ -DQCA_FEATURE_INSTALL_DIR=${QT_MKSPECDIR}/features \
+ -DQCA_MAN_INSTALL_DIR=${PREFIX}/man
+CONFIGURE_ENV= QC_CERTSTORE_PATH=${LOCALBASE}/share/certs/ca-root-nss.crt
+USE_LDCONFIG= yes
+
+CMAKE_ARGS+= -DQCA_SUFFIX=qt5
+USE_QT= core buildtools_build qmake_build
+
+PLIST_SUB= SHLIB_VER=${PORTVERSION}
+
+OPTIONS_DEFINE= BOTAN GNUPG OPENSSL SASL TEST
+OPTIONS_DEFAULT=GNUPG OPENSSL
+OPTIONS_SUB= yes
+
+BOTAN_CMAKE_ON= -DWITH_botan_PLUGIN=yes
+BOTAN_DESC= Build with Botan crypto library
+BOTAN_LIB_DEPENDS= libbotan-2.so:security/botan2
+BOTAN_USES= pkgconfig
+
+GNUPG_CMAKE_ON= -DWITH_gnupg_PLUGIN=yes
+GNUPG_RUN_DEPENDS= gpg2:security/gnupg
+
+OPENSSL_CMAKE_ON= -DWITH_ossl_PLUGIN=yes
+OPENSSL_USES= ssl
+
+SASL_CMAKE_ON= -DWITH_cyrus-sasl_PLUGIN=yes
+SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
+
+TEST_CMAKE_BOOL= BUILD_TESTS
+TEST_TEST_TARGET= test
+TEST_USE= QT=network,testlib
+
+.include <bsd.port.mk>
diff --git a/devel/qca-legacy/distinfo b/devel/qca-legacy/distinfo
new file mode 100644
index 000000000000..b4e73a9c7888
--- /dev/null
+++ b/devel/qca-legacy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1556314674
+SHA256 (qca-2.2.1.tar.xz) = d716d2d8e3ed8d95bbdb061f03081d7d032206f746a30a4d29d72196f50e7b02
+SIZE (qca-2.2.1.tar.xz) = 691676
diff --git a/devel/qca/files/patch-plugins_qca-botan_CMakeLists.txt b/devel/qca-legacy/files/patch-plugins_qca-botan_CMakeLists.txt
index fa9fe230c79a..fa9fe230c79a 100644
--- a/devel/qca/files/patch-plugins_qca-botan_CMakeLists.txt
+++ b/devel/qca-legacy/files/patch-plugins_qca-botan_CMakeLists.txt
diff --git a/devel/qca/files/patch-plugins_qca-ossl_ossl110-compat.h b/devel/qca-legacy/files/patch-plugins_qca-ossl_ossl110-compat.h
index a0e197ef3e4e..a0e197ef3e4e 100644
--- a/devel/qca/files/patch-plugins_qca-ossl_ossl110-compat.h
+++ b/devel/qca-legacy/files/patch-plugins_qca-ossl_ossl110-compat.h
diff --git a/devel/qca/files/patch-plugins_qca-ossl_qca-ossl.cpp b/devel/qca-legacy/files/patch-plugins_qca-ossl_qca-ossl.cpp
index a5ddc5f874ad..a5ddc5f874ad 100644
--- a/devel/qca/files/patch-plugins_qca-ossl_qca-ossl.cpp
+++ b/devel/qca-legacy/files/patch-plugins_qca-ossl_qca-ossl.cpp
diff --git a/devel/qca-legacy/pkg-descr b/devel/qca-legacy/pkg-descr
new file mode 100644
index 000000000000..72df515b47b5
--- /dev/null
+++ b/devel/qca-legacy/pkg-descr
@@ -0,0 +1,13 @@
+QCA aims to provide a straightforward and cross-platform crypto API,
+using Qt datatypes and conventions.
+
+Supported features:
+
+ * SSL/TLS
+ * X509
+ * SASL
+ * RSA
+ * Hashing (SHA1, MD5)
+ * Ciphers (Blowfish, 3DES, AES)
+
+WWW: http://delta.affinix.com/qca/
diff --git a/devel/qca-legacy/pkg-plist b/devel/qca-legacy/pkg-plist
new file mode 100644
index 000000000000..d9a46b9672ff
--- /dev/null
+++ b/devel/qca-legacy/pkg-plist
@@ -0,0 +1,33 @@
+bin/mozcerts-qt5
+bin/qcatool-qt5
+include/Qca-qt5/QtCrypto/QtCrypto
+include/Qca-qt5/QtCrypto/qca.h
+include/Qca-qt5/QtCrypto/qca_basic.h
+include/Qca-qt5/QtCrypto/qca_cert.h
+include/Qca-qt5/QtCrypto/qca_core.h
+include/Qca-qt5/QtCrypto/qca_export.h
+include/Qca-qt5/QtCrypto/qca_keystore.h
+include/Qca-qt5/QtCrypto/qca_publickey.h
+include/Qca-qt5/QtCrypto/qca_safetimer.h
+include/Qca-qt5/QtCrypto/qca_securelayer.h
+include/Qca-qt5/QtCrypto/qca_securemessage.h
+include/Qca-qt5/QtCrypto/qca_support.h
+include/Qca-qt5/QtCrypto/qca_textfilter.h
+include/Qca-qt5/QtCrypto/qca_tools.h
+include/Qca-qt5/QtCrypto/qca_version.h
+include/Qca-qt5/QtCrypto/qcaprovider.h
+include/Qca-qt5/QtCrypto/qpipe.h
+lib/cmake/Qca-qt5/Qca-qt5Config.cmake
+lib/cmake/Qca-qt5/Qca-qt5ConfigVersion.cmake
+lib/cmake/Qca-qt5/Qca-qt5Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qca-qt5/Qca-qt5Targets.cmake
+lib/libqca-qt5.so
+lib/libqca-qt5.so.2
+lib/libqca-qt5.so.%%SHLIB_VER%%
+%%BOTAN%%lib/qca-qt5/crypto/libqca-botan.so
+%%SASL%%lib/qca-qt5/crypto/libqca-cyrus-sasl.so
+%%GNUPG%%lib/qca-qt5/crypto/libqca-gnupg.so
+%%OPENSSL%%lib/qca-qt5/crypto/libqca-ossl.so
+%%QT_MKSPECDIR%%/features/crypto.prf
+libdata/pkgconfig/qca2-qt5.pc
+man/man1/qcatool-qt5.1.gz
diff --git a/devel/qca/Makefile b/devel/qca/Makefile
index bf85d6421f51..4331d115bc66 100644
--- a/devel/qca/Makefile
+++ b/devel/qca/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qca
-PORTVERSION= 2.2.1
-PORTREVISION= 4
+DISTVERSION= 2.3.0
CATEGORIES= devel
MASTER_SITES= KDE/stable/qca/${PORTVERSION}
PKGNAMESUFFIX= -qt5
@@ -52,4 +51,10 @@ TEST_CMAKE_BOOL= BUILD_TESTS
TEST_TEST_TARGET= test
TEST_USE= QT=network,testlib
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085 && ${SSL_DEFAULT} == base
+IGNORE= Does not support OpenSSL < 1.1
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/qca/distinfo b/devel/qca/distinfo
index b4e73a9c7888..01c9e8ca5be7 100644
--- a/devel/qca/distinfo
+++ b/devel/qca/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1556314674
-SHA256 (qca-2.2.1.tar.xz) = d716d2d8e3ed8d95bbdb061f03081d7d032206f746a30a4d29d72196f50e7b02
-SIZE (qca-2.2.1.tar.xz) = 691676
+TIMESTAMP = 1583676075
+SHA256 (qca-2.3.0.tar.xz) = 1d68ef41a1b61dc9786beb923a68902a6276a77cced5e5ea7ff985ef113932d7
+SIZE (qca-2.3.0.tar.xz) = 729504
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 04ed8fd30e33..ef02db2001e8 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -25,7 +25,6 @@ LIB_DEPENDS= libImath.so:graphics/ilmbase \
libpng.so:graphics/png \
libpoppler-qt5.so:graphics/poppler-qt5 \
libpoppler.so:graphics/poppler \
- libqca-qt5.so:devel/qca \
librevenge-0.0.so:textproc/librevenge \
libtiff.so:graphics/tiff \
libvisio-0.1.so:textproc/libvisio01 \
@@ -38,7 +37,7 @@ RUN_DEPENDS= pstoedit:graphics/pstoedit
USES= cmake cpe compiler:c++11-lib desktop-file-utils eigen:3 \
gettext iconv:translit jpeg kde:5 localbase:ldflags perl5 \
- pkgconfig qt:5 shared-mime-info sqlite tar:xz xorg
+ pkgconfig qca qt:5 shared-mime-info sqlite tar:xz xorg
USE_KDE= akonadicontacts activities archive auth bookmarks codecs completion \
config configwidgets contacts coreaddons crash dbusaddons doctools ecm \
emoticons guiaddons holidays i18n iconthemes init itemmodels itemviews \
diff --git a/finance/skrooge/Makefile b/finance/skrooge/Makefile
index f707c6f13ee3..268165961dd6 100644
--- a/finance/skrooge/Makefile
+++ b/finance/skrooge/Makefile
@@ -2,7 +2,7 @@
PORTNAME= skrooge
DISTVERSION= 2.21.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance kde
MASTER_SITES= KDE/stable/${PORTNAME}
DIST_SUBDIR= KDE/${PORTNAME}
@@ -15,11 +15,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= xsltproc:textproc/libxslt
LIB_DEPENDS= libofx.so:finance/libofx \
- libqca-qt5.so:devel/qca \
libsqlcipher.so:databases/sqlcipher
USES= cmake compiler:c++11-lib desktop-file-utils \
- gettext grantlee:5 kde:5 pkgconfig python:3.4+ qt:5 shared-mime-info \
+ gettext grantlee:5 kde:5 pkgconfig python:3.4+ qca qt:5 shared-mime-info \
shebangfix sqlite:3 tar:xz
USE_KDE= activities archive attica5 auth bookmarks codecs completion \
config configwidgets coreaddons crash dbusaddons \
diff --git a/games/ksirk/Makefile b/games/ksirk/Makefile
index fa21b669d6ae..6a26b21b172c 100644
--- a/games/ksirk/Makefile
+++ b/games/ksirk/Makefile
@@ -2,14 +2,13 @@
PORTNAME= ksirk
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= games kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME:tu}_DESC}
-LIB_DEPENDS= libqca-qt5.so:devel/qca
-
-USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang kde:5 qca qt:5 tar:xz
USE_KDE= attica auth codecs completion config configwidgets \
coreaddons crash i18n iconthemes kio libkdegames newstuff \
service wallet widgetsaddons xmlgui
diff --git a/graphics/okular/Makefile b/graphics/okular/Makefile
index b6625a2406dd..1402b4558d32 100644
--- a/graphics/okular/Makefile
+++ b/graphics/okular/Makefile
@@ -23,13 +23,12 @@ LIB_DEPENDS= libchm.so:misc/chmlib \
libqmobipocket.so:graphics/kdegraphics-mobipocket \
libpoppler.so:graphics/poppler \
libpoppler-qt5.so:graphics/poppler-qt5 \
- libqca-qt5.so:devel/qca \
libspectre.so:print/libspectre \
libtiff.so:graphics/tiff \
libzip.so:archivers/libzip
USES= cmake compiler:c++11-lib desktop-file-utils \
- gettext jpeg kde:5 pkgconfig qt:5 tar:xz
+ gettext jpeg kde:5 pkgconfig qca qt:5 tar:xz
USE_KDE= activities archive auth bookmarks codecs completion config \
configwidgets coreaddons crash dbusaddons ecm emoticons i18n \
iconthemes init itemmodels itemviews jobwidgets js \
diff --git a/graphics/qgis-ltr/Makefile b/graphics/qgis-ltr/Makefile
index ef509b75fc31..e3c361f58571 100644
--- a/graphics/qgis-ltr/Makefile
+++ b/graphics/qgis-ltr/Makefile
@@ -4,7 +4,7 @@
PORTNAME= qgis
DISTVERSIONPREFIX= final-
DISTVERSION= 3_4_11
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics geography
PKGNAMESUFFIX= -ltr
@@ -73,7 +73,6 @@ LIB_DEPENDS= libexiv2.so:graphics/exiv2 \
libhdf5.so:science/hdf5 \
libnetcdf.so:science/netcdf \
libproj.so:graphics/proj \
- libqca-qt5.so:devel/qca \
libqjson-qt5.so:devel/qjson \
libqscintilla2_qt5.so:devel/qscintilla2-qt5 \
libqt5keychain.so:security/qtkeychain \
@@ -86,7 +85,7 @@ LIB_DEPENDS= libexiv2.so:graphics/exiv2 \
### Fortran is needed by numpy, GRASS, etc.
USES= bison cmake compiler:features cpe desktop-file-utils \
- fortran gmake gnome pgsql pyqt:5 python:3.6+ qt:5 \
+ fortran gmake gnome pgsql pyqt:5 python:3.6+ qca qt:5 \
shebangfix sqlite:3
USE_GNOME= libxml2
USE_QT= 3d buildtools_build core concurrent dbus declarative \
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index aac7f14eb53f..289903e42e5b 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -4,7 +4,7 @@
PORTNAME= qgis
DISTVERSIONPREFIX= final-
DISTVERSION= 3_10_1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics geography
MAINTAINER= rhurlin@gwdg.de
@@ -76,7 +76,6 @@ LIB_DEPENDS= libexiv2.so:graphics/exiv2 \
libhdf5.so:science/hdf5 \
libnetcdf.so:science/netcdf \
libproj.so:graphics/proj \
- libqca-qt5.so:devel/qca \
libqjson-qt5.so:devel/qjson \
libqscintilla2_qt5.so:devel/qscintilla2-qt5 \
libqt5keychain.so:security/qtkeychain \
@@ -89,7 +88,7 @@ LIB_DEPENDS= libexiv2.so:graphics/exiv2 \
### Fortran is needed by numpy, GRASS, etc.
USES= bison cmake compiler:features cpe desktop-file-utils \
- fortran gl gmake gnome pgsql pyqt:5 python:3.6+ qt:5 \
+ fortran gl gmake gnome pgsql pyqt:5 python:3.6+ qca qt:5 \
shebangfix sqlite:3
USE_GNOME= libxml2
USE_GL= gl
diff --git a/irc/konversation/Makefile b/irc/konversation/Makefile
index cfc3cfd89c39..0ac8b9edea45 100644
--- a/irc/konversation/Makefile
+++ b/irc/konversation/Makefile
@@ -3,7 +3,7 @@
PORTNAME= konversation
PORTVERSION= 1.7.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= irc kde
MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}/src
@@ -13,10 +13,8 @@ COMMENT= User friendly IRC client for KDE
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libqca-qt5.so:devel/qca
-
USES= cmake compiler:c++11-lang desktop-file-utils gettext kde:5 \
- python:run qt:5 shebangfix tar:xz
+ python:run qca qt:5 shebangfix tar:xz
USE_KDE= archive auth bookmarks codecs completion config \
configwidgets coreaddons crash dbusaddons doctools ecm \
emoticons globalaccel i18n iconthemes idletime itemviews \
diff --git a/irc/quassel/Makefile b/irc/quassel/Makefile
index abda8dcb1809..cd325f960a4b 100644
--- a/irc/quassel/Makefile
+++ b/irc/quassel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= quassel
PORTVERSION= 0.13.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc
MAINTAINER= woodsb02@FreeBSD.org
@@ -39,7 +39,7 @@ CLIENT_LIB_DEPENDS= libdbusmenu-qt5.so:devel/libdbusmenu-qt \
CORE_DESC= Quassel core server (for use with client)
CORE_CMAKE_BOOL= WANT_CORE
CORE_USE= qt=script,sql
-CORE_LIB_DEPENDS= libqca-qt5.so:devel/qca
+CORE_USES= qca
CORE_SUB_FILES= pkg-message
CORE_VARS= use_rc_subr=quasselcore \
users=quasselcore \
@@ -50,7 +50,7 @@ CORE_PLIST_FILES= bin/quasselcore
MONO_DESC= Quassel standalone (monolithic binary: core+client combined)
MONO_CMAKE_BOOL= WANT_MONO
MONO_USE= qt=script,sql
-MONO_LIB_DEPENDS= libqca-qt5.so:devel/qca
+MONO_USES= qca
NLS_USE= QT=linguisttools_build
diff --git a/net-im/kopete/Makefile b/net-im/kopete/Makefile
index af10aaf6fb38..3befb638dbd0 100644
--- a/net-im/kopete/Makefile
+++ b/net-im/kopete/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kopete
PORTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -12,11 +12,10 @@ BUILD_DEPENDS= v4l_compat>0:multimedia/v4l_compat
LIB_DEPENDS= libidn.so:dns/libidn \
libjasper.so:graphics/jasper \
libotr.so:security/libotr \
- libqca-qt5.so:devel/qca \
libv4l2.so:multimedia/libv4l
USES= cmake compiler:c++11-lang desktop-file-utils gnome jpeg kde:5 \
- qt:5 shebangfix tar:xz
+ qca qt:5 shebangfix tar:xz
USE_GNOME= libxml2 libxslt
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons dnssd ecm emoticons guiaddons i18n \
diff --git a/net-im/ktp-auth-handler/Makefile b/net-im/ktp-auth-handler/Makefile
index b9916c7be70a..f92e67c71f07 100644
--- a/net-im/ktp-auth-handler/Makefile
+++ b/net-im/ktp-auth-handler/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ktp-auth-handler
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -10,15 +11,14 @@ COMMENT= KWallet integration module for KDE Telepathy
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libqca-qt5.so:devel/qca \
- libtelepathy-qt5.so:net-im/telepathy-qt \
+LIB_DEPENDS= libtelepathy-qt5.so:net-im/telepathy-qt \
libKTpCommonInternals.so:net-im/ktp-common-internals \
libaccounts-qt5.so:net-im/libaccounts-qt5 \
libkaccounts.so:net-im/kaccounts-integration \
libsignon-qt5.so:sysutils/signon-qt5
USES= compiler:c++11-lang cmake gettext kde:5 pkgconfig \
- qt:5 tar:xz
+ qca qt:5 tar:xz
USE_KDE= completion config coreaddons ecm i18n jobwidgets kdewebkit \
kio wallet service widgetsaddons
USE_QT= concurrent core dbus gui network webkit widgets xml \
diff --git a/net-im/psi/Makefile b/net-im/psi/Makefile
index e8bfeb24f81c..8829974aeba9 100644
--- a/net-im/psi/Makefile
+++ b/net-im/psi/Makefile
@@ -3,7 +3,7 @@
PORTNAME= psi
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
MASTER_SITES= SF/${PORTNAME}/Psi/${PORTVERSION}
@@ -13,11 +13,10 @@ COMMENT= Qt-based Jabber (XMPP) client
LICENSE= GPLv2
LIB_DEPENDS= libidn.so:dns/libidn \
- libminizip.so:archivers/minizip \
- libqca-qt5.so:devel/qca
+ libminizip.so:archivers/minizip
USES= cmake compiler:c++11-lang desktop-file-utils pkgconfig \
- qt:5 tar:xz xorg
+ qca qt:5 tar:xz xorg
USE_QT= concurrent core dbus gui multimedia network svg widgets \
x11extras xml buildtools_build qmake_build imageformats_run
USE_XORG= ice sm x11 xcb xext xscrnsaver
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index 7159a410d418..14398017ba64 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libktorrent
DISTVERSION= 2.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p kde
MASTER_SITES= KDE/stable/ktorrent/5.1.2/
@@ -15,10 +15,9 @@ COMMENT= Torrent library from KTorrent project
BUILD_DEPENDS= ${LOCALBASE}/include/boost/concept_check.hpp:devel/boost-libs
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
- libgmp.so:math/gmp \
- libqca-qt5.so:devel/qca
+ libgmp.so:math/gmp
-USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lang gettext kde:5 qca qt:5 tar:xz
USE_KDE= archive completion config coreaddons crash ecm i18n \
jobwidgets kio service solid widgetsaddons
USE_QT= core gui network testlib xml \
diff --git a/net/kget/Makefile b/net/kget/Makefile
index be297c7e440c..1163a9a62841 100644
--- a/net/kget/Makefile
+++ b/net/kget/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kget
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -14,10 +15,9 @@ LIB_DEPENDS= libKF5Torrent.so:net-p2p/libktorrent \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqca-qt5.so:devel/qca \
libqgpgme.so:security/gpgme-qt5
-USES= cmake compiler:c++11-lang desktop-file-utils kde:5 qt:5 \
+USES= cmake compiler:c++11-lang desktop-file-utils kde:5 qca qt:5 \
shebangfix sqlite tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
diff --git a/net/messagelib/Makefile b/net/messagelib/Makefile
index 8a7ce6a28a35..eceb207e6984 100644
--- a/net/messagelib/Makefile
+++ b/net/messagelib/Makefile
@@ -2,7 +2,7 @@
PORTNAME= messagelib
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net kde kde-applications
PATCH_SITES= https://github.com/KDE/messagelib/commit/
@@ -18,10 +18,9 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error \
libgpgme.so:security/gpgme \
libgpgmepp.so:security/gpgme-cpp \
- libqgpgme.so:security/gpgme-qt5 \
- libqca-qt5.so:devel/qca
+ libqgpgme.so:security/gpgme-qt5
-USES= cmake compiler:c++11-lib gettext grantlee:5 kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lib gettext grantlee:5 kde:5 qca qt:5 tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons ecm i18n iconthemes imap itemmodels itemviews jobwidgets \
kdewebkit kio service solid sonnet syntaxhighlighting \
diff --git a/net/qoauth-qt5/Makefile b/net/qoauth-qt5/Makefile
index c5e1e1fe0538..e9f291343e2d 100644
--- a/net/qoauth-qt5/Makefile
+++ b/net/qoauth-qt5/Makefile
@@ -4,7 +4,7 @@
PORTNAME= qoauth
PORTVERSION= 2.0.0
DISTVERSIONPREFIX= v
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net devel security
PKGNAMESUFFIX= -qt5
@@ -14,9 +14,7 @@ COMMENT= Qt5 support for OAuth-powered network services
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libqca-qt5.so:devel/qca
-
-USES= compiler:c++11-lang qmake:outsource qt:5
+USES= compiler:c++11-lang qmake:outsource qca qt:5
USE_LDCONFIG= yes
USE_QT= core network testlib buildtools_build qmake_build
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index f199a7954efc..f57b74aa42b6 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kadu
PORTVERSION= 4.3
-PORTREVISION= 18
+PORTREVISION= 19
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/:kadu \
@@ -23,7 +23,6 @@ BUILD_DEPENDS= bash:shells/bash \
LIB_DEPENDS= libmpdclient.so:audio/libmpdclient \
libsndfile.so:audio/libsndfile \
libinjeqt.so:devel/injeqt \
- libqca-qt5.so:devel/qca \
libidn.so:dns/libidn \
libqxmpp.so:net-im/qxmpp-qt5 \
libgadu.so:polish/libgadu \
@@ -37,7 +36,7 @@ GG6_EMOTS_DISTFILE= kompatybilne_z_GG6.tar.gz
GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
USES= cmake:insource compiler:c++11-lib gettext-runtime gnome \
- libarchive pkgconfig qt:5 readline tar:bzip2 xorg
+ libarchive pkgconfig qca qt:5 readline tar:bzip2 xorg
USE_XORG= x11 xext xfixes xscrnsaver
USE_GNOME= glib20
USE_QT= concurrent core dbus declarative gui multimedia network \
diff --git a/www/choqok/Makefile b/www/choqok/Makefile
index 91c56c1c082a..4194d5843947 100644
--- a/www/choqok/Makefile
+++ b/www/choqok/Makefile
@@ -2,7 +2,7 @@
PORTNAME= choqok
DISTVERSION= 1.6.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= www kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION:R}/src
DIST_SUBDIR= KDE/${PORTNAME}
@@ -14,11 +14,10 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libqjson-qt5.so:devel/qjson \
- libqca-qt5.so:devel/qca \
libqoauth-qt5.so:net/qoauth-qt5 \
libtelepathy-qt5.so:net-im/telepathy-qt
-USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig qt:5 tar:xz
+USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig qca qt:5 tar:xz
USE_KDE= attica auth bookmarks codecs completion config configwidgets \
coreaddons doctools ecm emoticons globalaccel guiaddons i18n \
itemviews jobwidgets kcmutils kdewebkit kio notifications \