aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2020-07-24 15:59:03 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2020-07-24 15:59:03 +0000
commit631df84d7cf75e4df12ef21735c8ff396edfa40b (patch)
tree84e8b41e391fc21010cf7103e46c1588f10163fc
parent7208e49e39cc1f461e3b28129b784ec241b87b96 (diff)
downloadports-631df84d7cf75e4df12ef21735c8ff396edfa40b.tar.gz
ports-631df84d7cf75e4df12ef21735c8ff396edfa40b.zip
Notes
-rw-r--r--sysutils/xen-guest-tools/Makefile2
-rw-r--r--sysutils/xen-guest-tools/distinfo6
-rw-r--r--sysutils/xen-guest-tools/files/patch-fsys_zfs.h20
-rw-r--r--sysutils/xen-guest-tools/files/patch-tools-xenstore-utils.h11
-rw-r--r--sysutils/xen-guest-tools/files/patch-tools-xenstore-xenstored_core.h11
5 files changed, 4 insertions, 46 deletions
diff --git a/sysutils/xen-guest-tools/Makefile b/sysutils/xen-guest-tools/Makefile
index 75d357d88a67..b7889b38dd32 100644
--- a/sysutils/xen-guest-tools/Makefile
+++ b/sysutils/xen-guest-tools/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xen-guest-tools
-PORTVERSION= 4.13.1
+PORTVERSION= 4.14.0
PORTREVISION= 0
CATEGORIES= sysutils
MASTER_SITES= https://downloads.xenproject.org/release/xen/${PORTVERSION}/
diff --git a/sysutils/xen-guest-tools/distinfo b/sysutils/xen-guest-tools/distinfo
index 6b6aef93bd9f..f050fb2e58fd 100644
--- a/sysutils/xen-guest-tools/distinfo
+++ b/sysutils/xen-guest-tools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1593766790
-SHA256 (xen-4.13.1.tar.gz) = b97ce363e55b12c992063f4466c43cba0a6386ceb7a747b4dc670311f337ef01
-SIZE (xen-4.13.1.tar.gz) = 39024612
+TIMESTAMP = 1595603681
+SHA256 (xen-4.14.0.tar.gz) = 06839f68ea7620669dbe8b67861213223cc2a7d02ced61b56e5249c50e87f035
+SIZE (xen-4.14.0.tar.gz) = 39950576
diff --git a/sysutils/xen-guest-tools/files/patch-fsys_zfs.h b/sysutils/xen-guest-tools/files/patch-fsys_zfs.h
deleted file mode 100644
index 248ce6acb3b5..000000000000
--- a/sysutils/xen-guest-tools/files/patch-fsys_zfs.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- tools/libfsimage/zfs/fsys_zfs.h.orig 2020-03-26 16:41:12 UTC
-+++ tools/libfsimage/zfs/fsys_zfs.h
-@@ -71,7 +71,7 @@ typedef unsigned int size_t;
- * Can only be used in functions returning non-0 for failure.
- */
- #define VERIFY_DN_TYPE(dnp, type) \
-- if (type && (dnp)->dn_type != type) { \
-+ if (type != DMU_OT_NONE && (dnp)->dn_type != type) { \
- return (ERR_FSYS_CORRUPT); \
- }
-
-@@ -80,7 +80,7 @@ typedef unsigned int size_t;
- * Can only be used in functions returning 0 for failure.
- */
- #define VERIFY_OS_TYPE(osp, type) \
-- if (type && (osp)->os_type != type) { \
-+ if (type != DMU_OST_NONE && (osp)->os_type != type) { \
- errnum = ERR_FSYS_CORRUPT; \
- return (0); \
- }
diff --git a/sysutils/xen-guest-tools/files/patch-tools-xenstore-utils.h b/sysutils/xen-guest-tools/files/patch-tools-xenstore-utils.h
deleted file mode 100644
index 3086dcd09fdd..000000000000
--- a/sysutils/xen-guest-tools/files/patch-tools-xenstore-utils.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/xenstore/utils.h.orig 2019-12-17 14:23:09 UTC
-+++ tools/xenstore/utils.h
-@@ -24,7 +24,7 @@ static inline bool strends(const char *a, const char *
- void barf(const char *fmt, ...) __attribute__((noreturn));
- void barf_perror(const char *fmt, ...) __attribute__((noreturn));
-
--void (*xprintf)(const char *fmt, ...);
-+extern void (*xprintf)(const char *fmt, ...);
-
- #define eprintf(_fmt, _args...) xprintf("[ERR] %s" _fmt, __FUNCTION__, ##_args)
-
diff --git a/sysutils/xen-guest-tools/files/patch-tools-xenstore-xenstored_core.h b/sysutils/xen-guest-tools/files/patch-tools-xenstore-xenstored_core.h
deleted file mode 100644
index 106869a302ce..000000000000
--- a/sysutils/xen-guest-tools/files/patch-tools-xenstore-xenstored_core.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/xenstore/xenstored_core.h.orig 2019-12-17 14:23:09 UTC
-+++ tools/xenstore/xenstored_core.h
-@@ -204,7 +204,7 @@ void finish_daemonize(void);
- /* Open a pipe for signal handling */
- void init_pipe(int reopen_log_pipe[2]);
-
--xengnttab_handle **xgt_handle;
-+extern xengnttab_handle **xgt_handle;
-
- int remember_string(struct hashtable *hash, const char *str);
-