aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-03-21 19:50:35 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-03-21 19:50:35 +0000
commit636881f4c253addbf7f547590cc52996bf813990 (patch)
treeb7659fd8951e5c57b75a2ee7c2cfedc130eee355
parentdf79c6de9f49e4d5c35c6bec8f5a3481f4887c71 (diff)
downloadports-636881f4c253addbf7f547590cc52996bf813990.tar.gz
ports-636881f4c253addbf7f547590cc52996bf813990.zip
Notes
-rw-r--r--benchmarks/apib/Makefile2
-rw-r--r--devel/anjuta/Makefile2
-rw-r--r--devel/apr1/Makefile13
-rw-r--r--devel/apr1/files/patch-PR61517126
-rw-r--r--devel/kdesvn-kde4/Makefile2
-rw-r--r--devel/log4cxx/Makefile2
-rw-r--r--devel/p5-subversion/Makefile2
-rw-r--r--devel/py-subversion/Makefile1
-rw-r--r--devel/ruby-subversion/Makefile1
-rw-r--r--devel/subversion/Makefile2
-rw-r--r--devel/subversion18/Makefile.common2
-rw-r--r--editors/libreoffice/Makefile.common1
-rw-r--r--editors/openoffice-4/Makefile2
-rw-r--r--editors/openoffice-devel/Makefile2
-rw-r--r--graphics/mapcache/Makefile1
-rw-r--r--java/java-subversion/Makefile1
-rw-r--r--lang/neko/Makefile2
-rw-r--r--security/orthrus/Makefile2
-rw-r--r--security/subversion-gnome-keyring/Makefile1
-rw-r--r--security/subversion-kwallet/Makefile2
-rw-r--r--sysutils/ftwin/Makefile2
-rw-r--r--sysutils/ganglia-monitor-core/Makefile1
-rw-r--r--www/apache22/Makefile2
-rw-r--r--www/apache24/Makefile1
-rw-r--r--www/flood/Makefile2
-rw-r--r--www/htdigest/Makefile2
-rw-r--r--www/httest/Makefile1
-rw-r--r--www/mod_asn/Makefile1
-rw-r--r--www/mod_dav_svn/Makefile1
-rw-r--r--www/mod_md-devel/Makefile1
-rw-r--r--www/mod_pagespeed/Makefile2
-rw-r--r--www/mod_security/Makefile1
-rw-r--r--www/rubygem-passenger/Makefile2
-rw-r--r--www/serf/Makefile2
-rw-r--r--www/tomcat-native/Makefile1
35 files changed, 164 insertions, 27 deletions
diff --git a/benchmarks/apib/Makefile b/benchmarks/apib/Makefile
index a948456faf1f..8b217deb6f6a 100644
--- a/benchmarks/apib/Makefile
+++ b/benchmarks/apib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apib
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= benchmarks www
MAINTAINER= danfe@FreeBSD.org
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index 742fb7a86411..3b1a58126429 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -3,7 +3,7 @@
PORTNAME= anjuta
PORTVERSION= 3.18.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index 3c83aff79a7a..c5105a88e5af 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -29,7 +29,7 @@ CPE_VERSION= ${APU_VERSION}
OPTIONS_SUB= yes
OPTIONS_GROUP= APU
-OPTIONS_DEFINE= IPV6 DEVRANDOM
+OPTIONS_DEFINE= IPV6
OPTIONS_GROUP_APU= BDB GDBM LDAP MYSQL NDBM ODBC PGSQL SQLITE
OPTIONS_RADIO= CRYPTO
OPTIONS_RADIO_CRYPTO= SSL NSS
@@ -46,7 +46,7 @@ SSL_DESC= OpenSSL crypto driver
BDB_USES= bdb:5+
GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
LDAP_USE= OPENLDAP=yes
-MYSQL_USE= MYSQL=yes
+MYSQL_USES= mysql
NSS_LIB_DEPENDS= libnss3.so:security/nss
ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
PGSQL_USES= pgsql
@@ -67,17 +67,15 @@ PLIST_SUB+= SHLIB_APR_MAJOR="${SHLIB_APR_MAJOR}" \
APR_CONF_ARGS= --with-installbuilddir=${DATADIR}/build-1 \
--enable-threads \
- --enable-posix-shm
+ --enable-posix-shm \
+ --with-devrandom
APU_CONF_ARGS= --with-apr=${APR_WRKDIR} \
- --with-expat=${LOCALBASE} \
- --with-iconv=${ICONV_PREFIX}
+ --with-expat=${LOCALBASE}
########## APR Options
IPV6_VARS= APR_CONF_ARGS+=--enable-ipv6
IPV6_VARS_OFF= APR_CONF_ARGS+=--disable-ipv6
-DEVRANDOM_VARS= APR_CONF_ARGS+=--with-devrandom
-DEVRANDOM_VARS_OFF= APR_CONF_ARGS+=--without-devrandom
######### APR-Util Options
# make sure 1st include is "${APR_WRKDIR}/include"
@@ -116,7 +114,6 @@ APU_CONF_ENV+= ${CONFIGURE_ENV:O:u} CC="${CC}" CFLAGS="${CFLAGS}" CPPFLAGS="${AP
.include <bsd.port.options.mk>
-# crypto (apache24)
.if ${PORT_OPTIONS:MSSL} || ${PORT_OPTIONS:MNSS}
APU_CONF_ARGS+= --with-crypto
.else
diff --git a/devel/apr1/files/patch-PR61517 b/devel/apr1/files/patch-PR61517
new file mode 100644
index 000000000000..1e729094a298
--- /dev/null
+++ b/devel/apr1/files/patch-PR61517
@@ -0,0 +1,126 @@
+diff -ur a/build/dbd.m4 b/build/dbd.m4
+--- apr-util-1.6.1/build/dbd.m4.orig 2017-05-03 19:18:52.000000000 -0400
++++ apr-util-1.6.1/build/dbd.m4 2017-09-13 16:58:07.369546391 -0400
+@@ -163,10 +163,15 @@
+ old_cppflags="$CPPFLAGS"
+ old_ldflags="$LDFLAGS"
+
++ my_library="mysqlclient"
++
+ AC_ARG_WITH([mysql], APR_HELP_STRING([--with-mysql=DIR], [enable MySQL DBD driver]),
+ [
+ if test "$withval" = "yes"; then
+ AC_PATH_PROG([MYSQL_CONFIG],[mysql_config])
++ if test "x$MYSQL_CONFIG" = "x"; then
++ AC_PATH_PROG([MYSQL_CONFIG],[mariadb_config])
++ fi
+ if test "x$MYSQL_CONFIG" != 'x'; then
+ mysql_CPPFLAGS="`$MYSQL_CONFIG --include`"
+ mysql_LDFLAGS="`$MYSQL_CONFIG --libs_r | sed -e 's/-l[[^ ]]\+//g'`"
+@@ -174,32 +179,40 @@
+
+ APR_ADDTO(CPPFLAGS, [$mysql_CPPFLAGS])
+ APR_ADDTO(LIBS, [$mysql_LIBS])
++
++ if $MYSQL_CONFIG --libs_r | grep -q mariadb; then
++ my_library="mariadb"
++ fi
+ fi
+
+- AC_CHECK_HEADERS([mysql.h my_global.h my_sys.h],
+- AC_CHECK_LIB(mysqlclient, mysql_init, [apu_have_mysql=1]),
+- [apu_have_mysql=0; break],
+- [#include <my_global.h>])
+- if test "$apu_have_mysql" = "0"; then
+- AC_CHECK_HEADERS([mysql/mysql.h mysql/my_global.h mysql/my_sys.h],
+- AC_CHECK_LIB(mysqlclient, mysql_init, [apu_have_mysql=1]),
+- [apu_have_mysql=0; break],
+- [#include <mysql/my_global.h>])
++ AC_CHECK_HEADERS([mysql.h errmsg.h], [apu_have_mysql=1], [apu_have_mysql=0; break])
++ if test "$apr_have_mysql" = "0"; then
++ AC_CHECK_HEADERS([mysql/mysql.h mysql/errmsg.h], [apu_have_mysql=1], [apu_have_mysql=0; break])
+ fi
+- if test "$apu_have_mysql" != "0" && test "x$MYSQL_CONFIG" != 'x'; then
+- APR_ADDTO(APRUTIL_PRIV_INCLUDES, [$mysql_CPPFLAGS])
++ if test "$apr_have_mysql" = "1"; then
++ AC_CHECK_HEADERS([my_global.h my_sys.h mysql/my_global.h mysql/my_sys.h])
++ AC_CHECK_LIB($my_library, mysql_init,, [apu_have_mysql=0])
++ fi
++ if test "$apu_have_mysql" = "1" && test "x$MYSQL_CONFIG" != 'x'; then
++ APR_ADDTO(APRUTIL_PRIV_INCLUDES, [$mysql_CPPFLAGS])
+ fi
+ elif test "$withval" = "no"; then
+ :
+ else
+ AC_PATH_PROG([MYSQL_CONFIG],[mysql_config],,[$withval/bin])
++ if test "x$MYSQL_CONFIG" = "x"; then
++ AC_PATH_PROG([MYSQL_CONFIG],[mariadb_config],,[$withval/bin])
++ fi
+ if test "x$MYSQL_CONFIG" != 'x'; then
+- mysql_CPPFLAGS="`$MYSQL_CONFIG --include`"
+- mysql_LDFLAGS="`$MYSQL_CONFIG --libs_r | sed -e 's/-l[[^ ]]\+//g'`"
+- mysql_LIBS="`$MYSQL_CONFIG --libs_r`"
++ mysql_CPPFLAGS="`$MYSQL_CONFIG --include`"
++ mysql_LDFLAGS="`$MYSQL_CONFIG --libs_r | sed -e 's/-l[[^ ]]\+//g'`"
++ mysql_LIBS="`$MYSQL_CONFIG --libs_r`"
++ if $MYSQL_CONFIG --libs_r | grep -q mariadb; then
++ my_library="mariadb"
++ fi
+ else
+- mysql_CPPFLAGS="-I$withval/include"
+- mysql_LDFLAGS="-L$withval/lib "
++ mysql_CPPFLAGS="-I$withval/include"
++ mysql_LDFLAGS="-L$withval/lib "
+ fi
+
+ APR_ADDTO(CPPFLAGS, [$mysql_CPPFLAGS])
+@@ -207,18 +220,15 @@
+ APR_ADDTO(LIBS, [$mysql_LIBS])
+
+ AC_MSG_NOTICE(checking for mysql in $withval)
+- AC_CHECK_HEADERS([mysql.h my_global.h my_sys.h],
+- AC_CHECK_LIB(mysqlclient, mysql_init, [apu_have_mysql=1]),
+- [apu_have_mysql=0; break],
+- [#include <my_global.h>])
+-
+- if test "$apu_have_mysql" != "1"; then
+- AC_CHECK_HEADERS([mysql/mysql.h mysql/my_global.h mysql/my_sys.h],
+- AC_CHECK_LIB(mysqlclient, mysql_init, [apu_have_mysql=1]),
+- [apu_have_mysql=0; break],
+- [#include <mysql/my_global.h>])
++ AC_CHECK_HEADERS([mysql.h errmsg.h], [apu_have_mysql=1], [apu_have_mysql=0; break])
++ if test "$apr_have_mysql" = "0"; then
++ AC_CHECK_HEADERS([mysql/mysql.h mysql/errmsg.h], [apu_have_mysql=1], [apu_have_mysql=0; break])
++ fi
++ if test "$apr_have_mysql" = "1"; then
++ AC_CHECK_HEADERS([my_global.h my_sys.h mysql/my_global.h mysql/my_sys.h])
++ AC_CHECK_LIB($my_library, mysql_init,, [apu_have_mysql=0])
+ fi
+- if test "$apu_have_mysql" != "0"; then
++ if test "$apu_have_mysql" = "1"; then
+ APR_ADDTO(APRUTIL_PRIV_INCLUDES, [$mysql_CPPFLAGS])
+ fi
+ fi
+@@ -229,7 +239,7 @@
+ dnl Since we have already done the AC_CHECK_LIB tests, if we have it,
+ dnl we know the library is there.
+ if test "$apu_have_mysql" = "1"; then
+- APR_ADDTO(LDADD_dbd_mysql, [$mysql_LDFLAGS -lmysqlclient $mysql_LIBS])
++ APR_ADDTO(LDADD_dbd_mysql, [$mysql_LDFLAGS -l$my_library $mysql_LIBS])
+ fi
+ AC_SUBST(LDADD_dbd_mysql)
+
+diff -ur a/dbd/apr_dbd_mysql.c b/dbd/apr_dbd_mysql.c
+--- apr-util-1.6.1/dbd/apr_dbd_mysql.c.orig 2017-05-03 19:18:52.000000000 -0400
++++ apr-util-1.6.1/dbd/apr_dbd_mysql.c 2017-09-13 19:15:20.894368809 -0400
+@@ -1262,7 +1262,9 @@
+
+ static void dbd_mysql_init(apr_pool_t *pool)
+ {
++#if MYSQL_VERSION_ID < 100000
+ my_init();
++#endif
+ mysql_thread_init();
+
+ /* FIXME: this is a guess; find out what it really does */
+
diff --git a/devel/kdesvn-kde4/Makefile b/devel/kdesvn-kde4/Makefile
index 34626350c42b..7fd84a52ad8d 100644
--- a/devel/kdesvn-kde4/Makefile
+++ b/devel/kdesvn-kde4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kdesvn
DISTVERSION= 1.7.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/
diff --git a/devel/log4cxx/Makefile b/devel/log4cxx/Makefile
index 6d1fd5c348dc..a779e6c91a05 100644
--- a/devel/log4cxx/Makefile
+++ b/devel/log4cxx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= log4cxx
PORTVERSION= 0.10.0
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= devel
MASTER_SITES= APACHE/logging/${PORTNAME}/${PORTVERSION}
DISTNAME= apache-${PORTNAME}-${PORTVERSION}
diff --git a/devel/p5-subversion/Makefile b/devel/p5-subversion/Makefile
index ecbca0b10b3d..ffc88ecfc731 100644
--- a/devel/p5-subversion/Makefile
+++ b/devel/p5-subversion/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PKGNAMEPREFIX= p5-
-PORTREVISION= 0
+PORTREVISION= 1
MAINTAINER= lev@FreeBSD.org
COMMENT= Perl bindings for Version control system
diff --git a/devel/py-subversion/Makefile b/devel/py-subversion/Makefile
index 5324f9ebe101..a6a6d4cb7855 100644
--- a/devel/py-subversion/Makefile
+++ b/devel/py-subversion/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PORTREVISION= 1
MAINTAINER= lev@FreeBSD.org
COMMENT= Python bindings for version control system
diff --git a/devel/ruby-subversion/Makefile b/devel/ruby-subversion/Makefile
index da0a195178b7..bebf2d551fd7 100644
--- a/devel/ruby-subversion/Makefile
+++ b/devel/ruby-subversion/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PKGNAMEPREFIX= ruby-
+PORTREVISION= 1
MAINTAINER= lev@FreeBSD.org
COMMENT= Ruby bindings for version control system
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index 17f2d8505bf3..765f4723e4d6 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -1,7 +1,7 @@
# Created by: rooneg@electricjellyfish.net
# $FreeBSD$
-PORTREVISION= 2
+PORTREVISION= 3
MAINTAINER= lev@FreeBSD.org
COMMENT= Version control system
diff --git a/devel/subversion18/Makefile.common b/devel/subversion18/Makefile.common
index 91b11623cd77..ee529c10e1c7 100644
--- a/devel/subversion18/Makefile.common
+++ b/devel/subversion18/Makefile.common
@@ -3,7 +3,7 @@
PORTNAME?= subversion
PORTVERSION= 1.8.19
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES+= devel
MASTER_SITES= APACHE/subversion
DIST_SUBDIR= subversion18
diff --git a/editors/libreoffice/Makefile.common b/editors/libreoffice/Makefile.common
index 7683f98ae0a9..dffa50cd52ca 100644
--- a/editors/libreoffice/Makefile.common
+++ b/editors/libreoffice/Makefile.common
@@ -2,6 +2,7 @@
PORTNAME= libreoffice
PORTVERSION= 6.0.2
+PORTREVISION= 1
CATEGORIES+= editors
MAINTAINER= office@FreeBSD.org
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 20d623a7e863..a419d415b108 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/sources \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index f55d3b22f7d5..1f1586d34f16 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION1}.${AOOVERSION2}.${SVNREVISION}
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 4
CATEGORIES= editors java
MASTER_SITES= https://dist.apache.org/repos/dist/dev/openoffice/${AOOVERSION}-${AOORC}-r${SVNREVISION}/source/ \
diff --git a/graphics/mapcache/Makefile b/graphics/mapcache/Makefile
index 48689e23d4e8..f80ace4fcfaa 100644
--- a/graphics/mapcache/Makefile
+++ b/graphics/mapcache/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mapcache
DISTVERSION= 1.4.0-94
+PORTREVISION= 1
DISTVERSIONSUFFIX= -g732b3fd
CATEGORIES= graphics
diff --git a/java/java-subversion/Makefile b/java/java-subversion/Makefile
index b0bd42d97969..ae4d72bec1a7 100644
--- a/java/java-subversion/Makefile
+++ b/java/java-subversion/Makefile
@@ -3,6 +3,7 @@
PKGNAMEPREFIX= java-
CATEGORIES= java
+PORTREVISION= 1
MAINTAINER= lev@FreeBSD.org
COMMENT= Java bindings for Version control system
diff --git a/lang/neko/Makefile b/lang/neko/Makefile
index 63f922088993..59b9de4c05ba 100644
--- a/lang/neko/Makefile
+++ b/lang/neko/Makefile
@@ -3,7 +3,7 @@
PORTNAME= neko
DISTVERSIONPREFIX= v
DISTVERSION= 2-2-0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MAINTAINER= penzin.dev@gmail.com
diff --git a/security/orthrus/Makefile b/security/orthrus/Makefile
index 062f6d6e3c32..cef9c05de295 100644
--- a/security/orthrus/Makefile
+++ b/security/orthrus/Makefile
@@ -3,7 +3,7 @@
PORTNAME= orthrus
PORTVERSION= 0.8.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/orthrus/ \
http://16degrees.com.au/${PORTNAME}/
diff --git a/security/subversion-gnome-keyring/Makefile b/security/subversion-gnome-keyring/Makefile
index 633230e67724..b41979116ccc 100644
--- a/security/subversion-gnome-keyring/Makefile
+++ b/security/subversion-gnome-keyring/Makefile
@@ -3,6 +3,7 @@
PKGNAMESUFFIX= -gnome-keyring
CATEGORIES= security gnome
+PORTREVISION= 1
MAINTAINER= lev@FreeBSD.org
COMMENT= Gnome KWyring integration for Version control system
diff --git a/security/subversion-kwallet/Makefile b/security/subversion-kwallet/Makefile
index efffad768a4a..9d3272586ad2 100644
--- a/security/subversion-kwallet/Makefile
+++ b/security/subversion-kwallet/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PKGNAMESUFFIX= -kwallet
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security kde
MAINTAINER= lev@FreeBSD.org
diff --git a/sysutils/ftwin/Makefile b/sysutils/ftwin/Makefile
index cfa5f21a422a..ec1cb15e0dac 100644
--- a/sysutils/ftwin/Makefile
+++ b/sysutils/ftwin/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ftwin
PORTVERSION= 0.8.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://files.etoilebsd.net/ftwin/ \
http://download.meroware.org/ftwin/
diff --git a/sysutils/ganglia-monitor-core/Makefile b/sysutils/ganglia-monitor-core/Makefile
index f8ab32dd7338..3bf7fce314ad 100644
--- a/sysutils/ganglia-monitor-core/Makefile
+++ b/sysutils/ganglia-monitor-core/Makefile
@@ -2,6 +2,7 @@
PORTNAME= monitor-core
PORTVERSION= 3.7.1
+PORTREVISION= 1
CATEGORIES= sysutils net
MASTER_SITES= SF/ganglia/ganglia%20monitoring%20core/${PORTVERSION}
PKGNAMEPREFIX= ganglia-
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 064ee510e7e2..76c033e215cc 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -2,7 +2,7 @@
PORTNAME= apache22
PORTVERSION= 2.2.34
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= www ipv6
MASTER_SITES= APACHE_HTTPD
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index 66c0707b4042..f2a9617ed36f 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -2,6 +2,7 @@
PORTNAME= apache24
PORTVERSION= 2.4.29
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= APACHE_HTTPD
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/flood/Makefile b/www/flood/Makefile
index 9b890dbe9c2e..e4634c365711 100644
--- a/www/flood/Makefile
+++ b/www/flood/Makefile
@@ -2,7 +2,7 @@
PORTNAME= flood
PORTVERSION= 0.20041105
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= www
MASTER_SITES= http://dist.bsdlab.org/
DISTNAME= httpd-test_20041105052051
diff --git a/www/htdigest/Makefile b/www/htdigest/Makefile
index c168e8a84226..2e50da194f14 100644
--- a/www/htdigest/Makefile
+++ b/www/htdigest/Makefile
@@ -2,7 +2,7 @@
PORTNAME= htdigest
PORTVERSION= 2.4.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www ipv6
MASTER_SITES= APACHE_HTTPD
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/httest/Makefile b/www/httest/Makefile
index f65b2539c702..06f407fb0eef 100644
--- a/www/httest/Makefile
+++ b/www/httest/Makefile
@@ -3,6 +3,7 @@
PORTNAME= httest
PORTVERSION= 2.4.23
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF/htt/htt${PORTVERSION:R}/${PORTNAME}-${PORTVERSION}
diff --git a/www/mod_asn/Makefile b/www/mod_asn/Makefile
index 6c02384ed99f..ca33b3bc41da 100644
--- a/www/mod_asn/Makefile
+++ b/www/mod_asn/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mod_asn
PORTVERSION= 1.7
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= LOCAL/kuriyama \
http://mirrorbrain.org/files/releases/
diff --git a/www/mod_dav_svn/Makefile b/www/mod_dav_svn/Makefile
index 39c3773c1a06..da2a46fb69e4 100644
--- a/www/mod_dav_svn/Makefile
+++ b/www/mod_dav_svn/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mod_dav_svn
DISTNAME= subversion-${PORTVERSION}
+PORTREVISION= 1
CATEGORIES= www
diff --git a/www/mod_md-devel/Makefile b/www/mod_md-devel/Makefile
index da865169c7c0..96c9a909a681 100644
--- a/www/mod_md-devel/Makefile
+++ b/www/mod_md-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mod_md
PORTVERSION= 1.1.10
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= www
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
diff --git a/www/mod_pagespeed/Makefile b/www/mod_pagespeed/Makefile
index 1de151388edf..2beb51b3cb92 100644
--- a/www/mod_pagespeed/Makefile
+++ b/www/mod_pagespeed/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mod_pagespeed
PORTVERSION= 1.12.34.2
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= www devel
MASTER_SITES= LOCAL/mmokhi:boringssl,chromium_base,chromium_build,googleurl,gflags_arch,gflags_src,libjpeg_turbo_src,yasm_patched,libwebp,modpb64 \
diff --git a/www/mod_security/Makefile b/www/mod_security/Makefile
index 08351c32703a..defc1763ff42 100644
--- a/www/mod_security/Makefile
+++ b/www/mod_security/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mod_security
PORTVERSION= 2.9.2
+PORTREVISION= 1
CATEGORIES= www security
MASTER_SITES= http://www.modsecurity.org/tarball/${PORTVERSION}/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
diff --git a/www/rubygem-passenger/Makefile b/www/rubygem-passenger/Makefile
index 4449122026d8..a93f95b22cf7 100644
--- a/www/rubygem-passenger/Makefile
+++ b/www/rubygem-passenger/Makefile
@@ -3,7 +3,7 @@
PORTNAME= passenger
PORTVERSION= 5.1.12
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www rubygems
MASTER_SITES= RG
PKGNAMEPREFIX= rubygem-
diff --git a/www/serf/Makefile b/www/serf/Makefile
index 8487ecb02719..68f9ee9a52ed 100644
--- a/www/serf/Makefile
+++ b/www/serf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= serf
PORTVERSION= 1.3.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= APACHE/serf
diff --git a/www/tomcat-native/Makefile b/www/tomcat-native/Makefile
index 792be18f25b6..e0a50f9491b1 100644
--- a/www/tomcat-native/Makefile
+++ b/www/tomcat-native/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tomcat-native
PORTVERSION= 1.2.16
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= APACHE/tomcat/tomcat-connectors/native/${PORTVERSION}/source
DISTNAME= ${PORTNAME}-${PORTVERSION}-src