aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-21 09:08:08 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-21 09:08:08 +0000
commit63e2e719c3a70d6191743207d759e2b923c1e632 (patch)
tree4cc8a1072270bb3133825a7f0a3fdb49305d7187
parentcb6d7de1cbc81752a3caaf11b82857d1055dacd8 (diff)
downloadports-63e2e719c3a70d6191743207d759e2b923c1e632.tar.gz
ports-63e2e719c3a70d6191743207d759e2b923c1e632.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/endless-sky/Makefile34
-rw-r--r--games/endless-sky/distinfo2
-rw-r--r--games/endless-sky/files/patch-SConstruct55
-rw-r--r--games/endless-sky/pkg-descr15
-rw-r--r--games/endless-sky/pkg-plist9
6 files changed, 116 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 20a192bbde00..1b5704942a58 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -230,6 +230,7 @@
SUBDIR += ember
SUBDIR += endgame-singularity
SUBDIR += endgame-singularity-music
+ SUBDIR += endless-sky
SUBDIR += enigma
SUBDIR += ensemblist
SUBDIR += entombed
diff --git a/games/endless-sky/Makefile b/games/endless-sky/Makefile
new file mode 100644
index 000000000000..c2ecb670e7bb
--- /dev/null
+++ b/games/endless-sky/Makefile
@@ -0,0 +1,34 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= endless-sky
+PORTVERSION= 0.8.4
+DISTVERSIONPREFIX= v
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Space exploration and combat game similar to Escape Velocity
+
+LICENSE= GPLv3 # or later
+
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
+
+BROKEN_FreeBSD_9= does not build
+
+USE_GITHUB= yes
+
+USES= compiler:c++11-lib jpeg localbase openal scons
+USE_SDL= sdl2
+USE_GL= gl glew
+INSTALLS_ICONS= yes
+
+PORTDATA= *
+
+post-build:
+ @${REINPLACE_CMD} -e 's|/usr/local/|${PREFIX}/|; s|share/games|share|' \
+ ${WRKSRC}/source/Files.cpp
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/games/endless-sky/distinfo b/games/endless-sky/distinfo
new file mode 100644
index 000000000000..25331cc609a7
--- /dev/null
+++ b/games/endless-sky/distinfo
@@ -0,0 +1,2 @@
+SHA256 (endless-sky-endless-sky-v0.8.4_GH0.tar.gz) = 6d04e98e443974458e5b35dca016b4cc06b230885788354e24e630daba99d150
+SIZE (endless-sky-endless-sky-v0.8.4_GH0.tar.gz) = 35028917
diff --git a/games/endless-sky/files/patch-SConstruct b/games/endless-sky/files/patch-SConstruct
new file mode 100644
index 000000000000..0db26d26c813
--- /dev/null
+++ b/games/endless-sky/files/patch-SConstruct
@@ -0,0 +1,55 @@
+--- SConstruct.orig 2015-10-06 21:52:04 UTC
++++ SConstruct
+@@ -14,7 +14,7 @@ if 'SCHROOT_CHROOT_NAME' in os.environ a
+
+ # Required build flags. If you want to use SSE optimization, you can turn on
+ # -msse3 or (if just building for your own computer) -march=native.
+-env.Append(CCFLAGS = ["-std=c++0x", "-O3", "-Wall"])
++env.Append(CCFLAGS = ["-std=c++0x", "-Wall"])
+ env.Append(LIBS = [
+ "SDL2",
+ "png",
+@@ -28,7 +28,7 @@ env.Append(LIBS = [
+ # Work with clang's static analyzer:
+ env["CC"] = os.getenv("CC") or env["CC"]
+ env["CXX"] = os.getenv("CXX") or env["CXX"]
+-env["ENV"].update(x for x in os.environ.items() if x[0].startswith("CCC_"))
++env["ENV"].update(x for x in os.environ.items())
+
+ opts = Variables()
+ opts.Add(PathVariable("PREFIX", "Directory to install under", "/usr/local", PathVariable.PathIsDirCreate))
+@@ -43,7 +43,7 @@ sky = env.Program("endless-sky", Glob("b
+
+
+ # Install the binary:
+-env.Install("$DESTDIR$PREFIX/games", sky)
++env.Install("$DESTDIR$PREFIX/bin", sky)
+
+ # Install the desktop file:
+ env.Install("$DESTDIR$PREFIX/share/applications", "endless-sky.desktop")
+@@ -68,7 +68,7 @@ if env.get("PREFIX").startswith("/usr/")
+
+ # Install the man page.
+ env.Command(
+- "$DESTDIR$PREFIX/share/man/man6/endless-sky.6.gz",
++ "$DESTDIR$PREFIX/man/man6/endless-sky.6.gz",
+ "endless-sky.6",
+ "gzip -c $SOURCE > $TARGET")
+
+@@ -81,11 +81,11 @@ def RecursiveInstall(env, target, source
+ RecursiveInstall(env, os.path.join(target, name), node.abspath)
+ else:
+ env.Install(target, node)
+-RecursiveInstall(env, "$DESTDIR$PREFIX/share/games/endless-sky/data", "data")
+-RecursiveInstall(env, "$DESTDIR$PREFIX/share/games/endless-sky/images", "images")
+-RecursiveInstall(env, "$DESTDIR$PREFIX/share/games/endless-sky/sounds", "sounds")
+-env.Install("$DESTDIR$PREFIX/share/games/endless-sky", "credits.txt")
+-env.Install("$DESTDIR$PREFIX/share/games/endless-sky", "keys.txt")
++RecursiveInstall(env, "$DESTDIR$PREFIX/share/endless-sky/data", "data")
++RecursiveInstall(env, "$DESTDIR$PREFIX/share/endless-sky/images", "images")
++RecursiveInstall(env, "$DESTDIR$PREFIX/share/endless-sky/sounds", "sounds")
++env.Install("$DESTDIR$PREFIX/share/endless-sky", "credits.txt")
++env.Install("$DESTDIR$PREFIX/share/endless-sky", "keys.txt")
+
+ # Make the word "install" in the command line do an installation.
+ env.Alias("install", "$DESTDIR$PREFIX")
diff --git a/games/endless-sky/pkg-descr b/games/endless-sky/pkg-descr
new file mode 100644
index 000000000000..c19c70761c13
--- /dev/null
+++ b/games/endless-sky/pkg-descr
@@ -0,0 +1,15 @@
+Explore other star systems. Earn money by trading, carrying passengers,
+or completing missions. Use your earnings to buy a better ship or
+to upgrade the weapons and engines on your current one. Blow up
+pirates. Take sides in a civil war. Or leave human space behind and
+hope to find some friendly aliens whose culture is more civilized
+than your own...
+
+Endless Sky is a sandbox-style space exploration game similar to
+Elite, Escape Velocity, or Star Control. You start out as the captain
+of a tiny space ship and can choose what to do from there. The game
+includes a major plot line and many minor missions, but you can
+choose whether you want to play through the plot or strike out on
+your own as a merchant or bounty hunter or explorer.
+
+WWW: http://endless-sky.github.io/
diff --git a/games/endless-sky/pkg-plist b/games/endless-sky/pkg-plist
new file mode 100644
index 000000000000..c2ced6414b0b
--- /dev/null
+++ b/games/endless-sky/pkg-plist
@@ -0,0 +1,9 @@
+bin/endless-sky
+man/man6/endless-sky.6.gz
+share/applications/endless-sky.desktop
+share/icons/hicolor/16x16/apps/endless-sky.png
+share/icons/hicolor/22x22/apps/endless-sky.png
+share/icons/hicolor/24x24/apps/endless-sky.png
+share/icons/hicolor/256x256/apps/endless-sky.png
+share/icons/hicolor/32x32/apps/endless-sky.png
+share/icons/hicolor/48x48/apps/endless-sky.png