aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-03-15 22:03:42 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-03-15 22:03:42 +0000
commit63f96859ce0b25a7057110abdd77cff71ff45681 (patch)
treed72ad8a21ce169d4163dc3bde69207c34ac21e0d
parent4cf78eacbab3fd0188059a00356e6e23e76e547b (diff)
downloadports-63f96859ce0b25a7057110abdd77cff71ff45681.tar.gz
ports-63f96859ce0b25a7057110abdd77cff71ff45681.zip
Notes
-rw-r--r--Mk/Uses/qmail.mk64
-rw-r--r--Mk/bsd.mail.mk71
-rw-r--r--Mk/bsd.port.mk4
-rw-r--r--mail/ezmlm-idx/Makefile8
-rw-r--r--mail/ezmlm/Makefile3
-rw-r--r--mail/mailfront/Makefile3
-rw-r--r--mail/mess822/Makefile8
-rw-r--r--mail/qmail-activedir/Makefile8
-rw-r--r--mail/qmail-auditor/Makefile8
-rw-r--r--mail/qmail-conf/Makefile8
-rw-r--r--mail/qmail-contrib/Makefile2
-rw-r--r--mail/qmail-dk/Makefile3
-rw-r--r--mail/qmail-rblchk/Makefile11
-rw-r--r--mail/qmail-scanner/Makefile3
-rw-r--r--mail/qmail-scanner1/Makefile10
-rw-r--r--mail/qmail/Makefile6
-rw-r--r--mail/qmailadmin-devel/Makefile8
-rw-r--r--mail/qmailadmin/Makefile3
-rw-r--r--mail/qmailanalog/Makefile3
-rw-r--r--mail/qmailmrtg7/Makefile9
-rw-r--r--mail/qmhandle/Makefile2
-rw-r--r--mail/qscan/Makefile9
-rw-r--r--mail/qsheff/Makefile8
-rw-r--r--mail/qtools/Makefile8
-rw-r--r--mail/queue-fix/Makefile3
-rw-r--r--mail/queue-repair/Makefile8
-rw-r--r--mail/sendok/Makefile8
-rw-r--r--mail/serialmail/Makefile8
-rw-r--r--mail/simscan/Makefile8
-rw-r--r--mail/softfail/Makefile9
-rw-r--r--mail/spamdyke/Makefile9
-rw-r--r--mail/usendmail/Makefile8
-rw-r--r--mail/vpopmail/Makefile2
-rw-r--r--mail/vqadmin/Makefile9
-rw-r--r--mail/xf-spf/Makefile8
35 files changed, 134 insertions, 216 deletions
diff --git a/Mk/Uses/qmail.mk b/Mk/Uses/qmail.mk
new file mode 100644
index 000000000000..60d02f11a8d5
--- /dev/null
+++ b/Mk/Uses/qmail.mk
@@ -0,0 +1,64 @@
+# $FreeBSD$
+#
+# MAINTAINER= bdrewery@FreeBSD.org
+#
+# Feature: qmail
+# Usage: USES=qmail or USES=qmail:ARGS
+# Valid ARGS: both (default, implicit), run, build, vars
+#
+# Ports can use the following vars:
+#
+# QMAIL_PREFIX - Define it if qmail is installed in a different PREFIX.
+# Default: /var/qmail
+#
+# QMAIL_SLAVEPORT - Define it if you install a slaveport of qmail, to
+# prevent stale dependencies. Valid slaveports are:
+# ldap, mysql, spamcontrol and tls.
+#
+
+.if !defined(_INCLUDE_QMAIL_MK)
+_INCLUDE_QMAIL_MK= yes
+
+QMAIL_PREFIX?= /var/qmail
+
+.if !defined(qmail_ARGS)
+qmail_ARGS= both
+.endif
+
+.if ${qmail_ARGS} == "build"
+BUILD_DEPENDS+= ${_QMAIL_DEPENDS}
+.elif ${qmail_ARGS} == "run"
+RUN_DEPENDS+= ${_QMAIL_DEPENDS}
+.elif ${qmail_ARGS} == "both"
+BUILD_DEPENDS+= ${_QMAIL_DEPENDS}
+RUN_DEPENDS+= ${_QMAIL_DEPENDS}
+.elif ${qmail_ARGS} == "vars"
+.else
+IGNORE= USES=qmail - invalid args: [${qmail_ARGS}] specified
+.endif
+
+.if ${qmail_ARGS} != "vars"
+
+_QMAIL_VALID_SLAVEPORTS= ldap mysql spamcontrol tls
+
+. if defined(QMAIL_SLAVEPORT)
+. for slave in ${_QMAIL_VALID_SLAVEPORTS}
+. if ${QMAIL_SLAVEPORT:L} == ${slave}
+_QMAIL_SLAVEPORT_OKAY= true
+. endif
+. endfor
+
+. if !defined(_QMAIL_SLAVEPORT_OKAY)
+IGNORE= Invalid QMAIL_SLAVEPORT value. Only one can be set, valid values are: ${_QMAIL_VALID_SLAVEPORTS}
+. endif
+. endif
+
+. if defined(QMAIL_SLAVEPORT)
+_QMAIL_DEPENDS= ${QMAIL_PREFIX}/bin/qmail-send:${PORTSDIR}/mail/qmail-${QMAIL_SLAVEPORT:L}
+. else
+_QMAIL_DEPENDS= ${QMAIL_PREFIX}/bin/qmail-send:${PORTSDIR}/mail/qmail
+. endif
+
+.endif
+
+.endif
diff --git a/Mk/bsd.mail.mk b/Mk/bsd.mail.mk
deleted file mode 100644
index 43b7e5c74e06..000000000000
--- a/Mk/bsd.mail.mk
+++ /dev/null
@@ -1,71 +0,0 @@
-#-*- tab-width: 4; -*-
-# ex:ts=4
-#
-# $FreeBSD$
-#
-# Please view me with 4 column tabs!
-
-.if !defined(_POSTMKINCLUDED) && !defined(Mail_Pre_Include)
-
-# Please make sure all changes to this file are passed through the maintainer.
-# Do not commit them yourself (unless of course you're the Port's Wraith ;).
-Mail_Include_MAINTAINER= bdrewery@FreeBSD.org
-Mail_Pre_Include= bsd.mail.mk
-
-
-## Begin QMAIL Stuff
-
-# Ports can use the following vars:
-#
-# QMAIL_PREFIX - Define it if qmail is installed in a different PREFIX.
-# Default: /var/qmail
-#
-# QMAIL_SLAVEPORT - Define it if you install a slaveport of qmail, to
-# prevent stale dependencies. Valid slaveports are:
-# ldap, mysql, spamcontrol and tls.
-#
-# USE_QMAIL_BUILD - Add qmail or qmail slaveport to BUILD_DEPENDS.
-#
-# USE_QMAIL_RUN - Add qmail or qmail slaveport to RUN_DEPENDS.
-#
-# USE_QMAIL - Add qmail or qmail slaveport to RUN and BUILD_DEPENDS.
-#
-# WANT_QMAIL - Set vars related to qmail, like QMAIL_PREFIX.
-
-QMAIL_PREFIX?= /var/qmail
-
-_QMAIL_VALID_SLAVEPORTS= ldap mysql spamcontrol tls
-
-.if defined(USE_QMAIL) || defined(USE_QMAIL_RUN) || defined (USE_QMAIL_BUILD)
-
-.if defined(QMAIL_SLAVEPORT)
-. for slave in ${_QMAIL_VALID_SLAVEPORTS}
-. if ${QMAIL_SLAVEPORT:L} == ${slave}
-_QMAIL_SLAVEPORT_OKAY= true
-. endif
-. endfor
-
-. if !defined(_QMAIL_SLAVEPORT_OKAY)
-IGNORE= Invalid QMAIL_SLAVEPORT value. Only one can be set, valid values are: ${_QMAIL_VALID_SLAVEPORTS}
-. endif
-.endif
-
-.if defined(QMAIL_SLAVEPORT)
-QMAIL_DEPENDS= ${QMAIL_PREFIX}/bin/qmail-send:${PORTSDIR}/mail/qmail-${QMAIL_SLAVEPORT:L}
-.else
-QMAIL_DEPENDS= ${QMAIL_PREFIX}/bin/qmail-send:${PORTSDIR}/mail/qmail
-.endif
-
-.if defined(USE_QMAIL) || defined(USE_QMAIL_RUN)
-RUN_DEPENDS+= ${QMAIL_DEPENDS}
-.endif
-
-.if defined(USE_QMAIL) || defined(USE_QMAIL_BUILD)
-BUILD_DEPENDS+= ${QMAIL_DEPENDS}
-.endif
-
-.endif
-
-## End QMAIL Stuff
-
-.endif
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 8280916e6b19..e132a5d5b430 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1488,10 +1488,6 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.include "${PORTSDIR}/Mk/bsd.gstreamer.mk"
.endif
-.if defined(USE_QMAIL) || defined(USE_QMAIL_RUN) || defined(USE_QMAIL_BUILD) || defined(WANT_QMAIL)
-.include "${PORTSDIR}/Mk/bsd.mail.mk"
-.endif
-
.if defined(USE_SDL) || defined(WANT_SDL)
.include "${PORTSDIR}/Mk/bsd.sdl.mk"
.endif
diff --git a/mail/ezmlm-idx/Makefile b/mail/ezmlm-idx/Makefile
index 6884ab53d3a6..de745fa411ff 100644
--- a/mail/ezmlm-idx/Makefile
+++ b/mail/ezmlm-idx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ezmlm-idx
-# Date created: 28 November 1998
-# Whom: Neil Blakey-Milner <nbm@rucus.ru.ac.za>
-#
+# Created by: Neil Blakey-Milner <nbm@rucus.ru.ac.za>
# $FreeBSD$
-#
PORTNAME= ezmlm-idx
PORTVERSION= 7.1.1
@@ -19,7 +15,7 @@ MAKE_JOBS_UNSAFE= yes
LICENSE= GPLv2
-USE_QMAIL_RUN= yes
+USES= qmail:run
CONFLICTS= ezmlm-0.*
diff --git a/mail/ezmlm/Makefile b/mail/ezmlm/Makefile
index b65d0c9dd969..f0ad2bfbf0b1 100644
--- a/mail/ezmlm/Makefile
+++ b/mail/ezmlm/Makefile
@@ -16,8 +16,9 @@ MASTER_SITES= http://cr.yp.to/software/ \
MAINTAINER= c.petrik.sosa@gmail.com
COMMENT= Easy-to-use, high-speed mailing list manager for qmail
+USES= qmail:run
+
USE_GCC= any
-USE_QMAIL_RUN= yes
CONFLICTS= ezmlm-idx-*
diff --git a/mail/mailfront/Makefile b/mail/mailfront/Makefile
index 14d5c5be76fe..c483a0ff2401 100644
--- a/mail/mailfront/Makefile
+++ b/mail/mailfront/Makefile
@@ -14,7 +14,8 @@ LIB_DEPENDS= cvm-v2client:${PORTSDIR}/security/cvm
OPTIONS_DEFINE= LUA
-WANT_QMAIL= yes
+USES= qmail:vars
+
CFLAGS+= -I${CVM_INC}
CFLAGS_SO= ${CFLAGS} -fPIC -shared -L${CVM_LIB}
LDFLAGS+= -g -L${CVM_LIB}
diff --git a/mail/mess822/Makefile b/mail/mess822/Makefile
index aa416fcea10e..9e0963ea0496 100644
--- a/mail/mess822/Makefile
+++ b/mail/mess822/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mess822
-# Date created: 4 February 2001
-# Whom: David Siebörger <drs@rucus.ru.ac.za>
-#
+# Created by: David Siebörger <drs@rucus.ru.ac.za>
# $FreeBSD$
-#
PORTNAME= mess822
PORTVERSION= 0.58
@@ -17,7 +13,7 @@ MASTER_SITES= http://cr.yp.to/software/ \
MAINTAINER= drs@rucus.ru.ac.za
COMMENT= RFC 822 mail message parsing library and rewriting utilities
-USE_QMAIL_RUN= yes
+USES= qmail:run
RESTRICTED= Violates djb\'s license
diff --git a/mail/qmail-activedir/Makefile b/mail/qmail-activedir/Makefile
index 90410cc7fd8b..53c4d3b5a9ce 100644
--- a/mail/qmail-activedir/Makefile
+++ b/mail/qmail-activedir/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qmail-activedir
-# Date created: 2005-11-08
-# Whom: Jean Milanez Melo <jmelo@FreeBSD.org>
-#
+# Created by: Jean Milanez Melo <jmelo@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= qmail-activedir
PORTVERSION= 0.17
@@ -14,7 +10,7 @@ MASTER_SITES= http://fo2k.com/qmail-activedir/
MAINTAINER= jmelo@FreeBSD.org
COMMENT= Programs to allow qmail to authenticate users through a MS ad
-USE_QMAIL_RUN= yes
+USES= qmail:run
SUB_FILES= pkg-message
SUB_LIST+= QMAIL_PREFIX=${QMAIL_PREFIX}
USE_OPENLDAP= yes
diff --git a/mail/qmail-auditor/Makefile b/mail/qmail-auditor/Makefile
index 26d464178f1c..9c5aee3f8e82 100644
--- a/mail/qmail-auditor/Makefile
+++ b/mail/qmail-auditor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qmail-auditor
-# Date created: 2007-02-08
-# Whom: Patrick Tracanelli <eksffa@freebsdbrasil.com.br>
-#
+# Created by: Patrick Tracanelli <eksffa@freebsdbrasil.com.br>
# $FreeBSD$
-#
PORTNAME= qmail-auditor
PORTVERSION= 0.47
@@ -16,7 +12,7 @@ COMMENT= Selective e-mail auditing for qmail by means of qmail-queue wrapping
WRKSRC= ${WRKDIR}/${PORTNAME:R}
-USE_QMAIL_RUN= yes
+USES= qmail:run
GNU_CONFIGURE= yes
SUB_FILES= pkg-message
diff --git a/mail/qmail-conf/Makefile b/mail/qmail-conf/Makefile
index 575095582357..1c47e6f61dd2 100644
--- a/mail/qmail-conf/Makefile
+++ b/mail/qmail-conf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qmail-conf
-# Date created: 8 April 2003
-# Whom: roam@FreeBSD.org
-#
+# Created by: roam@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= qmail-conf
PORTVERSION= 0.60
@@ -18,7 +14,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Configure various qmail services to run under daemontools
-WANT_QMAIL= yes
+USES= qmail:vars
ALL_TARGET= it
INSTALL_TARGET= setup check
diff --git a/mail/qmail-contrib/Makefile b/mail/qmail-contrib/Makefile
index a60d50ae0a11..ef12a4212dd9 100644
--- a/mail/qmail-contrib/Makefile
+++ b/mail/qmail-contrib/Makefile
@@ -16,7 +16,7 @@ COMMENT= Contributed programs for qmail
OPTIONS_DEFINE= DOCS
-USE_QMAIL_RUN= yes
+USES= qmail:run
MAKE_JOBS_SAFE= yes
ALL_TARGET= it
diff --git a/mail/qmail-dk/Makefile b/mail/qmail-dk/Makefile
index ebc093aaf69a..c90a24da0fa1 100644
--- a/mail/qmail-dk/Makefile
+++ b/mail/qmail-dk/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS+= domainkeys:${PORTSDIR}/mail/libdomainkeys
PATCH_SITES= ${MASTER_SITE_QMAIL}
PATCHFILES= qmail-1.03-dk-0.54.patch
-USE_QMAIL= yes
+USES= qmail
+
MAKE_JOBS_SAFE= yes
PREFIX?= ${QMAIL_PREFIX}
diff --git a/mail/qmail-rblchk/Makefile b/mail/qmail-rblchk/Makefile
index 220d0c211234..7c3060f34bf2 100644
--- a/mail/qmail-rblchk/Makefile
+++ b/mail/qmail-rblchk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qmail-rblchk
-# Date created: 21 Jun 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= qmail-rblchk
PORTVERSION= 2.4.1
@@ -12,9 +8,10 @@ MASTER_SITES= http://www.morettoni.net/qmail/ \
CRITICAL
MAINTAINER= ports@FreeBSD.org
-COMMENT= A qmail RBL filter
+COMMENT= Qmail RBL filter
+
+USES= qmail:run
-USE_QMAIL_RUN= yes
MAKE_JOBS_SAFE= yes
LDFLAGS?= -s
diff --git a/mail/qmail-scanner/Makefile b/mail/qmail-scanner/Makefile
index 5d539f96c765..3ce2c2ed58e8 100644
--- a/mail/qmail-scanner/Makefile
+++ b/mail/qmail-scanner/Makefile
@@ -21,8 +21,9 @@ BUILD_DEPENDS+= reformime:${PORTSDIR}/mail/maildrop \
CONFLICTS= qmail-scanner-1.*
+USES= qmail
+
USE_PERL5= yes
-USE_QMAIL= yes
SPOOLDIR?= /var/spool/qscand
PLIST_SUB= SPOOLDIR=${SPOOLDIR}
diff --git a/mail/qmail-scanner1/Makefile b/mail/qmail-scanner1/Makefile
index b72416a031d4..7627c9618b42 100644
--- a/mail/qmail-scanner1/Makefile
+++ b/mail/qmail-scanner1/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qmail-scanner
-# Date created: 2003-08-24
-# Whom: moeti
-#
+# Created by: moeti
# $FreeBSD$
-#
PORTNAME= qmail-scanner
PORTVERSION= 1.25
@@ -27,6 +23,8 @@ SUB_LIST= SPOOLDIR=${SPOOLDIR}
NO_LATEST_LINK= yes
CONFLICTS= qmail-scanner-2.*
+USES= qmail
+
QMAIL_QUEUE= ${QMAIL_PREFIX}/bin/qmail-queue
USE_PERL5= yes
@@ -82,8 +80,6 @@ CONFIGURE_ARGS+= --spams-tosuffix "${QMAILSCAN_SPAMSTOSUFFIX}"
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_QMAIL= yes
-
SPOOLDIR= ${PREFIX}/qmailscan
PLIST_SUB= SPOOLDIR="${SPOOLDIR:S,${PREFIX}/,,}"
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index 8f12ab673fd9..9884e4c870de 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -18,6 +18,9 @@ DIST_SUBDIR= qmail
CONFLICTS?= qmail-ldap-[0-9]* qmail-mysql-[0-9]* qmail-spamcontrol-[0-9]* qmail-tls-[0-9]*
CONFLICTS+= qmail-vida-[0-9]*
+USES= qmail:vars
+PREFIX?= ${QMAIL_PREFIX}
+
MAKE_JOBS_UNSAFE= yes
PORTSCOUT= skipv:1.04
@@ -150,7 +153,6 @@ PATCHFILES+= qmail-1.03-tls-${TLS_PATCH_DATE}-renato_v2.patch:tls
PATCH_SITES+= ${MASTER_SITE_LOCAL:S/$/:dns,sendmail_flagf,rfc2821,ldap,mysql,tls,quota,blockexec,doublebounce,spf,localtime,qmtpc_outgoingip/}
PATCH_SITE_SUBDIR+= garga/qmail/:dns,sendmail_flagf,rfc2821,ldap,mysql,tls,quota,blockexec,doublebounce,spf,localtime,qmtpc_outgoingip
-PREFIX?= ${QMAIL_PREFIX}
QMAIL_VERSION?= 1.03
.if !defined(BARRIER_SMTP_AUTH_PATCH)
@@ -336,8 +338,6 @@ BOOTFILES= home home+df proc proc+df binm1 binm1+df \
CONFIGUREPROGRAMS= install dnsfq hostname dnsip ipmeprint dnsptr
CONFIGURESCRIPTS= config config-fast
-WANT_QMAIL= yes
-
.include <bsd.port.options.mk>
.if defined(SLAVE_LDAP) && ${PORT_OPTIONS:MTLS}
diff --git a/mail/qmailadmin-devel/Makefile b/mail/qmailadmin-devel/Makefile
index 509994aefc0e..30180e7e1235 100644
--- a/mail/qmailadmin-devel/Makefile
+++ b/mail/qmailadmin-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qmailadmin
-# Date created: 31 May 2009
-# Whom: Ismail YENIGUL
-#
+# Created by: Ismail YENIGUL
# $FreeBSD$
-#
PORTNAME= qmailadmin
PORTVERSION= 1.2.13
@@ -42,7 +38,7 @@ LATEST_LINK= qmailadmin-devel
GNU_CONFIGURE= YES
USE_GMAKE= YES
-WANT_QMAIL= yes
+USES= qmail:vars
#
# User-configurable variables
diff --git a/mail/qmailadmin/Makefile b/mail/qmailadmin/Makefile
index 4c7616b69b14..df6af0a089a4 100644
--- a/mail/qmailadmin/Makefile
+++ b/mail/qmailadmin/Makefile
@@ -21,6 +21,8 @@ RUN_DEPENDS= \
autorespond:${PORTSDIR}/mail/autorespond \
${VPOPMAIL_DIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
+USES= qmail:vars
+
CONFLICTS= qmailadmin-devel-1.*
PATCH_SITES+= http://qmail.jms1.net/vpopmail/:onchange \
@@ -57,7 +59,6 @@ VPOPMAIL_DIR?= ${LOCALBASE}/vpopmail
GNU_CONFIGURE= YES
USE_GMAKE= YES
-WANT_QMAIL= yes
# Notes and comments:
#
diff --git a/mail/qmailanalog/Makefile b/mail/qmailanalog/Makefile
index c2c17c988267..b80c01f6e621 100644
--- a/mail/qmailanalog/Makefile
+++ b/mail/qmailanalog/Makefile
@@ -11,7 +11,8 @@ MASTER_SITES= http://cr.yp.to/software/ \
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Tools to analyze qmail-send's activity
-USE_QMAIL_RUN= yes
+USES= qmail:run
+
MAKE_JOBS_SAFE= yes
ALL_TARGET= it
diff --git a/mail/qmailmrtg7/Makefile b/mail/qmailmrtg7/Makefile
index 9866b4c82e1f..0c94fb6e89a1 100644
--- a/mail/qmailmrtg7/Makefile
+++ b/mail/qmailmrtg7/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qmailmrtg7
-# Date created: 16 Jun 2004
-# Whom: Alex Dupre <ale@FreeBSD.org>
-#
+# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= qmailmrtg7
PORTVERSION= 4.2
@@ -15,7 +11,8 @@ MAINTAINER= ale@FreeBSD.org
COMMENT= A program to create mrtg graphs for qmail activity
RUN_DEPENDS= mrtg:${PORTSDIR}/net-mgmt/mrtg
-USE_QMAIL= yes
+
+USES= qmail
.include <bsd.port.pre.mk>
diff --git a/mail/qmhandle/Makefile b/mail/qmhandle/Makefile
index f44cc85f9f61..06d0440c64b0 100644
--- a/mail/qmhandle/Makefile
+++ b/mail/qmhandle/Makefile
@@ -12,7 +12,7 @@ COMMENT= Tool to view and manage a qmail queue
OPTIONS_DEFINE= DOCS
-USE_QMAIL_RUN= yes
+USES= qmail:run
NO_BUILD= yes
USE_PERL5= yes
diff --git a/mail/qscan/Makefile b/mail/qscan/Makefile
index 104bd125ce87..47cb6ad2ff8e 100644
--- a/mail/qscan/Makefile
+++ b/mail/qscan/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qscan
-# Date created: 8 Apr 2004
-# Whom: Alex Dupre <ale@FreeBSD.org>
-#
+# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= qscan
PORTVERSION= 1.5
@@ -17,7 +13,8 @@ COMMENT= A mail filter for Qmail that scans messages with ClamAV
RUN_DEPENDS= clamdscan:${PORTSDIR}/security/clamav \
ripmime:${PORTSDIR}/mail/ripmime
-USE_QMAIL_RUN= yes
+
+USES= qmail:run
GNU_CONFIGURE= yes
diff --git a/mail/qsheff/Makefile b/mail/qsheff/Makefile
index e69182121524..76c15bef8e6f 100644
--- a/mail/qsheff/Makefile
+++ b/mail/qsheff/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qsheff
-# Date created: 14 Jul 2005
-# Whom: Ozkan KIRIK <ozkan@enderunix.org>
-#
+# Created by: Ozkan KIRIK <ozkan@enderunix.org>
# $FreeBSD$
-#
PORTNAME= qsheff-II
PORTVERSION= 2.1.r3
@@ -22,7 +18,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= YES
-USE_QMAIL= yes
+USES= qmail
DOCS= README COPYING AUTHORS ChangeLog INSTALL THANKS TODO
EXAMPLES= sample-OK.msg sample-SPAM.msg sample-VIRUS.msg
diff --git a/mail/qtools/Makefile b/mail/qtools/Makefile
index f17380fb9a69..565a6a99faff 100644
--- a/mail/qtools/Makefile
+++ b/mail/qtools/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qtools
-# Date created: 3 July 2001
-# Whom: petef@FreeBSD.org
-#
+# Created by: petef@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= qtools
PORTVERSION= 0.56
@@ -16,7 +12,7 @@ COMMENT= Tools to use in .qmail files
RUN_DEPENDS= ${EZMLM_DIR}/bin/ezmlm-weed:${PORTSDIR}/mail/ezmlm
-WANT_QMAIL= yes
+USES= qmail:vars
ALL_TARGET= it
INSTALL_TARGET= setup check
diff --git a/mail/queue-fix/Makefile b/mail/queue-fix/Makefile
index e36947ce8c6f..e8045e25bf02 100644
--- a/mail/queue-fix/Makefile
+++ b/mail/queue-fix/Makefile
@@ -11,7 +11,8 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Repairs or generates a qmail queue structure
-USE_QMAIL_RUN= yes
+USES= qmail:run
+
MAKE_JOBS_SAFE= yes
PREFIX?= ${QMAIL_PREFIX}
diff --git a/mail/queue-repair/Makefile b/mail/queue-repair/Makefile
index a8d6770c29e8..fbf1d39fd2a0 100644
--- a/mail/queue-repair/Makefile
+++ b/mail/queue-repair/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: queue-repair
-# Date created: 22 Aug 2002
-# Whom: Sergei Kolobov <sergei@kolobov.com>
-#
+# Created by: Sergei Kolobov <sergei@kolobov.com>
# $FreeBSD$
-#
PORTNAME= queue-repair
PORTVERSION= 0.9.0
@@ -15,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A qmail queue diagnostic and repair tool
.if !defined(WITHOUT_QMAIL_PORT)
-USE_QMAIL_RUN= yes
+USES= qmail:run
.endif
USE_PYTHON= yes
diff --git a/mail/sendok/Makefile b/mail/sendok/Makefile
index c4192ba3558b..99ec28152804 100644
--- a/mail/sendok/Makefile
+++ b/mail/sendok/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sendok
-# Date created: 18 October 2005
-# Whom: Zak Johnson <zakj@nox.cx>
-#
+# Created by: Zak Johnson <zakj@nox.cx>
# $FreeBSD$
-#
PORTNAME= sendok
PORTVERSION= 0.9.2
@@ -14,7 +10,7 @@ MASTER_SITES= http://peff.net/sendok/ \
MAINTAINER= zakj@nox.cx
COMMENT= Generates qmail email addresses with timed cookies
-USE_QMAIL_RUN= yes
+USES= qmail:run
PLIST_FILES= bin/sendok-check bin/sendok-create
diff --git a/mail/serialmail/Makefile b/mail/serialmail/Makefile
index 1bcb9f6d651a..d5a6b15729a6 100644
--- a/mail/serialmail/Makefile
+++ b/mail/serialmail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: serialmail
-# Date created: 2 November 1998
-# Whom: Tom Hukins <tom@eborcom.com>
-#
+# Created by: Tom Hukins <tom@eborcom.com>
# $FreeBSD$
-#
PORTNAME= serialmail
PORTVERSION= 0.75
@@ -18,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Tools for passing mail across serial links
RUN_DEPENDS= tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
-USE_QMAIL_RUN= yes
+USES= qmail:run
RESTRICTED= Unsure of DJB license
diff --git a/mail/simscan/Makefile b/mail/simscan/Makefile
index 8e3ac81481bb..278cf18e109e 100644
--- a/mail/simscan/Makefile
+++ b/mail/simscan/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: simscan
-# Date created: 1 Apr 2005
-# Whom: Anton Karpov <toxa@toxahost.ru>
-#
+# Created by: Anton Karpov <toxa@toxahost.ru>
# $FreeBSD$
-#
PORTNAME= simscan
PORTVERSION= 1.4.0
@@ -15,7 +11,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
MAINTAINER= lippe@FreeBSD.org
COMMENT= Fast Content/Anti-virus Scanner for qmail Written in C
-USE_QMAIL_BUILD= yes
+USES= qmail:build
GNU_CONFIGURE= yes
diff --git a/mail/softfail/Makefile b/mail/softfail/Makefile
index da9cc440fc66..c398a5675212 100644
--- a/mail/softfail/Makefile
+++ b/mail/softfail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: softfail
-# Date created: 2007-02-01
-# Whom: Patrick Tracanelli <eksffa@freebsdbrasil.com.br>
-#
+# Created by: Patrick Tracanelli <eksffa@freebsdbrasil.com.br>
# $FreeBSD$
-#
PORTNAME= softfail
PORTVERSION= 2.0
@@ -25,9 +21,10 @@ PLIST_SUB= QMAIL_PREFIX=${QMAIL_PREFIX}
PORTDOCS= README softfail.sql
+USES= qmail
+
USE_BZIP2= yes
USE_MYSQL= yes
-USE_QMAIL= yes
.if defined(QMAIL_SLAVEPORT) && ( ${QMAIL_SLAVEPORT} != "spamcontrol" && ${QMAIL_SLAVEPORT} != "ldap" )
IGNORE= software only works with qmail-spamcontrol or qmail-ldap
diff --git a/mail/spamdyke/Makefile b/mail/spamdyke/Makefile
index 0bc7acc1d2b5..db38f722c0db 100644
--- a/mail/spamdyke/Makefile
+++ b/mail/spamdyke/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: spamdyke
-# Date created: 11 January 2007
-# Whom: Peter Kieser <peter@kieser.ca>
-#
+# Created by: Peter Kieser <peter@kieser.ca>
# $FreeBSD$
-#
PORTNAME= spamdyke
PORTVERSION= 4.3.1
@@ -18,7 +14,8 @@ RUN_DEPENDS= ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
WRKSRC= ${WRKDIR}/${DISTNAME}/spamdyke
-USE_QMAIL= yes
+USES= qmail
+
GNU_CONFIGURE= yes
ALL_TARGET= spamdyke
diff --git a/mail/usendmail/Makefile b/mail/usendmail/Makefile
index 7890ec073bf1..5d7488637b6b 100644
--- a/mail/usendmail/Makefile
+++ b/mail/usendmail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: usendmail
-# Date created: 2004-02-19
-# Whom: Thomas Seck <tmseck@netcologne.de>
-#
+# Created by: Thomas Seck <tmseck@netcologne.de>
# $FreeBSD$
-#
PORTNAME= usendmail
PORTVERSION= 0.1.6
@@ -14,7 +10,7 @@ MASTER_SITES= http://www.ohse.de/uwe/usendmail/
MAINTAINER= tmseck@FreeBSD.org
COMMENT= A replacement for qmail's sendmail drop-in
-USE_QMAIL= yes
+USES= qmail
WRKSRC= ${WRKDIR}/mail/${DISTNAME}
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index 307e21406228..21781f240cad 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
PATCH_STRIP= -p1
-USE_QMAIL= yes
+USES= qmail
CONFLICTS= vpopmail-devel-5.*
diff --git a/mail/vqadmin/Makefile b/mail/vqadmin/Makefile
index b34941948f86..3b62edc38102 100644
--- a/mail/vqadmin/Makefile
+++ b/mail/vqadmin/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: vqadmin
-# Date created: 29 Mar 2001
-# Whom: nbm
-#
+# Created by: nbm
# $FreeBSD$
-#
PORTNAME= vqadmin
PORTVERSION= 2.3.6
@@ -18,7 +14,8 @@ BUILD_DEPENDS= ${LOCALBASE}/vpopmail/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
RUN_DEPENDS= ${LOCALBASE}/vpopmail/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
GNU_CONFIGURE= YES
-WANT_QMAIL= yes
+
+USES= qmail:vars
CGIBINDIR?= www/cgi-bin-dist
WEBDATADIR?= www/data-dist
diff --git a/mail/xf-spf/Makefile b/mail/xf-spf/Makefile
index d965e21ae803..95289edc18d1 100644
--- a/mail/xf-spf/Makefile
+++ b/mail/xf-spf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xf-spf
-# Date created: 2007-09-12
-# Whom: Felippe de Meirelles Motta <lippe@freebsdbrasil.com.br>
-#
+# Created by: Felippe de Meirelles Motta <lippe@freebsdbrasil.com.br>
# $FreeBSD$
-#
PORTNAME= xf-spf
PORTVERSION= 0.2
@@ -16,7 +12,7 @@ COMMENT= SPF checker for Qmail's SMTPEXTFORK patch
LIB_DEPENDS+= spf2.3:${PORTSDIR}/mail/libspf2
-USE_QMAIL= yes
+USES= qmail
USE_BZIP2= yes
SUB_FILES= pkg-message