aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2005-02-12 23:25:03 +0000
committerEric Anholt <anholt@FreeBSD.org>2005-02-12 23:25:03 +0000
commit6406f57df897961677cb7725ed75c045996e17b7 (patch)
tree7eeef4cac0ee0ea06a3d7c0f5daf8e732f4b92ef
parented300258b2ca200f89fbeb75f9278240b04b2367 (diff)
downloadports-6406f57df897961677cb7725ed75c045996e17b7.tar.gz
ports-6406f57df897961677cb7725ed75c045996e17b7.zip
New port: gtkguitune, a guitar (and other instruments) tuner for GTK.
Notes
Notes: svn path=/head/; revision=128654
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gtkguitune/Makefile29
-rw-r--r--audio/gtkguitune/distinfo2
-rw-r--r--audio/gtkguitune/files/patch-guitune.cc14
-rw-r--r--audio/gtkguitune/files/patch-main.cc14
-rw-r--r--audio/gtkguitune/pkg-descr9
6 files changed, 69 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 6e4df82408ea..9cbfdc0b5740 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -152,6 +152,7 @@
SUBDIR += gstreamer-monkeysaudio
SUBDIR += gtick
SUBDIR += gtkgep
+ SUBDIR += gtkguitune
SUBDIR += gtkpod
SUBDIR += holyshout
SUBDIR += hydrogen
diff --git a/audio/gtkguitune/Makefile b/audio/gtkguitune/Makefile
new file mode 100644
index 000000000000..d7c688f1e966
--- /dev/null
+++ b/audio/gtkguitune/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gtkguitune
+# Date created: 12 Feb 2005
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkguitune
+PORTVERSION= 0.7
+CATEGORIES= audio
+MASTER_SITES= http://www.geocities.com/harpin_floh/mysoft/
+
+MAINTAINER= anholt@FreeBSD.org
+COMMENT= A guitar (and other instruments) tuner for GTK
+
+LIB_DEPENDS= gtkmm.2:${PORTSDIR}/x11-toolkits/gtk--
+
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG=yes
+
+PLIST_FILES= bin/gtkguitune
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+CFLAGS+= -fhuge-objects
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/gtkguitune/distinfo b/audio/gtkguitune/distinfo
new file mode 100644
index 000000000000..b4afb150ca50
--- /dev/null
+++ b/audio/gtkguitune/distinfo
@@ -0,0 +1,2 @@
+MD5 (gtkguitune-0.7.tar.gz) = 1fa82bf4034b45750c831902a1a96bdf
+SIZE (gtkguitune-0.7.tar.gz) = 54992
diff --git a/audio/gtkguitune/files/patch-guitune.cc b/audio/gtkguitune/files/patch-guitune.cc
new file mode 100644
index 000000000000..711d88d5d22b
--- /dev/null
+++ b/audio/gtkguitune/files/patch-guitune.cc
@@ -0,0 +1,14 @@
+--- guitune.cc.orig Sat Feb 12 11:14:56 2005
++++ guitune.cc Sat Feb 12 11:15:02 2005
+@@ -24,7 +24,11 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
++#ifdef __linux__
+ #include <linux/soundcard.h>
++#else
++#include <sys/soundcard.h>
++#endif
+
+ #include <gtk--/main.h>
+ #include <gtk--/box.h>
diff --git a/audio/gtkguitune/files/patch-main.cc b/audio/gtkguitune/files/patch-main.cc
new file mode 100644
index 000000000000..62f1005164f8
--- /dev/null
+++ b/audio/gtkguitune/files/patch-main.cc
@@ -0,0 +1,14 @@
+--- main.cc.orig Sat May 31 16:31:12 2003
++++ main.cc Sat Feb 12 11:22:19 2005
+@@ -24,7 +24,11 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <sys/ioctl.h>
++#ifdef __linux__
+ #include <linux/soundcard.h>
++#else
++#include <sys/soundcard.h>
++#endif
+
+ #include <gtk/gtk.h>
+ #include <gtk--/window.h>
diff --git a/audio/gtkguitune/pkg-descr b/audio/gtkguitune/pkg-descr
new file mode 100644
index 000000000000..8a9fe5e61bcd
--- /dev/null
+++ b/audio/gtkguitune/pkg-descr
@@ -0,0 +1,9 @@
+gtkguitune is a program for tuning guitars and other instruments. Rather than
+using FFT like many programs, it counts the number of triggerings between two
+trigger levels in a certain amount of time, which tends to be more accurate for
+instrument tuning while requiring less processing than FFT.
+
+WWW: http://www.geocities.com/harpin_floh/kguitune_page.html
+
+- Eric Anholt
+anholt@FreeBSD.org