aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-08-17 09:11:08 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-08-17 09:11:08 +0000
commit642bf72f2742aca6846abd7b1b794f6e6228d785 (patch)
tree16b60ab8fc707c56fd010a1332dd069eb8d17ae4
parentebdae4c240c2d48dec79872f8a8899fd6f1730b0 (diff)
downloadports-642bf72f2742aca6846abd7b1b794f6e6228d785.tar.gz
ports-642bf72f2742aca6846abd7b1b794f6e6228d785.zip
Add regexps capacity to PLIST_SUB.
This adds the possibility to use regular expressions for the makeplist stage of the PLIST_SUB life. From time to time, the values are too generic, and they get in the way of other stuff. This adds the possibility to have a `VAR_regex=regex` that will be used instead of the `VAR=string` to search for possible replacements. For example, in lang/perl5*, there is PERL_ARCH=mach, which will get replaced in paths if a file is called, say "machine", will end up being "%%PERL_ARCH%%ine". Adding PERL_ARCH_regex="\bmach\b" will ensure only full words are replaced, so machine will stay machine, but "lib/mach/foo "will still be replaced by "lib/%%PERL_ARCH%%/foo". Reviewed by: bdrewery Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D7335
Notes
Notes: svn path=/head/; revision=420328
-rw-r--r--CHANGES18
-rw-r--r--Mk/bsd.port.mk4
2 files changed, 21 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 68914e2d5353..0bbff468ba76 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,24 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20160317:
+AUTHOR: mat@FreeBSD.org
+
+ This adds the possibility to use regular expressions for the makeplist stage
+ of the PLIST_SUB life.
+
+ From time to time, the values are too generic, and they get in the way of
+ other stuff.
+
+ This adds the possibility to have a `VAR_regex=regex` that will be used
+ instead of the `VAR=string` to search for possible replacements.
+
+ For example, in lang/perl5*, there is PERL_ARCH=mach, which will get replaced
+ in paths if a file is called, say "machine", will end up being
+ "%%PERL_ARCH%%ine". Adding PERL_ARCH_regex="\bmach\b" will ensure only full
+ words are replaced, so machine will stay machine, but "lib/mach/foo "will
+ still be replaced by "lib/%%PERL_ARCH%%/foo".
+
20160803:
AUTHOR: mat@FreeBSD.org
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index e4e3b70cddc0..7c5bebf3e249 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1611,9 +1611,11 @@ PLIST_SUB_SED_tmp1= ${PLIST_SUB:C/.*=.{1,${PLIST_SUB_SED_MIN}}$//g}
# Remove empty values
# Remove @comment values
PLIST_SUB_SED_tmp2= ${PLIST_SUB_tmp1:NEXTRACT_SUFX=*:NOSREL=*:NLIB32DIR=*:NPREFIX=*:NLOCALBASE=*:NRESETPREFIX=*:N*="":N*="@comment*}
+# Handle VARS for which there is a _regex entry
+PLIST_SUB_SED_tmp3?= ${PLIST_SUB_SED_tmp1:C/(${PLIST_SUB:M*_regex=*:C/_regex=.*/=.*/:Q:S/\\ /|/g:S/\\//g})//:C/(.*)_regex=(.*)/\1=\2/}
# Remove quotes
# Replace . with \. for later sed(1) usage
-PLIST_SUB_SED?= ${PLIST_SUB_SED_tmp2:C/([^=]*)="?([^"]*)"?/s!\2!%%\1%%!g;/g:C/\./\\./g}
+PLIST_SUB_SED?= ${PLIST_SUB_SED_tmp3:C/([^=]*)="?([^"]*)"?/s!\2!%%\1%%!g;/g:C/\./\\./g}
# kludge to strip trailing whitespace from CFLAGS;
# sub-configure will not # survive double space