aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2016-10-04 17:32:58 +0000
committerMax Khon <fjoe@FreeBSD.org>2016-10-04 17:32:58 +0000
commit64970e81af9eb30ad6852a14c4c44b20426e073a (patch)
tree9cf0002c95349f6bced52c216d0f4262bb74c007
parente4ca8be4b2ee15f80e694399e3dbc7c22fd5c7c0 (diff)
downloadports-64970e81af9eb30ad6852a14c4c44b20426e073a.tar.gz
ports-64970e81af9eb30ad6852a14c4c44b20426e073a.zip
Notes
-rw-r--r--news/golded+/Makefile15
-rw-r--r--news/golded+/distinfo5
-rw-r--r--news/golded+/files/patch-GNUmakef.def14
-rw-r--r--news/golded+/files/patch-golded3-gckeys.cpp11
-rw-r--r--news/golded+/files/patch-golded3-geinit.cpp36
-rw-r--r--news/golded+/files/patch-golded3_Makefile11
-rw-r--r--news/golded+/files/patch-goldlib-gmb3-gmohuds.h14
-rw-r--r--news/golded+/files/patch-goldlib-gmb3-gmohuds2.cpp11
-rw-r--r--news/golded+/files/patch-goldlib-gmb3-gmohuds4.cpp11
9 files changed, 18 insertions, 110 deletions
diff --git a/news/golded+/Makefile b/news/golded+/Makefile
index 7269c14bfbc0..75faf7c9145b 100644
--- a/news/golded+/Makefile
+++ b/news/golded+/Makefile
@@ -5,20 +5,21 @@ PORTNAME= golded+
PORTVERSION= 1.1.5.a${SNAPDATE}
PORTREVISION= 1
CATEGORIES= news mail
-MASTER_SITES= SF/golded-plus/Golded%2B%201.1.5%20snapshots
-DISTNAME= gps115-${SNAPDATE}
-SNAPDATE= 20110223
+MASTER_SITES= SF/golded-plus/Golded%2B%201.1.5%20snapshots/2016.03.22
+DISTNAME= gpsrc-115-${SNAPDATE}
+EXTRACT_SUFX= .tgz
+SNAPDATE= 20160322
MAINTAINER= fjoe@FreeBSD.org
COMMENT= GoldEd+ (FTN message editor)
-USES= gmake ncurses tar:bzip2
+USES= gmake ncurses
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/golded-plus/${PORTNAME}
MAN1= golded.1 goldnode.1 rddt.1
DOCS= copying copying.lib license.txt notework.txt rusfaq.txt\
- tips.txt notework.rus tokencfg.txt tokentpl.txt goldnode.txt
+ tips.txt notework.rus
PORTDOCS= ${DOCS} gold_ref.txt gold_usr.txt
SUB_FILES= pkg-message
@@ -31,7 +32,7 @@ post-patch:
@${SED}\
-e 's,^\(#define __GVER_VENDOR_NAME__\).*,\1 "",'\
-e 's,\(#define __GVER_VENDOR_FIDO__\).*,\1 "",'\
- -e 's,\(#define __GVER_VENDOR_EMAIL__\).*,\1 "",'\
+ -e 's,\(#define __GVER_VENDOR_EMAIL__\).*,\1 "${MAINTAINER}",'\
-e 's,\(#define __GVER_RELEASENAME__\).*,\1 "Golded+ FreeBSD port",'\
-e 's,\(#define __GVER_POSTVERSION__\).*,\1 "-b${SNAPDATE}",'\
<${WRKSRC}/golded3/mygolded.__h >${WRKSRC}/golded3/mygolded.h
diff --git a/news/golded+/distinfo b/news/golded+/distinfo
index 0bd1f0d303b2..7b4b8ac963f2 100644
--- a/news/golded+/distinfo
+++ b/news/golded+/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gps115-20110223.tar.bz2) = cdc0976bcad8dc2419318b17e1a9069cfd0feb4b61d8057e46a075f8b2936d2c
-SIZE (gps115-20110223.tar.bz2) = 7824955
+TIMESTAMP = 1475600527
+SHA256 (gpsrc-115-20160322.tgz) = b937696f5a21f77fae3e5cf4040fd08acdbfa58aa695bad134a97c585b8a2577
+SIZE (gpsrc-115-20160322.tgz) = 1848932
diff --git a/news/golded+/files/patch-GNUmakef.def b/news/golded+/files/patch-GNUmakef.def
index 0525d449958c..995ebaf8eed7 100644
--- a/news/golded+/files/patch-GNUmakef.def
+++ b/news/golded+/files/patch-GNUmakef.def
@@ -1,6 +1,6 @@
---- GNUmakef.def.orig 2011-02-20 04:37:40.000000000 +0600
-+++ GNUmakef.def 2011-12-15 11:32:23.000000000 +0700
-@@ -135,8 +135,8 @@
+--- GNUmakef.def.orig 2015-11-28 07:03:45.000000000 +0000
++++ GNUmakef.def 2016-10-04 17:08:05.099233000 +0000
+@@ -141,8 +141,8 @@
CAT=cat
SED=sed
GREP=grep
@@ -11,14 +11,14 @@
AR=ar
RANLIB=ranlib
PLATFORM=lnx
-@@ -155,8 +155,8 @@
+@@ -162,8 +162,8 @@
endif
endif
endif
--CFLAGS+=-funsigned-char -g $(INCS) -Wall -Wno-sign-compare -pedantic -O2 -DPRAGMA_PACK # -fomit-frame-pointer
+-CFLAGS+=-funsigned-char -g $(INCS) -Wall -Wno-long-long -Wno-sign-compare -pedantic -O2 -DPRAGMA_PACK # -fomit-frame-pointer
-LNKFLAGS+=-g
-+CFLAGS+=-funsigned-char $(INCS) -Wall -Wno-sign-compare -O2 -DPRAGMA_PACK # -g -pedantic -fomit-frame-pointer
++CFLAGS+=-funsigned-char $(INCS) -Wall -Wno-long-long -Wno-sign-compare -O2 -DPRAGMA_PACK # -g -pedantic -fomit-frame-pointer
+#LNKFLAGS+=-g
- CPPFLAGS+=$(CFLAGS) -fno-rtti # -fno-exceptions
+ CPPFLAGS+=$(CFLAGS)
# Run `make USE_NCURSES=0` if you dislike ncurses
diff --git a/news/golded+/files/patch-golded3-gckeys.cpp b/news/golded+/files/patch-golded3-gckeys.cpp
deleted file mode 100644
index 3a401561f979..000000000000
--- a/news/golded+/files/patch-golded3-gckeys.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- golded3/gckeys.cpp.orig 2013-11-18 18:54:22.000000000 +0700
-+++ golded3/gckeys.cpp 2013-11-18 18:54:34.000000000 +0700
-@@ -989,7 +989,7 @@
- // ------------------------------------------------------------------
-
- //bool CmdKeyCmp(CmdKey a, CmdKey b) {
--bool operator<(CmdKey &a, CmdKey &b) {
-+bool operator<(const CmdKey &a, const CmdKey &b) {
-
- int cmp = CmpV(a.type, b.type);
- if(cmp != 0)
diff --git a/news/golded+/files/patch-golded3-geinit.cpp b/news/golded+/files/patch-golded3-geinit.cpp
deleted file mode 100644
index 8c4e76e8d59c..000000000000
--- a/news/golded+/files/patch-golded3-geinit.cpp
+++ /dev/null
@@ -1,36 +0,0 @@
---- golded3/geinit.cpp.orig 2011-02-23 02:31:26.000000000 +0600
-+++ golded3/geinit.cpp 2011-12-15 11:37:21.000000000 +0700
-@@ -420,19 +420,22 @@
- wcenters(12, C_BRAGW, "redistribute the program or any parts hereof under cer-");
- wcenters(13, C_BRAGW, "tain conditions. See the LICENSE.TXT for more details.");
-
-- wcenters(MAXROW-10, C_BRAGW, "This executable is distributed by");
-- if (*__gver_vendor_fido__)
-+ if (*__gver_vendor_name__)
- {
-- gsprintf(PRINTF_DECLARE_BUFFER(buf), "%s (Fido: %s) - <%s>",
-- __gver_vendor_name__, __gver_vendor_fido__, __gver_vendor_email__);
-- }
-- else
-- {
-- gsprintf(PRINTF_DECLARE_BUFFER(buf), "%s <%s>",
-- __gver_vendor_name__, __gver_vendor_email__);
-+ wcenters(MAXROW-10, C_BRAGW, "This executable is distributed by");
-+ if (*__gver_vendor_fido__)
-+ {
-+ gsprintf(PRINTF_DECLARE_BUFFER(buf), "%s (Fido: %s) - <%s>",
-+ __gver_vendor_name__, __gver_vendor_fido__, __gver_vendor_email__);
-+ }
-+ else
-+ {
-+ gsprintf(PRINTF_DECLARE_BUFFER(buf), "%s <%s>",
-+ __gver_vendor_name__, __gver_vendor_email__);
-+ }
-+
-+ wcenters(MAXROW-9, C_BRAGW, buf);
- }
--
-- wcenters(MAXROW-9, C_BRAGW, buf);
- gsprintf(PRINTF_DECLARE_BUFFER(buf), "Compiled on %s %s", __gver_date__, __gver_time__);
- wcenters(MAXROW-8, C_BRAGW, buf);
- }
diff --git a/news/golded+/files/patch-golded3_Makefile b/news/golded+/files/patch-golded3_Makefile
deleted file mode 100644
index 89c5311d5f15..000000000000
--- a/news/golded+/files/patch-golded3_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- golded3/Makefile.orig 2011-02-19 22:37:43 UTC
-+++ golded3/Makefile
-@@ -36,7 +36,7 @@ endif
- include $(TOP)/GNUmakef.inc
-
- ifeq ($(USE_NCURSES),1)
--STDLIBS+= $(LIBCURSES)
-+STDLIBS+= $(LDFLAGS) $(LIBCURSES)
- endif
-
- include $(TOP)/GNUmakef.prg
diff --git a/news/golded+/files/patch-goldlib-gmb3-gmohuds.h b/news/golded+/files/patch-goldlib-gmb3-gmohuds.h
deleted file mode 100644
index eb705f971c10..000000000000
--- a/news/golded+/files/patch-goldlib-gmb3-gmohuds.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- goldlib/gmb3/gmohuds.h.orig 2011-12-15 12:15:21.000000000 +0700
-+++ goldlib/gmb3/gmohuds.h 2011-12-15 12:17:29.000000000 +0700
-@@ -252,9 +252,9 @@
-
- void realloc_pm_scan();
-
-- void update_netecho(char* __name, msgn_t __hdridx, int __delete);
-+ void update_netecho(const char* __name, msgn_t __hdridx, int __delete);
-
-- void test_open(gfile &__file, char* __fname, int __oaccess);
-+ void test_open(gfile &__file, const char* __fname, int __oaccess);
- void raw_open(int __oaccess=0, int __all=true);
- void raw_close();
- void refresh();
diff --git a/news/golded+/files/patch-goldlib-gmb3-gmohuds2.cpp b/news/golded+/files/patch-goldlib-gmb3-gmohuds2.cpp
deleted file mode 100644
index a793fa79b70f..000000000000
--- a/news/golded+/files/patch-goldlib-gmb3-gmohuds2.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- goldlib/gmb3/gmohuds2.cpp.orig 2011-12-15 12:13:53.000000000 +0700
-+++ goldlib/gmb3/gmohuds2.cpp 2011-12-15 12:14:22.000000000 +0700
-@@ -48,7 +48,7 @@
- // ------------------------------------------------------------------
-
- template <class msgn_t, class rec_t, class attr_t, class board_t, class last_t, bool __HUDSON>
--void _HudsWide<msgn_t, rec_t, attr_t, board_t, last_t, __HUDSON>::test_open(gfile &__file, char* __fname, int __oaccess)
-+void _HudsWide<msgn_t, rec_t, attr_t, board_t, last_t, __HUDSON>::test_open(gfile &__file, const char* __fname, int __oaccess)
- {
- GFTRK("HudsTestOpen");
-
diff --git a/news/golded+/files/patch-goldlib-gmb3-gmohuds4.cpp b/news/golded+/files/patch-goldlib-gmb3-gmohuds4.cpp
deleted file mode 100644
index 157c0c4b248a..000000000000
--- a/news/golded+/files/patch-goldlib-gmb3-gmohuds4.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- goldlib/gmb3/gmohuds4.cpp.orig 2011-12-15 12:17:48.000000000 +0700
-+++ goldlib/gmb3/gmohuds4.cpp 2011-12-15 12:18:02.000000000 +0700
-@@ -29,7 +29,7 @@
- // ------------------------------------------------------------------
-
- template <class msgn_t, class rec_t, class attr_t, class board_t, class last_t, bool __HUDSON>
--void _HudsWide<msgn_t, rec_t, attr_t, board_t, last_t, __HUDSON>::update_netecho(char* __name, msgn_t __hdridx, int __delete)
-+void _HudsWide<msgn_t, rec_t, attr_t, board_t, last_t, __HUDSON>::update_netecho(const char* __name, msgn_t __hdridx, int __delete)
- {
- GFTRK("HudsUpdateNetEcho");
-