aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2021-02-04 23:01:49 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2021-02-04 23:01:49 +0000
commit665302ab569e8dc20f5cf773df1e33710f37710d (patch)
treeda86be1783df2be18a2e99ba3ff7bba198200b60
parent33af2733b6046cb6cb27357050e248c9ef17e402 (diff)
downloadports-665302ab569e8dc20f5cf773df1e33710f37710d.tar.gz
ports-665302ab569e8dc20f5cf773df1e33710f37710d.zip
Change the default location for NGINX Unit's state directory has changed.
It was moved from /usr/local/libexec/unit to /var/db/unit in order to avoid write operations on /usr/local filesystem. Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=564068
-rw-r--r--UPDATING8
-rw-r--r--www/unit/Makefile6
2 files changed, 13 insertions, 1 deletions
diff --git a/UPDATING b/UPDATING
index 715927db4e3c..45e187d39ad6 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20210204:
+ AFFECTS: users of www/unit
+ AUTHOR: osa@FreeBSD.org
+
+ The default location for NGINX Unit's state directory has changed. It
+ was moved from /usr/local/libexec/unit to /var/db/unit in order to
+ avoid write operations on /usr/local filesystem.
+
20210124:
AFFECTS: users of net-mgmt/netbox
AUTHOR: kai@FreeBSD.org
diff --git a/www/unit/Makefile b/www/unit/Makefile
index f617a93aa3c4..000820ab58a7 100644
--- a/www/unit/Makefile
+++ b/www/unit/Makefile
@@ -3,6 +3,7 @@
PORTNAME= unit
PORTVERSION= 1.22.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES?= https://unit.nginx.org/download/
@@ -41,6 +42,7 @@ UNIXSOCK_DESC= Enable unix sockets
HAS_CONFIGURE= yes
UNIT_VARDIR?= /var
+UNIT_DBDIR?= ${UNIT_VARDIR}/db/${PORTNAME}
UNIT_LOGDIR?= ${UNIT_VARDIR}/log/${PORTNAME}
UNIT_LOGFILE?= ${UNIT_LOGDIR}/${PORTNAME}.log
UNIT_PIDFILE?= ${UNIT_RUNDIR}/${PORTNAME}.pid
@@ -53,7 +55,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--log=${UNIT_LOGFILE} \
--modules=libexec/unit/modules \
--pid=${UNIT_PIDFILE} \
- --state=libexec/unit \
+ --state=${UNIT_DBDIR} \
--tmp=${UNIT_TMPDIR} \
--user=${WWWOWN} --group=${WWWGRP}
@@ -108,9 +110,11 @@ CONFIGURE_ARGS+=--control=unix:${UNIT_SOCK}
.if !target(post-install)
post-install:
+ ${MKDIR} ${STAGEDIR}${UNIT_DBDIR}
${MKDIR} ${STAGEDIR}${UNIT_LOGDIR}
${MKDIR} ${STAGEDIR}${UNIT_RUNDIR}
${MKDIR} ${STAGEDIR}${UNIT_TMPDIR}
+ ${ECHO_CMD} @dir ${UNIT_DBDIR} >> ${TMPPLIST}
${ECHO_CMD} @dir ${UNIT_LOGDIR} >> ${TMPPLIST}
${ECHO_CMD} @dir ${UNIT_RUNDIR} >> ${TMPPLIST}
${ECHO_CMD} @dir ${UNIT_TMPDIR} >> ${TMPPLIST}