aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-03-09 07:19:48 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-03-09 07:19:48 +0000
commit6751830b8d75b9c3d4731e676f18bb7b6932b598 (patch)
treef78ce114417cd699810033f7e78fefa5c5f6eb14
parentdeba41f25f91d7ed54b3a2827c94b78a3a6e9ab8 (diff)
downloadports-6751830b8d75b9c3d4731e676f18bb7b6932b598.tar.gz
ports-6751830b8d75b9c3d4731e676f18bb7b6932b598.zip
Notes
-rw-r--r--games/liquidwar/Makefile32
-rw-r--r--games/liquidwar/distinfo5
-rw-r--r--games/liquidwar/files/patch-Makefile.in11
-rw-r--r--games/liquidwar/files/patch-configure14
-rw-r--r--games/liquidwar/files/patch-src-Makefile.in11
-rw-r--r--games/liquidwar/files/patch-src_wwwsrv.c18
-rw-r--r--games/liquidwar/pkg-plist100
7 files changed, 98 insertions, 93 deletions
diff --git a/games/liquidwar/Makefile b/games/liquidwar/Makefile
index 03eabc782497..0e7ec8ef4aea 100644
--- a/games/liquidwar/Makefile
+++ b/games/liquidwar/Makefile
@@ -2,30 +2,40 @@
# $FreeBSD$
PORTNAME= liquidwar
-PORTVERSION= 5.6.4
-PORTREVISION= 5
+PORTVERSION= 5.6.5
CATEGORIES= games
-MASTER_SITES= http://liquidwar.sunsite.dk/archive/ \
+MASTER_SITES= http://www.ufoot.org/download/liquidwar/v5/${PORTVERSION}/ \
+ http://liquidwar.sunsite.dk/archive/ \
SAVANNAH \
http://ufoot.hd.free.fr/pub/archive/
MAINTAINER= ports@FreeBSD.org
COMMENT= You control an army of liquid and have to try and eat your opponents
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= liballeg.so:devel/allegro
+USES= gmake python:2.7,build
+
GNU_CONFIGURE= yes
-USES= gmake makeinfo python:2.7,build
-CONFIGURE_ARGS= --disable-target-opt --disable-doc-ps --disable-doc-pdf
-CONFIGURE_ENV= ac_cv_prog_PYTHON=yes
+CONFIGURE_ARGS= --disable-doc-info \
+ --disable-doc-pdf \
+ --disable-doc-ps \
+ --disable-target-opt
+MAKE_ARGS= DATADIR=${DATADIR} \
+ GAMEDIR=${PREFIX}/bin \
+ MANDIR=${PREFIX}/man/man6
+INSTALL_TARGET= install_nolink
-INFO= liquidwar
+BINARY_ALIAS= python=${PYTHON_CMD}
-OPTIONS_DEFINE= ASM
+OPTIONS_DEFINE= ASM DOCS
ASM_CONFIGURE_OFF= --disable-asm
-
-post-patch:
- @${REINPLACE_CMD} 's,python,${PYTHON_CMD},' ${WRKSRC}/doc/Makefile.in
+DOCS_CONFIGURE_OFF= --disable-doc-html \
+ --disable-doc-man \
+ --disable-doc-txt
.include <bsd.port.mk>
diff --git a/games/liquidwar/distinfo b/games/liquidwar/distinfo
index e32302169ec1..7d9f14896966 100644
--- a/games/liquidwar/distinfo
+++ b/games/liquidwar/distinfo
@@ -1,2 +1,3 @@
-SHA256 (liquidwar-5.6.4.tar.gz) = 32c52e4588e8e723f907ef43703b4ddf009e8ff1f29555c09bcc1f70bf5b93a3
-SIZE (liquidwar-5.6.4.tar.gz) = 3268432
+TIMESTAMP = 1549264493
+SHA256 (liquidwar-5.6.5.tar.gz) = dad0aa84dd416cad055421ed9b40df39efae78d3df759c0583c64c54f7f2ff5f
+SIZE (liquidwar-5.6.5.tar.gz) = 6508987
diff --git a/games/liquidwar/files/patch-Makefile.in b/games/liquidwar/files/patch-Makefile.in
deleted file mode 100644
index 9631bfa3d14a..000000000000
--- a/games/liquidwar/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 2007-10-17 22:00:47.000000000 +0200
-+++ Makefile.in 2018-11-02 12:39:01.122951000 +0100
-@@ -16,7 +16,7 @@ DESKTOPDIR = $(datadir)/applications
- # directory since the FHS (File Hierarchy Standard recommends
- # to place man pages in $(datadir)/man (ie /usr/share/man).
- # MANDIR = $(mandir)/man6
--MANDIR = $(datadir)/man/man6
-+MANDIR = $(prefix)/man/man6
- # We don't use the autoconf default infodir=$(prefix)/info info
- # directory since the FHS (File Hierarchy Standard recommends
- # to place info pages in $(datadir)/info (ie /usr/share/info).
diff --git a/games/liquidwar/files/patch-configure b/games/liquidwar/files/patch-configure
index 8609cc8d1548..61b0199b98ab 100644
--- a/games/liquidwar/files/patch-configure
+++ b/games/liquidwar/files/patch-configure
@@ -1,8 +1,8 @@
---- configure.orig Sun Mar 11 09:05:03 2007
-+++ configure Sun Mar 11 09:05:54 2007
-@@ -5345,9 +5345,9 @@
- if test "${ac_cv_prog_PYTHON+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
+--- configure.orig 2018-12-23 19:04:36 UTC
++++ configure
+@@ -3787,9 +3787,9 @@ $as_echo_n "checking for $ac_word... " >&6; }
+ if ${ac_cv_prog_PYTHON+:} false; then :
+ $as_echo_n "(cached) " >&6
else
- if test -n "$PYTHON"; then
- ac_cv_prog_PYTHON="$PYTHON" # Let the user override the test.
@@ -13,7 +13,7 @@
as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
for as_dir in $PATH
do
-@@ -5364,7 +5364,7 @@
+@@ -3807,7 +3807,7 @@ IFS=$as_save_IFS
test -z "$ac_cv_prog_PYTHON" && ac_cv_prog_PYTHON="no"
fi
@@ -21,4 +21,4 @@
+#fi
PYTHON=$ac_cv_prog_PYTHON
if test -n "$PYTHON"; then
- echo "$as_me:$LINENO: result: $PYTHON" >&5
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYTHON" >&5
diff --git a/games/liquidwar/files/patch-src-Makefile.in b/games/liquidwar/files/patch-src-Makefile.in
deleted file mode 100644
index dc2f07e18f23..000000000000
--- a/games/liquidwar/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig
-+++ src/Makefile.in
-@@ -250,7 +250,7 @@
-
- liquidwar-mapgen: $(OBJ_FILES_MAPGEN)
- @echo "Linking $@ (target=$(TARGET), debug=$(DEBUG), static=$(STATIC))"
-- @$(CC) $(LDFLAGS) $(LINK_OPTIONS) -o $@ $(OBJ_FILES_MAPGEN) $(PTHREAD) $(EXTERN_LIBS)
-+ @$(CC) $(LDFLAGS) $(LINK_OPTIONS) -o $@ $(OBJ_FILES_MAPGEN) $(PTHREAD) $(EXTERN_LIBS) -lm
-
- dep:
- @find . \
diff --git a/games/liquidwar/files/patch-src_wwwsrv.c b/games/liquidwar/files/patch-src_wwwsrv.c
new file mode 100644
index 000000000000..4f32eda8195d
--- /dev/null
+++ b/games/liquidwar/files/patch-src_wwwsrv.c
@@ -0,0 +1,18 @@
+--- src/wwwsrv.c.orig 2018-12-23 19:04:36 UTC
++++ src/wwwsrv.c
+@@ -100,12 +100,12 @@ lw_wwwsrv_init (LW_WWWSRV_DATA * data,
+
+ data->privacy = privacy;
+ data->log = log;
+- strncpy (data->metaserver, metaserver, URL_SIZE);
++ strncpy (data->metaserver, metaserver, sizeof(data->metaserver));
+ data->port = port;
+ data->busy_players = busy_players;
+ data->max_players = max_players;
+- strncpy (data->password, password, PASSWORD_SIZE);
+- strncpy (data->comment, comment, COMMENT_SIZE);
++ strncpy (data->password, password, sizeof(data->password));
++ strncpy (data->comment, comment, sizeof(data->comment));
+ }
+
+ /*------------------------------------------------------------------*/
diff --git a/games/liquidwar/pkg-plist b/games/liquidwar/pkg-plist
index 0400eba3a83f..3ff6030b3c81 100644
--- a/games/liquidwar/pkg-plist
+++ b/games/liquidwar/pkg-plist
@@ -4,55 +4,53 @@ bin/liquidwar-mapgen
man/man6/liquidwar-mapgen.6.gz
man/man6/liquidwar-server.6.gz
man/man6/liquidwar.6.gz
-%%DOCSDIR%%/txt/algorithm.txt
-%%DOCSDIR%%/txt/authors.txt
-%%DOCSDIR%%/txt/bugs.txt
-%%DOCSDIR%%/txt/copying.txt
-%%DOCSDIR%%/txt/mailinglists.txt
-%%DOCSDIR%%/txt/network.txt
-%%DOCSDIR%%/txt/options.txt
-%%DOCSDIR%%/txt/parameters.txt
-%%DOCSDIR%%/txt/platforms.txt
-%%DOCSDIR%%/txt/rules.txt
-%%DOCSDIR%%/txt/source.txt
-%%DOCSDIR%%/txt/todo.txt
-%%DOCSDIR%%/txt/userlevels.txt
-%%DOCSDIR%%/txt/fanfic.txt
-%%DOCSDIR%%/txt/wip.txt
-%%DOCSDIR%%/html/algorithm.html
-%%DOCSDIR%%/html/authors.html
-%%DOCSDIR%%/html/bugs.html
-%%DOCSDIR%%/html/copying.html
-%%DOCSDIR%%/html/index.html
-%%DOCSDIR%%/html/mailinglists.html
-%%DOCSDIR%%/html/network.html
-%%DOCSDIR%%/html/options.html
-%%DOCSDIR%%/html/parameters.html
-%%DOCSDIR%%/html/platforms.html
-%%DOCSDIR%%/html/rules.html
-%%DOCSDIR%%/html/source.html
-%%DOCSDIR%%/html/todo.html
-%%DOCSDIR%%/html/userlevels.html
-%%DOCSDIR%%/html/fanfic.html
-%%DOCSDIR%%/html/wip.html
-%%DOCSDIR%%/COPYING
-%%DOCSDIR%%/README
-%%DOCSDIR%%/README.fr
-%%DOCSDIR%%/README.de
-%%DOCSDIR%%/README.dk
-share/pixmaps/liquidwar.xpm
share/applications/liquidwar.desktop
-share/games/liquidwar/liquidwar.dat
-share/games/liquidwar/map/meditate.bmp
-share/games/liquidwar/map/pacman.bmp
-share/games/liquidwar/map/paille.bmp
-share/games/liquidwar/map/t4.bmp
-share/games/liquidwar/music/colossus.mid
-share/games/liquidwar/texture/bluesq.bmp
-share/games/liquidwar/texture/clovers.bmp
-share/games/liquidwar/texture/meditate.bmp
-share/games/liquidwar/texture/rust.bmp
-share/games/liquidwar/texture/warning.bmp
-games/liquidwar-server
-games/liquidwar-mapgen
-games/liquidwar
+%%PORTDOCS%%%%DOCSDIR%%/txt/algorithm.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/authors.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/bugs.txt
+@comment %%PORTDOCS%%%%DOCSDIR%%/txt/copying.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/mailinglists.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/network.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/options.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/parameters.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/platforms.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/rules.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/source.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/todo.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/userlevels.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/fanfic.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/wip.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/algorithm.html
+%%PORTDOCS%%%%DOCSDIR%%/html/authors.html
+%%PORTDOCS%%%%DOCSDIR%%/html/bugs.html
+@comment %%PORTDOCS%%%%DOCSDIR%%/html/copying.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/mailinglists.html
+%%PORTDOCS%%%%DOCSDIR%%/html/network.html
+%%PORTDOCS%%%%DOCSDIR%%/html/options.html
+%%PORTDOCS%%%%DOCSDIR%%/html/parameters.html
+%%PORTDOCS%%%%DOCSDIR%%/html/platforms.html
+%%PORTDOCS%%%%DOCSDIR%%/html/rules.html
+%%PORTDOCS%%%%DOCSDIR%%/html/source.html
+%%PORTDOCS%%%%DOCSDIR%%/html/todo.html
+%%PORTDOCS%%%%DOCSDIR%%/html/userlevels.html
+%%PORTDOCS%%%%DOCSDIR%%/html/fanfic.html
+%%PORTDOCS%%%%DOCSDIR%%/html/wip.html
+@comment %%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.fr
+%%PORTDOCS%%%%DOCSDIR%%/README.de
+%%PORTDOCS%%%%DOCSDIR%%/README.dk
+%%PORTDOCS%%%%DOCSDIR%%/README.pl
+%%DATADIR%%/liquidwar.dat
+%%DATADIR%%/map/meditate.bmp
+%%DATADIR%%/map/pacman.bmp
+%%DATADIR%%/map/paille.bmp
+%%DATADIR%%/map/t4.bmp
+%%DATADIR%%/music/colossus.mid
+%%DATADIR%%/texture/bluesq.bmp
+%%DATADIR%%/texture/clovers.bmp
+%%DATADIR%%/texture/meditate.bmp
+%%DATADIR%%/texture/rust.bmp
+%%DATADIR%%/texture/warning.bmp
+share/pixmaps/liquidwar.xpm