aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-02-09 02:25:01 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-02-09 02:25:01 +0000
commit6811fc7090f228bf55c021a6e53309f22201ea46 (patch)
tree6c82929e4799e0e6cc28bae78bf6a9884f58e614
parent66f1986ceb8ee9a156dbc6d4bb8342320f4fbcde (diff)
downloadports-6811fc7090f228bf55c021a6e53309f22201ea46.tar.gz
ports-6811fc7090f228bf55c021a6e53309f22201ea46.zip
Notes
-rw-r--r--x11-toolkits/fox16/Makefile136
-rw-r--r--x11-toolkits/fox16/distinfo4
-rw-r--r--x11-toolkits/fox16/pkg-descr10
-rw-r--r--x11-toolkits/fox16/pkg-plist140
4 files changed, 131 insertions, 159 deletions
diff --git a/x11-toolkits/fox16/Makefile b/x11-toolkits/fox16/Makefile
index ef42b5169b66..ed26d60b1f41 100644
--- a/x11-toolkits/fox16/Makefile
+++ b/x11-toolkits/fox16/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= fox
-PORTVERSION= 1.6.49
-PORTREVISION= 5
+PORTVERSION= 1.6.50
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.fox-toolkit.org/pub/ \
http://ftp.fox-toolkit.org/pub/
@@ -12,113 +11,88 @@ PKGNAMESUFFIX= ${PORTVERSION:R:S/.//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast and extensive C++ GUI toolkit -- ver.1.6
+LICENSE= LGPL3 # (or later)
+
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
-MAJORVER= ${PORTVERSION:R}
-PLIST_SUB+= MAJORVER=${MAJORVER}
-
USES= libtool pathfix
USE_GL= yes
-USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-opengl --with-x
-PORTDOCS= *
+CONFIGURE_ARGS= --with-opengl --with-x --with-xim
+USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include -fPIC
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= OPTIMIZED_CFLAGS CUPS DEBUG DOCS APPS PROFILE SHM XFT
-OPTIONS_DEFAULT=SHM XFT
-APPS_DESC= Install sample applications
-SHM_DESC= Shared Memory support
+PLIST_SUB= MAJORVER="${MAJORVER}"
-.include <bsd.port.options.mk>
+PORTDOCS= *
-##
-## Additional Options
-##
-#
-.if ${PORT_OPTIONS:MXFT}
-CONFIGURE_ARGS+=--with-xft=yes
-USE_XORG+= xft
-CPPFLAGS+= `freetype-config --cflags`
-LDFLAGS+= `freetype-config --libs`
-.else
-CONFIGURE_ARGS+= --with-xft=no
-.endif
-#
-.if ${PORT_OPTIONS:MSHM}
-CONFIGURE_ARGS+= --with-xshm=yes
-.else
-CONFIGURE_ARGS+= --with-xshm=no
-.endif
-#
-.if ${PORT_OPTIONS:MCUPS}
-LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client
-.endif
-#
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug
-.else
-CONFIGURE_ARGS+= --enable-release
-.endif
-#
-.if ${PORT_OPTIONS:MAPPS}
-PLIST_SUB+= APPS=""
-.else
-PLIST_SUB+= APPS="@comment "
-.endif
-#
-.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
-# turn distribution-recommended optimization flags back on
-CXXFLAGS+= -O2 -Wuninitialized -ffast-math -finline-functions -fexpensive-optimizations
-.if ${PORT_OPTIONS:MPROFILE} == "" # Incompatible with profiling flags
-CXXFLAGS+= -fomit-frame-pointer
-.endif
-.endif
-#
-.if ${PORT_OPTIONS:MPROFILE}
-CONFIGURE_ARGS+= --with-profiling=gprof
-.endif
+OPTIONS_DEFINE= APPS DEBUG DOCS OPTIMIZED_CFLAGS PROFILE SHM XFT
+OPTIONS_DEFAULT= SHM XFT
+OPTIONS_SUB= yes
+
+APPS_DESC= Install sample applications
+DEBUG_CONFIGURE_ON= --enable-debug
+DEBUG_CONFIGURE_OFF= --enable-release
+OPTIMIZED_CFLAGS_CXXFLAGS=\
+ -ffast-math -fexpensive-optimizations \
+ -finline-functions -fomit-frame-pointer
+PROFILE_CONFIGURE_ON= --with-profiling=gprof
+SHM_DESC= Shared Memory support
+SHM_CONFIGURE_ON= --with-xshm=yes
+SHM_CONFIGURE_OFF= --with-xshm=no
+XFT_USE= xorg=xft
+XFT_CONFIGURE_ON= --with-xft=yes
+XFT_CONFIGURE_OFF= --with-xft=no
+XFT_CPPFLAGS= $$(freetype-config --cflags)
+XFT_LDFLAGS= $$(freetype-config --libs)
+
+MAJORVER= ${PORTVERSION:R}
+
+.include <bsd.port.options.mk>
post-patch:
# Rename man pages as in manpage.1 --> manpage-16.1 to avoid
# conflicts with fox14 and fox17
files=$$(${FIND} ${WRKSRC} -name *.1); \
for f in $$files; do \
- ${MV} $$f `echo $$f | sed -e 's|\.1|-16.1|'`; \
+ ${MV} $$f `${ECHO_CMD} $$f | ${SED} -e 's|\.1|-16.1|'`; \
done;
- ${FIND} ${WRKSRC} -name Makefile.am -o -name Makefile.in | ${XARGS} \
- ${REINPLACE_CMD} -i '' -e '/man_MANS/s|\.1|-16.1|g'
- ${REINPLACE_CMD} -e '/^Libs:/s|$$| ${PTHREAD_LIBS}|; s|"||g' ${WRKSRC}/fox.pc.in
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ '/man_MANS/s|\.1|-16.1|g'
+ @${REINPLACE_CMD} -e \
+ '/^Libs:/s|$$| -pthread|; \
+ s|"||g' ${WRKSRC}/fox.pc.in
# CXXFLAGS safeness
- @${REINPLACE_CMD} -E -e \
- 's|-O2|${CXXFLAGS}|g ; \
- s|-lc_r|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e \
+ 's|^\(CXXFLAGS=\)|#\1| ; \
+ /CXXFLAGS/s|-O2 ||; \
+ /CXXFLAGS/s|\(-Wuninitialized\).*"|\1"|; \
+ /LDFLAGS/s|-s ||' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
# doc prefix safeness
- @${REINPLACE_CMD} -E -e \
- 's|^(htmldir).*$$|\1=${DOCSDIR}/html|' \
+ @${REINPLACE_CMD} -e \
+ 's|^\(htmldir\).*$$|\1=${DOCSDIR}/html|' \
${WRKSRC}/doc/Makefile.in
- @${REINPLACE_CMD} -E -e \
- 's|^(artdir).*$$|\1=${DOCSDIR}/html|' \
+ @${REINPLACE_CMD} -e \
+ 's|^\(artdir\).*$$|\1=${DOCSDIR}/html|' \
${WRKSRC}/doc/art/Makefile.in
- @${REINPLACE_CMD} -E -e \
- 's|^(screenshotsdir).*$$|\1=${DOCSDIR}/html|' \
+ @${REINPLACE_CMD} -e \
+ 's|^\(screenshotsdir\).*$$|\1=${DOCSDIR}/html|' \
${WRKSRC}/doc/screenshots/Makefile.in
-.if ${PORT_OPTIONS:MDOCS} == ""
+.if !${PORT_OPTIONS:MAPPS}
@${REINPLACE_CMD} -e \
- '/^SUBDIRS/s/ doc//' \
- ${WRKSRC}/Makefile.in
-.endif
-.if ${PORT_OPTIONS:MAPPS} == ""
- @${REINPLACE_CMD} -E -e \
- 's,^(SUBDIRS.*)adie,\1,; \
- s,^(SUBDIRS.*)pathfinder,\1,; \
- s,^(SUBDIRS.*)calculator,\1,' \
+ 's|^\(SUBDIRS.*\)adie|\1|; \
+ s|^\(SUBDIRS.*\)pathfinder|\1|; \
+ s|^\(SUBDIRS.*\)calculator|\1|' \
${WRKSRC}/Makefile.in
.endif
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libCHART-${MAJORVER}.so.[0-9].*
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libFOX-${MAJORVER}.so.[0-9].*
+
.include <bsd.port.mk>
diff --git a/x11-toolkits/fox16/distinfo b/x11-toolkits/fox16/distinfo
index 2a46d7ba9b49..266cad6e318d 100644
--- a/x11-toolkits/fox16/distinfo
+++ b/x11-toolkits/fox16/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fox-1.6.49.tar.gz) = 3679ecd23064958259fbef5898aabb048d63b2dcb796de1d8801fe0b51e5a90e
-SIZE (fox-1.6.49.tar.gz) = 4383152
+SHA256 (fox-1.6.50.tar.gz) = 342c751d2a7edab136ad26cb4483329da3c16c7abf2f283f318d666ef12d0887
+SIZE (fox-1.6.50.tar.gz) = 4381855
diff --git a/x11-toolkits/fox16/pkg-descr b/x11-toolkits/fox16/pkg-descr
index f8ea8b196509..39424ae29663 100644
--- a/x11-toolkits/fox16/pkg-descr
+++ b/x11-toolkits/fox16/pkg-descr
@@ -1,9 +1,7 @@
-FOX is a C++ GUI toolkit that is supposed to
-allow programmers to write a program once, and
-compile anywhere (or so the website says, it sounds
-like Java to me). FOX is a very flexible library,
-it has all sorts of functions and options, and is
-supposed to be fairly fast.
+FOX is a C++ GUI toolkit that is supposed to allow programmers to write
+a program once, and compile anywhere (or so the website says, it sounds
+like Java to me). FOX is a very flexible library, it has all sorts of
+functions and options, and is supposed to be fairly fast.
Author: Jeroen van der Zijp <jvz@cfdrc.com>
WWW: http://www.fox-toolkit.org/fox.html
diff --git a/x11-toolkits/fox16/pkg-plist b/x11-toolkits/fox16/pkg-plist
index 42a5df188a67..f702e63374c2 100644
--- a/x11-toolkits/fox16/pkg-plist
+++ b/x11-toolkits/fox16/pkg-plist
@@ -1,10 +1,18 @@
%%APPS%%bin/PathFinder
-%%APPS%%bin/adie
%%APPS%%bin/Adie.stx
+%%APPS%%bin/adie
%%APPS%%bin/calculator
+bin/fox-config
bin/reswrap
bin/shutterbug
-bin/fox-config
+include/fox-%%MAJORVER%%/FX4Splitter.h
+include/fox-%%MAJORVER%%/FX7Segment.h
+include/fox-%%MAJORVER%%/FX885910Codec.h
+include/fox-%%MAJORVER%%/FX885911Codec.h
+include/fox-%%MAJORVER%%/FX885913Codec.h
+include/fox-%%MAJORVER%%/FX885914Codec.h
+include/fox-%%MAJORVER%%/FX885915Codec.h
+include/fox-%%MAJORVER%%/FX885916Codec.h
include/fox-%%MAJORVER%%/FX88591Codec.h
include/fox-%%MAJORVER%%/FX88592Codec.h
include/fox-%%MAJORVER%%/FX88593Codec.h
@@ -14,12 +22,26 @@ include/fox-%%MAJORVER%%/FX88596Codec.h
include/fox-%%MAJORVER%%/FX88597Codec.h
include/fox-%%MAJORVER%%/FX88598Codec.h
include/fox-%%MAJORVER%%/FX88599Codec.h
-include/fox-%%MAJORVER%%/FX885910Codec.h
-include/fox-%%MAJORVER%%/FX885911Codec.h
-include/fox-%%MAJORVER%%/FX885913Codec.h
-include/fox-%%MAJORVER%%/FX885914Codec.h
-include/fox-%%MAJORVER%%/FX885915Codec.h
-include/fox-%%MAJORVER%%/FX885916Codec.h
+include/fox-%%MAJORVER%%/FXAccelTable.h
+include/fox-%%MAJORVER%%/FXApp.h
+include/fox-%%MAJORVER%%/FXArray.h
+include/fox-%%MAJORVER%%/FXArrowButton.h
+include/fox-%%MAJORVER%%/FXBMPIcon.h
+include/fox-%%MAJORVER%%/FXBMPImage.h
+include/fox-%%MAJORVER%%/FXBZFileStream.h
+include/fox-%%MAJORVER%%/FXBitmap.h
+include/fox-%%MAJORVER%%/FXBitmapFrame.h
+include/fox-%%MAJORVER%%/FXBitmapView.h
+include/fox-%%MAJORVER%%/FXButton.h
+include/fox-%%MAJORVER%%/FXCP1250Codec.h
+include/fox-%%MAJORVER%%/FXCP1251Codec.h
+include/fox-%%MAJORVER%%/FXCP1252Codec.h
+include/fox-%%MAJORVER%%/FXCP1253Codec.h
+include/fox-%%MAJORVER%%/FXCP1254Codec.h
+include/fox-%%MAJORVER%%/FXCP1255Codec.h
+include/fox-%%MAJORVER%%/FXCP1256Codec.h
+include/fox-%%MAJORVER%%/FXCP1257Codec.h
+include/fox-%%MAJORVER%%/FXCP1258Codec.h
include/fox-%%MAJORVER%%/FXCP437Codec.h
include/fox-%%MAJORVER%%/FXCP850Codec.h
include/fox-%%MAJORVER%%/FXCP852Codec.h
@@ -35,72 +57,19 @@ include/fox-%%MAJORVER%%/FXCP865Codec.h
include/fox-%%MAJORVER%%/FXCP866Codec.h
include/fox-%%MAJORVER%%/FXCP869Codec.h
include/fox-%%MAJORVER%%/FXCP874Codec.h
-include/fox-%%MAJORVER%%/FXCP1250Codec.h
-include/fox-%%MAJORVER%%/FXCP1251Codec.h
-include/fox-%%MAJORVER%%/FXCP1252Codec.h
-include/fox-%%MAJORVER%%/FXCP1253Codec.h
-include/fox-%%MAJORVER%%/FXCP1254Codec.h
-include/fox-%%MAJORVER%%/FXCP1255Codec.h
-include/fox-%%MAJORVER%%/FXCP1256Codec.h
-include/fox-%%MAJORVER%%/FXCP1257Codec.h
-include/fox-%%MAJORVER%%/FXCP1258Codec.h
-include/fox-%%MAJORVER%%/FXKOI8RCodec.h
-include/fox-%%MAJORVER%%/FX7Segment.h
-include/fox-%%MAJORVER%%/FXBZFileStream.h
-include/fox-%%MAJORVER%%/FXChoiceBox.h
-include/fox-%%MAJORVER%%/FXColorList.h
-include/fox-%%MAJORVER%%/FXColorRing.h
-include/fox-%%MAJORVER%%/FXComposeContext.h
-include/fox-%%MAJORVER%%/FXDate.h
-include/fox-%%MAJORVER%%/FXDir.h
-include/fox-%%MAJORVER%%/FXDockBar.h
-include/fox-%%MAJORVER%%/FXDockHandler.h
-include/fox-%%MAJORVER%%/FXDockSite.h
-include/fox-%%MAJORVER%%/FXDockTitle.h
-include/fox-%%MAJORVER%%/FXExpression.h
-include/fox-%%MAJORVER%%/FXExtentd.h
-include/fox-%%MAJORVER%%/FXExtentf.h
-include/fox-%%MAJORVER%%/FXGUISignal.h
-include/fox-%%MAJORVER%%/FXGZFileStream.h
-include/fox-%%MAJORVER%%/FXIO.h
-include/fox-%%MAJORVER%%/FXIFFImage.h
-include/fox-%%MAJORVER%%/FXIFFIcon.h
-include/fox-%%MAJORVER%%/FXIconDict.h
-include/fox-%%MAJORVER%%/FXIconSource.h
-include/fox-%%MAJORVER%%/FXKnob.h
-include/fox-%%MAJORVER%%/FXMemMap.h
-include/fox-%%MAJORVER%%/FXPath.h
-include/fox-%%MAJORVER%%/FXPipe.h
-include/fox-%%MAJORVER%%/FXRASIcon.h
-include/fox-%%MAJORVER%%/FXRASImage.h
-include/fox-%%MAJORVER%%/FXRulerView.h
-include/fox-%%MAJORVER%%/FXSocket.h
-include/fox-%%MAJORVER%%/FXSplashWindow.h
-include/fox-%%MAJORVER%%/FXStat.h
-include/fox-%%MAJORVER%%/FXSystem.h
-include/fox-%%MAJORVER%%/FXTranslator.h
-include/fox-%%MAJORVER%%/fxascii.h
-include/fox-%%MAJORVER%%/fxunicode.h
-include/fox-%%MAJORVER%%/FX4Splitter.h
-include/fox-%%MAJORVER%%/FXAccelTable.h
-include/fox-%%MAJORVER%%/FXApp.h
-include/fox-%%MAJORVER%%/FXArray.h
-include/fox-%%MAJORVER%%/FXArrowButton.h
-include/fox-%%MAJORVER%%/FXBMPIcon.h
-include/fox-%%MAJORVER%%/FXBMPImage.h
-include/fox-%%MAJORVER%%/FXBitmap.h
-include/fox-%%MAJORVER%%/FXBitmapFrame.h
-include/fox-%%MAJORVER%%/FXBitmapView.h
-include/fox-%%MAJORVER%%/FXButton.h
include/fox-%%MAJORVER%%/FXCURCursor.h
include/fox-%%MAJORVER%%/FXCanvas.h
include/fox-%%MAJORVER%%/FXCheckButton.h
+include/fox-%%MAJORVER%%/FXChoiceBox.h
include/fox-%%MAJORVER%%/FXColorBar.h
include/fox-%%MAJORVER%%/FXColorDialog.h
+include/fox-%%MAJORVER%%/FXColorList.h
+include/fox-%%MAJORVER%%/FXColorRing.h
include/fox-%%MAJORVER%%/FXColorSelector.h
include/fox-%%MAJORVER%%/FXColorWell.h
include/fox-%%MAJORVER%%/FXColorWheel.h
include/fox-%%MAJORVER%%/FXComboBox.h
+include/fox-%%MAJORVER%%/FXComposeContext.h
include/fox-%%MAJORVER%%/FXComposite.h
include/fox-%%MAJORVER%%/FXCursor.h
include/fox-%%MAJORVER%%/FXDC.h
@@ -108,21 +77,30 @@ include/fox-%%MAJORVER%%/FXDCPrint.h
include/fox-%%MAJORVER%%/FXDCWindow.h
include/fox-%%MAJORVER%%/FXDLL.h
include/fox-%%MAJORVER%%/FXDataTarget.h
+include/fox-%%MAJORVER%%/FXDate.h
include/fox-%%MAJORVER%%/FXDebugTarget.h
include/fox-%%MAJORVER%%/FXDelegator.h
include/fox-%%MAJORVER%%/FXDial.h
include/fox-%%MAJORVER%%/FXDialogBox.h
include/fox-%%MAJORVER%%/FXDict.h
+include/fox-%%MAJORVER%%/FXDir.h
include/fox-%%MAJORVER%%/FXDirBox.h
include/fox-%%MAJORVER%%/FXDirDialog.h
include/fox-%%MAJORVER%%/FXDirList.h
include/fox-%%MAJORVER%%/FXDirSelector.h
+include/fox-%%MAJORVER%%/FXDockBar.h
+include/fox-%%MAJORVER%%/FXDockHandler.h
+include/fox-%%MAJORVER%%/FXDockSite.h
+include/fox-%%MAJORVER%%/FXDockTitle.h
include/fox-%%MAJORVER%%/FXDocument.h
include/fox-%%MAJORVER%%/FXDragCorner.h
include/fox-%%MAJORVER%%/FXDrawable.h
include/fox-%%MAJORVER%%/FXDriveBox.h
include/fox-%%MAJORVER%%/FXElement.h
include/fox-%%MAJORVER%%/FXException.h
+include/fox-%%MAJORVER%%/FXExpression.h
+include/fox-%%MAJORVER%%/FXExtentd.h
+include/fox-%%MAJORVER%%/FXExtentf.h
include/fox-%%MAJORVER%%/FXFile.h
include/fox-%%MAJORVER%%/FXFileDialog.h
include/fox-%%MAJORVER%%/FXFileDict.h
@@ -148,6 +126,8 @@ include/fox-%%MAJORVER%%/FXGLSphere.h
include/fox-%%MAJORVER%%/FXGLTriangleMesh.h
include/fox-%%MAJORVER%%/FXGLViewer.h
include/fox-%%MAJORVER%%/FXGLVisual.h
+include/fox-%%MAJORVER%%/FXGUISignal.h
+include/fox-%%MAJORVER%%/FXGZFileStream.h
include/fox-%%MAJORVER%%/FXGradientBar.h
include/fox-%%MAJORVER%%/FXGroupBox.h
include/fox-%%MAJORVER%%/FXHash.h
@@ -155,8 +135,13 @@ include/fox-%%MAJORVER%%/FXHeader.h
include/fox-%%MAJORVER%%/FXHorizontalFrame.h
include/fox-%%MAJORVER%%/FXICOIcon.h
include/fox-%%MAJORVER%%/FXICOImage.h
+include/fox-%%MAJORVER%%/FXIFFIcon.h
+include/fox-%%MAJORVER%%/FXIFFImage.h
+include/fox-%%MAJORVER%%/FXIO.h
include/fox-%%MAJORVER%%/FXIcon.h
+include/fox-%%MAJORVER%%/FXIconDict.h
include/fox-%%MAJORVER%%/FXIconList.h
+include/fox-%%MAJORVER%%/FXIconSource.h
include/fox-%%MAJORVER%%/FXId.h
include/fox-%%MAJORVER%%/FXImage.h
include/fox-%%MAJORVER%%/FXImageFrame.h
@@ -164,6 +149,8 @@ include/fox-%%MAJORVER%%/FXImageView.h
include/fox-%%MAJORVER%%/FXInputDialog.h
include/fox-%%MAJORVER%%/FXJPGIcon.h
include/fox-%%MAJORVER%%/FXJPGImage.h
+include/fox-%%MAJORVER%%/FXKOI8RCodec.h
+include/fox-%%MAJORVER%%/FXKnob.h
include/fox-%%MAJORVER%%/FXLabel.h
include/fox-%%MAJORVER%%/FXList.h
include/fox-%%MAJORVER%%/FXListBox.h
@@ -176,6 +163,7 @@ include/fox-%%MAJORVER%%/FXMat3f.h
include/fox-%%MAJORVER%%/FXMat4d.h
include/fox-%%MAJORVER%%/FXMat4f.h
include/fox-%%MAJORVER%%/FXMatrix.h
+include/fox-%%MAJORVER%%/FXMemMap.h
include/fox-%%MAJORVER%%/FXMemoryStream.h
include/fox-%%MAJORVER%%/FXMenuBar.h
include/fox-%%MAJORVER%%/FXMenuButton.h
@@ -198,7 +186,9 @@ include/fox-%%MAJORVER%%/FXPNGImage.h
include/fox-%%MAJORVER%%/FXPPMIcon.h
include/fox-%%MAJORVER%%/FXPPMImage.h
include/fox-%%MAJORVER%%/FXPacker.h
+include/fox-%%MAJORVER%%/FXPath.h
include/fox-%%MAJORVER%%/FXPicker.h
+include/fox-%%MAJORVER%%/FXPipe.h
include/fox-%%MAJORVER%%/FXPoint.h
include/fox-%%MAJORVER%%/FXPopup.h
include/fox-%%MAJORVER%%/FXPrintDialog.h
@@ -206,6 +196,8 @@ include/fox-%%MAJORVER%%/FXProgressBar.h
include/fox-%%MAJORVER%%/FXProgressDialog.h
include/fox-%%MAJORVER%%/FXQuatd.h
include/fox-%%MAJORVER%%/FXQuatf.h
+include/fox-%%MAJORVER%%/FXRASIcon.h
+include/fox-%%MAJORVER%%/FXRASImage.h
include/fox-%%MAJORVER%%/FXRGBIcon.h
include/fox-%%MAJORVER%%/FXRGBImage.h
include/fox-%%MAJORVER%%/FXRadioButton.h
@@ -221,6 +213,7 @@ include/fox-%%MAJORVER%%/FXReplaceDialog.h
include/fox-%%MAJORVER%%/FXRex.h
include/fox-%%MAJORVER%%/FXRootWindow.h
include/fox-%%MAJORVER%%/FXRuler.h
+include/fox-%%MAJORVER%%/FXRulerView.h
include/fox-%%MAJORVER%%/FXScrollArea.h
include/fox-%%MAJORVER%%/FXScrollBar.h
include/fox-%%MAJORVER%%/FXScrollPane.h
@@ -232,17 +225,21 @@ include/fox-%%MAJORVER%%/FXShell.h
include/fox-%%MAJORVER%%/FXShutter.h
include/fox-%%MAJORVER%%/FXSize.h
include/fox-%%MAJORVER%%/FXSlider.h
+include/fox-%%MAJORVER%%/FXSocket.h
include/fox-%%MAJORVER%%/FXSphered.h
include/fox-%%MAJORVER%%/FXSpheref.h
include/fox-%%MAJORVER%%/FXSpinner.h
+include/fox-%%MAJORVER%%/FXSplashWindow.h
include/fox-%%MAJORVER%%/FXSplitter.h
include/fox-%%MAJORVER%%/FXSpring.h
+include/fox-%%MAJORVER%%/FXStat.h
include/fox-%%MAJORVER%%/FXStatusBar.h
include/fox-%%MAJORVER%%/FXStatusLine.h
include/fox-%%MAJORVER%%/FXStream.h
include/fox-%%MAJORVER%%/FXString.h
include/fox-%%MAJORVER%%/FXStringDict.h
include/fox-%%MAJORVER%%/FXSwitcher.h
+include/fox-%%MAJORVER%%/FXSystem.h
include/fox-%%MAJORVER%%/FXTGAIcon.h
include/fox-%%MAJORVER%%/FXTGAImage.h
include/fox-%%MAJORVER%%/FXTIFIcon.h
@@ -262,6 +259,7 @@ include/fox-%%MAJORVER%%/FXToolBarShell.h
include/fox-%%MAJORVER%%/FXToolBarTab.h
include/fox-%%MAJORVER%%/FXToolTip.h
include/fox-%%MAJORVER%%/FXTopWindow.h
+include/fox-%%MAJORVER%%/FXTranslator.h
include/fox-%%MAJORVER%%/FXTreeList.h
include/fox-%%MAJORVER%%/FXTreeListBox.h
include/fox-%%MAJORVER%%/FXTriStateButton.h
@@ -287,21 +285,23 @@ include/fox-%%MAJORVER%%/FXXPMImage.h
include/fox-%%MAJORVER%%/chart/FXChart.h
include/fox-%%MAJORVER%%/fx.h
include/fox-%%MAJORVER%%/fx3d.h
+include/fox-%%MAJORVER%%/fxascii.h
include/fox-%%MAJORVER%%/fxdefs.h
include/fox-%%MAJORVER%%/fxkeys.h
+include/fox-%%MAJORVER%%/fxunicode.h
include/fox-%%MAJORVER%%/fxver.h
include/fox-%%MAJORVER%%/xincs.h
lib/libCHART-%%MAJORVER%%.a
lib/libCHART-%%MAJORVER%%.so
lib/libCHART-%%MAJORVER%%.so.0
-lib/libCHART-%%MAJORVER%%.so.0.0.49
+lib/libCHART-%%MAJORVER%%.so.0.0.50
lib/libFOX-%%MAJORVER%%.a
lib/libFOX-%%MAJORVER%%.so
lib/libFOX-%%MAJORVER%%.so.0
-lib/libFOX-%%MAJORVER%%.so.0.0.49
-man/man1/shutterbug-16.1.gz
-man/man1/reswrap-16.1.gz
+lib/libFOX-%%MAJORVER%%.so.0.0.50
+libdata/pkgconfig/fox.pc
%%APPS%%man/man1/PathFinder-16.1.gz
%%APPS%%man/man1/adie-16.1.gz
%%APPS%%man/man1/calculator-16.1.gz
-libdata/pkgconfig/fox.pc
+man/man1/reswrap-16.1.gz
+man/man1/shutterbug-16.1.gz