aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-10-19 17:30:43 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-10-19 17:30:43 +0000
commit6844063487911f57a10a90656c3e897593c8fd81 (patch)
treed8b88d4329ae4b8cee68f012f19f487e372cdc73
parente31ee5822945d2cfeb9f03816f88af343b8553aa (diff)
downloadports-6844063487911f57a10a90656c3e897593c8fd81.tar.gz
ports-6844063487911f57a10a90656c3e897593c8fd81.zip
Notes
-rw-r--r--games/aestats/Makefile19
-rw-r--r--games/aestats/files/fbsd_stub.c1
2 files changed, 11 insertions, 9 deletions
diff --git a/games/aestats/Makefile b/games/aestats/Makefile
index 822ac311a0f4..27298af2ff6e 100644
--- a/games/aestats/Makefile
+++ b/games/aestats/Makefile
@@ -5,8 +5,7 @@ PORTNAME= aestats
PORTVERSION= 5.39
CATEGORIES= games
MASTER_SITES= ftp://download:download@download.hugelaser.com/aeons.poweredbylasers.com/${PORTNAME}/ \
- http://freebsd.nsu.ru/distfiles/ ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= danfe
+ http://freebsd.nsu.ru/distfiles/ LOCAL/danfe
DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= danfe@FreeBSD.org
@@ -33,20 +32,22 @@ post-extract: .SILENT
# us Linux .o files instead. With some hacking, we can build native FreeBSD
# executables from those .o files. Pretty neat, huh? :-)
#
-NO_STAGE= yes
pre-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} -c fbsd_stub.c
${OBJCOPY} --redefine-sym stdout=__stdoutp ${WRKSRC}/aespages.o
${OBJCOPY} --redefine-sym stdout=__stdoutp ${WRKSRC}/paessubs.o
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/AEstats ${WRKSRC}/preAEs ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/AEstats ${WRKSRC}/preAEs \
+ ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${LINUXBINDIR}/AEsscore.cfg \
- ${LINUXBINDIR}/AEstats.cfg ${LINUXBINDIR}/banlist.txt ${DATADIR}
- ${INSTALL_DATA} ${LINUXBINDIR}/alias-example.txt ${DATADIR}/alias.txt
- ${INSTALL_DATA} ${WRKSRC}/../AEstats.txt ${DATADIR}
+ ${LINUXBINDIR}/AEstats.cfg ${LINUXBINDIR}/banlist.txt \
+ ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${LINUXBINDIR}/alias-example.txt \
+ ${STAGEDIR}${DATADIR}/alias.txt
+ ${INSTALL_DATA} ${WRKSRC}/../AEstats.txt ${STAGEDIR}${DATADIR}
cd ${WRKSRC}/.. && ${FIND} logs stats unrealmod | \
- ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
+ ${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/games/aestats/files/fbsd_stub.c b/games/aestats/files/fbsd_stub.c
index 8ffa6c1d67c8..863bceaa44c6 100644
--- a/games/aestats/files/fbsd_stub.c
+++ b/games/aestats/files/fbsd_stub.c
@@ -1,6 +1,7 @@
#include <sys/param.h>
#include <sys/stat.h>
#include <runetype.h>
+#include <stdlib.h>
long int
__strtol_internal(__const char *__restrict __nptr, char **__restrict __endptr,