aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-27 12:52:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-27 12:52:57 +0000
commit686b43f00cba818b9a0480d69297951c6e8bb510 (patch)
treec929184a6643b6759332859cb5e74dba0e2fce49
parent6db69e9fe779ce0bdb130401495b58ddc83be89b (diff)
downloadports-686b43f00cba818b9a0480d69297951c6e8bb510.tar.gz
ports-686b43f00cba818b9a0480d69297951c6e8bb510.zip
Notes
-rw-r--r--print/poster/Makefile5
-rw-r--r--print/poster/files/patch-poster.c6
2 files changed, 7 insertions, 4 deletions
diff --git a/print/poster/Makefile b/print/poster/Makefile
index 04e30f2fb77e..b3fd2f237903 100644
--- a/print/poster/Makefile
+++ b/print/poster/Makefile
@@ -10,6 +10,9 @@ DISTNAME= poster
MAINTAINER= ports@FreeBSD.org
COMMENT= Resize a postscript image to print on larger media and/or multiple sheets
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
ALL_TARGET= poster
MAKEFILE= /dev/null
MAKE_ENV= LDLIBS="-lm"
@@ -19,6 +22,6 @@ PLIST_FILES= bin/poster man/man1/poster.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/${DISTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${DISTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/print/poster/files/patch-poster.c b/print/poster/files/patch-poster.c
index 8c14e4a52760..fb244468a7f5 100644
--- a/print/poster/files/patch-poster.c
+++ b/print/poster/files/patch-poster.c
@@ -1,6 +1,6 @@
---- poster.c.org Thu Apr 29 00:22:46 1999
-+++ poster.c Sun Jan 30 00:48:11 2000
-@@ -570,7 +570,7 @@
+--- poster.c.orig 1999-04-28 15:22:46 UTC
++++ poster.c
+@@ -570,7 +570,7 @@ static int dsc_infile( double ps_bb[4])
got_bb = 0;
dsc_cont = inbody = gotall = level = atend = 0;