aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-10-28 15:06:34 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-10-28 15:06:34 +0000
commit68785eddd7570ac4c5bef9bea7a407dacfc6cfff (patch)
treefa4eb240adcfb3a02b5e81326ac363e65c3bd7ab
parent5fbb907419bfc67138b1755322fc74dab992f2d0 (diff)
downloadports-68785eddd7570ac4c5bef9bea7a407dacfc6cfff.tar.gz
ports-68785eddd7570ac4c5bef9bea7a407dacfc6cfff.zip
Notes
-rw-r--r--games/quake2forge/Makefile38
-rw-r--r--games/quake2forge/pkg-plist16
2 files changed, 33 insertions, 21 deletions
diff --git a/games/quake2forge/Makefile b/games/quake2forge/Makefile
index 473776b87ac2..f087a3fffadf 100644
--- a/games/quake2forge/Makefile
+++ b/games/quake2forge/Makefile
@@ -19,7 +19,6 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=15
USE_AUTOCONF_VER=259
-USE_XLIB= yes
USE_REINPLACE= yes
WANT_SDL= yes
@@ -43,42 +42,52 @@ WITH_LIBAO= yes
.if !defined (WITHOUT_LIBAO) && defined(WITH_LIBAO)
LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
CONFIGURE_ARGS+=--with-ao=${LOCALBASE}
-PLIST_SUB+= AO:=""
+PLIST_SUB+= AO=""
.else
CONFIGURE_ARGS+=--without-ao
-PLIST_SUB+= AO:="@comment "
+PLIST_SUB+= AO="@comment "
.endif
.if !defined (WITHOUT_SVGALIB) && defined(WITH_SVGALIB)
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
CONFIGURE_ARGS+=--with-svgalib=${LOCALBASE}
-PLIST_SUB+= SVGA:=""
+PLIST_SUB+= SVGA=""
.else
CONFIGURE_ARGS+=--with-svgalib=no
-PLIST_SUB+= SVGA:="@comment "
+PLIST_SUB+= SVGA="@comment "
+.endif
+
+.if !defined(WITHOUT_X11)
+USE_XLIB= yes
+CONFIGURE_ARGS+=--with-x
+PLIST_SUB+= X11=""
+.else
+WITHOUT_GL= yes
+CONFIGURE_ARGS+=--without-x
+PLIST_SUB+= X11="@comment "
.endif
.if !defined(WITHOUT_GL)
CONFIGURE_ARGS+=--with-opengl=${X11BASE}
-PLIST_SUB+= GL:=""
+PLIST_SUB+= GL=""
.else
CONFIGURE_ARGS+=--with-opengl=no
-PLIST_SUB+= GL:="@comment "
+PLIST_SUB+= GL="@comment "
.endif
.if !defined(WITHOUT_SDL) && defined(WITH_SDL)
USE_SDL= yes
CONFIGURE_ARGS+=--with-sdl=${LOCALBASE}
.if !defined(WITHOUT_GL)
-PLIST_SUB+= SDLGL:=""
+PLIST_SUB+= SDLGL=""
.else
-PLIST_SUB+= SDLGL:="@comment "
+PLIST_SUB+= SDLGL="@comment "
.endif
-PLIST_SUB+= SDL:=""
+PLIST_SUB+= SDL=""
.else
CONFIGURE_ARGS+=--disable-sdl --disable-sdltest
-PLIST_SUB+= SDL:="@comment "
-PLIST_SUB+= SDLGL:="@comment "
+PLIST_SUB+= SDL="@comment "
+PLIST_SUB+= SDLGL="@comment "
.endif
pre-everything::
@@ -91,8 +100,11 @@ pre-everything::
.if !defined(WITH_SDL)
@${ECHO_MSG} "Define WITH_SDL to use SDL"
.endif
+.if !defined(WITHOUT_X11)
+ @${ECHO_MSG} "Define WITHOUT_X11 to disable X11 and OpenGL support"
+.endif
.if !defined(WITHOUT_GL)
- @${ECHO_MSG} "Define WITHOUT_GL to disable GL"
+ @${ECHO_MSG} "Define WITHOUT_GL to disable OpenGL support"
.endif
.if ( ${OSVERSION} < 500000 )
diff --git a/games/quake2forge/pkg-plist b/games/quake2forge/pkg-plist
index 8bce7870d3b0..5c7df75d795e 100644
--- a/games/quake2forge/pkg-plist
+++ b/games/quake2forge/pkg-plist
@@ -1,13 +1,13 @@
bin/q2f
-%%SVGA:%%lib/quake2/ref_soft.so
-%%SDL:%%lib/quake2/ref_softsdl.so
-%%SDLGL:%%lib/quake2/ref_sdlgl.so
-%%GL:%%lib/quake2/ref_glx.so
-%%SVGA:%%%%GL:%%lib/quake2/ref_tdfx.so
-lib/quake2/ref_softx.so
+%%SVGA%%lib/quake2/ref_soft.so
+%%SDL%%lib/quake2/ref_softsdl.so
+%%SDLGL%%lib/quake2/ref_sdlgl.so
+%%GL%%lib/quake2/ref_glx.so
+%%SVGA%%%%GL%%lib/quake2/ref_tdfx.so
+%%X11%%lib/quake2/ref_softx.so
lib/quake2/snd_oss.so
-%%SDL:%%lib/quake2/snd_sdl.so
-%%AO:%%lib/quake2/snd_ao.so
+%%SDL%%lib/quake2/snd_sdl.so
+%%AO%%lib/quake2/snd_ao.so
lib/quake2/baseq2/game.so
lib/quake2/ctf/game.so
%%PORTDOCS%%share/doc/quake2/README.axp