aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-04-12 06:30:30 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-04-12 06:30:30 +0000
commit6987b2c75547dc39e8c95eaee0aabb36e4043ef0 (patch)
tree721b1feb0f32b73ba0cf5bc557bb387b39b1bac7
parentd52a062c21818ebf421fc66c56ed58b8b58c1642 (diff)
New port: misc/orion: QML/C++-written desktop client for Twitch.tv
Notes
Notes: svn path=/head/; revision=498697
-rw-r--r--misc/Makefile1
-rw-r--r--misc/orion/Makefile32
-rw-r--r--misc/orion/distinfo3
-rw-r--r--misc/orion/pkg-descr10
4 files changed, 46 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index bd2ecf724ceb..2ffe54201ecf 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -271,6 +271,7 @@
SUBDIR += openmvg
SUBDIR += openr2
SUBDIR += orange3
+ SUBDIR += orion
SUBDIR += orville-write
SUBDIR += osinfo-db
SUBDIR += ossp-uuid
diff --git a/misc/orion/Makefile b/misc/orion/Makefile
new file mode 100644
index 000000000000..6c8faa9dd671
--- /dev/null
+++ b/misc/orion/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= orion
+DISTVERSION= 1.6.6-20
+DISTVERSIONSUFFIX= -g127664b
+CATEGORIES= misc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= QML/C++-written desktop client for Twitch.tv
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libmpv.so:multimedia/mpv
+
+USES= gl qmake qt:5
+USE_GITHUB= yes
+GH_ACCOUNT= alamminsalo
+USE_QT= core declarative gui network quickcontrols2 widgets buildtools_build
+USE_GL= gl
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/applications/Orion.desktop \
+ share/icons/hicolor/scalable/apps/${PORTNAME}.svgz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/distfiles/Orion.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
+ ${GZIP_CMD} ${GZIP} < ${WRKSRC}/distfiles/${PORTNAME}.svg > ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}.svgz
+
+.include <bsd.port.mk>
diff --git a/misc/orion/distinfo b/misc/orion/distinfo
new file mode 100644
index 000000000000..e2699cfec75b
--- /dev/null
+++ b/misc/orion/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1555049076
+SHA256 (alamminsalo-orion-1.6.6-20-g127664b_GH0.tar.gz) = 478a8e573fa33c4f177d4cde65a0cac95e5bea3a27b37794a59bd3c97663d8e9
+SIZE (alamminsalo-orion-1.6.6-20-g127664b_GH0.tar.gz) = 644978
diff --git a/misc/orion/pkg-descr b/misc/orion/pkg-descr
new file mode 100644
index 000000000000..bdcc9c47d5ad
--- /dev/null
+++ b/misc/orion/pkg-descr
@@ -0,0 +1,10 @@
+QML/C++-written desktop client for Twitch.tv
+
+Features:
+* Login by twitch credentials
+* Desktop notifications
+* Integrated player
+* Chat support
+* Support for live streams and vods
+
+WWW: https://alamminsalo.github.io/orion/