aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2024-05-15 03:34:26 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2024-05-15 03:34:26 +0000
commit69ce5e29a540b5550a269d18651fdea2b7c79eda (patch)
treee3c813afa316be8538580cc1ac4240e6a25ce13b
parent78f0812c11bfee118ab4dc3fb397456f2ff97de4 (diff)
downloadports-69ce5e29a540b5550a269d18651fdea2b7c79eda.tar.gz
ports-69ce5e29a540b5550a269d18651fdea2b7c79eda.zip
lang/python27: Fix build with 'DEFAULT_VERSIONS=ssl=openssl'
Reported by: Odhiambo Washington Approved by: portmgr blanket (just fix it) MFH: 2024Q2
-rw-r--r--lang/python27/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 8aeab6d28008..245835f5be22 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -120,7 +120,8 @@ post-patch:
# openssl/opensslv.h so setup.py just detects the string as 00000000
# However care should be taken for the OSVERSION. If OpenSSL 3.0.9
# lands later the OSVERSION string should be fixed accordingly
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && (${SSL_DEFAULT} == base || ${SSL_DEFAULT:Mopenssl3*} )
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && (${SSL_DEFAULT} == base || \
+ ${SSL_DEFAULT} == openssl || ${SSL_DEFAULT:Mopenssl3*} )
@${REINPLACE_CMD} -e 's|00907000|00000000|' \
${WRKSRC}/setup.py
.endif