aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-01-13 18:40:50 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-01-13 18:40:50 +0000
commit6a684b14e10bb55ecf30035b9e78390da02c76c8 (patch)
tree78c972fd01560fc25b5179d4ad3b3f0bc8cdf59d
parenta71898a3f3b462fb438e97c5136f459427a52a25 (diff)
downloadports-6a684b14e10bb55ecf30035b9e78390da02c76c8.tar.gz
ports-6a684b14e10bb55ecf30035b9e78390da02c76c8.zip
Notes
-rw-r--r--textproc/libxml++26/Makefile2
-rw-r--r--textproc/libxml++26/files/patch-c++1146
-rw-r--r--textproc/libxml++26/files/patch-libxml++_io_istreamparserinputbuffer.cc10
-rw-r--r--textproc/libxml++26/files/patch-libxml++_io_ostreamoutputbuffer.cc18
4 files changed, 47 insertions, 29 deletions
diff --git a/textproc/libxml++26/Makefile b/textproc/libxml++26/Makefile
index 76391f5c5ece..171839a0ceab 100644
--- a/textproc/libxml++26/Makefile
+++ b/textproc/libxml++26/Makefile
@@ -4,7 +4,7 @@
PORTNAME= libxml++
PORTVERSION= 2.34.2
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= textproc
MASTER_SITES= GNOME
diff --git a/textproc/libxml++26/files/patch-c++11 b/textproc/libxml++26/files/patch-c++11
new file mode 100644
index 000000000000..6374f9db386f
--- /dev/null
+++ b/textproc/libxml++26/files/patch-c++11
@@ -0,0 +1,46 @@
+From 7dbfb0aed508451e8237c34472815e44925a545c Mon Sep 17 00:00:00 2001
+From: Mikhail Titov <mlt@gmx.us>
+Date: Thu, 30 Apr 2015 17:51:20 +0200
+Subject: Fix the build with C++11 compilers, such as MS Visual C++ 2013.
+
+Implicit conversions from streams to bool are no longer allowed.
+---
+ libxml++/io/istreamparserinputbuffer.cc | 2 +-
+ libxml++/io/ostreamoutputbuffer.cc | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/libxml++/io/istreamparserinputbuffer.cc b/libxml++/io/istreamparserinputbuffer.cc
+index b1d6e5b..7a7f283 100644
+--- libxml++/io/istreamparserinputbuffer.cc
++++ libxml++/io/istreamparserinputbuffer.cc
+@@ -39,6 +39,6 @@ namespace xmlpp
+
+ bool IStreamParserInputBuffer::do_close()
+ {
+- return input_;
++ return input_.good();
+ }
+ }
+diff --git a/libxml++/io/ostreamoutputbuffer.cc b/libxml++/io/ostreamoutputbuffer.cc
+index 0a3e6db..b23a8b6 100644
+--- libxml++/io/ostreamoutputbuffer.cc
++++ libxml++/io/ostreamoutputbuffer.cc
+@@ -29,13 +29,13 @@ namespace xmlpp
+ // here we rely on the ostream implicit conversion to boolean, to know if the stream can be used and/or if the write succeded.
+ if(output_)
+ output_.write(buffer, len);
+- return output_;
++ return output_.good();
+ }
+
+ bool OStreamOutputBuffer::do_close()
+ {
+ if(output_)
+ output_.flush();
+- return output_;
++ return output_.good();
+ }
+ }
+--
+cgit v0.12
+
diff --git a/textproc/libxml++26/files/patch-libxml++_io_istreamparserinputbuffer.cc b/textproc/libxml++26/files/patch-libxml++_io_istreamparserinputbuffer.cc
deleted file mode 100644
index 109e1e543470..000000000000
--- a/textproc/libxml++26/files/patch-libxml++_io_istreamparserinputbuffer.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- libxml++/io/istreamparserinputbuffer.cc.orig 2010-12-15 10:41:27 UTC
-+++ libxml++/io/istreamparserinputbuffer.cc
-@@ -39,6 +39,6 @@ namespace xmlpp
-
- bool IStreamParserInputBuffer::do_close()
- {
-- return input_;
-+ return bool(input_);
- }
- }
diff --git a/textproc/libxml++26/files/patch-libxml++_io_ostreamoutputbuffer.cc b/textproc/libxml++26/files/patch-libxml++_io_ostreamoutputbuffer.cc
deleted file mode 100644
index 666d10d74920..000000000000
--- a/textproc/libxml++26/files/patch-libxml++_io_ostreamoutputbuffer.cc
+++ /dev/null
@@ -1,18 +0,0 @@
---- libxml++/io/ostreamoutputbuffer.cc.orig 2010-12-15 10:41:27 UTC
-+++ libxml++/io/ostreamoutputbuffer.cc
-@@ -29,13 +29,13 @@ namespace xmlpp
- // here we rely on the ostream implicit conversion to boolean, to know if the stream can be used and/or if the write succeded.
- if(output_)
- output_.write(buffer, len);
-- return output_;
-+ return bool(output_);
- }
-
- bool OStreamOutputBuffer::do_close()
- {
- if(output_)
- output_.flush();
-- return output_;
-+ return bool(output_);
- }
- }