aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-02-01 11:02:50 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-02-01 11:02:50 +0000
commit6b457d242382ce12ee4d9b505e273a6fc79092c4 (patch)
tree02aa269896e812e2ab477b43ddaadd7fa00259ff
parent4b7fee3c203faea1991eb598a0e3910211f75c23 (diff)
downloadports-6b457d242382ce12ee4d9b505e273a6fc79092c4.tar.gz
ports-6b457d242382ce12ee4d9b505e273a6fc79092c4.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/stud/Makefile31
-rw-r--r--security/stud/distinfo2
-rw-r--r--security/stud/pkg-descr6
4 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 5732ba9b93f9..473e9fed5083 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1067,6 +1067,7 @@
SUBDIR += stoken
SUBDIR += strobe
SUBDIR += strongswan
+ SUBDIR += stud
SUBDIR += stunnel
SUBDIR += subversion-gnome-keyring
SUBDIR += subversion-kwallet
diff --git a/security/stud/Makefile b/security/stud/Makefile
new file mode 100644
index 000000000000..50336c18e4b9
--- /dev/null
+++ b/security/stud/Makefile
@@ -0,0 +1,31 @@
+# Created by: Franz Bettag <franz@bett.ag>
+# $FreeBSD$
+
+PORTNAME= stud
+PORTVERSION= 0.4
+PORTREVISION= 1
+CATEGORIES= security
+
+MAINTAINER= franz@bett.ag
+COMMENT= Scalable TLS Unwrapping Daemon
+
+LICENSE= BSD2CLAUSE
+
+LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev
+
+USES= gmake
+USE_GITHUB= yes
+USE_OPENSSL= yes
+
+GH_ACCOUNT= wasted
+
+MAKE_ARGS= MANDIR="${MANDIRS}"
+MAKE_JOBS_UNSAFE= yes
+
+PLIST_FILES= bin/stud \
+ man/man8/stud.8.gz
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/security/stud/distinfo b/security/stud/distinfo
new file mode 100644
index 000000000000..108660d02f02
--- /dev/null
+++ b/security/stud/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wasted-stud-0.4_GH0.tar.gz) = 8753a5015dbc7998e19dd353057d52e67fd203d713d80a0851fe24a21fadad63
+SIZE (wasted-stud-0.4_GH0.tar.gz) = 45621
diff --git a/security/stud/pkg-descr b/security/stud/pkg-descr
new file mode 100644
index 000000000000..ccba1b73ffc6
--- /dev/null
+++ b/security/stud/pkg-descr
@@ -0,0 +1,6 @@
+stud is a network proxy that terminates TLS/SSL connections
+and forwards the unencrypted traffic to some backend. It's
+designed to handle 10s of thousands of connections
+efficiently on multicore machines.
+
+WWW: https://github.com/bumptech/stud